source: projects/specs/branches/6/d/dump/dump-vl.spec @ 3748

Revision 3748, 14.8 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with rpm-4.8.1

Line 
1%define _sbindir /sbin
2# XXX --enable-kerberos         needs krcmd
3%define myoptions --enable-largefile --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline
4
5Summary: Programs for backing up and restoring ext2/ext3 filesystems.
6Summary(ja): ext2/ext3 ファイルシステムをバックアップ/リストアするプログラム
7Name: dump
8Version: 0.4b41
9Release: 3%{?_dist_release}
10License: BSD
11Group: Applications/Archiving
12URL: http://dump.sourceforge.net
13Source: dump-%{version}.tar.gz
14Patch1: dump-dmfix.patch
15#Patch2: dump-immutable.patch
16#Patch3: dump-0.4b41-libtinfo.patch
17
18
19BuildRoot: %{_tmppath}/%{name}-root
20
21BuildRequires: libtermcap-devel
22BuildRequires: e2fsprogs-devel >= 1.18, readline-devel >= 4.1
23BuildRequires: zlib-devel, device-mapper-devel
24BuildRequires: libblkid-devel
25BuildRequires: libuuid-devel
26BuildRequires: bzip2-devel
27# This Prereq is now required because we only ship static binaries, and
28# need to ensure the "disk" group is created before installation (#60461)
29Requires(pre): setup
30Requires: rmt
31Obsoletes: dump-static
32#Provides: dump-static
33
34Packager: daisuke, kazutaka
35
36%description
37The dump package contains both dump and restore. Dump examines files
38in a filesystem, determines which ones need to be backed up, and
39copies those files to a specified disk, tape, or other storage medium.
40The restore command performs the inverse function of dump; it can
41restore a full backup of a filesystem. Subsequent incremental backups
42can then be layered on top of the full backup. Single files and
43directory subtrees may also be restored from full or partial backups.
44
45Install dump if you need a system for both backing up filesystems and
46restoring filesystems after backups.
47
48%description -l ja
49dump パッケージは dump と restore の両方を含んでいます。dump はファイル
50システム上のファイルを検査し、どれがバックアップが必要が特定し、指定し
51たディスク、テープ、あるいはその他のバックアップ用メディアにファイルを
52コピーします。
53restore コマンドは dump とは反対の処理を行います。restore コマンドを使
54うとファイルシステムのフルバックアップを復元できます。またフルバックアッ
55プからの増分バックアップを適用することもできます。フルバックアップ、ま
56たは部分パックアップから、単一のファイルやディレクトリのサブツリーだけ
57を復元することもできます。
58
59もしファイルシステムのフルバックアップや復元が必要な場合は、dump をイン
60ストールしてください。
61
62%package -n rmt
63Summary: Provides certain programs with access to remote tape devices.
64Summary(ja): リモートテープ装置のアクセスに必要なプログラム
65Group: Applications/Archiving
66
67%description -n rmt
68The rmt utility provides remote access to tape devices for programs
69like dump (a filesystem backup program), restore (a program for
70restoring files from a backup), and tar (an archiving program).
71
72%description -n rmt -l ja
73rmt ユーティリティは、dump (ファイルシステムのバックアップ)や restore
74(バックアップからの復元)、tar (アーカイブの作成/展開) といったプログラ
75ムに、テープ装置へのリモートアクセスを提供します。
76
77%prep
78%setup -q
79%patch1 -p1 -b .dmfix
80#%patch2 -p1 -b .orig
81#%patch3 -p1 -b .libtinfo
82
83
84%build
85%configure %{myoptions} --disable-static --enable-rmt
86
87%ifarch alpha
88RPM_OPT_FLAGS=""
89%endif
90make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
91                         -Wmissing-prototypes -Wno-char-subscripts "
92
93
94%install
95rm -rf %{buildroot}
96mkdir -p %{buildroot}%{_sbindir}
97mkdir -p %{buildroot}%{_mandir}/man8
98
99%makeinstall SBINDIR=%{buildroot}%{_sbindir} BINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
100
101pushd $RPM_BUILD_ROOT
102  ln -sf dump .%{_sbindir}/rdump
103#  ln -sf dump .%{_sbindir}/rdump.static
104#  ln -sf dump .%{_sbindir}/dump.static
105  ln -sf restore .%{_sbindir}/rrestore
106#  ln -sf restore .%{_sbindir}/rrestore.static
107#  ln -sf restore .%{_sbindir}/restore.static
108  chmod ug-s .%{_sbindir}/rmt
109  mkdir -p .%{_sysconfdir}
110  > .%{_sysconfdir}/dumpdates
111  ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
112  strip $RPM_BUILD_ROOT/sbin/* $RPM_BUILD_ROOT/usr/sbin/* || :
113popd
114
115%clean
116rm -rf %{buildroot}
117
118%files
119%defattr(-,root,root)
120%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
121%doc dump.lsm
122%attr(0664,root,disk)   %config(noreplace) %{_sysconfdir}/dumpdates
123%attr(0755,root,root)   /sbin/dump
124/sbin/rdump
125%attr(0755,root,root)   /sbin/restore
126/sbin/rrestore
127#/sbin/*.static
128%{_mandir}/man8/dump.*
129%{_mandir}/man8/rdump.*
130%{_mandir}/man8/restore.*
131%{_mandir}/man8/rrestore.*
132
133%files -n rmt
134%defattr(-,root,root)
135%attr(0755,root,root)
136%{_sbindir}/rmt
137%{_sysconfdir}/rmt
138%{_mandir}/man8/rmt.*
139
140%changelog
141* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4b41-3
142- rebuild with rpm-4.8.1
143- add BuildRequires: libblkid-devel, libuuid-devel, bzip2-devel
144
145* Mon Jun 22 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-2
146- spec in UTF-8
147- change configure option to --disable-static
148- remove -static stuffs
149
150* Sun Apr 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-1
151- add Patch1 based on fedora development to build with device-mapper
152- add japanese summary and description.
153- apply new versioning policy.
154
155* Sun May 13 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-0vl1
156- new upstream release
157
158* Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4b34-0vl2
159- spec file was in SJIS. fixed.
160
161* Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b34-0vl1
162- new upstream release
163
164* Sun Feb  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b28-5vl1
165- update upstream release based on rawhide package.
166- rebuild on new environment.
167  * Fri Mar 15 2002 Toru Sagami <sagami@vinelinux.org> 0.4b22-4vl2
168  - rebuilt against fixed statically linked system libraries
169  * Sat Jul 14 2001 Toru Sagami <sagami@vinelinux.org>
170  - 0.4b22-4vl1: based on 0.4b22-4 from Rawhide
171
172* Mon Oct  7 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-5
173- All-arch rebuild
174
175* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
176- automated rebuild
177
178* Sun May 26 2002 Tim Powers <timp@redhat.com>
179- automated rebuild
180
181* Tue May 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-2
182- Updated to dump 0.4b28
183- Removed atomic_read/write patch, not needed anymore
184
185* Fri Mar  1 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-3
186- BuildRequires readline-devel >= 4.2 for the rl_completion_matches function
187- Added dump-0.4b27-dump-atomic-read-write.patch to avoid namespace conflict
188  with included kernel headers.  atomic_read is a function on s390 and as
189  such, cannot be #undef'd
190
191* Thu Feb 28 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-2
192- Added prereq on "setup" to ensure disk group is created prior to this
193  package being installed
194- Somehow the dump package changelog got hosed, and part of the spec file
195  regressed.  I believe it is fixed now.
196
197* Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-1
198- Updated to dump 0.4b27-1
199
200* Fri Feb 22 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-5
201- Bumped release up a couple notches to rebuild in rawhide
202 
203* Thu Feb 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-1.72.0
204- Rebuilt 0.4b25 for erratum release.  Fixes various bugs that have been
205  reported in bugzilla which are logged below.  Also fixes a bug caused by
206  linking statically to a faulty system library.
207- Added Provides dump-static line
208 
209* Mon Feb 11 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-3
210- Added missing zlib buildprereq
211- Rebuild in new environment
212
213* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
214- automated rebuild
215
216* Wed Nov 21 2001 Mike A. Harris <mharris@redhat.com> 0.4b25-1
217- Updated to version 0.4b25-1
218- Added homepage URL for RFE (#54601)
219- Also fixed in this release are (#21272, #52663, #56616)
220- Dropped time.h patch as it is unneeded now
221
222* Tue Nov  6 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-7
223- Updated BuildPreReq to e2fsprogs-devel >= 1.18, readline-devel >= 4.1 to
224  explicitly state the minimum required deps and fix (#51900)
225
226* Sat Sep  8 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-6
227- Kill the static subpackage - the standard binaries are now static
228  This removes /usb/sbin/*. The static versions are now in /sbin
229  (#53433)
230- Obsolete dump-static
231
232* Tue Aug 14 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-5
233- Move non-static binaries to /usr/sbin (#49520)
234
235* Fri Jun 29 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-4
236- Added BuildPrereq: readline-devel (#44734 - which was reopened and changed)
237
238* Sat Jun 16 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-3
239- Added BuildPrereq: libtermcap-devel (#44734)
240
241* Tue Jun 12 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-2
242- Removed release tag from buildroot dirname - messy.
243- Broke all lines over multiple lines for readability in specfile.
244- Added --enable-largefile configure flags
245
246* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de> 0.4b22-1
247- 0.4b22
248
249* Mon May  7 2001 Mike A. Harris <mharris@redhat.com> 0.4b21-5
250- Added BuildPrereq: e2fsprogs-devel (#27428)
251
252* Mon Apr  9 2001 Bill Nottingham <notting@redhat.com>
253- fix ia64
254
255* Wed Feb 14 2001 Bill Nottingham <notting@redhat.com>
256- fix build with current glibc
257
258* Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
259- change copyright: UCB to License: BSD
260
261* Fri Jan 26 2001 Nalin Dahyabhai <nalin@redhat.com>
262- update to 0.4b21.
263
264* Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
265- update to 0.4b20.
266
267* Fri Nov 10 2000 Stelian Pop <pop@cybercable.fr>
268- dump 0.4b20 released, first packaging.
269
270* Tue Oct 31 2000 Jeff Johnson <jbj@redhat.com>
271- remove setuid bits for Red Hat 5.x errata.
272
273* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
274- rebuild to cope with glibc locale binary incompatibility, again
275
276* Wed Aug 30 2000 Preston Brown <pbrown@redhat.com>
277- fix for dumping files between 2 and 4 gigs (#16466)
278
279* Mon Aug 21 2000 Matt Wilson <msw@redhat.com>
280- don't use -O2 on alpha because of compiler ICE
281
282* Sun Aug 20 2000 Jeff Johnson <jbj@redhat.com>
283- update to 0.4b19.
284
285* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
286- summaries from specspo.
287
288* Wed Aug 16 2000 Erik Troan <ewt@redhat.com>
289- support LABEL= in fstab
290
291* Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
292- if dump/restore aren't set(u|g)id, they don't need group tty (#12670)
293
294* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
295- rebuild to cope with glibc locale binary incompatibility
296
297* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
298- automatic rebuild
299
300* Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
301- whoops I had dump commented out of the file list.  fixed.
302- dropped suid bits on the static binaries.
303- fix char buffer size issue (#11880)
304
305* Mon Jun 19 2000 Preston Brown <pbrown@redhat.com>
306- dropped SUID bits
307
308* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
309- update to 0.4b17.
310- FHS packaging.
311
312* Thu Jun  1 2000 Stelian Pop <pop@cybercable.fr>
313- dump 0.4b17 released, first packaging.
314
315* Sat Mar 11 2000 Stelian Pop <pop@cybercable.fr>
316- dump 0.4b16 released, first packaging.
317
318* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
319- use posix signal handling to preserve dump functionality with libc5.
320
321* Thu Mar  2 2000 Bill Nottingham <notting@redhat.com>
322- update to 0.4b15
323
324* Thu Feb 10 2000 Jeff Johnson <jbj@redhat.com>
325- dump -0ufB /dev/ftape 1638000 /mnt2 fails to use /mnt2 as tape device (#8036)
326
327* Thu Feb 10 2000 Stelian Pop <pop@cybercable.fr>
328- dump 0.4b14 released, first packaging.
329
330* Wed Feb  9 2000 Jeff Johnson <jbj@redhat.com>
331- compress man pages.
332
333* Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
334- update to 0.4b13.
335
336* Fri Jan 21 2000 Stelian Pop <pop@cybercable.fr>
337- dump 0.4b13 released, first packaging.
338
339* Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com.
340- update to 0.4b12.
341
342* Fri Jan 8 2000 Stelian Pop <pop@cybercable.fr>
343- dump 0.4b12 released, first packaging.
344
345* Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
346- dump 0.4b11 released, first packaging.
347
348* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
349- intergrate Stelian's fixes (Thanks!).
350
351* Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
352- dump 0.4b10 released, first packaging.
353
354* Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
355- make static versions also for rescue purposes.
356
357* Wed Nov 5 1999 Stelian Pop <pop@cybercable.fr>
358- dump 0.4b9 released, first packaging.
359
360* Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
361- dump 0.4b8 released, first packaging.
362
363* Thu Oct 8 1999 Stelian Pop <pop@cybercable.fr>
364- dump 0.4b7 released, first packaging.
365
366* Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
367- dump 0.4b6 released, first packaging.
368
369* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
370- recompile with e2fsprogs = 1.15 (#4962).
371
372* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
373- workaround egcs bug (#4281) that caused dump problems (#2989).
374- use sigjmp_buf, not jmp_buf (#3260).
375- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
376- use glibc21 err/glob rather than the internal compatibility routines.
377- wire $(OPT) throughout Makefile's.
378- fix many printf problems, mostly lint clean.
379- merge SuSE, Debian and many OpenBSD fixes.
380
381* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
382- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
383
384* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
385- auto rebuild in the new build environment (release 6)
386
387* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
388- strip binaries.
389
390* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
391- Fix dangling symlinks (#1551).
392
393* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
394- Top O' the morning, build root's fixed for man pages. 
395
396* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
397- upgraded to dump 0.4b4, massaged patches.
398
399* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
400- added patch from Derrick J Brashear for traverse.c to stop bread errors
401
402* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
403- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
404- mark /etc/dumpdates as noreplace.
405
406* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
407- add build root.
408
409* Tue May 05 1998 Prospector System <bugs@redhat.com>
410- translations modified for de, fr, tr
411
412* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
413- added a patch for resolving linux/types.h and sys/types.h conflicts
414
415* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
416- added prototype of llseek() so dump would work on large partitions
417
418* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
419- made all symlinks relative instead of absolute
420
421* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
422- built against glibc
423
424* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
425- Moved rmt to its own package.
426
427* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
428- Added endian cleanups for SPARC
429
430* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
431- Made /etc/dumpdates writeable by group disk.
Note: See TracBrowser for help on using the repository browser.