source: projects/specs/branches/6/d/dovecot/dovecot-vl.spec @ 6671

Revision 6671, 33.0 KB checked in by iwamoto, 12 years ago (diff)

dovecot: update & fix ssl key path

Line 
1Summary: Dovecot Secure imap server
2Summary(ja): Dovecot セキュア IMAP サーバ
3Name: dovecot
4Version: 2.0.21
5Release: 2%{?_dist_release}
6#dovecot itself is MIT, a few sources are PD, pigeonhole is LGPLv2
7License: MIT and LGPLv2 and BSD with advertising
8Group: System Environment/Daemons
9
10%define build_postgres 1
11%define build_mysql 1
12%define build_sqlite 1
13%define build_ldap 1
14
15# pigeonhole
16%define build_pigeonhole 1
17%define pigeonholever 0.2.6
18
19# pop before smtp (drac)
20%define build_drac 1
21
22URL: http://www.dovecot.org/
23
24Source: http://www.dovecot.org/releases/2.0/%{name}-%{version}.tar.gz
25Source1: dovecot.init
26Source2: dovecot.pam
27Source8: http://www.rename-it.nl/dovecot/2.0/dovecot-2.0-pigeonhole-%{pigeonholever}.tar.gz
28Source9: dovecot.sysconfig
29Source10: dovecot.tmpfilesd
30
31#our own
32Source14: dovecot.conf.5
33
34# drac plugin (pop before smtp)
35# Source100: http://www.dovecot.org/patches/1.1/drac.c
36Source100: http://sourceforge.jp/projects/dovecot2-drac/downloads/53176/dovecot2-drac-0.1.tar.gz
37Source110: README.plugin-drac
38
39Patch1: dovecot-2.0-defaultconfig.patch
40Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
41# local filesystem rules
42Patch3: dovecot-1.0.rc7-mkcert-paths.patch
43
44Packager: iwamoto
45Vendor: Project Vine
46Distribution: Vine Linux
47
48Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
49BuildRequires: openssl-devel, pam-devel, zlib-devel
50BuildRequires: bzip2-devel, libcap-devel
51BuildRequires: libtool autoconf automake, gettext-devel
52BuildRequires: pkgconfig
53BuildRequires: krb5-devel
54
55# Package includes an initscript service file,
56# needs to require initscripts package
57Requires: initscripts
58Requires(pre): /usr/sbin/useradd
59Requires(post): /sbin/chkconfig, /usr/sbin/useradd, /sbin/chkconfig
60Requires(preun): /usr/sbin/userdel, /usr/sbin/groupdel
61Requires(preun): /sbin/chkconfig, /sbin/service
62Requires(postun): /sbin/service
63
64%if %{build_postgres}
65BuildRequires: postgresql-devel
66%endif
67
68%if %{build_mysql}
69BuildRequires: mysql-devel
70%endif
71
72%if %{build_sqlite}
73BuildRequires: sqlite3-devel
74%endif
75
76%if %{build_ldap}
77BuildRequires: openldap-devel
78%endif
79
80%if %{build_drac}
81BuildRequires: dracd
82%endif
83
84%define docdir %{_docdir}/%{name}
85%define ssldir %{_sysconfdir}/pki/%{name}
86
87%description
88Dovecot is an IMAP server for Linux/UNIX-like systems, written with security
89primarily in mind.  It also contains a small POP3 server.  It supports mail
90in either of maildir or mbox formats.
91
92The SQL drivers and authentication plugins are in their subpackages.
93
94
95%if %{build_pigeonhole}
96%package pigeonhole
97Requires: %{name} = %{version}-%{release}
98Obsoletes: dovecot-sieve
99Summary: Sieve and managesieve plug-in for dovecot
100Group: System Environment/Daemons
101License: MIT and LGPLv2
102
103%description pigeonhole
104This package provides sieve and managesieve plug-in for dovecot LDA.
105
106%endif
107
108%if %{build_postgres}
109%package pgsql
110Requires: %{name} = %{version}-%{release}
111Summary: Postgres SQL backend for dovecot
112Group: System Environment/Daemons
113%description pgsql
114This package provides the Postgres SQL backend for dovecot-auth etc.
115%endif
116
117%if %{build_mysql}
118%package mysql
119Requires: %{name} = %{version}-%{release}
120Summary: MySQL backend for dovecot
121Group: System Environment/Daemons
122%description mysql
123This package provides the MySQL backend for dovecot-auth etc.
124%endif
125
126%if %{build_sqlite}
127%package sqlite
128Requires: %{name} = %{version}-%{release}
129Summary: SQLite backend for dovecot
130Group: System Environment/Daemons
131%description sqlite
132This package provides the SQLite backend for dovecot-auth etc.
133%endif
134
135%if %{build_ldap}
136%package ldap
137Requires: %{name} = %{version}-%{release}
138Summary: LDAP auth plugin for dovecot
139Group: System Environment/Daemons
140%description ldap
141This package provides the LDAP auth plugin for dovecot-auth etc.
142%endif
143
144%if %{build_drac}
145%package drac
146Summary: Dovecot plugin module for support drac (POP before SMTP)
147Group: System Environment/Daemons
148Requires: %{name} = %{version}-%{release}
149Requires: dracd
150Obsoletes: %{name}-plugin-drac < %{version}-%{release}
151
152%description drac
153Dovecot plugin module for support drac (POP before SMTP)
154%endif
155
156%package devel
157Requires: %{name} = %{version}-%{release}
158Summary: Development files dor dovecot
159Group: Development/Libraries
160%description devel
161This package provides the development files for dovecot.
162
163
164%prep
165
166%setup -q
167
168%patch1 -p1 -b .default-settings
169%patch2 -p1 -b .mkcert-permissions
170%patch3 -p1 -b .mkcert-paths
171
172%if %{build_drac}
173%setup -T -D -q -a 100
174mv dovecot2-drac/README README.dovecot2-drac
175mv dovecot2-drac/README.j README.dovecot2-drac.jp
176cp %{SOURCE110} .
177%endif
178
179%if %{build_pigeonhole}
180%setup -q -D -T -a 8
181%endif
182
183%build
184# rm -f ./configure
185# autoreconf -i -f
186%configure                           \
187    INSTALL_DATA="install -c -p -m644" \
188    --enable-header-install      \
189    --disable-static             \
190%if %{build_postgres}
191    --with-pgsql                 \
192%endif
193%if %{build_mysql}
194    --with-mysql                 \
195%endif
196%if %{build_sqlite}
197    --with-sqlite                \
198%endif
199    --with-sql=plugin            \
200    --with-sql-drivers           \
201    --with-ssl=openssl           \
202    --with-ssldir=%{ssldir}      \
203    --with-libcap                \
204    --with-zlib                  \
205%if %{build_ldap}
206    --with-ldap=plugin
207%endif
208
209sed -i 's|/etc/ssl|/etc/pki/dovecot|' doc/mkcert.sh doc/example-config/conf.d/10-ssl.conf
210
211make %{?_smp_mflags}
212
213%if %{build_pigeonhole}
214#pigeonhole
215pushd dovecot-2.0-pigeonhole-%{pigeonholever}
216autoreconf -fiv
217%configure                             \
218    INSTALL_DATA="install -c -p -m644" \
219    --disable-static                   \
220    --with-dovecot=../                 \
221    --without-unfinished-features
222
223make %{?_smp_mflags}
224popd
225%endif
226
227%if %{build_drac}
228pushd dovecot2-drac
229make DOVDIR=../
230popd
231%endif
232
233%install
234rm -rf $RPM_BUILD_ROOT
235make install DESTDIR=$RPM_BUILD_ROOT
236rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
237
238%if %{build_pigeonhole}
239pushd dovecot-2.0-pigeonhole-%{pigeonholever}
240make install DESTDIR=$RPM_BUILD_ROOT
241popd
242%endif
243
244%if %{build_drac}
245pushd dovecot2-drac
246install -m 755 drac_plugin.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/
247mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dovecot/imap/
248mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dovecot/pop3/
249ln -s ../drac_plugin.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/imap/
250ln -s ../drac_plugin.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/pop3/
251popd
252%endif
253
254# install -p -m 755 src/plugins/convert/convert-tool $RPM_BUILD_ROOT%{_libexecdir}/%{name}
255
256mkdir -p $RPM_BUILD_ROOT%{_initrddir}
257install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/dovecot
258
259mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
260install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/dovecot
261
262mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
263install -p -m 600 %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/dovecot
264
265#install man pages
266install -p -D -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_mandir}/man5/dovecot.conf.5
267
268# generate ghost .pem file
269mkdir -p $RPM_BUILD_ROOT%{ssldir}/certs
270mkdir -p $RPM_BUILD_ROOT%{ssldir}/private
271touch $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
272chmod 600 $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
273touch $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
274chmod 600 $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
275
276mkdir -p $RPM_BUILD_ROOT/var/run/dovecot/login
277chmod 755 $RPM_BUILD_ROOT/var/run/dovecot
278chmod 700 $RPM_BUILD_ROOT/var/run/dovecot/login
279       
280# Install dovecot.conf and dovecot-openssl.cnf
281mkdir -p $RPM_BUILD_ROOT%{ssldir}
282mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
283install -p -m 644 doc/example-config/dovecot.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot
284install -p -m 644 doc/example-config/conf.d/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
285install -p -m 644 doc/example-config/conf.d/*.conf.ext $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
286install -p -m 644 doc/dovecot-openssl.cnf $RPM_BUILD_ROOT%{ssldir}/dovecot-openssl.cnf
287
288# Install pigeonhole conf
289pushd dovecot-2.0-pigeonhole-%{pigeonholever}
290install -p -m 644 doc/example-config/conf.d/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/conf.d
291popd
292
293# Install some of our own documentation
294# install -p -m644 %{SOURCE7} $RPM_BUILD_ROOT%{docdir}/REDHAT-FAQ.txt
295
296# Install the licensing files into the documentation area
297install -p -m644 COPYING* $RPM_BUILD_ROOT%{docdir}
298
299mkdir -p $RPM_BUILD_ROOT%{docdir}/examples/
300install -p -m755 doc/mkcert.sh $RPM_BUILD_ROOT%{_libexecdir}/%{name}/mkcert.sh
301# for f in `cd doc; echo *.conf`; do
302#      install -p -m644 doc/$f $RPM_BUILD_ROOT%{docdir}/examples/$f;
303# done
304
305mv $RPM_BUILD_ROOT%{docdir} $RPM_BUILD_ROOT%{docdir}-%{version}
306mkdir -p $RPM_BUILD_ROOT/var/lib/dovecot
307
308#remove the libtool archives
309find $RPM_BUILD_ROOT%{_libdir}/%{name}/ -name '*.la' | xargs rm -f
310
311#prepare the filelist
312(
313    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -type d | sed -e "s|^|%dir |";
314    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -! -type d | \
315        grep -v 'dovecot-config\|lib90_cmusieve_plugin\.so\|libdriver_.*\.so\|libauthdb_.*\.so\|libmech_.*\.so\|drac\.so';
316) | sed -e "s|$RPM_BUILD_ROOT||" >libs.filelist
317
318#remove what we don't want
319rm -f $RPM_BUILD_ROOT%{_sysconfdir}/dovecot/README
320pushd doc
321#rm -f securecoding.txt thread-refs.txt
322popd
323
324%clean
325rm -rf $RPM_BUILD_ROOT
326
327
328%pre
329getent group dovecot >/dev/null || groupadd -r dovecot
330getent passwd dovecot >/dev/null || \
331useradd -r -g dovecot -d /usr/libexec/dovecot -s /sbin/nologin -c "Dovecot IMAP server" dovecot
332getent group dovenull >/dev/null || groupadd -r dovenull
333getent passwd dovenull >/dev/null || \
334useradd -r -g dovenull -d /usr/libexec/dovecot -s /sbin/nologin -c "Dovecot's unauthorized user" dovenull
335exit 0
336
337%post
338/sbin/chkconfig --add %{name}
339# generate the ssl certificates
340if [ ! -f %{ssldir}/certs/%{name}.pem ]; then
341    SSLDIR=%{ssldir} OPENSSLCONFIG=%{ssldir}/dovecot-openssl.cnf \
342         %{_libexecdir}/%{name}/mkcert.sh &> /dev/null
343fi
344
345if ! test -f /var/run/dovecot/login/ssl-parameters.dat; then
346    dovecot --build-ssl-parameters &>/dev/null
347fi
348exit 0
349
350%preun
351if [ $1 = 0 ]; then
352    /sbin/service %{name} stop > /dev/null 2>&1 || :
353    /sbin/chkconfig --del %{name} || :
354fi
355
356%postun
357if [ "$1" -ge "1" ]; then
358    /sbin/service %{name} condrestart 2>/dev/null || :
359fi
360
361%check
362make check
363cd dovecot-2.0-pigeonhole-%{pigeonholever}
364make check
365
366%files -f libs.filelist
367%defattr(-,root,root,-)
368%doc doc/* AUTHORS ChangeLog COPYING COPYING.LGPL COPYING.MIT NEWS README
369# %doc AUTHORS ChangeLog NEWS README doc/*.txt
370
371%dir %{_sysconfdir}/dovecot
372%dir %{_sysconfdir}/dovecot/conf.d
373%config(noreplace) %{_sysconfdir}/dovecot/dovecot.conf
374%config(noreplace) %{_sysconfdir}/dovecot/conf.d/*.conf
375%config(noreplace) %{_sysconfdir}/dovecot/conf.d/*.conf.ext
376# %config(noreplace) %{_sysconfdir}/dovecot.conf
377
378%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/dovecot
379%{_initrddir}/dovecot
380%config(noreplace) %{_sysconfdir}/pam.d/dovecot
381%dir %{ssldir}
382%dir %{ssldir}/certs
383%dir %{ssldir}/private
384%config(noreplace) %{ssldir}/dovecot-openssl.cnf
385%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/certs/dovecot.pem
386%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/private/dovecot.pem
387
388%{_libexecdir}/%{name}
389%{_sbindir}/dovecot
390# %{_sbindir}/dovecotpw
391%{_bindir}/doveadm
392%{_bindir}/doveconf
393%{_bindir}/dsync
394
395%attr(0755,root,dovecot) %dir /var/run/dovecot
396%attr(0750,root,dovenull) %dir /var/run/dovecot/login
397# %attr(0755,root,dovecot) %{_libexecdir}/%{name}/mkcert.sh
398%attr(0750,dovecot,dovecot) %dir /var/lib/dovecot
399
400%{_mandir}/man1/deliver.1.gz
401%{_mandir}/man1/doveadm*.1.gz
402%{_mandir}/man1/doveconf.1.gz
403%{_mandir}/man1/dovecot*.1.gz
404%{_mandir}/man1/dsync.1.gz
405%{_mandir}/man5/dovecot.conf.5.gz
406%{_mandir}/man7/doveadm-search-query.7.gz
407
408%if %{build_pigeonhole}
409%files pigeonhole
410%defattr(-,root,root,-)
411%{_bindir}/sieve-dump
412%{_bindir}/sieve-test
413%{_bindir}/sievec
414%config(noreplace) %{_sysconfdir}/dovecot/conf.d/90-sieve.conf
415%config(noreplace) %{_sysconfdir}/dovecot/conf.d/20-managesieve.conf
416%{_libexecdir}/%{name}/managesieve
417%{_libexecdir}/%{name}/managesieve-login
418
419%dir %{_libdir}/dovecot/settings
420%{_libdir}/dovecot/settings/libmanagesieve_*.so
421
422%{_mandir}/man1/sieve-test.1.gz
423%{_mandir}/man1/sieve-dump.1.gz
424%{_mandir}/man1/sievec.1.gz
425%{_mandir}/man1/sieved.1.gz
426%{_mandir}/man7/pigeonhole.7.gz
427%endif
428
429%if %{build_mysql}
430%files mysql
431%defattr(-,root,root,-)
432%{_libdir}/%{name}/libdriver_mysql.so
433%{_libdir}/%{name}/auth/libdriver_mysql.so
434%{_libdir}/%{name}/dict/libdriver_mysql.so
435%endif
436
437%if %{build_postgres}
438%files pgsql
439%defattr(-,root,root,-)
440%{_libdir}/%{name}/libdriver_pgsql.so
441%{_libdir}/%{name}/auth/libdriver_pgsql.so
442%{_libdir}/%{name}/dict/libdriver_pgsql.so
443%endif
444
445%if %{build_sqlite}
446%files sqlite
447%defattr(-,root,root,-)
448%{_libdir}/%{name}/libdriver_sqlite.so
449%{_libdir}/%{name}/auth/libdriver_sqlite.so
450%{_libdir}/%{name}/dict/libdriver_sqlite.so
451%endif
452
453%if %{build_ldap}
454%files ldap
455%defattr(-,root,root,-)
456%{_libdir}/%{name}/auth/libauthdb_ldap.so
457%endif
458
459%if %{build_drac}
460%files drac
461%defattr(-,root,root)
462%{_libdir}/%{name}/drac_plugin.so
463%{_libdir}/%{name}/imap/drac_plugin.so
464%{_libdir}/%{name}/pop3/drac_plugin.so
465%doc README.plugin-drac
466%endif
467
468%files devel
469%defattr(-,root,root,-)
470%{_includedir}/%{name}
471%{_libdir}/%{name}/dovecot-config
472%{_datadir}/aclocal/dovecot.m4
473
474%changelog
475* Tue Jul 31 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.21-2
476- fix default ssl path (10-ssl.conf and etc)
477
478* Sat Jun 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.21-1
479- new upstream release
480- new upstream release pigeonhole 0.2.6
481
482* Mon Oct 31 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.15-1
483- new upstream release
484
485* Tue Sep 28 2011 Masanobu HAGANE <masanobu@hagane.jp> 2.0.13-2
486- revival drac_plugin.so (POP bedore SMTP) support
487- use DRAC plugin for Dovecot-2.x
488-  (get from http://sourceforge.jp/projects/dovecot2-drac/releases/)
489
490* Sat May 21 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.13-1
491- new upstream release
492
493* Sun Apr 17 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.12-1
494- new upstream release
495- new upstream release pigeonholever 0.2.3
496
497* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.0.9-6
498- rebuilt with postgresql-9.0.3
499
500* Mon Feb 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-5
501- fix pigeonhole R: (remove epoch)
502
503* Mon Jan 24 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-4
504- fix source url
505
506* Wed Jan 19 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-3
507- disable drac sub package (drac plugin not work with dovecot 2.x)
508
509* Mon Jan 17 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-2
510- fix config file path in dovecot.init
511- fix group of /var/run/dovecot/login
512
513* Sun Jan 16 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.9-1
514- new upstream release 2.0.x
515
516* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.15-2
517- rebuild with openssl-1.0.0c
518
519* Sat Oct  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.15-1
520- new upstream release with security fixes (CVE-2010-3780,3779,3707,3706)
521- add BR: pkgconfig
522
523* Thu Mar 11 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.11-1
524- new upstream release with mbox DoS fix
525
526* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-2
527- fix drac.so in libs.files
528
529* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-1
530- new upstream release
531
532* Fri Jan  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.9-1
533- new upstream release
534- update to dovecot sieve 1.1.8
535
536* Thu Sep 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-2
537- update to dovecot sieve 1.1.7 to fix BoF
538- add BR: bzip2-devel, libcap-devel
539
540* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-1
541- new upstream release
542
543* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-1
544- new upstream release 
545
546* Sun Jul 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.1-1
547- new upstream release
548
549* Tue Jul  7 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-1
550- new upstream 1.2.x release
551- update Patch1 to fit new release
552- README.plugin-drac in UTF-8
553
554* Tue Jun  2 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.16-1
555- new upstream release
556
557* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-3
558- rebuilt with MySQL-5.1.34.
559
560* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-2
561- add BuildRequires gettext-devel instead of gettext
562
563* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-1
564- new upstream release
565- update patch1 to fix new release
566
567* Mon Apr 27 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.14-1
568- new upstream release
569
570* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.13-2
571- rebuilt with openldap-2.4.11
572
573* Sun Mar 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.13-1
574- new upstream release
575
576* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.11-1
577- new upstream release
578
579* Sun Feb 01 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.10-1
580- new upstream release
581
582* Sun Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.8-1
583- new upstream release
584
585* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.6-1
586- new upstream release
587
588* Tue Oct 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-2
589- change BuildRequires sqlite-devel -> sqlite3-devel
590
591* Mon Oct 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-1
592- new upstream release
593
594* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
595- new upstream release
596
597* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
598- new upstream release
599- split ldap plugin to subpackage
600- split sql plugins to subpackages
601- add -devel subpackage
602- update drac module, rename to -drac from -plugin-drac
603- add dovecot-sieve
604
605* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.13-0vl2
606- build for VineSeed (0vl1 is for VinePlus 4.x)
607- new upstream release
608
609* Mon Jan 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.10-0vl2
610- build for VineSeed (0vl1 is for VinePlus 4.x)
611- new upstream release with security fix (CVE-2007-6598)
612- turn on daemon stop massage (Already start message is on)
613
614* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-0vl1
615- new upstream source
616
617* Wed Nov 21 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.7-0vl4
618- updated %%install section to support lib64 architecture
619
620* Sun Nov 04 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl3
621- rebuild for VineSeed (from VinePlus 4.x)
622
623  * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl1
624  - new upstream release
625  - rebuilt with postgresql-devel 8.2.5
626
627  * Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
628  - new upstream release
629
630  * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
631  - new upstream release
632
633* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl2
634- add Require dracd tag in plugin-drac
635
636* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl1
637- new upstream release
638
639* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl4
640- fix drac plugin make method
641- change drac.so install method (use sym link)
642- add README.plugin-drac
643
644* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl3
645- add dovecot-openssl.cnf install to doc
646- daemon restart message turn on when package is upgraded
647
648* Tue Oct 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl2
649- add drac.so (POP bedore SMTP) support
650
651* Mon Oct 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl1
652- new upstream release
653- drop patch500 (it is included in new release)
654- move Mysql buildreq tag to "if build_mysql" section
655- add Requires: postgresql-libs and Requires: MySQL-shared in "if-endif"
656- add Requires: openldap
657
658* Wed Aug 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0-0.rc17.0vl2
659- add Patch500 to fix directory traversal vulnerability (CVE-2007-2231)
660  note that version 1.0.rc29 and up have been already fixed in upstream
661
662* Mon Jan 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc17.0vl1
663- new upstream RC release
664
665* Sun Jan 07 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc16.0vl1
666- new upstream RC release
667
668* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl2
669- add Vendor/Distribution tag
670
671* Sun Dec 10 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl1
672- new upstream RC release
673- add BuildRequires: MySQL-shared, MySQL-devel
674- update patch100
675
676* Mon Oct 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-0.rc7.1vl2
677- rebuilt with MySQL 5.0.27
678
679* Mon Aug 28 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc7.1vl1
680- new upstream release
681- update default settings patch (Patch100)
682- build with openldap-2.3.24
683
684* Tue Aug  1 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc2.1vl1
685- first release for Vine Linux
686
687* Mon Jul 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.1
688- reenable inotify and see what happens
689
690* Thu Jul 13 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2
691- update to latest upstream release candidate
692- disable inotify for now, doesn't build -- this needs fixing though
693
694* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta8.2.1
695- rebuild
696
697* Thu Jun 08 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.2
698- put back pop3_uidl_format default that got lost
699  in the beta2->beta7 upgrade (would cause pop3 to not work
700  at all in many situations)
701
702* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.1
703- upgrade to latest upstream beta release (beta8)
704- contains a security fix in mbox handling
705
706* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta7.1
707- upgrade to latest upstream beta release
708- fixed BR 173048
709
710* Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
711- fix sqlite detection in upstream configure checks, second part
712  of #182240
713
714* Wed Mar  8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
715- fix scriplet noise some more
716
717* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.beta2.6
718- fix scriptlet error (mitr, #184151)
719
720* Mon Feb 27 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.5
721- fix #182240 by looking in lib64 for libs first and then lib
722- fix comment #1 in #182240 by copying over the example config files
723  to documentation directory
724
725* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.4.1
726- bump again for double-long bug on ppc(64)
727
728* Thu Feb 09 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.4
729- enable inotify as it should work now (#179431)
730
731* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.3.1
732- rebuilt for new gcc4.1 snapshot and glibc changes
733
734* Thu Feb 02 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.3
735- change the compiled-in defaults and adjust the default's configfile
736  commented-out example settings to match compiled-in defaults,
737  instead of changing the defaults only in the configfile, as per #179432
738- fix #179574 by providing a default uidl_format for pop3
739- half-fix #179620 by having plaintext auth enabled by default... this
740  needs more thinking (which one we really want) and documentation
741  either way
742
743* Tue Jan 31 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.2
744- update URL in description
745- call dovecot --build-ssl-parameters in postinst as per #179430
746
747* Mon Jan 30 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.1
748- fix spec to work with BUILD_DIR != SOURCE_DIR
749- forward-port and split pam-nocred patch
750
751* Mon Jan 23 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2
752- new upstream version, hopefully fixes #173928, #163550
753- fix #168866, use install -p to install documentation
754
755* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
756- rebuilt
757
758* Sat Nov 12 2005 Tom Lane <tgl@redhat.com> - 0.99.14-10.fc5
759- Rebuild due to mysql update.
760
761* Wed Nov  9 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-9.fc5
762- rebuilt with new openssl
763
764* Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-8.fc5
765- use include instead of pam_stack in pam config
766
767* Wed Jul 27 2005 John Dennis <jdennis@redhat.com> - 0.99.14-7.fc5
768- fix bug #150888, log authenication failures with ip address
769
770* Fri Jul 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-6.fc5
771- fix bug #149673, add dummy PAM_TTY
772
773* Thu Apr 28 2005 John Dennis <jdennis@redhat.com> - 0.99.14-5.fc4
774- fix bug #156159 insecure location of restart flag file
775
776* Fri Apr 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-4.fc4
777- openssl moved its certs, CA, etc. from /usr/share/ssl to /etc/pki
778
779* Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.99.14-3.fc4
780- Rebuild for Postgres 8.0.2 (new libpq major version).
781
782* Mon Mar  7 2005 John Dennis <jdennis@redhat.com> 0.99.14-2.fc4
783- bump rev for gcc4 build
784
785* Mon Feb 14 2005 John Dennis <jdennis@redhat.com> - 0.99.14-1.fc4
786- fix bug #147874, update to 0.99.14 release
787  v0.99.14 2005-02-11  Timo Sirainen <tss at iki.fi>
788  - Message address fields are now parsed differently, fixing some
789    issues with spaces. Affects only clients which use FETCH ENVELOPE
790    command.
791  - Message MIME parser was somewhat broken with missing MIME boundaries
792  - mbox: Don't allow X-UID headers in mails to override the UIDs we
793    would otherwise set. Too large values can break some clients and
794    cause other trouble.
795  - passwd-file userdb wasn't working
796  - PAM crashed with 64bit systems
797  - non-SSL inetd startup wasn't working
798  - If UID FETCH notices and skips an expunged message, don't return
799    a NO reply. It's not needed and only makes clients give error
800    messages.
801
802* Wed Feb  2 2005 John Dennis <jdennis@redhat.com> - 0.99.13-4.devel
803- fix bug #146198, clean up temp kerberos tickets
804
805* Mon Jan 17 2005 John Dennis <jdennis@redhat.com> 0.99.13-3.devel
806- fix bug #145214, force mbox_locks to fcntl only
807- fix bug #145241, remove prereq on postgres and mysql, allow rpm auto
808  dependency generator to pick up client lib dependency if needed.
809
810* Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.devel
811- make postgres & mysql conditional build
812- remove execute bit on migration example scripts so rpm does not pull
813  in additional dependences on perl and perl modules that are not present
814  in dovecot proper.
815- add REDHAT-FAQ.txt to doc directory
816
817* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.devel
818- bring up to date with latest upstream, 0.99.13, bug #143707
819  also fix bug #14462, bad dovecot-uid macro name
820
821* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel
822- fix bug #133618, removed LITERAL+ capability from capability string
823
824* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel
825- fix bug #134325, stop dovecot during installation
826
827* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel
828- fix bug #129539, dovecot starts too early,
829  set chkconfig to 65 35 to match cyrus-imapd
830- also delete some old commented out code from SSL certificate creation
831
832* Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel
833- add UW to Dovecot migration documentation and scripts, bug #139954
834  fix SSL documentation and scripts, add missing documentation, bug #139276
835
836* Thu Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1
837- rebuild against MySQL4
838
839* Thu Oct 21 2004 John Dennis <jdennis@redhat.com>
840- fix bug #136623
841  Change License field from GPL to LGPL to reflect actual license
842
843* Thu Sep 30 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.3
844- fix bug #124786, listen to ipv6 as well as ipv4
845
846* Wed Sep  8 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.1
847- bring up to latest upstream,
848  comments from Timo Sirainen <tss at iki.fi> on release v0.99.11 2004-09-04 
849  + 127.* and ::1 IP addresses are treated as secured with
850    disable_plaintext_auth = yes
851  + auth_debug setting for extra authentication debugging
852  + Some documentation and error message updates
853  + Create PID file in /var/run/dovecot/master.pid
854  + home setting is now optional in static userdb
855  + Added mail setting to static userdb
856  - After APPENDing to selected mailbox Dovecot didn't always notice the
857    new mail immediately which broke some clients
858  - THREAD and SORT commands crashed with some mails
859  - If APPENDed mail ended with CR character, Dovecot aborted the saving
860  - Output streams sometimes sent data duplicated and lost part of it.
861    This could have caused various strange problems, but looks like in
862    practise it rarely caused real problems.
863
864* Wed Aug  4 2004 John Dennis <jdennis@redhat.com>
865- change release field separator from comma to dot, bump build number
866
867* Mon Aug  2 2004 John Dennis <jdennis@redhat.com> 0.99.10.9-1,FC3,1
868- bring up to date with latest upstream, fixes include:
869- LDAP support compiles now with Solaris LDAP library
870- IMAP BODY and BODYSTRUCTURE replies were wrong for MIME parts which
871  didn't contain Content-Type header.
872- MySQL and PostgreSQL auth didn't reconnect if connection was lost
873  to SQL server
874- Linking fixes for dovecot-auth with some systems
875- Last fix for disconnecting client when downloading mail longer than
876  30 seconds actually made it never disconnect client. Now it works
877  properly: disconnect when client hasn't read _any_ data for 30
878  seconds.
879- MySQL compiling got broken in last release
880- More PostgreSQL reconnection fixing
881
882
883* Mon Jul 26 2004 John Dennis <jdennis@redhat.com> 0.99.10.7-1,FC3,1
884- enable postgres and mySQL in build
885- fix configure to look for mysql in alternate locations
886- nuke configure script in tar file, recreate from configure.in using autoconf
887
888- bring up to latest upstream, which included:
889- Added outlook-pop3-no-nuls workaround to fix Outlook hang in mails with NULs.
890- Config file lines can now contain quoted strings ("value ")
891- If client didn't finish downloading a single mail in 30 seconds,
892  Dovecot closed the connection. This was supposed to work so that
893  if client hasn't read data at all in 30 seconds, it's disconnected.
894- Maildir: LIST now doesn't skip symlinks
895
896
897* Wed Jun 30 2004 John Dennis <jdennis@redhat.com>
898- bump rev for build
899- change rev for FC3 build
900
901* Fri Jun 25 2004 John Dennis <jdennis@redhat.com> - 0.99.10.6-1
902- bring up to date with upstream,
903  recent change log comments from Timo Sirainen were:
904  SHA1 password support using OpenSSL crypto library
905  mail_extra_groups setting
906  maildir_stat_dirs setting
907  Added NAMESPACE capability and command
908  Autocreate missing maildirs (instead of crashing)
909  Fixed occational crash in maildir synchronization
910  Fixed occational assertion crash in ioloop.c
911  Fixed FreeBSD compiling issue
912  Fixed issues with 64bit Solaris binary
913
914* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
915- rebuilt
916
917* Thu May 27 2004 David Woodhouse <dwmw2@redhat.com> 0.99.10.5-1
918- Update to 0.99.10.5 to fix maildir segfaults (#123022)
919
920* Fri May 07 2004 Warren Togami <wtogami@redhat.com> 0.99.10.4-4
921- default auth config that is actually usable
922- Timo Sirainen (author) suggested functionality fixes
923  maildir, imap-fetch-body-section, customflags-fix
924
925* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
926- Use ':' instead of '.' as separator for chown.
927
928* Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0.99.10.4-3
929- restart properly if it dies (#115594)
930
931* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
932- rebuilt
933
934* Mon Nov 24 2003 Jeremy Katz <katzj@redhat.com> 0.99.10.4-1
935- update to 0.99.10.4
936
937* Mon Oct  6 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-7
938- another patch from upstream to fix returning invalid data on partial
939  BODY[part] fetches
940- patch to avoid confusion of draft/deleted in indexes
941
942* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-6
943- add some patches from upstream (#104288)
944
945* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-5
946- fix startup with 2.6 with patch from upstream (#103801)
947
948* Tue Sep  2 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-4
949- fix assert in search code (#103383)
950
951* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.99.10-3
952- rebuild
953
954* Thu Jul 17 2003 Bill Nottingham <notting@redhat.com> 0.99.10-2
955- don't run by default
956
957* Thu Jun 26 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-1
958- 0.99.10
959
960* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.2
961- 0.99.10-rc2 (includes ssl detection fix)
962- a few tweaks from fedora
963  - noreplace the config file
964  - configure --with-ldap to get LDAP enabled
965
966* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.1
967- 0.99.10-rc1
968- add fix for ssl detection
969- add zlib-devel to BuildRequires
970- change pam service name to dovecot
971- include pam config
972
973* Thu May  8 2003 Jeremy Katz <katzj@redhat.com> 0.99.9.1-1
974- update to 0.99.9.1
975- add patch from upstream to fix potential bug when fetching with
976  CR+LF linefeeds
977- tweak some things in the initscript and config file noticed by the
978  fedora folks
979
980* Sun Mar 16 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-2
981- fix ssl dir
982- own /var/run/dovecot/login with the correct perms
983- fix chmod/chown in post
984
985* Fri Mar 14 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-1
986- update to 0.99.8.1
987
988* Tue Mar 11 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-2
989- add a patch to fix quoting problem from CVS
990
991* Mon Mar 10 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-1
992- 0.99.8
993- add some buildrequires
994- fixup to build with openssl 0.9.7
995- now includes a pop3 daemon (off by default)
996- clean up description and %%preun
997- add dovecot user (uid/gid of 97)
998- add some buildrequires
999- move the ssl cert to %{_datadir}/ssl/certs
1000- create a dummy ssl cert in %post
1001- own /var/run/dovecot
1002- make the config file a source so we get default mbox locks of fcntl
1003
1004* Sun Dec  1 2002 Seth Vidal <skvidal@phy.duke.edu>
1005- 0.99.4 and fix startup so it starts imap-master not vsftpd :)
1006
1007* Tue Nov 26 2002 Seth Vidal <skvidal@phy.duke.edu>
1008- first build
Note: See TracBrowser for help on using the repository browser.