source: projects/specs/branches/6/d/docutils/docutils-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name docutils
2%define version 0.5
3%define release 3%{?_dist_release}
4
5Summary: an open-source text processing system written in Python
6Summary(ja): Pythonで書かれたテキスト処理システム
7Name: %{name}
8Version: %{version}
9Release: %{release}
10Source0: http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
11License: public domain
12Group: Applications/Text
13URL: http://docutils.sourceforge.net/
14
15Requires: python
16BuildRequires: python-devel
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildArch: noarch
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24Docutils is an open-source text processing system for processing
25plaintext documentation into useful formats, such as HTML or LaTeX.
26It includes reStructuredText, the easy to read, easy to use,
27what-you-see-is-what-you-get plaintext markup language.
28
29%description -l ja
30Docutilsはオープンソースのテキスト処理システムで、プレーンテキストの
31文書をHTMLやLaTeXなどの使いやすいフォーマットに変換するものです。
32読みやすく使いやすくWYSIWYGなプレーンテキストのマークアップ言語である
33reStructuresTextを含んでいます。
34
35%prep
36%setup -q
37
38%build
39%{__python} setup.py build
40
41%install
42rm -rf $RPM_BUILD_ROOT
43%{__python} setup.py install --root=${RPM_BUILD_ROOT}
44
45for file in %{buildroot}/%{_bindir}/*.py; do
46    mv $file `dirname $file`/`basename $file .py`
47    ln -sf `basename $file .py` `dirname $file`/`basename $file`
48done
49
50install -D -m644 extras/roman.py ${RPM_BUILD_ROOT}/%{python_sitelib}/roman.py
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(-,root,root)
57%doc BUGS.txt HISTORY.txt RELEASE-NOTES.txt docs COPYING.txt THANKS.txt FAQ.txt README.txt
58%{_bindir}/*
59%{python_sitelib}/%{name}/
60%{python_sitelib}/roman.*
61%{python_sitelib}/docutils-*.egg-info
62
63%changelog
64* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.5-3
65- rebuilt with python-2.6.4
66
67* Thu Aug  6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5-2
68- rename /usr/bin/*.py to /usr/bin/*
69  (keep symlinking to *.py for compatibility - should be removed in the future)
70
71* Wed Jul 01 2009 Shu KONNO <owa@bg.wakwak.com> 0.5-1
72- updated docutils to 0.5
73- added BuildArch: noarch
74
75* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-1vl5
76- rebuilt with python-2.5.2
77- applied new versioning policy and spec in utf-8
78
79* Thu Jan 31 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-0vl4
80- defined python_sitelib by using distutils.sysconfig.get_python_lib()
81- updated module directory with platform-independent path
82- added script to install extras/roman.py (missing if it's already on the system)
83
84* Sun Sep 9 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.4-0vl2
85- initial build for Vine Linux
86
Note: See TracBrowser for help on using the repository browser.