source: projects/specs/branches/6/d/dockmanager/dockmanager-vl.spec @ 3440

Revision 3440, 2.6 KB checked in by owa, 13 years ago (diff)

dbus-sharp,dbus-sharp-glib,dockmanager,docky

Line 
1Summary:        dock-independent helper scripts
2Summary(ja):    ドック用ヘルパースクリプト
3Name:           dockmanager
4Version:        0.1.0
5Release:        2%{?_dist_release}
6Source0:        %{name}-%{version}.tar.gz
7License:        GPLv3
8Group:          System Environment/Libraries
9URL:            https://launchpad.net/dockmanager
10
11BuildRequires:  glib2 >= 2.18.0
12BuildRequires:  libdesktop-agnostic-devel >= 0.3.9
13BuildRequires:  libdesktop-agnostic-bin >= 0.3.9
14BuildRequires:  dbus-glib-devel
15Requires(pre):  GConf2
16Requires(post): GConf2
17Requires(preun):GConf2
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20Packager:       kazutaka
21
22%description
23This package contains dock-independent helper scripts, which add functionality
24to any dock implementing the DockManager DBus interface specification.
25
26%description -l ja
27このパッケージには、DockManager DBus インターフェーススペックに準拠した
28ドックで利用できるヘルパースクリプトが含まれます。
29
30
31%prep
32%setup -q
33
34
35%build
36%configure --enable-shared \
37           --disable-static \
38           --disable-debug
39%{__make} %{?_smp_mflags}
40
41
42%install
43%{__rm} -rf $RPM_BUILD_ROOT
44%{__make} install DESTDIR=$RPM_BUILD_ROOT
45
46# remove unnecessary files
47##find $RPM_BUILD_ROOT/%{_libdir} -name "*.la" -exec %{__rm} -f "{}" \;
48##find $RPM_BUILD_ROOT/%{_libdir} -name "*.a" -exec %{__rm} -f "{}" \;
49find $RPM_BUILD_ROOT/%{_prefix}/lib -name "*.la" -exec %{__rm} -f "{}" \;
50find $RPM_BUILD_ROOT/%{_prefix}/lib -name "*.a" -exec %{__rm} -f "{}" \;
51
52
53%clean
54%{__rm} -rf $RPM_BUILD_ROOT
55
56
57%pre
58# uninstall old schemas before update
59if [ "$1" -gt 1 ]; then
60  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
61  gconftool-2 --makefile-uninstall-rule \
62      %{_sysconfdir}/gconf/schemas/%{name}-daemon.schemas > /dev/null ||:
63fi
64
65%post
66# install schemas after install/update
67export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
68gconftool-2 --makefile-install-rule \
69    %{_sysconfdir}/gconf/schemas/%{name}-daemon.schemas > /dev/null ||:
70
71%preun
72# uninstall schemas before clean remove
73if [ "$1" -eq 0 ]; then
74  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
75  gconftool-2 --makefile-uninstall-rule \
76      %{_sysconfdir}/gconf/schemas/%{name}-daemon.schemas > /dev/null;
77fi
78
79
80%files
81%defattr(-,root,root)
82%doc AUTHORS COPYING
83%{_sysconfdir}/gconf/schemas/%{name}-daemon.schemas
84%{_bindir}/%{name}-settings
85%{_libexecdir}/%{name}-daemon
86%{python_sitelib}/%{name}
87%{_datadir}/dbus-1/services/%{name}.service
88%{_datadir}/%{name}
89
90
91%changelog
92* Wed Apr 13 2011 Shu KONNO <owa@bg.wakwak.com> 0.1.0-2
93- fixed remove files path
94- fixed changelog typo
95
96* Sun Jan 23 2005 Kazutaka HARADA <kazutaka@vinelinux.org> 0.1.0-1
97- initial build for Vine Linux
98
Note: See TracBrowser for help on using the repository browser.