source: projects/specs/branches/6/d/docbook-utils/docbook-utils-vl.spec @ 3010

Revision 3010, 7.9 KB checked in by daisuke, 13 years ago (diff)

docbook-utils: add patch to use grep-2.7 (char class syntax was changed)

Line 
1%define name    docbook-utils
2%define ver     0.6.14
3%define rel     4%{?_dist_release}
4
5Summary:        Shell scripts for managing DocBook documents.
6Summary(ja):    DocBook ドキュメントを操作するためのスクリプト集
7Name:           %{name}
8Version:        %{ver}
9Release:        %{rel}
10License:        GPL
11Group:          Applications/Text
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildArch:      noarch
14
15Requires:       docbook-style-dsssl >= 1.72
16Requires:       docbook-dtds
17Requires:       perl-SGMLSpm >= 1.03ii
18Requires:       which
19Requires:       texlive w3m
20Obsoletes:      stylesheets
21Provides:       stylesheets
22
23BuildRequires:  docbook-style-dsssl >= 1.72
24BuildRequires:  docbook-dtds
25BuildRequires:  perl-SGMLSpm
26
27Source0: %{name}-%{version}.tar.gz
28Source1: db2html
29Source2: gdp-both.dsl
30# Vine (Original of Source3 is Source2)
31Source3: gdp-both.dsl.vine 
32
33# Vine Patches
34# for using w3m priority
35Patch100: docbook-utils-w3m.patch
36
37# for grep-2.7 character class syntax
38Patch110: docbook-utils-0.6.14-grep27.patch
39
40%description
41This package contains scripts are for easy conversion from DocBook
42files to other formats (for example, HTML, RTF, and PostScript), and
43for comparing SGML files.
44
45%description -l ja
46DocBook ドキュメントを他の形式 (例: HTML, RTF, PostScript) に変換したり、
47SGML と比較するためのスクリプト集です。
48
49%package pdf
50Summary: A script for converting DocBook documents to PDF format.
51Summary(ja): DocBook ドキュメントを PDF 形式に変換するスクリプト
52Group: Applications/Text
53Requires: texlive
54Requires: docbook-utils = %{version}
55Obsoletes: stylesheets-db2pdf
56Provides: stylesheets-db2pdf
57
58
59%description pdf
60This package contains a script for converting DocBook documents to
61PDF format.
62
63%description pdf
64DocBook ドキュメントを PDF 形式に変換するためのスクリプトです。
65
66%prep
67%setup -q
68%patch100 -p1 -b .w3m
69%patch110 -p1 -b .grep27
70
71%build
72
73%configure --prefix=%{_prefix} --mandir=%{_mandir}
74make
75
76%install
77[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
78
79%makeinstall
80for util in dvi html pdf ps rtf
81do
82        ln -s docbook2$util $RPM_BUILD_ROOT%{_bindir}/db2$util
83        ln -s jw.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/db2$util.1
84done
85# db2html is not just a symlink, as it has to create the output directory
86rm -f $RPM_BUILD_ROOT%{_bindir}/db2html
87install -c -m 775 %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/db2html
88install -c -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/sgml/docbook/utils-%{version}/docbook-utils.dsl
89install -c -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/sgml/docbook/utils-%{version}/docbook-utils-a4.dsl
90perl -pi -e 's/^ "USletter"/ "A4"/' $RPM_BUILD_ROOT%{_datadir}/sgml/docbook/utils-%{version}/docbook-utils-a4.dsl
91
92# rm docdir
93rm -r $RPM_BUILD_ROOT/usr/doc
94
95%clean
96[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
97
98
99%files
100%defattr (-,root,root)
101%doc README COPYING TODO doc/HTML/*.html
102%{_bindir}/jw
103%{_bindir}/docbook2dvi
104%{_bindir}/docbook2html
105%{_bindir}/docbook2man
106%{_bindir}/docbook2ps
107%{_bindir}/docbook2rtf
108%{_bindir}/docbook2tex
109%{_bindir}/docbook2texi
110%{_bindir}/docbook2txt
111%{_bindir}/db2dvi
112%{_bindir}/db2html
113%{_bindir}/db2ps
114%{_bindir}/db2rtf
115%{_bindir}/sgmldiff
116%{_datadir}/sgml/docbook/utils-%{version}
117%{_mandir}/*/db2dvi.*
118%{_mandir}/*/db2html.*
119%{_mandir}/*/db2ps.*
120%{_mandir}/*/db2rtf.*
121%{_mandir}/*/docbook2dvi.*
122%{_mandir}/*/docbook2html.*
123%{_mandir}/*/docbook2ps.*
124%{_mandir}/*/docbook2rtf.*
125%{_mandir}/*/docbook2man.*
126%{_mandir}/*/docbook2tex.*
127%{_mandir}/*/docbook2texi.*
128%{_mandir}/*/jw.*
129%{_mandir}/*/sgmldiff.*
130%{_mandir}/*/*-spec.*
131
132%files pdf
133%defattr (-,root,root)
134%{_bindir}/docbook2pdf
135%{_bindir}/db2pdf
136%{_mandir}/*/db2pdf.*
137%{_mandir}/*/docbook2pdf.*
138
139%changelog
140* Sat Mar 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.14-4
141- add patch110 to use grep-2.7 (char class syntax was changed)
142
143* Sun Aug 15 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.14-3
144- change BuildRequires: texlive instead of jadetex
145
146* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.14-2vl5
147- applied new versioning policy, spec in utf-8
148
149* Tue Jul 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.14-2vl1
150- new upstream release
151- dropped Patch0 and 1 because those integrated to upstream
152- add Requires: jadetex, w3m
153- added Patch100 to use /usr/bin/w3m priority
154
155* Mon Sep 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.13-7vl1
156- based on Rawhide 0.6.13-7
157  * Tue Jun 10 2003 Tim Waugh <twaugh@redhat.com> 0.6.13-7
158  - Fix manpage output: escape dots in column 1 (bug #97087).
159
160* Sun May 18 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.13-3vl2
161- use gdp-both.dsl.vine instead of gdp-both.dsl
162  (for enable use-id-as-filename)
163- fixed spec file
164
165* Wed May  7 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.13-3vl1
166- based on Rawhide 0.6.13-3
167  - Move docbook2pdf man pages to pdf subpackage (bug #90041).
168  - 0.6.13, fixing bug #86152.
169- added html document in %{_docdir}
170
171* Sun Feb  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.12-5vl1
172- based on Rawhide 0.6.12-5
173  - Build reqires perl-SGMLSpm
174  - Fixed from CVS
175  - No longer need separate stylesheet for A4
176- add Japanese summary and description
177
178* Sat Oct 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.12-0vl1
179- 0.6.12
180- add BuildRequires docbook-dtd31-sgml (make uses this...)
181
182* Mon Sep 30 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.11-2vl4
183- fix Requires (previous version didn't change... )
184
185* Sat Sep 28 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.11-2vl3
186- change Require docbook-dtd-sgml, docbook-dtd-xml
187
188* Sat Sep 28 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.11-2vl2
189- updated to 0.6.11 by based on rawhide 0.6.11-2
190- don't apply patch
191
192* Thu Oct 11 2001 Akira TAGOH <tagoh@gnome.gr.jpj> 0.6.9-2vl1
193- Rebuild for Vine.
194
195* Mon Aug 13 2001 Tim Waugh <twaugh@redhat.com> 0.6.9-2
196- Larger bottom margin in gdp-both.dsl to fix RTF output (bug #49677).
197
198* Tue Jul  3 2001 Tim Waugh <twaugh@redhat.com> 0.6.9-1
199- 0.6.9.
200- With --nochunks, send output to a file instead of stdout (bug #46913).
201
202* Mon Jun  4 2001 Tim Waugh <twaugh@redhat.com> 0.6.8-2
203- Make sure COPYING isn't installed as a symlink.
204
205* Mon May 21 2001 Tim Waugh <twaugh@redhat.com> 0.6.8-1
206- 0.6.8.
207
208* Mon May 21 2001 Tim Waugh <twaugh@redhat.com> 0.6-14
209- db2html: copy admon graphics to output directory (bug #40143).
210- Require docbook-style-dsssl 1.64-2 for symbolic link used by db2html.
211- db2html: handle arguments with spaces better.
212
213* Sat Mar 24 2001 Tim Waugh <twaugh@redhat.com> 0.6-13
214- Fix man pages (bug #32820).
215
216* Mon Mar 12 2001 Tim Waugh <twaugh@redhat.com>
217- Fix argument parsing in docbook2xxx (bug #31518).
218- Fix argument passing in db2html (bug #31520).
219- Fix pdf generation (bug #31524).
220
221* Fri Feb 23 2001 Tim Waugh <twaugh@redhat.com>
222- Allow the use of custom backends and frontends (bug #29067).
223
224* Fri Feb 16 2001 Tim Waugh <twaugh@redhat.com>
225- Use gdp-both.dsl as the default stylesheet.
226
227* Mon Feb 12 2001 Tim Waugh <twaugh@redhat.com>
228- REALLY only create output directory for db2html (duh).
229- Handle filenames with dots in properly.
230
231* Sun Feb 11 2001 Tim Waugh <twaugh@redhat.com>
232- Only create output directory for db2html (bug #27092). (docbook2html
233  does not create an output directory in the upstream version, but
234  the compatibility script has been made to do so.)
235
236* Mon Jan 22 2001 Tim Waugh <twaugh@redhat.com>
237- Move the jadetex requirement to the -pdf subpackage.
238
239* Tue Jan 16 2001 Tim Waugh <twaugh@redhat.com>
240- Put output files in new directory instead of current directory.
241
242* Mon Jan 15 2001 Tim Waugh <twaugh@redhat.com>
243- Don't play so many macro games.
244- Be sure to own utils directory.
245
246* Fri Jan 12 2001 Tim Waugh <twaugh@redhat.com>
247- Split off docbook2pdf into subpackage for dependency reasons.
248
249* Mon Jan 08 2001 Tim Waugh <twaugh@redhat.com>
250- Change group.
251- Use %%{_mandir} and %%{_prefix}.
252- db2* symlinks.
253- Obsolete stylesheets (and -db2pdf).
254- Change Copyright: to License:.
255- Remove Packager: line.
256- Reword description.
257
258* Mon Jan 08 2001 Tim Waugh <twaugh@redhat.com>
259- Based on Eric Bischoff's new-trials packages.
Note: See TracBrowser for help on using the repository browser.