source: projects/specs/branches/6/d/dnsmasq/dnsmasq-vl.spec @ 3525

Revision 3525, 8.5 KB checked in by owa, 13 years ago (diff)

rebuilt

Line 
1Name:           dnsmasq
2Version:        2.45
3Release:        2%{?_dist_release}
4Summary:        A lightweight DHCP/caching DNS server
5Summary(ja):    軽量 DHCP/DNSキャッシュサーバ
6
7Group:          System Environment/Daemons
8License:        GPLv2 or GPLv3
9URL:            http://www.thekelleys.org.uk/dnsmasq/
10Source0:        http://www.thekelleys.org.uk/dnsmasq/%{name}-%{version}.tar.gz
11Patch0:         %{name}-2.33-initscript.patch
12Patch1:         %{name}-configuration.patch
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildRequires:  dbus-devel
16BuildRequires:  pkgconfig
17
18Requires(post):  /sbin/chkconfig
19Requires(post):  /sbin/service
20Requires(post):  /bin/sed /bin/grep
21Requires(preun): /sbin/chkconfig
22Requires(preun): /sbin/service
23
24%description
25Dnsmasq is lightweight, easy to configure DNS forwarder and DHCP server.
26It is designed to provide DNS and, optionally, DHCP, to a small network.
27It can serve the names of local machines which are not in the global
28DNS. The DHCP server integrates with the DNS server and allows machines
29with DHCP-allocated addresses to appear in the DNS with names configured
30either in each host or in a central configuration file. Dnsmasq supports
31static and dynamic DHCP leases and BOOTP for network booting of diskless
32machines.
33
34
35%prep
36%setup -q -n %{name}-%{version}
37%patch0 -p1
38%patch1 -p1
39
40%build
41make %{?_smp_mflags}
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46# normally i'd do 'make install'...it's a bit messy, though
47mkdir -p $RPM_BUILD_ROOT%{_sbindir} $RPM_BUILD_ROOT%{_initrddir} \
48        $RPM_BUILD_ROOT%{_mandir}/man8 \
49        $RPM_BUILD_ROOT%{_var}/lib/dnsmasq \
50        $RPM_BUILD_ROOT%{_sysconfdir}/dnsmasq.d \
51        $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d
52install src/dnsmasq $RPM_BUILD_ROOT%{_sbindir}/dnsmasq
53install dnsmasq.conf.example $RPM_BUILD_ROOT%{_sysconfdir}/dnsmasq.conf
54install dbus/dnsmasq.conf $RPM_BUILD_ROOT%{_sysconfdir}/dbus-1/system.d/
55install rpm/dnsmasq.init $RPM_BUILD_ROOT%{_initrddir}/dnsmasq
56install -m 644 man/dnsmasq.8 $RPM_BUILD_ROOT%{_mandir}/man8/
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post
62if [ "$1" = "2" ]; then # if we're being upgraded
63    # if using the old leases location, move the file to the new one
64    # but only if we're not clobbering another file
65    #
66    if [ -f /var/lib/misc/dnsmasq.leases -a ! -f /var/lib/dnsmasq/dnsmasq.leases ]; then
67        # causes rpmlint to report dangerous-command-in-post,
68        # but that's the price of selinux compliance :-(
69        mv -f /var/lib/misc/dnsmasq.leases /var/lib/dnsmasq/dnsmasq.leases || :
70    fi
71    # ugly, but kind of necessary
72    if [ ! `grep -q dhcp-leasefile=/var/lib/misc/dnsmasq.leases %{_sysconfdir}/dnsmasq.conf` ]; then
73        cp %{_sysconfdir}/dnsmasq.conf %{_sysconfdir}/dnsmasq.conf.tmp || :
74        sed -e 's/var\/lib\/misc/var\/lib\/dnsmasq/' < %{_sysconfdir}/dnsmasq.conf.tmp > %{_sysconfdir}/dnsmasq.conf || :
75        rm -f %{_sysconfdir}/dnsmasq.conf.tmp || :
76    fi
77    /sbin/service dnsmasq condrestart >/dev/null 2>&1 || :
78else # if we're being installed
79    /sbin/chkconfig --add dnsmasq
80fi
81
82%preun
83if [ "$1" = "0" ]; then     # execute this only if we are NOT doing an upgrade
84    /sbin/service dnsmasq stop >/dev/null 2>&1 || :
85    /sbin/chkconfig --del dnsmasq
86fi
87
88
89%files
90%defattr(-,root,root,-)
91%doc CHANGELOG COPYING FAQ doc.html setup.html dbus/DBus-interface
92%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dnsmasq.conf
93%dir /etc/dnsmasq.d
94%dir %{_var}/lib/dnsmasq
95%config(noreplace) %attr(644,root,root) %{_sysconfdir}/dbus-1/system.d/dnsmasq.conf
96%{_initrddir}/dnsmasq
97%{_sbindir}/dnsmasq
98%{_mandir}/man8/dnsmasq*
99
100
101%changelog
102* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2.45-2
103- rebuilt with rpm-4.8.1-3
104
105* Thu Jul 31 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.45-1
106- initial build for Vine Linux
107
108* Mon Jul 21 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.45-1
109- Upstream release (bugfixes)
110
111* Wed Jul 16 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.43-2
112- New upstream release, contains fixes for CVE-2008-1447/CERT VU#800113
113- Dropped patch for newer glibc (merged upstream)
114
115* Wed Feb 13 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.8
116- Added upstream-authored patch for newer glibc (thanks Simon!)
117
118* Wed Feb 13 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.7
119- New upstream release
120
121* Wed Jan 30 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.6.rc1
122- Release candidate
123- Happy Birthday Isaac!
124
125* Wed Jan 23 2008 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.5.test30
126- Bugfix update
127
128* Mon Dec 31 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.4.test26
129- Bugfix/feature enhancement update
130
131* Thu Dec 13 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.3.test24
132- Upstream fix for fairly serious regression
133
134* Tue Dec 04 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.41-0.2.test20
135- New upstream test release
136- Moving dnsmasq.leases to /var/lib/dnsmasq/ as per BZ#407901
137- Ignoring dangerous-command-in-%%post rpmlint warning (as per above fix)
138- Patch consolidation/cleanup
139- Removed conditionals for Fedora <= 3 and Aurora 2.0
140
141* Tue Sep 18 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.40-1
142- Finalized upstream release
143- Removing URLs from patch lines (CVS is the authoritative source)
144- Added more magic to make spinning rc/test packages more seamless
145
146* Sun Aug 26 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.40-0.1.rc2
147- New upstream release candidate (feature-frozen), thanks Simon!
148- License clarification
149
150* Tue May 29 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.39-1
151- New upstream version (bugfixes, enhancements)
152
153* Mon Feb 12 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.38-1
154- New upstream version with bugfix for potential hang
155
156* Tue Feb 06 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.37-1
157- New upstream version
158
159* Wed Jan 24 2007 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.36-1
160- New upstream version
161
162* Mon Nov 06 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.35-2
163- Stop creating /etc/sysconfig on %%install
164- Create /etc/dnsmasq.d on %%install
165
166* Mon Nov 06 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.35-1
167- Update to 2.35
168- Removed UPGRADING_to_2.0 from %%doc as per upstream change
169- Enabled conf-dir in default config as per RFE BZ#214220 (thanks Chris!)
170- Added %%dir /etc/dnsmasq.d to %%files as per above RFE
171
172* Tue Oct 24 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.34-2
173- Fixed BZ#212005
174- Moved %%postun scriptlet to %%post, where it made more sense
175- Render scriptlets safer
176- Minor cleanup for consistency
177
178* Thu Oct 19 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.34-1
179- Hardcoded version in patches, as I'm getting tired of updating them
180- Update to 2.34
181
182* Mon Aug 28 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.33-2
183- Rebuild for FC6
184
185* Tue Aug 15 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.33-1
186- Update
187
188* Sat Jul 22 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.32-3
189- Added pkgconfig BuildReq due to reduced buildroot
190
191* Thu Jul 20 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.32-2
192- Forced update due to dbus version bump
193
194* Mon Jun 12 2006 Patrick "Jima" Laughton <jima@beer.tclug.org> 2.32-1
195- Update from upstream
196- Patch from Dennis Gilmore fixed the conditionals to detect Aurora Linux
197
198* Mon May  8 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.31-1
199- Removed dbus config patch (now provided upstream)
200- Patched in init script (no longer provided upstream)
201- Added DBus-interface to docs
202
203* Tue May  2 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-4.2
204- More upstream-recommended cleanups :)
205- Killed sysconfig file (provides unneeded functionality)
206- Tweaked init script a little more
207
208* Tue May  2 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-4
209- Moved options out of init script and into /etc/sysconfig/dnsmasq
210- Disabled DHCP_LEASE in sysconfig file, fixing bug #190379
211- Simon Kelley provided dbus/dnsmasq.conf, soon to be part of the tarball
212
213* Thu Apr 27 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-3
214- Un-enabled HAVE_ISC_READER, a hack to enable a deprecated feature (request)
215- Split initscript & enable-dbus patches, conditionalized dbus for FC3
216- Tweaked name field in changelog entries (trying to be consistent)
217
218* Mon Apr 24 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-2
219- Disabled stripping of binary while installing (oops)
220- Enabled HAVE_ISC_READER/HAVE_DBUS via patch
221- Added BuildReq for dbus-devel
222
223* Mon Apr 24 2006 Patrick "Jima" Laughton <jima@auroralinux.org> 2.30-1
224- Initial Fedora Extras RPM
Note: See TracBrowser for help on using the repository browser.