source: projects/specs/branches/6/d/dmraid/dmraid-vl.spec @ 3308

Revision 3308, 13.8 KB checked in by daisuke, 13 years ago (diff)

dmraid:

  • update to 1.0.0.rc16
  • update patches from fedora package
  • add BR: libudev-static, device-mapper-static, glibc-static
  • add BR: device-mapper-event-devel
  • add -events, -events-logwatch subpackage
  • move libdmraid.so to main package
  • use %ghost for /var/lock/dmraid
Line 
1Summary: Device-mapper RAID tool and library.
2Summary(ja): Device-mapper RAID ツールおよびライブラリ
3Name: dmraid
4Version: 1.0.0.rc16
5Release: 1%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8URL: http://people.redhat.com/heinzm/sw/dmraid
9
10Source: ftp://people.redhat.com/heinzm/sw/dmraid/src/%{name}-%{version}.tar.bz2
11Patch0: dmraid-1.0.0.rc16-test_devices.patch
12Patch1: ddf1_lsi_persistent_name.patch
13Patch2: pdc_raid10_failure.patch
14Patch3: return_error_wo_disks.patch
15Patch4: fix_sil_jbod.patch
16Patch5: avoid_register.patch
17Patch6: move_pattern_file_to_var.patch
18Patch7: libversion.patch
19Patch8: libversion-display.patch
20Patch9: bz635995-data_corruption_during_activation_volume_marked_for_rebuild.patch
21Patch11: bz626417_19-enabling_registration_degraded_volume.patch
22Patch12: bz626417_20-cleanup_some_compilation_warning.patch
23Patch13: bz626417_21-add_option_that_postpones_any_metadata_updates.patch
24
25Patch100: dmraid-1.0.0.rc16-libudev.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: device-mapper-devel >= 1.02.22
29BuildRequires: device-mapper-event-devel
30BuildRequires: device-mapper-static
31BuildRequires: libudev-static
32BuildRequires: glibc-static
33Requires: device-mapper >= 1.02.22
34Requires(postun): ldconfig
35Requires(post): ldconfig
36
37%description
38DMRAID supports RAID device discovery, RAID set activation and display of
39properties for ATARAID on Linux >= 2.4 using device-mapper.
40
41%package -n dmraid-devel
42Summary: Development libraries and headers for dmraid.
43Group: Development/Libraries
44
45%description -n dmraid-devel
46dmraid-devel provides a library interface for RAID device discovery,
47RAID set activation and display of properties for ATARAID volumes.
48
49%package -n dmraid-events
50Summary: dmevent_tool (Device-mapper event tool) and DSO
51Group: System Environment/Base
52Requires: dmraid = %{version}-%{release}, sgpio
53Requires: device-mapper-event
54
55%description -n dmraid-events
56Provides a dmeventd DSO and the dmevent_tool to register devices with it
57for device monitoring.  All active RAID sets should be manually registered
58with dmevent_tool.
59
60%package -n dmraid-events-logwatch
61Summary: dmraid logwatch-based email reporting
62Group: System Environment/Base
63Requires: dmraid-events = %{version}-%{release}, logwatch, /etc/cron.d
64
65%description -n dmraid-events-logwatch
66Provides device failure reporting via logwatch-based email reporting.
67Device failure reporting has to be activated manually by activating the
68/etc/cron.d/dmeventd-logwatch entry and by calling the dmevent_tool
69(see manual page for examples) for any active RAID sets.
70
71%prep
72%setup -q -n dmraid/%{version}
73%patch0 -p1
74%patch1 -p1
75%patch2 -p1
76%patch3 -p1
77%patch4 -p1
78%patch5 -p1
79%patch6 -p1
80%patch7 -p1
81%patch8 -p1
82%patch9 -p1
83%patch11 -p1
84%patch12 -p1
85%patch13 -p1
86%patch100 -p1
87
88%build
89%configure \
90  --prefix=${RPM_BUILD_ROOT}/usr --sbindir=${RPM_BUILD_ROOT}/sbin \
91  --libdir=${RPM_BUILD_ROOT}/%{_libdir} --mandir=${RPM_BUILD_ROOT}/%{_mandir} \
92  --includedir=${RPM_BUILD_ROOT}/%{_includedir} \
93  --disable-libselinux --enable-static_link
94make DESTDIR=$RPM_BUILD_ROOT
95mv tools/dmraid tools/dmraid.static
96make clean
97%configure \
98  --prefix=${RPM_BUILD_ROOT}/usr --sbindir=${RPM_BUILD_ROOT}/sbin \
99  --libdir=${RPM_BUILD_ROOT}/%{_libdir} --mandir=${RPM_BUILD_ROOT}/%{_mandir} \
100  --includedir=${RPM_BUILD_ROOT}/%{_includedir} \
101  --disable-libselinux --disable-static_link
102make -C lib DESTDIR=$RPM_BUILD_ROOT libdmraid.so
103
104%install
105rm -rf $RPM_BUILD_ROOT
106install -m 755 -d $RPM_BUILD_ROOT{%{_libdir},/sbin,%{_sbindir},%{_bindir},%{_libdir},%{_includedir}/dmraid/,/var/lock/dmraid,%{_sysconfdir}/cron.d/}
107install -m 755 -d $RPM_BUILD_ROOT{%{_sysconfdir}/logwatch/conf/services/,%{_sysconfdir}/logwatch/scripts/services/,/var/cache/logwatch/dmeventd}
108make DESTDIR=$RPM_BUILD_ROOT install
109install -m 755 tools/dmraid.static $RPM_BUILD_ROOT/sbin/dmraid.static
110
111# Provide convenience link from dmevent_tool
112(cd $RPM_BUILD_ROOT/sbin ; ln -f dmevent_tool dm_dso_reg_tool)
113(cd $RPM_BUILD_ROOT/%{_mandir}/man8 ; ln -f dmevent_tool.8 dm_dso_reg_tool.8 ; ln -f dmraid.8 dmraid.static.8)
114
115#
116install -m 644 include/dmraid/*.h $RPM_BUILD_ROOT%{_includedir}/dmraid/
117
118# Install the libdmraid and libdmraid-events (for dmeventd) DSO
119# Create version symlink to libdmraid.so.1 we link against
120install -m 755 lib/libdmraid.so \
121        $RPM_BUILD_ROOT%{_libdir}/libdmraid.so.%{version}
122(cd $RPM_BUILD_ROOT/%{_libdir} ; ln -sf libdmraid.so.%{version} libdmraid.so ; ln -sf libdmraid.so.%{version} libdmraid.so.1)
123install -m 755 lib/libdmraid-events-isw.so \
124        $RPM_BUILD_ROOT%{_libdir}/libdmraid-events-isw.so.%{version}
125(cd $RPM_BUILD_ROOT/%{_libdir} ; ln -sf libdmraid-events-isw.so.%{version} libdmraid-events-isw.so ; ln -sf libdmraid-events-isw.so.%{version} libdmraid-events-isw.so.1)
126                 
127# Install logwatch config file and script for dmeventd
128install -m 644 logwatch/dmeventd.conf $RPM_BUILD_ROOT%{_sysconfdir}/logwatch/conf/services/dmeventd.conf
129install -m 755 logwatch/dmeventd $RPM_BUILD_ROOT%{_sysconfdir}/logwatch/scripts/services/dmeventd
130install -m 644 logwatch/dmeventd_cronjob.txt $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/dmeventd-logwatch
131install -m 0700 /dev/null $RPM_BUILD_ROOT/var/cache/logwatch/dmeventd/syslogpattern.txt
132
133# remove static libs
134rm -f $RPM_BUILD_ROOT/%{_libdir}/libdmraid.a
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post -p /sbin/ldconfig
140 
141%postun -p /sbin/ldconfig
142
143%files
144%defattr(-,root,root)
145%doc CHANGELOG CREDITS KNOWN_BUGS LICENSE LICENSE_GPL LICENSE_LGPL README TODO doc/dmraid_design.txt
146%{_mandir}/man8/*
147/sbin/*
148%{_libdir}/libdmraid.so*
149%{_libdir}/libdmraid-events-isw.so*
150%ghost /var/lock/dmraid
151
152%files -n dmraid-devel
153%defattr(-,root,root)
154%dir %{_includedir}/dmraid
155%{_includedir}/dmraid/*
156
157%files -n dmraid-events
158%defattr(-,root,root)
159/%{_mandir}/man8/dmevent_tool*
160/%{_mandir}/man8/dm_dso_reg_tool*
161/sbin/dmevent_tool
162/sbin/dm_dso_reg_tool
163
164%files -n dmraid-events-logwatch
165%defattr(-,root,root)
166%config(noreplace) %{_sysconfdir}/logwatch/*
167%config(noreplace) %{_sysconfdir}/cron.d/dmeventd-logwatch
168%dir /var/cache/logwatch/dmeventd
169%ghost /var/cache/logwatch/dmeventd/syslogpattern.txt
170
171
172%changelog
173* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0.rc16-1
174- update to 1.0.0.rc16
175- update patches from fedora package
176- add BR: libudev-static, device-mapper-static, glibc-static
177- add BR: device-mapper-event-devel
178- add -events, -events-logwatch subpackage
179- move libdmraid.so to main package
180- use %ghost for /var/lock/dmraid
181
182* Sat Mar 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0.rc15-1
183- new upstream release
184
185* Mon Dec 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl0.rc14.1
186- initial build for Vine Linux
187- disable selinux
188- require device-mapper 1.02.22
189
190* Wed Nov 21 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-6
191- Bug 379911: dmraid needs to generate UUIDs for lib device-mapper
192  - add "DMRAID-" prefix to dmraid UUID string.
193
194* Wed Nov 14 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-5
195- Bug 379911: dmraid needs to generate UUIDs for lib device-mapper
196- Bug 379951: dmraid needs to activate device-mapper mirror resynchronization error handling
197
198* Mon Oct 22 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-4
199- Fix SEGV on "dmraid -r -E" (bz 236891).
200
201* Wed Apr 18 2007 Peter Jones <pjones@redhat.com> - 1.0.0.rc14-3
202- Fix jmicron name parsing (#219058)
203
204* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.0.rc14-2
205- Add build dependency on new device-mapper-devel package.
206- Add dependency on device-mapper.
207- Add post and postun ldconfig.
208- Update BuildRoot and Summary.
209
210* Wed Nov 08 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc14-1
211- asr.c: fixed Adaptec HostRAID DDF1 metadata discovery (bz#211016)
212- ddf1_crc.c: added crc() routine to avoid linking to zlib alltogether,
213              because Ubuntu had problems with this
214- dropped zlib build requirement
215
216* Thu Oct 26 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc14-bz211016-1
217- ddf1.c: get_size() fixed (bz#211016)
218- ddf1_lib.c: ddf1_cr_off_maxpds_helper() fixed (bz#211016)
219
220* Wed Oct 11 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc13-1
221- metadata.c: fixed bug returning wrang unified RAID type (bz#210085)
222- pdc.c: fixed magic number check
223
224* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc12-7
225- rebuilt for unwind info generation, broken in gcc-4.1.1-21
226
227* Fri Sep 22 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc12-1
228- sil.c: quorate() OBO fix
229- activate.c: handler() OBO fix
230- added SNIA DDF1 support
231- added reload functionality to devmapper.c
232- added log_zero_sectors() to various metadata format handlers
233- sil.[ch]: added JBOD support
234
235* Fri Sep  1 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-4
236- Require kpartx, so initscripts doesn't have to if you're not using dmraid
237
238* Thu Aug 17 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc11-3
239- Change Release to follow guidelines, and add dist tag.
240
241* Thu Aug 17 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-FC6.3
242- No more excludearch for s390/s390x
243
244* Fri Jul 28 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-FC6.2
245- Fix bounds checking on hpt37x error log
246- Only build the .so, not the .a
247- Fix asc.c duplication in makefile rule
248
249* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc11-FC6.1.1
250- rebuild
251
252* Fri Jul  7 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC6.1
253- rebuilt for FC6 with dos partition discovery fix (#197573)
254
255* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC6
256- rebuilt for FC6 with better tag
257
258* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC5_7.2
259- rebuilt for FC5
260
261* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC5_7.1
262- jm.c: checksum() calculation
263- misc.c: support "%d" in p_fmt and fix segfault with wrong format identifier
264- nv.c: size fix in setup_rd()
265- activate.c:
266        o striped devices could end on non-chunk boundaries
267        o calc_region_size() calculated too small sizes causing large
268          dirty logs in memory
269- isw.c: set raid5 type to left asymmetric
270- toollib.c: fixed 'No RAID...' message
271- support selection of RAID5 allocation algorithm in metadata format handlers
272- build
273
274* Mon Mar 27 2006 Milan Broz <mbroz@redhat.com> - 1.0.0.rc10-FC5_6.2
275- fixed /var/lock/dmraid in specfile (#168195)
276
277* Fri Feb 17 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc10-FC5_6
278- add doc/dmraid_design.txt to %doc (#181885)
279- add --enable-libselinux --enable-libsepol to configure
280- rebuilt
281
282* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc9-FC5_5.2
283- bump again for double-long bug on ppc(64)
284
285* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc9-FC5_5.1
286- rebuilt for new gcc4.1 snapshot and glibc changes
287
288* Sun Jan 22 2006 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_5
289- Add selinux build deps
290- Don't set owner during make install
291
292* Fri Dec  9 2005 Jesse Keating <jkeating@redhat.com> 1.0.0.rc9-FC5_4.1
293- rebuilt
294
295* Sun Dec  3 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_4
296- rebuild for device-mapper-1.02.02-2
297
298* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_3
299- rebuild for device-mapper-1.02.02-1
300
301* Thu Nov 10 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_2
302- update to 1.0.0.rc9
303- make "make install" do the right thing with the DSO
304- eliminate duplicate definitions in the headers
305- export more symbols in the DSO
306- add api calls to retrieve dm tables
307- fix DESTDIR for 'make install'
308- add api calls to identify degraded devices
309- remove several arch excludes
310
311* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
312- add -lselinux -lsepol for new device-mapper deps
313
314* Fri May 20 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc8-FC4_2
315- specfile change to build static and dynamic binray into one package
316- rebuilt
317
318* Thu May 19 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc8-FC4_1
319- nv.c: fixed stripe size
320- sil.c: avoid incarnation_no in name creation, because the Windows
321         driver changes it every time
322- added --ignorelocking option to avoid taking out locks in early boot
323  where no read/write access to /var is given
324
325* Wed Mar 16 2005 Elliot Lee <sopwith@redhat.com>
326- rebuilt
327
328* Tue Mar 15 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc6.1-4_FC4
329- VIA metadata format handler
330- added RAID10 to lsi metadata format handler
331- "dmraid -rD": file device size into {devicename}_{formatname}.size
332- "dmraid -tay": pretty print multi-line tables ala "dmsetup table"
333- "dmraid -l": display supported RAID levels + manual update
334- _sil_read() used LOG_NOTICE rather than LOG_INFO in order to
335  avoid messages about valid metadata areas being displayed
336  during "dmraid -vay".
337- isw, sil filed metadata offset on "-r -D" in sectors rather than in bytes.
338- isw needed dev_sort() to sort RAID devices in sets correctly.
339- pdc metadata format handler name creation. Lead to
340  wrong RAID set grouping logic in some configurations.
341- pdc RAID1 size calculation fixed (rc6.1)
342- dos.c: partition table code fixes by Paul Moore
343- _free_dev_pointers(): fixed potential OOB error
344- hpt37x_check: deal with raid_disks = 1 in mirror sets
345- pdc_check: status & 0x80 doesn't always show a failed device;
346  removed that check for now. Status definitions needed.
347- sil addition of RAID sets to global list of sets
348- sil spare device memory leak
349- group_set(): removal of RAID set in case of error
350- hpt37x: handle total_secs > device size
351- allow -p with -f
352- enhanced error message by checking target type against list of
353  registered target types
354
355* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> 1.0.0.rc5f-2
356- Rebuild to pick up new libdevmapper.
357
358* Fri Nov 26 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc5f
359- specfile cleanup
360
361* Tue Aug 20 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-rc4-pre1
362- Removed make flag after fixing make.tmpl.in
363
364* Tue Aug 18 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-rc3
365- Added make flag to prevent make 3.80 from looping infinitely
366
367* Thu Jun 17 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-pre1
368- Created
Note: See TracBrowser for help on using the repository browser.