source: projects/specs/branches/6/d/directfb/directfb-vl.spec @ 3940

Revision 3940, 4.8 KB checked in by Takemikaduchi, 13 years ago (diff)

fix permission

Line 
1%define oname DirectFB
2%define libver 1.4-5
3
4Summary:        Hardware graphics acceleration library
5Name:           directfb
6Version:        1.4.11
7Release:        2%{?_dist_release}
8License:        GPL
9Group:          System Environment/Libraries
10Source0:        http://www.directfb.org/downloads/Core/%{name}-1.4/%{oname}-%{version}.tar.gz
11##Patch0:               %{oname}-%{version}_ppc.patch
12Patch0:         %{oname}-1.1.1_ppc.patch
13URL:            http://www.directfb.org/
14BuildRequires:  libpng-devel >= 1.2.0
15BuildRequires:  zlib-devel >= 1.1.3
16BuildRequires:  libjpeg-turbo-devel
17BuildRequires:  freetype2-devel >= 2.0.2
18BuildRequires:  libX11-devel
19BuildRequires:  libvncserver-devel
20BuildRequires:  sysfsutils-devel
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22
23Vendor:       Project Vine
24Distribution: Vine Linux
25
26%description
27DirectFB hardware graphics acceleration - libraries.
28
29
30%package -n lib%{name}
31Summary:        Shared library part of %oname
32Group:          System Environment/Libraries
33
34%description -n lib%{name}
35DirectFB hardware graphics acceleration - libraries.
36
37This package contains the %oname shared library and interface modules.
38It's required for running apps based on %oname.
39
40#'
41%package -n lib%{name}-devel
42Group:          Development/Libraries
43Summary:        Header files for compiling DirectFB applications
44Requires:       lib%{name} = %{version}-%{release}
45Provides:       %{oname}-devel = %{version}-%{release}
46
47%description -n lib%{name}-devel
48DirectFB header files for building applications based on %oname.
49
50%package doc
51Summary:        DirectFB - documentation
52Group:          Applications/Documentation
53
54%description doc
55DirectFB documentation and examples.
56
57%prep
58%setup  -q -n %{oname}-%{version}
59%patch0 -p1
60
61%build
62%configure \
63        --enable-multi \
64        --enable-shared \
65        --with-gfxdrivers=ati128,i810,i830,mach64,nvidia,radeon,savage,sis315,vmware
66
67make
68
69%install
70rm -rf $RPM_BUILD_ROOT
71make install DESTDIR=$RPM_BUILD_ROOT
72
73find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
74
75# we don't ship dfbg ATM
76rm -f $RPM_BUILD_ROOT%{_bindir}/dfbg
77rm -f $RPM_BUILD_ROOT%{_mandir}/man1/dfbg.1
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%post -n lib%{name} -p /sbin/ldconfig
83
84%postun -n lib%{name} -p /sbin/ldconfig
85
86
87%files -n lib%{name}
88%defattr(-,root,root,-)
89%doc README* AUTHORS ChangeLog NEWS TODO
90%{_bindir}/dfbdump
91%{_bindir}/dfbfx
92%{_bindir}/dfbinfo
93%{_bindir}/dfbinput
94%{_bindir}/dfbinspector
95%{_bindir}/dfbmaster
96%{_bindir}/dfblayer
97%{_bindir}/dfbscreen
98%{_bindir}/dfbpenmount
99%{_bindir}/mkdfiff
100%{_bindir}/mkdgiff
101%{_bindir}/mkdgifft
102%{_libdir}/lib*.so.*
103%dir %{_libdir}/directfb-%{libver}
104%dir %{_libdir}/directfb-%{libver}/gfxdrivers
105%dir %{_libdir}/directfb-%{libver}/inputdrivers
106%dir %{_libdir}/directfb-%{libver}/interfaces
107%dir %{_libdir}/directfb-%{libver}/systems
108%dir %{_libdir}/directfb-%{libver}/wm
109%{_libdir}/directfb-%{libver}/gfxdrivers/*.so
110%{_libdir}/directfb-%{libver}/inputdrivers/*.so
111%{_libdir}/directfb-%{libver}/interfaces/*/*.so
112%{_libdir}/directfb-%{libver}/systems/*.so
113%{_libdir}/directfb-%{libver}/wm/*.so
114#{_libdir}/directfb-%{libver}/*.so
115%{_datadir}/directfb-%{version}
116%{_mandir}/man5/directfbrc.5*
117
118%files -n lib%{name}-devel
119%defattr(-,root,root,-)
120%{_bindir}/directfb-config
121%{_bindir}/directfb-csource
122%{_includedir}/*
123%{_libdir}/pkgconfig/*.pc
124#{_libdir}/*.la
125%{_libdir}/*.so
126%{_mandir}/man1/directfb-csource.1*
127
128%files doc
129%defattr(-,root,root,-)
130%doc docs/html/*
131
132%changelog
133* Sun May 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.11-2
134- fix permission
135
136* Tue Dec 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.11-1
137- new upstream release
138- change Source URL
139- add BuildRequires: libX11-devel, libvncserver-devel, sysfsutils-devel
140- change BuildRequires: libjpeg-turbo-devel instead libjpeg-devel >= 6g
141- fix %%files
142
143* Mon Oct 11 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-1
144- updated DirectFB to 1.2.5
145- rebuilt with rpm-4.8.1 for pkg-config
146
147* Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.1-2
148- add Patch0 to fix ppc build problem (with newer kernels)
149
150* Fri May  2 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.1-1
151- new upstream release
152
153* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.16-2vl2
154- changed doc Group to Applications/Documentation
155
156* Fri Nov 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.16-2vl1
157- changed packages Group:
158- cleaned spec file (a little bit!)
159
160* Fri Feb 28 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.9.16-2vl0
161- new upstream version
162- convert to Vine Linux
163
164* Fri Dec 27 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.15-2mdk
165- rebuild
166
167* Wed Nov 13 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.15-1mdk
168- new version
169
170* Tue Oct 29 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.14-1mdk
171- fix group of doc package
172- new version
173
174* Fri Aug 23 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.13-1mdk
175- add directfb-csource and man page
176- 0.9.13
177
178* Thu Jul 11 2002 Gz Waschk <waschk@linux-mandrake.com> 0.9.12-1mdk
179- initial package based on PLD effort
180
Note: See TracBrowser for help on using the repository browser.