source: projects/specs/branches/6/d/diffutils/diffutils-vl.spec @ 521

Revision 521, 6.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A GNU collection of diff utilities.
2Summary(ja): GNU diff ユーティリティ集
3Name: diffutils
4Version: 2.8.1
5Release: 13%{?_dist_release}
6Group: Applications/Text
7URL: http://www.gnu.org/software/diffutils/diffutils.html
8Source: ftp://ftp.gnu.org/gnu/diffutils/diffutils-%{version}.tar.gz
9Source1: cmp.1
10Source2: diff.1
11Source3: diff3.1
12Source4: sdiff.1
13Patch0: diffutils-2.8.4-i18n.patch
14Patch1: diffutils-2.8.1-badc.patch
15License: GPL
16
17Requires(post): /sbin/install-info
18Requires(preun): /sbin/install-info
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: coreutils
21
22%description
23Diffutils includes four utilities: diff, cmp, diff3 and sdiff. Diff
24compares two files and shows the differences, line by line.  The cmp
25command shows the offset and line numbers where two files differ, or
26cmp can show the characters that differ between the two files.  The
27diff3 command shows the differences between three files.  Diff3 can be
28used when two people have made independent changes to a common
29original; diff3 can produce a merged file that contains both sets of
30changes and warnings about conflicts.  The sdiff command can be used
31to merge two files interactively.
32
33Install diffutils if you need to compare text files.
34
35%description -l ja
36diffutils には diff, cmp, diff3, sdiff の 4つのユーティリティが
37収められています.diff は 2つのファイルを行単位で比較し相違点を
38出力します.cmp コマンドは 2つのファイルの相違点をオフセットと行番号で
39表示できますし,どの文字が異なるかを表示することも出来ます.
40diff3 コマンドは 3つのファイルの相違点を出力します.diff3 は
411つのオリジナルファイルを2人が変更した場合等に良く使われます.
42diff3 を使って,2つの変更をマージした変更ファイルを出力することが
43出来ますし,コンフリクトした変更点を出力することも出来ます.
44sdiff コマンドは2つのファイルを対話的にマージするのに使います.
45
46テキストファイルを比較したい場合は diffutils をインストールして下さい.
47
48
49%prep
50%setup -q
51%patch0 -p1 -b .i18n
52%patch1 -p1 -b .badc
53
54%build
55%configure
56make PR_PROGRAM=%{_bindir}/pr
57
58%install
59rm -rf $RPM_BUILD_ROOT
60%makeinstall
61
62( cd $RPM_BUILD_ROOT
63  gzip -9nf .%{_infodir}/diff*
64  mkdir -p .%{_mandir}/man1
65  for manpage in %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4}
66  do
67    install -m 0644 ${manpage} .%{_mandir}/man1
68  done
69)
70
71rm -f $RPM_BUILD_ROOT%{_infodir}/dir
72%find_lang %{name}
73
74
75%post
76/sbin/install-info %{_infodir}/diff.info.gz %{_infodir}/dir --entry="* diff: (diff).                 The GNU diff."
77exit 0
78
79%preun
80if [ $1 = 0 ]; then
81    /sbin/install-info --delete %{_infodir}/diff.info.gz %{_infodir}/dir --entry="* diff: (diff).                 The GNU diff."
82fi
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%files -f %{name}.lang
88%defattr(-,root,root)
89%doc NEWS README
90%{_bindir}/*
91%{_mandir}/*/*
92%{_infodir}/diff.info*gz
93
94
95%changelog
96* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-13
97- spec in utf-8
98
99* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-12
100- applied new versioning policy
101- added BuildRequires: coreutils
102
103* Fri Sep 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-11vl2
104- rebuild to add gpg sign
105
106* Fri Mar 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-11vl1
107- added Patch1 from Fedora 2.8.1-11
108  * Thu Jan  8 2004 Tim Waugh <twaugh@redhat.com> 2.8.1-10
109  - Fix mistaken use of '|' instead of '||'.
110- fixed typo at description(ja)
111
112* Wed Dec 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-5vl1
113- merge Rawhide's 2.8.1-5 and Vine's 2.8.1-0vl1:
114
115  - Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
116  - new upstream release 2.8.1
117  - drop old unneeded patches.
118
119  - Mon Jun 18 2001 <sagami@vinelinux.org>
120  - 2.7.2-0vl3: patch taken from RH's 2.7.2-2 (not in sync, actually)
121  - Install diff.1, since it's no longer in man-pages.
122
123  - Tue Jan 09 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
124  - 2.7.2-0vl2
125  - use better macros (%%{_localedir})
126  - %%makeinstall was here again
127  - added Japanese summary and description
128
129  - Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
130  - updated to 2.7.2 (NLS support version)
131  - added poor gettext_fix patch
132  - added ja.po from fj.sources
133  - remove %%makeinstall and use "make install prefix..." for rpm 3.x
134
135* Tue Nov 19 2002 Tim Waugh <twaugh@redhat.com> 2.8.1-5
136- i18n patch.
137
138* Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.8.1-4
139- Ship translations.
140
141* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
142- automated rebuild
143
144* Thu May 23 2002 Tim Powers <timp@redhat.com>
145- automated rebuild
146
147* Mon Apr 22 2002 Tim Waugh <twaugh@redhat.com> 2.8.1-1
148- 2.8.1.
149- No longer need immunix-owl-tmp patch.
150
151* Wed Feb 27 2002 Tim Waugh <twaugh@redhat.com> 2.7.2-5
152- Rebuild in new environment.
153
154* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
155- automated rebuild
156
157* Fri Nov 02 2001 Tim Waugh <twaugh@redhat.com> 2.7.2-3
158- Make sure %%post scriplet doesn't fail if --excludedocs is used.
159
160* Fri Jun 01 2001 Tim Waugh <twaugh@redhat.com> 2.7.2-2
161- Install diff.1, since it's no longer in man-pages.
162
163* Fri Mar 30 2001 Tim Waugh <twaugh@redhat.com> 2.7.2-1
164- 2.7.2.
165
166* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
167- automatic rebuild
168
169* Thu Jul 06 2000 Trond Eivind Glomsr <teg@redhat.com>
170- fix %%changelog entries (escape them)
171- update source location
172- remove manual stripping
173- add URL
174
175* Tue Jun 06 2000 Than Ngo <than@redhat.de>
176- add %%defattr
177- use rpm macros
178
179* Wed May 31 2000 Ngo Than <than@redhat.de>
180- put man pages and info files in correct place
181- cleanup specfile
182
183* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
184- rebuild to gzip man pages.
185
186* Mon Apr 19 1999 Jeff Johnson <jbj@redhat.com>
187- man pages not in %%files.
188- but avoid conflict for diff.1
189
190* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
191- auto rebuild in the new build environment (release 14)
192
193* Sun Mar 14 1999 Jeff Johnson <jbj@redhat.com>
194- add man pages (#831).
195- add %%configure and Prefix.
196
197* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
198- build for glibc 2.1
199
200* Tue Jul 14 1998 Bill Kawakami <billk@home.com>
201- included the four man pages stolen from Slackware
202
203* Tue May 05 1998 Prospector System <bugs@redhat.com>
204- translations modified for de, fr, tr
205
206* Sun May 03 1998 Cristian Gafton <gafton@redhat.com>
207- fixed spec file to reference/use the $RPM_BUILD_ROOT always
208   
209* Wed Dec 31 1997 Otto Hammersmith <otto@redhat.com>
210- fixed where it looks for 'pr' (/usr/bin, rather than /bin)
211
212* Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
213- added BuildRoot
214
215* Sun Sep 14 1997 Erik Troan <ewt@redhat.com>
216- uses install-info
217
218* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
219- built against glibc
Note: See TracBrowser for help on using the repository browser.