source: projects/specs/branches/6/d/dhcpcd/dhcpcd-vl.spec @ 521

Revision 521, 7.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define mainver 1.3.22
2%define patchlevel pl4
3
4Summary:     A DHCP (Dynamic Host Configuration Protocol) client.
5Summary(ja): DHCP (Dynamic Host Configuration Protocol) クライアント
6Name:        dhcpcd
7Version:     %{mainver}%{patchlevel}
8Release:     1%{?_dist_release}
9License:     GPL
10Group:       System Environment/Base
11Source:      http://www.phystech.com/ftp/dhcpcd-%{mainver}-%{patchlevel}.tar.gz
12Patch:       dhcpcd-1.3.21-post.patch
13URL:         http://www.phystech.com/download/
14BuildRoot:   %{_tmppath}/%{name}-%{version}-root
15Prereq:      file, fileutils, grep
16BuildRequires: autoconf, automake, libtool
17
18%description
19DHCP (Dynamic Host Configuration Protocol) is a protocol which allows
20individual devices on an IP network to get their own network
21configuration information (IP address, subnetmask, broadcast address,
22etc.) from a DHCP server.  The overall purpose of DHCP is to make it
23easier to administer a large network.  The dhcpcd package includes a
24DHCP client daemon.
25
26If you're going to use DHCP on your network, you'll need to install
27the server package (dhcp) on the server, and a client package on the
28client machines. The dhcpcd package includes a DHCP client, but we
29suggest that you instead install the DHCP client included in the pump
30package, which provides a faster and simpler DHCP client.
31
32%description -l ja
33DHCP (Dynamic Host Configuration Protocol) は,IP ネットワークの
34各デバイスに,ネットワーク設定情報 (IP アドレス,サブネットマスク,
35ブロードキャストアドレス等) を割り当てる為のプロトコルです.
36DHCP の主な目的は,大規模なネットワークでの管理を簡単にすることです.
37この dhcpcd パッケージには DHCP クライアントデーモンが含まれています.
38
39あなたのネットワークで DHCP を使うためには,サーバ側に dhcp サーバ
40(dhcp パッケージ) を,そしてクライアント側に dhcp クライアント
41(dhcpcd パッケージ) をインストールする必要があります.
42この dhcpcd パッケージには DHCP クライアントが含まれていますが,
43代わりに pump パッケージの DHCP クライアントをインストールすることを
44お勧めします.pump はより高速でよりシンプルな DHCP クライアントです.
45
46
47%prep
48%setup -q -n dhcpcd-%{mainver}-%{patchlevel}
49%patch -p1
50
51
52%build
53libtoolize -c -f
54autoreconf
55%configure --sbindir=/sbin
56make CFLAGS="$RPM_OPT_FLAGS" %{?_smp_mflags}
57
58
59%install
60rm -rf $RPM_BUILD_ROOT
61%makeinstall sbindir=$RPM_BUILD_ROOT/sbin
62
63rm -rf $RPM_BUILD_ROOT/etc/dhcpc*
64
65mkdir -p $RPM_BUILD_ROOT/etc/dhcpc
66ln -s dhcpc $RPM_BUILD_ROOT/etc/dhcpcd
67
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72
73%files
74%defattr(-,root,root)
75%doc README dhcpcd-eth0.exe
76/etc/dhcpcd
77%dir /etc/dhcpc
78/sbin/dhcpcd
79%{_mandir}/man8/dhcpcd.8*
80
81
82%pre
83exec > /dev/null 2> /dev/null
84# We can't replace a directory with a symlink, but this directory is supposed
85# to be a symlink.
86if [ -d /etc/dhcpcd ] ; then
87        mv /etc/dhcpcd/* /etc/dhcpc
88        mv /etc/dhcpcd /etc/dhcpcd.rpmsave
89fi
90# Remove the circular link which was in a previous version of this package.
91if [ -L /etc/dhcpc/dhcpc ] ; then
92        if file /etc/dhcpc/dhcpc | grep -q "symbolic link to dhcpc" ; then
93                rm /etc/dhcpc/dhcpc
94                # Leave a file for RPM to remove.
95                touch /etc/dhcpc/dhcpc
96        fi
97fi
98if [ -L /etc/dhcpc/dhcpcd ] && [ ! -f /etc/dhcpc/dhcpcd ]; then
99        rm -f /etc/dhcpc/dhcpcd
100fi
101
102
103%changelog
104* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.22pl4-1vl5
105- applied new versioning policy, spec in utf-8
106
107* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.22pl4-0vl3
108- run libtoolize/autoreconf to build on x86_64
109
110* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.22pl4-0vl2
111- rebuild to add gpg sign
112
113* Tue Feb  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.22pl4-0vl1
114- new upstream release to fix security bug
115
116* Thu Jan 31 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.21pl2-2vl1
117- updated in sync with 1.3.21pl2-2 from Rawhide and built for Vine Linux
118- added Japanese summary and description
119
120* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
121- automated rebuild
122
123* Fri Jan 04 2002 Elliot Lee <sopwith@redhat.com> 1.3.21pl2-1
124- Update to pl2
125- Fix #54600
126
127* Mon Dec 31 2001 Elliot Lee <sopwith@redhat.com> 1.3.21pl1-3
128- dhcpcd-1.3.21-multicast.patch sets IFF_MULTICAST (fixes 48669).
129
130* Sun Dec 30 2001 Elliot Lee <sopwith@redhat.com> 1.3.21pl1-2
131- After updating to a new version, reincorporate the dhcpcd-post.patch and fix some other nits.
132
133* Thu Sep 20 2001 Elliot Lee <sopwith@redhat.com> 1.3.20pl0
134- Update to new version
135
136* Mon Jul 16 2001 Elliot Lee <sopwith@redhat.com>
137- Bug #7961 plus my own observations resulted in Patch5 to fix alignment errors.
138
139* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
140- don't write two search lines to resolv.conf
141- suppress output from %%pre script
142
143* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
144- Bump release + rebuild.
145
146* Wed Mar 14 2001 Bill Nottingham <notting@redhat.com>
147- fix running of ifup-post on ip address change
148
149* Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
150- remove the circular link which was in a previous version of this package
151
152* Wed Feb 14 2001 Bill Nottingham <notting@redhat.com>
153- fix the symlink, for real (#27622)
154
155* Mon Feb 12 2001 Bill Nottingham <notting@redhat.com>
156- run ifup-post on ip address change
157
158* Mon Aug 21 2000 Bill Nottingham <notting@redhat.com>
159- package up /etc/dhcpcd as a symlink instead
160
161* Fri Jul 21 2000 Erik Troan <ewt@redhat.com>
162- package up /etc/dhcpc as a symlink
163
164* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
165- automatic rebuild
166
167* Thu Jun 22 2000 Bill Nottingham <notting@redhat.com>
168- actually update to 1.3.18pl8
169
170* Mon Jun 19 2000 Preston Brown <pbrown@redhat.com>
171- FHS paths
172
173* Thu May 11 2000 Karsten Hopp <Karsten.Hopp@redhat.de>
174- updated to dhcpcd-1.3.18pl8
175
176* Thu Feb 03 2000 Erik Troan <ewt@redhat.com>
177- updated to dhcpcd-1.3.18pl3
178- don't statically link the binary
179
180* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
181- rebuild to fix the descriptions and summary
182- man pages are compressed
183
184* Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
185- rebuild against the latest glibc in the sparc tree
186
187* Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
188- include 802.2 token ring support patch (#2061).
189
190* Sat May 29 1999 Jeff Johnson <jbj@redhat.com>
191- include /etc/dhcpc in package (#3097).
192- upgrade to 1.3.17-pl5.
193
194* Mon Apr 19 1999 Bill Nottingham <notting@redhat.com>
195- build for 6.0
196
197* Wed Dec 23 1998 Jeff Johnson <jbj@redhat.com>
198- mark default route up.
199
200* Sun Jun  7 1998 Jeff Johnson <jbj@redhat.com>
201- Fix packet alignment problems on sparc.
202- build root.
203
204* Mon Jun 01 1998 Prospector System <bugs@redhat.com>
205- translations modified for de
206
207* Wed May  6 1998 Alan Cox
208- fixed some potential buffer exploits reported by Chris Evans
209
210* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
211- translations modified for de, fr, tr
212
213* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
214- spec file cleanups
215
216* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
217- built against glibc, updated to 0.65
218
219* Mon Apr 21 1997 Otto Hammersmith <otto@redhat.com>
220- fixed summary line... was a summary for tar.
Note: See TracBrowser for help on using the repository browser.