source: projects/specs/branches/6/d/device-mapper-multipath/device-mapper-multipath-vl.spec @ 3839

Revision 3839, 8.3 KB checked in by daisuke, 13 years ago (diff)

device-mapper-multipath: add RH patches

Line 
1Summary: Tools to manage multipath devices using device-mapper
2Name: device-mapper-multipath
3Version: 0.4.9
4Release: 3%{?_dist_release}
5License: GPL+
6Group: System Environment/Base
7URL: http://christophe.varoqui.free.fr/
8Source0: multipath-tools-%{version}.tar.bz2
9Source1: multipath.conf
10
11# patch that should go upstream
12Patch1: 0001-for-upstream-add-tpg_pref-prioritizer.patch
13
14# RH patches
15Patch1007: 0007-RH-do-not-remove.patch
16Patch1008: 0008-RH-Make-build-system-RH-Fedora-friendly.patch
17Patch1009: 0009-RH-multipathd-blacklist-all-by-default.patch
18Patch1010: 0010-RH-multipath-rules-udev-changes.patch
19Patch1014: 0014-RH-add-hp_tur-checker.patch
20Patch1017: 0017-RHBZ-554592-man-page-note.patch
21Patch1018: 0018-RHBZ-554596-SUN-6540-config.patch
22Patch1019: 0019-RHBZ-554598-fix-multipath-locking.patch
23Patch1020: 0020-RHBZ-554605-fix-manual-failover.patch
24Patch1021: 0021-RHBZ-548874-add-find-multipaths-2.patch
25Patch1022: 0022-RHBZ-557845-RHEL5-style-partitions-2.patch
26Patch1023: 0023-RHBZ-557810-emc-invista-config.patch
27Patch1024: 0024-RHBZ-565933-checker-timeout-2.patch
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
30Requires(post): chkconfig
31Requires(preun): chkconfig
32Requires: kpartx = %{version}-%{release}
33Requires: device-mapper >= 1.02.39
34BuildRequires: sysfsutils-devel, device-mapper-devel
35#BuildRequires: libselinux-devel, libsepol-devel
36BuildRequires: readline-devel, ncurses-devel
37BuildRequires: libaio-devel
38
39Vendor: Project Vine
40Distribution: Vine Linux
41Packager: daisuke
42
43%description
44%{name} provides tools to manage multipath devices by instructing the
45device-mapper multipath kernel module what to do.
46The tools are :
47* multipath :   Scan the system for multipath devices and assemble them.
48* multipathd :  Detects when paths fail and execs multipath to update things.
49
50
51%package -n kpartx
52Summary: Partition device manager for device-mapper devices
53Group: System Environment/Base
54Provides: kpartx = %{version}-%{release}
55
56
57%description -n kpartx
58kpartx manages partition creation and removal for device-mapper devices.
59
60
61%prep
62%setup -q -c
63%patch1 -p1
64%patch1007 -p1
65%patch1008 -p1
66%patch1009 -p1
67%patch1010 -p1
68%patch1014 -p1
69%patch1017 -p1
70%patch1018 -p1
71%patch1019 -p1
72%patch1020 -p1
73%patch1021 -p1
74%patch1022 -p1
75%patch1023 -p1
76%patch1024 -p1
77
78
79%build
80make LIB=%{_lib}
81
82%install
83rm -rf $RPM_BUILD_ROOT
84make install \
85  DESTDIR=$RPM_BUILD_ROOT \
86  bindir=%{_syssbindir} \
87  syslibdir=/%{_lib} \
88  libdir=/%{_lib}/multipath \
89  rcdir=%{_initrddir}
90
91install -d %{buildroot}/etc/multipath
92install -m644 %{SOURCE1} %{buildroot}/etc/multipath.conf
93
94install -m755 multipathd/multipathd.init.redhat %{buildroot}%{_initrddir}/multipathd
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99
100%post
101/sbin/ldconfig
102/sbin/chkconfig --add multipathd
103if [ "$1" -gt "1" -a ! -e /etc/multipath/bindings -a \
104    -f /var/lib/multipath/bindings ]; then
105       mv /var/lib/multipath/bindings /etc/multipath/bindings
106       ln -s /etc/multipath/bindings /var/lib/multipath/bindings
107fi
108
109%preun
110if [ "$1" = 0 ]; then
111        /sbin/service multipathd stop /dev/null 2>&1
112        /sbin/chkconfig --del multipathd
113fi
114
115
116%postun
117/sbin/ldconfig
118if [ "$1" -ge "1" ]; then
119        /sbin/service multipathd condrestart >/dev/null 2>&1 || :
120fi
121
122
123%files
124%defattr(-,root,root,-)
125%doc AUTHOR COPYING README* FAQ
126%doc multipath.conf.annotated multipath.conf.defaults
127%doc multipath.conf.synthetic
128%{_syssbindir}/multipath
129%{_syssbindir}/multipathd
130%config /lib/udev/rules.d/40-multipath.rules
131%{_mandir}/man8/multipath.8.gz
132%{_mandir}/man8/multipathd.8.gz
133%{_mandir}/man5/multipath.conf.5.gz
134%config /etc/rc.d/init.d/multipathd
135%config(noreplace) /etc/multipath.conf
136%dir /etc/multipath
137/%{_lib}/libmultipath.so*
138%dir /%{_lib}/multipath
139/%{_lib}/multipath/*
140
141%files -n kpartx
142%defattr(-,root,root,-)
143%{_syssbindir}/kpartx
144%{_mandir}/man8/kpartx.8.gz
145
146
147%changelog
148* Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-3
149- import patches from RH package
150
151* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-2
152- install multipath libraries to %%{_lib}/multipath
153
154* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-1
155- update to 0.4.9
156- drop static version
157- add BR: libaio-devel
158
159* Sun Sep 07 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.7-12vl5
160- applied new versioning policy
161
162* Thu Feb 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.7-11vl1
163- initial build for VineSeed
164- add Patch100 to disable linking to libselinux and libsepol
165
166* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 0.4.7-11.fc7
167- Add build dependency on new device-mapper-devel package.
168- Add dependency on device-mapper.
169
170* Wed Jan 31 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-10.fc7
171- Update BuildRoot and PreReq lines.
172
173* Mon Jan 15 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-9.fc7
174- Fixed spec file.
175
176* Mon Jan 15 2007 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-8.fc7
177- Update to latest code (t0_4_7_head2)
178
179* Wed Dec 13 2006 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-7.fc7
180- Update to latest code (t0_4_7_head1)
181
182* Thu Sep  7 2006 Peter Jones <pjones@redhat.com> - 0.4.7-5
183- Fix kpartx to handle with drives >2TB correctly.
184
185* Thu Aug 31 2006 Peter Jones <pjones@redhat.com> - 0.4.7-4.1
186- Split kpartx out into its own package so dmraid can use it without
187  installing multipathd
188- Fix a segfault in kpartx
189
190* Mon Jul 17 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-4.0
191- Updated to latest source. Fixes bug in default multipath.conf
192
193* Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.1
194- Added ncurses-devel to BuildRequires
195
196* Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.0
197- Updated to latest source. deals with change in libsysfs API
198
199* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.4.7-2.2.1
200- rebuild
201
202* Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.2
203- fix tagging issue.
204
205* Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.1
206- changed BuildRequires from sysfsutils-devel to libsysfs-devel
207
208* Wed Jun 28 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.0
209- Updated to latest upstream source, fixes kpartx udev rule issue
210
211* Mon Jun 06 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-1.0
212- Updated to Christophe's latest source
213
214* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-16.0
215- Newer upstream source (t0_4_5_post59).
216
217* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-12.3
218- BuildRequires: libsepol-devel, readline-devel
219
220* Mon Feb 27 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.5-12.2
221- Prereq: chkconfig
222
223* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 0.4.5-12.1
224- BuildRequires: libselinux-devel
225
226* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-12.0.1
227- bump again for double-long bug on ppc(64)
228
229* Tue Feb 07 2006 Benjamin Marzinski <bmarzins@redhat.com> -0.4.5-12.0
230- Updated to latest upstream source (t0_4_5_post56)
231
232* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-9.1.1
233- rebuilt for new gcc4.1 snapshot and glibc changes
234
235* Mon Dec 19 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.1
236- added patch for fedora changes
237
238* Fri Dec 16 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.0
239- Updated to latest upstream source (t)_4_5_post52)
240
241* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
242- rebuilt
243
244* Sun Dec  4 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.6
245- rebuild for newer libs
246
247* Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.5
248- unsplit kpartx.  parted knows how to do this now, so we don't
249  need this in a separate package.
250
251* Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.4
252- split kpartx out into its own package
253
254* Fri May 06 2005 Bill Nottingham <notting@redhat.com> - 0.4.4-2.3
255- Fix last fix.
256
257* Thu May 05 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.2
258- Fix last fix.
259
260* Wed May 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.1
261- By default, disable the multipathd service.
262
263* Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.0
264- Fix core dump from last build.
265
266* Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-1.0
267- Move cache file into /var/cache/multipath.
268
269* Fri Apr 08 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.1
270- Remove pp_balance_units.
271
272* Mon Apr 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.0
273- Incorporate numerous upstream fixes.
274- Update init script to distribution standards.
275
276* Tue Mar 01 2005 Alasdair Kergon <agk@redhat.com> - 0.4.2-1.0
277- Initial import based on Christophe Varoqui's spec file.
Note: See TracBrowser for help on using the repository browser.