source: projects/specs/branches/6/d/devhelp/devhelp-vl.spec @ 2041

Revision 2041, 6.3 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1Version:        2.32.0
2Release:        1%{?_dist_release}
3
4%define gtk_required            2.22.0
5%define libwnck_required        2.30.5
6
7Summary:        API document browser
8Summary(ja):    API ドキュメントブラウザ
9Name:           devhelp
10License:        GPL
11Group:          Applications/Development
12Url:            http://live.gnome.org/devhelp
13Source:         http://ftp.gnome.org/pub/GNOME/sources/devhelp/2.32/%{name}-%{version}.tar.bz2
14#Patch10:       %{name}-0.19.1-xulrunner19.patch
15#Patch11:       %{name}-webkit.patch
16#Patch:         %{name}-r1265.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: yasumichi
23
24Requires(pre,preun,post): GConf2
25Requires(post,postun): gtk2     >= %{gtk_required}
26
27BuildRequires:  gtk2-devel      >= %{gtk_required}
28BuildRequires:  GConf2-devel    >= 2.6.0
29BuildRequires:  libglade2-devel >= 2.4.0
30BuildRequires:  libwnck-devel   >= %{libwnck_required}
31BuildRequires:  zlib-devel
32BuildRequires:  WebKit-gtk-devel >= 1.1.13
33BuildRequires:  libsoup-devel
34BuildRequires:  unique-devel
35
36%description
37An API document browser for GNOME 2.
38
39%description -l ja
40GNOME2 用の API ブラウザです。
41
42%package devel
43Summary:        Library to embed Devhelp in other applications.
44Group:          Development/Libraries
45Requires:       %{name} = %{version}
46Requires:       gtk2-devel      >= %{gtk_required}
47Requires:       GConf2-devel    >= 2.6.0
48Requires:       libglade2-devel >= 2.4.0
49Requires:       libwnck-devel   >= %{libwnck_required}
50Requires:       WebKit-gtk-devel
51Requires:       libsoup-devel
52Requires:       unique-devel
53
54%description devel
55Library of Devhelp for embedding into other applications.
56
57%prep
58%setup -q
59#patch10 -p1 -b .xulrunner19
60#%patch -p1
61
62%build
63%configure --disable-static --disable-schemas-install
64
65make
66
67%install
68[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
69
70export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
71%makeinstall PREFIX=$RPM_BUILD_ROOT%{_prefix} install
72unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
73
74# remove, not shipped
75rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
76#rm -f $RPM_BUILD_ROOT%{_libdir}/libdevhelp-1.so
77#rm -rf $RPM_BUILD_ROOT%{_libdir}/pkgconfig
78#rm -rf $RPM_BUILD_ROOT%{_includedir}
79rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
80
81%find_lang %{name}
82
83%clean
84[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
85
86%post
87/sbin/ldconfig
88touch --no-create %{_datadir}/icons/hicolor
89if [ -x /usr/bin/gtk-update-icon-cache ]; then
90  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
91fi
92 
93%postun
94/sbin/ldconfig
95glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
96touch --no-create %{_datadir}/icons/hicolor
97if [ -x /usr/bin/gtk-update-icon-cache ]; then
98  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
99fi
100
101%posttrans
102glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
103
104 
105%files -f %{name}.lang
106%defattr(-, root, root)
107%doc AUTHORS COPYING ChangeLog NEWS README INSTALL
108%config %{_sysconfdir}/gconf/schemas/*.schemas
109%{_bindir}/devhelp
110%{_libdir}/lib*.so.*
111%{_datadir}/applications/devhelp.desktop
112%{_datadir}/devhelp
113%{_datadir}/icons/hicolor/scalable/apps/devhelp.svg
114%{_datadir}/icons/hicolor/*/apps/devhelp.png
115%{_libdir}/gedit-2/plugins/*
116
117%files devel
118%defattr(-,root,root)
119%{_includedir}/*
120#%{_libdir}/libdevhelp*.la
121%{_libdir}/libdevhelp*.so
122%{_libdir}/pkgconfig/*
123
124%changelog
125* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
126- new upstream release
127- remove %pre, %preun
128- fix %post, %postun
129- add %posttrans
130
131* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-2
132- rebuilt with rpm-4.8.1 for pkg-config
133
134* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
135- new upstream release
136
137* Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
138- new upstream release
139
140* Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.1-2
141- add unique-devel to BR
142
143* Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.28.1-1
144- New upstream release.
145- remove Patch
146- build with WebKit-1.1.15.3
147- add Vendor, Distribution and Packager.
148
149* Mon Aug 10 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-4
150- update Patch(See follow url)
151- http://git.gnome.org/cgit/devhelp/commit/?id=af67fbedccab5044808a489a9f3a5540d42adcf2
152
153* Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-3
154- update Url.
155- add Patch11(http://bugzilla.gnome.org/show_bug.cgi?id=586559)
156
157* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-2
158- remove unneeded Requires:
159- remove Requires/BuildRequires to gecko.
160
161* Tue Apr 28 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.23-1
162- new upstream release
163- added Requires: Webkit-gtk,libsoup BuildRequires: Webkit-gtk-devel,libsoup-devel
164
165* Tue Sep 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.21-1
166- new upstream release (dropped Patch10)
167- updated BuildRequires: gecko-devel-unstable instead of gecko-devel
168- added Requires: gecko-libs instead of firefox
169
170* Thu Jul 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.19.1-2
171- add Patch10 to build with xulrunner-1.9
172- add %%pre %%preun scripts to remove old gconf schemas
173- add %%postun to update icon cache
174- add unpackaged icons to %%files
175
176* Fri May 30 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.19.1
177- new upstream version.
178
179* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.16.1-2
180- use macro for Release
181
182* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org>
183- apply new virsioning policy.
184- remove *.la
185
186* Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.1-0vl2
187- rebuilt with libwnck 2.20.2
188
189* Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-0vl1
190- new upstream version
191- removed icon-theme.cache in %%install section
192
193* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.15-0vl1
194- new upstream release
195
196* Tue Apr 03 2007 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-0vl2
197- icon-theme.cache is not included.
198
199* Sun Apr 01 2007 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.13-0vl1
200- update to 0.13
201
202* Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.12-0vl2
203- build devel package
204
205* Sun Oct 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12-0vl1
206- updated to 0.12
207- using firefox(gecko) instead of gtkhtml2
208- disabled intltoolize before configure
209
210* Thu Aug 25 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.3-0vl2
211- add "--force" to intltoolize
212
213* Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.3-0vl1
214- build for Vine Linux
215- do not build devel package
216
217* Sun Jun 29 2003 Mikael Hallendal <micke@imendio.com>
218- Released 0.7
Note: See TracBrowser for help on using the repository browser.