source: projects/specs/branches/6/d/dev86/dev86-vl.spec @ 3525

Revision 3525, 4.9 KB checked in by owa, 13 years ago (diff)

rebuilt

Line 
1Summary: A real mode 80x86 assembler and linker
2Summary(ja): リアルモード 80x86 アセンブラとリンカ
3Name: dev86
4Version: 0.16.17
5Release: 3%{?_dist_release}
6License: GPL
7Group: Development/Languages
8URL: http://homepage.ntlworld.com/robert.debath/
9Source: http://homepage.ntlworld.com/robert.debath/dev86/Dev86src-%{version}.tar.gz
10Patch0: dev86-noelks.patch
11Patch1: dev86-x86_64.patch
12Patch2: dev86-nostrip.patch
13Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
14Obsoletes: bin86
15BuildRequires: gawk
16
17%define __os_install_post    /usr/lib/rpm/brp-compress /usr/lib/rpm/brp-strip %{__strip} /usr/lib/rpm/brp-strip-comment-note %{__strip} %{__objdump} %{nil}
18
19%description
20The dev86 package provides an assembler and linker for real mode 80x86
21instructions. You'll need to have this package installed in order to
22build programs that run in real mode, including LILO and the kernel's
23bootstrapping code, from their sources.
24
25You should install dev86 if you intend to build programs that run in real
26mode from their source code.
27
28%description -l ja
29dev86 パッケージは リアルモード 80x86 命令のアセンブラとリンカを提供
30します。LILO や kernel のブートストラップコードを含むリアルモードで
31走るプログラムをソースから作成するときにはこのパッケージがインストー
32ルされている必要があります。
33
34リアルモードで走るプログラムをソースから作成するつもりなら dev86 を
35インストールしてください。
36
37%prep
38%setup -q
39%patch0 -p1 -b .noelks
40%ifarch x86_64
41%patch1 -p1 -b .x86_64
42%endif
43%patch2 -p1 -b .nostrip
44
45%build
46make <<EOF
475
48quit
49EOF
50
51%install
52rm -rf ${RPM_BUILD_ROOT}
53
54make    DIST=${RPM_BUILD_ROOT} \
55        MANDIR=%{_mandir} \
56        LIBDIR=%{_libdir}/bcc \
57        INCLDIR=%{_libdir}/bcc \
58        LOCALPREFIX=%{_prefix} \
59        install install-man
60
61# preserve READMEs
62for i in bootblocks copt dis88 unproto bin86 ; do cp $i/README README.$i ; done
63cp bin86/README-0.4 README-0.4.bin86
64cp bin86/ChangeLog ChangeLog.bin86
65
66pushd ${RPM_BUILD_ROOT}%{_bindir}
67rm -f nm86 size86
68ln -s objdump86 nm86
69ln -s objdump86 size86
70popd
71
72%clean
73rm -rf ${RPM_BUILD_ROOT}
74
75%files
76%defattr(-,root,root,-)
77%doc README MAGIC Contributors README.bootblocks README.copt README.dis88
78%doc README.unproto README-0.4.bin86 README.bin86 ChangeLog.bin86
79%dir %{_libdir}/bcc
80%{_bindir}/bcc
81%{_bindir}/ar86
82%{_bindir}/as86
83%{_bindir}/ld86
84%{_bindir}/objdump86
85%{_bindir}/nm86
86%{_bindir}/size86
87%{_libdir}/bcc/*
88%{_mandir}/man1/*
89
90%changelog
91* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 0.16.17-3
92- rebuilt with rpm-4.8.1-3
93
94* Tue Jan  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.16.17-2
95- remove ExclusiveArch to allow to run dev86 on different arches
96
97* Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.17-1vl5
98- applied new versioning policy, spec in utf-8
99
100* Tue Nov 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.16.17-0vl1
101- new upstream release
102
103* Sat Sep 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.3-9vl1
104- based on Rawhide 0.16.3-9
105  * Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 0.16.3-9
106  - preserve README files with separate names
107  * Fri Jan 31 2003 Florian La Roche <Florian.LaRoche@redhat.de>
108  - do not strip static archive to get rebuild working again
109  * Sat Aug 10 2002 Florian La Roche <Florian.LaRoche@redhat.de>
110  - add ar86 to filelist
111  * Wed Jun 19 2002 Florian La Roche <Florian.LaRoche@redhat.de>
112  - do not strip apps
113
114- rebuild with new toolchains
115- s/Copyright/License/
116
117* Sat Jul 14 2001 <sagami@vinelinux.org>
118- 0.15.5-1vl2: use %%{ix86} for ExclusiveArch instead of i386
119- enabled %%clean (why was it disabled?)
120
121* Sun May 27 2001 <sagami@vinelinux.org>
122- 0.15.5-1vl1: added Japanese summary and description
123
124* Mon May  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.15.5-1
125- Update to 0.15.5, lots of fixes
126
127* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
128- automatic rebuild
129
130* Mon Jun 19 2000 Florian La Roche <Florian.LaRoche@redhat.com>
131- add defattr
132
133* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
134- use %%{_mandir}
135
136* Fri Feb 04 2000 Nalin Dahyabhai <nalin@redhat.com>
137- change default header directory to match libs and fix bug #9121
138
139* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
140- version 0.15.0
141- man pages are compressed
142
143* Mon Sep 20 1999 Donnie Barnes <djb@redhat.com>
144- removed "Distribution:" line (was RHCN)
145- changed description and summary to the ones from bin86 with s/bin/dev/
146  done throughout
147- added patch to keep from installing in /usr/bcc and simply in /usr
148- moved include files to /usr/lib/bcc/include
149
150* Tue Sep 07 1999 Erik Troan <ewt@redhat.com>
151- updated to Dev86src
152- included in Red Hat 6.1
153
154* Sat Nov 14 1998 Simon Weijgers <simon@mbit.doa.org>
155
156- First release of this package to be shipped to rhcn.
157
158- To be fixed: Bug in Makefile which installs headerfiles
159  double. E.g. /usr/bcc/include/arch is also installed under
160  /usr/bcc/include/arch/arch. This doesn't hinder operation,
161  just eats a tiny bit of diskspace.
162
Note: See TracBrowser for help on using the repository browser.