source: projects/specs/branches/6/d/ddd/ddd-vl.spec @ 521

Revision 521, 9.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define rpm_clean 1
2%define desktop_file 1
3%define desktop_file_utils_version 0.2.93
4%define debug_package %{nil}
5Summary: A GUI for several command-line debuggers.
6Summary(ja): コマンドラインデバッガ用のGUIツール
7Name: ddd
8Version: 3.3.11
9Release: 2%{?_dist_release}
10License: GPL
11Group: Applications/Development
12URL: http://www.gnu.org/software/ddd/
13BuildRoot: %{_tmppath}/%{name}-root
14Vendor: Project Vine
15Distribution: Vine Linux
16
17Source0: http://heanet.dl.sourceforge.net/sourceforge/ddd/ddd-%{version}.tar.gz
18Source2: ddd.desktop
19Source3: ddd.png
20Patch: ddd-3.3.11-lang.patch
21
22Prereq: /sbin/install-info
23BuildPreReq: openMotif-devel
24BuildPreReq: libtermcap-devel
25BuildPreReq: ncurses-devel
26BuildPreReq: gcc-c++
27BuildRequires: xorg-x11-devel
28Requires: openMotif
29
30%if %{desktop_file}
31BuildPrereq: desktop-file-utils >= %{desktop_file_utils_version}
32%endif
33
34%description
35The Data Display Debugger (DDD) is a popular GUI for command-line
36debuggers like GDB, DBX, JDB, WDB, XDB, the Perl debugger, and the
37Python debugger. DDD allows you to view source texts and provides an
38interactive graphical data display, in which data structures are
39displayed as graphs. You can use your mouse to dereference pointers
40or view structure contents, which are updated every time the program
41stops. DDD can debug programs written in Ada, C, C++, Chill, Fortran,
42Java, Modula, Pascal, Perl, and Python. DDD provides machine-level
43debugging; hypertext source navigation and lookup; breakpoint,
44watchpoint, backtrace, and history editors; array plots; undo and
45redo; preferences and settings editors; program execution in the
46terminal emulation window, debugging on a remote host, an on-line
47manual, extensive help on the Motif user interface, and a command-line
48interface with full editing, history and completion capabilities.
49
50%description -l ja
51The Data Display Debugger (DDD)はGDB、DBX、JDB、WDB、XDB、Perl
52デバッガおよびPythonデバッガのようなコマンドラインデバッガ用の
53ポピュラーなGUIツールです。DDD はソーステキストを見ることを可能
54にし対話型のグラフィカルなデータ構造の表示を提供します。マウス
55を使用して参照や表示内容を操作でき、プログラムが止まるごとに
56それらは更新されます。DDDは、Ada, C, C++, Chill, Fortran, Java,
57Modula, Pascal, PerlおよびPythonで書かれたプログラムをデバッグ
58することができます。DDDはマシンレベルのデバッギングを提供します。
59ハイパーテキストなソースナビゲーションおよび検索、ブレークポイント
60ウォッチポイント、バックトレースおよびヒストリエディタ、配列プロット
61取消、やり直し、プレファレンスおよびセッティングエディタ、
62ターミナルエミュレーションウィンドウでの実行、リモートホスト
63デバッキング、オンラインマニュアル、Motifユーザインターフェース
64での広範囲なヘルプ、コマンドラインインターフェイスでのフル編集
65ヒストリおよび完全な互換性。
66
67%prep
68%setup -q
69%patch -p1 -b .lang
70
71%build
72%configure
73make %{?smp_mflags}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78mkdir -p $RPM_BUILD_ROOT%{_bindir} \
79         $RPM_BUILD_ROOT%{_datadir}/pixmaps
80
81%makeinstall
82rm -f $RPM_BUILD_ROOT/%{_infodir}/dir*
83
84# desktop-file-install
85%if %{desktop_file}
86mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications/
87install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/applications/x-ddd.desktop
88%else
89mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/applnk/Development
90install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/X11/applnk/Development/ddd.desktop
91%endif
92
93install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/pixmaps
94
95gzip -9nfq $RPM_BUILD_ROOT/%{_infodir}/*
96
97%post
98/sbin/install-info %{_infodir}/ddd.info.gz %{_infodir}/dir
99 
100%preun
101if [ $1 = 0 ]; then
102   /sbin/install-info --delete %{_infodir}/ddd.info.gz %{_infodir}/dir
103fi
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%files
109%defattr(-,root,root)
110%doc doc/ddd.pdf
111%defattr(-,root,root)
112%{_bindir}/*
113%{_mandir}/*/*
114%{_infodir}/*
115%if %{desktop_file}
116%{_datadir}/applications/*
117%else
118%{_sysconfdir}/X11/applnk/Development/ddd.desktop
119%endif
120%{_datadir}/%{name}-%{version}
121%{_datadir}/pixmaps/ddd.png
122
123%changelog
124* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 3.3.11-2vl5
125- rebuild with libXaw.so.7 (libXaw-1.0.5)
126
127* Sat Jun 07 2008 Shu KONNO <owa@bg.wakwak.com> 3.3.11-1vl5
128- applied new versioning policy and utf-8
129- added BuildRequires: xorg-x11-devel
130
131* Mon Jun 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.3.11-0vl3
132- rebuilt with new toolchain
133
134* Tue Mar 13 2007 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 3.3.11-0vl2
135- updated Patch (fixed locale bug <bts:498>)
136
137* Sat Mar 3 2007 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 3.3.11-0vl1
138- new upstream release
139- changed Group to Applications/Development
140- updated Source0 and Patch
141
142* Sun Dec 5 2004 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 3.3.10-0vl1
143- new upstream release
144
145* Sun Sep 5 2004 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 3.3.9-0vl1
146- new upstream release
147- added summary(ja) and description(ja)
148- changed to BuildPreReq XOrg-devel
149
150* Mon Nov 10 2003 Than Ngo <than@redhat.com> 3.3.8-3vl1
151- based on Fedora development
152- rebuild with new toolchains
153- s/Copyright/License/
154- added --program-prefix optiion to %configure
155
156* Mon Nov 10 2003 Than Ngo <than@redhat.com> 3.3.8-3
157- 3.3.8
158
159* Wed Oct 08 2003 Than Ngo <than@redhat.com> 3.3.7-3
160- fixed utf-8 issue, bug #84816
161
162* Thu Aug 21 2003 Than Ngo <than@redhat.com> 3.3.7-2
163- install icon in correct place (bug #102794)
164 
165* Fri Jun 27 2003 Than Ngo <than@redhat.com> 3.3.7-1
166- 3.3.7
167
168* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
169- rebuilt
170
171* Tue Jun  3 2003 Than Ngo <than@redhat.com> 3.3.6-1
172- 3.3.6
173
174* Mon May  5 2003 Than Ngo <than@redhat.com> 3.3.5-1.1
175- use smp_mflags
176
177* Mon May  5 2003 Than Ngo <than@redhat.com> 3.3.5-1
178- 3.3.5 (bug #89523)
179
180* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
181- rebuilt
182
183* Thu Jan  2 2003 Than Ngo <than@redhat.com> 3.3.1-22
184- disable debug_package
185
186* Wed Nov  6 2002 Tim Powers <timp@redhat.com> 3.3.1-20
187- rebuilt to drop old libelf dep
188- add NEWS and COPYING files to filelist
189
190* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 3.3.1-19
191- rebuilt with gcc-3.2 (we hope)
192
193* Wed Jul 24 2002 Than Ngo <than@redhat.com> 3.3.1-18
194- desktop file issue (bug #69381)
195
196* Sat Jul 20 2002 Than Ngo <than@redhat.com> 3.3.1-17
197- use desktop-file-install
198
199* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
200- automated rebuild
201
202* Sat Jun 08 2002 Than Ngo <than@redhat.com> 3.3.1-15
203- PHP DBG support (bug #62180)
204
205* Thu May 23 2002 Tim Powers <timp@redhat.com>
206- automated rebuild
207
208* Fri Mar 22 2002 Tim Powers <timp@redhat.com>
209- rebuilt against openmotif-2.2.2
210
211* Mon Mar 18 2002 Than Ngo <than@redhat.com> 3.3.1-12
212- fix broken desktop file (bug #53193)
213
214* Fri Feb 22 2002 Than Ngo <than@redhat.com> 3.3.1-11
215- clean up patch file (bug #59935)
216- rebuild in new enviroment
217
218* Thu Jan 17 2002 Trond Eivind Glomsr <teg@redhat.com> 3.3.1-10
219- Don't include %%{_infodir}/dir
220
221* Thu Jan 17 2002 Than Ngo <than@redhat.com> 3.3.1-9
222- fix bug #52954
223- fix to build against gcc 3
224
225* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
226- rebuild with new gcc and binutils
227
228* Thu Jul 19 2001 Than Ngo <than@redhat.com>
229- add some build requires
230- Copyright->License
231
232* Fri Jun 29 2001 Karsten Hopp <karsten@redhat.de>
233- add desktop icons (gnome-cpu.png isn't always installed)
234
235* Sun Jun 10 2001 Than Ngo <than@redhat.com>
236- buildrequires lesstif-devel
237
238* Tue May 22 2001 Tim Powers <timp@redhat.com>
239- built for the distro
240
241* Thu May 03 2001 Than Ngo <than@redhat.com>
242- update to 3.3.1, it brings a couple of minor bug fixes
243
244* Sat Feb 03 2001 Than Ngo <than@redhat.com>
245- updated to 3.3
246
247* Tue Jan 23 2001 Than Ngo <than@redhat.com>
248- updated to 3.2.98, a release candidate for DDD 3.3
249
250* Mon Dec 04 2000 Than Ngo <than@redhat.com>
251- updated to 2.3.92 (Bug #16254)
252
253* Mon Jul 24 2000 Prospector <prospector@redhat.com>
254- rebuilt
255
256* Sat Jul 22 2000 Tim Powers <timp@redhat.com>
257- fixed missing BuildPreReq
258
259* Mon Jul 17 2000 Tim Powers <timp@redhat.com>
260- added defattr
261
262* Wed Jul 12 2000 Than Ngo <than@redhat.de>
263- rebuilt
264
265* Mon Jun 12 2000 Than Ngo <than@redhat.de>
266- rebuild with openmotif-2.1.30 for 7.0
267- clean up specfile
268- FHS fixes
269
270* Mon May 8 2000 Tim Powers <timp@redhat.com>
271- updated to 3.2.1
272- use applnk
273
274* Fri Feb 11 2000 Tim Powers <timp@redhat.com>
275- applied patch for ddd for use with lesstif 0.89 which caused the "view news"
276        etc. help items not to uncompress the news and manual properly, resulting in
277        an error message. Patch was from Andreas Zeller
278        <andreas.zeller@fmi.uni-passau.de>
279       
280* Tue Feb 01 2000 Tim Powers <timp@redhat.com>
281- bzipped sources to conserve space
282- built for 6.2
283
284* Tue Feb 01 2000 Trond Eivind Glomsr <teg@pvv.ntnu.no>
285- includes pdf doc instead of postscript
286- upgraded to 3.2
287- changed source locations and URLs to point at the new GNU sites
288- now does a make strip
289- added GNOME desktop entry
290
291
292* Fri Jan 07 2000 Trond Eivind Glomsr <teg@pvv.ntnu.no>
293- removed ptrace patch
294- now installs pydb
295- upgraded to 3.1.99
296- removed lots of old log entries
297
298* Thu Aug 19 1999 Tim Powers <timp@redhat.com>
299- reapplied patch for ptrace problems with sparc
300
301* Thu Aug 19 1999 Dale Lovelace <dale@redhat.com>
302- added ddd.wmconfig
303
304* Thu Jul 1 1999 Tim Powers <timp@redhat.com>
305- added the --with-motif-includes= and --with-motif-libraries= lines
306  so that it would build
307- rebuilt package for Powertools
308
309* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
310- update to 3.1.5.
311
312* Tue Apr 13 1999 Michael Maher <mike@redhat.com>
313- built package for 6.0
314- updated package
Note: See TracBrowser for help on using the repository browser.