source: projects/specs/branches/6/d/dbus-python/dbus-python-vl.spec @ 2387

Revision 2387, 5.1 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%{!?python_sitearch:    %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%{!?python_sitelib:     %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
3
4%define dbus_glib_version       0.92
5%define dbus_version            1.4.1
6%define pkg_release             1%{?_dist_release}
7
8Name:           dbus-python
9Summary:        D-Bus Python Bindings
10Summary(ja):    D-Bus Python バインディング
11Version:        0.83.2
12Release:        %{pkg_release}
13
14Group:          System Environment/Libraries
15License:        MIT
16URL:            http://www.freedesktop.org/software/dbus/
17
18Source0:        http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  dbus-devel >= %{dbus_version}
22BuildRequires:  dbus-glib-devel >= %{dbus_glib_version}
23BuildRequires:  python-devel
24
25%description
26D-Bus python bindings for use with python programs.   
27
28%description -l ja
29D-Bus を python プログラムから使う為のバインディングです。   
30
31
32%package devel
33Summary:        Libraries and headers for dbus-python
34Summary(ja):    dbus-python のライブラリ及びヘッダファイル
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37
38%description devel
39Headers and static libraries for hooking up custom mainloops to the dbus python
40bindings.
41
42%description devel -l ja
43dbus-python バインディング用のカスタム・メインループをフックする為の
44ヘッダファイルとスタティック・ライブラリです。
45
46
47%prep
48%setup -q
49
50%build
51%configure
52%{__make} %{?_smp_mflags}
53
54
55%install
56%{__rm} -rf ${RPM_BUILD_ROOT}
57%{__make} install DESTDIR=${RPM_BUILD_ROOT}
58
59# remove unnecessary *.la files
60find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} \;
61
62
63%clean
64rm -rf ${RPM_BUILD_ROOT}
65
66%files
67%defattr(-,root,root)
68%doc COPYING ChangeLog README NEWS TODO
69%doc doc/API_CHANGES.txt doc/HACKING.txt doc/tutorial.txt
70%exclude %{_datadir}/doc/dbus-python
71%dir %{python_sitelib}/dbus
72%dir %{python_sitelib}/dbus/mainloop
73%{python_sitearch}/*.so
74%{python_sitelib}/*.py*
75%{python_sitelib}/dbus/*.py*
76%{python_sitelib}/dbus/mainloop/*.py*
77
78%files devel
79%defattr(-,root,root)
80%{_includedir}/dbus-1.0/dbus/dbus-python.h
81%{_libdir}/pkgconfig/dbus-python.pc
82
83%changelog
84* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.83.2-1
85- new upstream release
86
87* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.83.1-1
88- new upstream release
89- dropt Patch0 (merged into upstream)
90- built with rpm-4.8.1 for pkg-config
91
92* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.83.0-4
93- rebuilt with gcc-4.4.3-3 on ppc
94
95* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.83.0-3
96- rebuilt with rpm-4.8.0-3 (on ppc)
97
98* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.83.0-2
99- rebuild with python-2.6
100
101* Sat Dec 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.83.0-1
102- initital build for Vine Linux based on fedora package
103
104* Tue Sep 16 2008 Marco Pesenti Gritti - 0.83.0-3
105- Add patch for https://bugs.freedesktop.org/show_bug.cgi?id=17551
106
107* Tue Aug 05 2008  Huang Peng <phuang@redhat.com> - 0.83.0-2
108- Update to 0.83.0.
109
110* Wed Jul 16 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.82.4-3
111- fix license tag
112
113* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.82.4-2
114- Autorebuild for GCC 4.3
115
116* Sun Jan 20 2008 Matthias Clasen <mclasen@redhat.com> - 0.82.4-1
117- Update to 0.82.4
118
119* Mon Oct 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.82.0-3
120- Rebuild against new dbus-glib
121
122* Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.82.0-2
123- Rebuild for selinux ppc32 issue.
124
125* Fri Jun 22 2007 Matthias Clasen <mclasen@redhat.com> - 0.82.0-1
126- Update to 0.82.0
127- Put all docs in the usual place
128
129* Tue Apr 03 2007 David Zeuthen <davidz@redhat.com> - 0.80.2-3
130- Rebuild
131
132* Tue Apr 03 2007 David Zeuthen <davidz@redhat.com> - 0.80.2-2
133- Don't examine args for functions declared METH_NOARGS (#235017)
134
135* Tue Feb 13 2007 John (J5) Palmieri <johnp@redhat.com> - 0.80.2-1
136- upgrade to 0.80.2 which fixes some memleaks
137
138* Wed Jan 24 2007 John (J5) Palmieri <johnp@redhat.com> - 0.80.1-1
139- upgrade to 0.80.1
140- remove dependency on Pyrex and libxml2
141- some API breakage,
142  please see http://dbus.freedesktop.org/doc/dbus-python/NEWS.html
143  for notes on changes
144
145* Wed Jan  3 2007 David Zeuthen <davidz@redhat.com> - 0.70-9%{?dist}
146- rebuild against new Pyrex
147
148* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 0.70-8
149- rebuild against python 2.5
150
151* Tue Nov  7 2006 Matthias Clasen <mclasen@redhat.com> - 0.70-7
152- Fix a typo in the spec file
153
154* Fri Aug 18 2006 Karsten Hopp <karsten@redhat.com> - 0.70-6
155- require libxml2-python for site-packages/dbus/introspect_parser.py
156
157* Thu Jul 20 2006 Jesse Keating <jkeating@redhat.com> - 0.70-5
158- Remove unnecessary obsoletes
159
160* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-4
161- Try python_sitearch this time
162
163* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-3
164- Add a BR on dbus-devel
165
166* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-2
167- Spec file cleanups
168- Add PKG_CONFIG_PATH
169
170* Mon Jul 17 2006 John (J5) Palmieri <johnp@redhat.com> - 0.70-1
171- Initial package import
Note: See TracBrowser for help on using the repository browser.