source: projects/specs/branches/6/d/db46/db46-vl.spec @ 521

Revision 521, 28.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# the set of arches on which libgcj provides gcj and libgcj-javac-placeholder.sh
4%define java_arches %{ix86} alpha ia64 ppc s390 s390x sparc sparcv9 x86_64
5
6##VINE##
7%undefine java_arches
8
9%define __soversion     4.6
10%define _libdb_a        libdb-%{__soversion}.a
11%define _libcxx_a       libdb_cxx-%{__soversion}.a
12
13Summary: The Berkeley DB database library (version 4) for C
14Name: db46
15Version: 4.6.21
16Release: 8%{?_dist_release}
17Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
18Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
19Patch1: http://www.oracle.com/technology/products/berkeley-db/xml/update/4.6.21/patch.4.6.21.1
20Patch2: db-4.3.29-sparc64.patch
21Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
22Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
23Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
24Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
25Patch14: db-1.85-errno.patch
26Patch20: db-4.6.18-glibc.patch
27Patch22: db-4.5.20-jni-include-dir.patch
28URL: http://www.oracle.com/database/berkeley-db/
29License: BSD-style
30Group: System Environment/Libraries
31Obsoletes: db1, db2, db3
32BuildRequires: perl, libtool, ed, tcl >= 8.4.4
33#BuildRequires: util-linux-ng
34%ifarch %{java_arches}
35BuildRequires: gcc-java
36BuildRequires: java-1.5.0-gcj
37BuildRequires: java-1.5.0-gcj-devel
38%endif
39BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
40
41
42%description
43The Berkeley Database (Berkeley DB) is a programmatic toolkit that
44provides embedded database support for both traditional and
45client/server applications. The Berkeley DB includes B+tree, Extended
46Linear Hashing, Fixed and Variable-length record access methods,
47transactions, locking, logging, shared memory caching, and database
48recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
49used by many applications, including Python and Perl, so this should
50be installed on all systems.
51
52
53%package -n compat32-%{name}
54Summary: The Berkeley DB database library (version 4) for C.
55Group: System Environment/Libraries
56Requires: db4 = %{version}-%{release}
57
58%description -n compat32-%{name}
59The Berkeley Database (Berkeley DB) is a programmatic toolkit that
60provides embedded database support for both traditional and
61client/server applications. The Berkeley DB includes B+tree, Extended
62Linear Hashing, Fixed and Variable-length record access methods,
63transactions, locking, logging, shared memory caching, and database
64recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
65used by many applications, including Python and Perl, so this should
66be installed on all systems.
67
68
69%package cxx
70Summary: The Berkeley DB database library (version 4) for C++
71Group: System Environment/Libraries
72
73%description cxx
74The Berkeley Database (Berkeley DB) is a programmatic toolkit that
75provides embedded database support for both traditional and
76client/server applications. The Berkeley DB includes B+tree, Extended
77Linear Hashing, Fixed and Variable-length record access methods,
78transactions, locking, logging, shared memory caching, and database
79recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
80used by many applications, including Python and Perl, so this should
81be installed on all systems.
82
83
84%package -n compat32-%{name}-cxx
85Summary: The Berkeley DB database library (version 4) for C++
86Group: System Environment/Libraries
87
88%description -n compat32-%{name}-cxx
89The Berkeley Database (Berkeley DB) is a programmatic toolkit that
90provides embedded database support for both traditional and
91client/server applications. The Berkeley DB includes B+tree, Extended
92Linear Hashing, Fixed and Variable-length record access methods,
93transactions, locking, logging, shared memory caching, and database
94recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
95used by many applications, including Python and Perl, so this should
96be installed on all systems.
97
98
99%package utils
100Summary: Command line tools for managing Berkeley DB (version 4) databases
101Group: Applications/System
102Requires: db4 = %{version}-%{release}
103Obsoletes: db1-utils, db2-utils, db3-utils
104
105%description utils
106The Berkeley Database (Berkeley DB) is a programmatic toolkit that
107provides embedded database support for both traditional and
108client/server applications. Berkeley DB includes B+tree, Extended
109Linear Hashing, Fixed and Variable-length record access methods,
110transactions, locking, logging, shared memory caching, and database
111recovery. DB supports C, C++, Java and Perl APIs.
112
113
114%package devel
115Summary: C development files for the Berkeley DB (version 4) library
116Group: Development/Libraries
117Requires: db4 = %{version}-%{release}
118Obsoletes: db1-devel, db2-devel, db3-devel
119
120%description devel
121The Berkeley Database (Berkeley DB) is a programmatic toolkit that
122provides embedded database support for both traditional and
123client/server applications. This package contains the header files,
124libraries, and documentation for building programs which use the
125Berkeley DB.
126
127
128%package -n compat32-%{name}-devel
129Summary: Development files for the Berkeley DB (version 4) library.
130Group: Development/Libraries
131Requires: compat32-%{name} = %{version}-%{release}
132Requires: %{name}-devel    = %{version}-%{release}
133
134%description -n compat32-%{name}-devel
135The Berkeley Database (Berkeley DB) is a programmatic toolkit that
136provides embedded database support for both traditional and
137client/server applications. This package contains the header files,
138libraries, and documentation for building programs which use the
139Berkeley DB.
140
141
142%package tcl
143Summary: Development files for using the Berkeley DB (version 4) with tcl
144Group: Development/Libraries
145Requires: %{name} = %{version}-%{release}
146
147%description tcl
148The Berkeley Database (Berkeley DB) is a programmatic toolkit that
149provides embedded database support for both traditional and
150client/server applications. This package contains the libraries
151for building programs which use the Berkeley DB in Tcl.
152
153
154%package -n compat32-%{name}-tcl
155Summary: Development files for using the Berkeley DB (version 4) with tcl.
156Group: Development/Libraries
157Requires: compat32-%{name} = %{version}-%{release}
158Requires: %{name}-tcl      = %{version}-%{release}
159
160%description -n compat32-%{name}-tcl
161The Berkeley Database (Berkeley DB) is a programmatic toolkit that
162provides embedded database support for both traditional and
163client/server applications. This package contains the libraries
164for building programs which use the Berkeley DB in Tcl.
165
166
167%package java
168Summary: Development files for using the Berkeley DB (version 4) with Java
169Group: Development/Libraries
170Requires: %{name} = %{version}-%{release}
171
172%description java
173The Berkeley Database (Berkeley DB) is a programmatic toolkit that
174provides embedded database support for both traditional and
175client/server applications. This package contains the libraries
176for building programs which use the Berkeley DB in Java.
177
178
179%prep
180%setup -q -n db-%{version} -a 1
181%patch1 -p0 -b .4.6.21.1
182%patch2 -p1 -b .sparc64
183
184pushd dist
185#libtoolize --copy --force
186#cat %{_datadir}/aclocal/libtool.m4 >> aclocal.m4
187popd
188pushd db.1.85/PORT/linux
189%patch10 -p0 -b .1.1
190popd
191pushd db.1.85
192%patch11 -p0 -b .1.2
193%patch12 -p0 -b .1.3
194%patch13 -p0 -b .1.4
195%patch14 -p1 -b .errno
196popd
197
198%patch20 -p1 -b .glibc
199%patch22 -p1 -b .4.5.20.jni
200
201# Remove tags files which we don't need.
202find . -name tags | xargs rm -f
203# Define a shell function for fixing HREF references in the docs, which
204# would otherwise break when we split the docs up into subpackages.
205fixup_href() {
206    for doc in $@ ; do
207        chmod u+w ${doc}
208        sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
209            -e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
210            -e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
211            -e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
212            -e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
213            -e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
214            -e 's,="../java/,="../../%{name}-devel-%{version}/java/,g' \
215            -e 's,="java/,="../%{name}-devel-%{version}/java/,g' \
216            -e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
217            -e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
218            -e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
219            -e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
220            -e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
221            -e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
222            -e 's,="../images/,="../../%{name}-devel-%{version}/images/,g' \
223            -e 's,="images/,="../%{name}-devel-%{version}/images/,g' \
224            -e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
225            -e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
226        touch -r ${doc} ${doc}.new
227        cat ${doc}.new > ${doc}
228        touch -r ${doc}.new ${doc}
229        rm -f ${doc}.new
230    done
231}
232
233set +x  # XXX painful to watch
234# Fix all of the HTML files.
235fixup_href `find . -name "*.html"`
236set -x  # XXX painful to watch
237
238cd dist
239#./s_config
240
241
242%build
243CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"; export CFLAGS
244
245# Build the old db-185 libraries.
246make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
247
248build() {
249        test -d dist/$1 || mkdir dist/$1
250        # Static link db_dump185 with old db-185 libraries.
251        /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/$1/db_dump185.lo
252        /bin/sh libtool --mode=link    %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
253
254        pushd dist/$1
255        ln -sf ../configure .
256        # XXX --enable-diagnostic should be disabled for production (but is
257        # useful).
258        # XXX --enable-debug_{r,w}op should be disabled for production.
259        %configure -C \
260                --enable-compat185 --enable-dump185 \
261                --enable-shared --enable-static --enable-rpc \
262                --enable-tcl --with-tcl=%{_libdir} \
263                --enable-cxx \
264%ifarch %{java_arches}
265                --enable-java \
266%else
267                --disable-java \
268%endif
269                --enable-test \
270                # --enable-diagnostic \
271                # --enable-debug --enable-debug_rop --enable-debug_wop \
272
273        # Remove libtool predep_objects and postdep_objects wonkiness so that
274        # building without -nostdlib doesn't include them twice.  Because we
275        # already link with g++, weird stuff happens if you don't let the
276        # compiler handle this.
277        perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
278        perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
279        perl -pi -e 's/-shared -nostdlib/-shared/' libtool
280
281        make    %{?_smp_mflags}
282
283        # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
284        LDBJ=./.libs/libdb_java-%{__soversion}.la
285        if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
286            sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
287        fi
288
289        popd
290}
291
292build dist-tls
293
294
295%install
296rm -rf ${RPM_BUILD_ROOT}
297mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
298mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
299
300%makeinstall -C dist/dist-tls
301
302# XXX Nuke non-versioned archives and symlinks
303rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a}
304rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb-4.so
305rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_cxx-4.so
306rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl-4.so
307rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl.so
308
309chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
310
311# Move the main shared library from /usr/lib* to /lib* directory.
312if [ "%{_libdir}" != "/%{_lib}" ]; then
313  mkdir -p $RPM_BUILD_ROOT/%{_lib}/
314  mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
315
316# Leave relative symlinks in %{_libdir}.
317  touch $RPM_BUILD_ROOT/rootfile
318  root=..
319  while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
320    root=${root}/..
321  done
322  rm $RPM_BUILD_ROOT/rootfile
323
324  ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb.so
325  ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/
326  ln -sf libdb_cxx-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb_cxx.so
327fi
328
329# Move the header files to a subdirectory, in case we're deploying on a
330# system with multiple versions of DB installed.
331mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/db4
332mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/db4/
333
334# Create symlinks to includes so that "use <db.h> and link with -ldb" works.
335for i in db.h db_cxx.h db_185.h; do
336        ln -s db4/$i ${RPM_BUILD_ROOT}%{_includedir}
337done
338
339%ifarch %{java_arches}
340# Move java jar file to the correct place
341mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
342mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
343%endif
344
345# Eliminate installed doco
346rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
347
348# XXX Avoid Permission denied. strip when building as non-root.
349chmod u+w ${RPM_BUILD_ROOT}%{_bindir}
350
351
352%clean
353rm -rf ${RPM_BUILD_ROOT}
354
355
356%post -p /sbin/ldconfig
357
358%postun -p /sbin/ldconfig
359
360%post -n compat32-%{name} -p /sbin/ldconfig
361
362%postun -n compat32-%{name} -p /sbin/ldconfig
363
364%files
365%defattr(-,root,root)
366%doc LICENSE README
367/%{_lib}/libdb-%{__soversion}.so
368%{_libdir}/libdb-%{__soversion}.so
369
370%if %{build_compat32}
371%files -n compat32-%{name}
372%defattr(-,root,root)
373/%{_lib}/libdb-%{__soversion}.so
374%{_libdir}/libdb-%{__soversion}.so
375%endif
376
377
378%changelog
379* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6.21-8
380- rebuilt with gcc-4.4.3-3 on ppc
381
382* Mon Feb 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6.21-7
383- rename to db46 to build as compatibility package
384
385* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.6.21-6
386- initial build of db-4.6.21 on Vine Linux
387- temporarily commented out "libtoolize" and "s_config" lines
388  until Vine's autotools get updated (maybe?)
389
390* Fri Apr  3 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-5
391- add upstream patch to fix a race condition between checkpoint
392  and DB->close which can result in the checkpoint thread self-deadlocking
393
394* Mon Mar 10 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-4
395- don't list headers twice in filelist (#436701)
396
397* Mon Feb 25 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-3
398- manual rebuild because of gcc-4.3 (#434185)
399
400* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.6.21-2
401- Autorebuild for GCC 4.3
402
403* Thu Oct 11 2007 Jindrich Novy <jnovy@redhat.com> 4.6.21-1
404- update to 4.6.21
405- own %%{_includedir}/db4 (#274251)
406
407* Mon Sep  3 2007 Jindrich Novy <jnovy@redhat.com> 4.6.19-1
408- update to 4.6.19 (#273461)
409
410* Thu Aug 29 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-2
411- rebuild for BuildID
412- BR util-linux-ng
413
414* Mon Jul 30 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-1
415- update to 4.6.18
416- drop upstream patches for 4.5.20 and gcj patch
417- remove nptl-abi-note.S, useless as we are definitely
418  running kernel >= 2.4.20 (#245416)
419- move C++ stuff to subpackages to reduce dependency bloat (#220484)
420- package db_codegen
421- correct open() calls so that new db4 compiles with the new glibc
422
423* Sat Mar 24 2007 Thomas Fitzsimmons <fitzsim@redhat.com> 4.5.20-5
424- Require java-1.5.0-gcj and java-1.5.0-gcj-devel for build.
425
426* Mon Dec  4 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-4
427- apply upstream patches for 4.5.20
428  (Java API <-> core API related fixes)
429
430* Fri Dec  1 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-3
431- temporarily remove ppc64 from java arches
432
433* Sun Nov 26 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-2
434- sync db4 and compat-db licenses to BSD-style as the result of
435  consultation with legal department
436- fix some rpmlint warnings
437
438* Fri Nov 10 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-1
439- update to db-4.5.20 (#198038)
440- fix BuildRoot
441- drop .64bit patch
442- patch/source URLs now point to correct location
443
444* Tue Sep 12 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-9
445- rebuild
446
447* Wed Sep  6 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-8
448- revert the previous fix, it crashes OOo help
449
450* Sun Sep  3 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-7.fc6
451- fix memleak caused by SET_TXN macro in xa_db.c, when opening
452  database created with DB_XA_CREATE flag (#204920)
453
454* Wed Jul 19 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-6
455- fix sparc64 build (#199358)
456
457* Mon Jul 17 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-5
458- rebuild because of gnu_hash
459
460* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-4.1
461- rebuild
462
463* Fri Mar 24 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-4
464- drop useless java, lfs patches
465
466* Mon Mar 13 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-3
467- apply x86_64 fix from Henrik Nordstrom (#184588)
468- don't nuke non-versioned archives twice
469
470* Wed Feb 15 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-2
471- don't package /usr/share/doc/images in the main db4 package
472  and move it to db4-devel (#33328)
473- make db4 LFS capable (#33849)
474- move db4-devel, db4-tcl, db4-java to Development/Libraries
475  group instead of System Environment/Libraries (#54320)
476- BuildPrereq -> BuildRequires
477- don't use RPM_SOURCE_DIR
478- Obsoletes db3, db2
479
480* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2.1
481- bump again for double-long bug on ppc(64)
482
483* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2
484- rebuilt for new gcc4.1 snapshot and glibc changes
485
486* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
487- rebuilt
488
489* Fri Oct 07 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.29-1
490- New upstream release
491
492* Fri Sep 30 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-4
493- Re-enable java for ppc64
494
495* Wed Sep 21 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-3
496- Add fno-strict-aliasing for java (#168965)
497
498* Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-2
499- no java for ppc64 for now (#166657)
500
501* Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-1
502- FC5 is nptl only (derived from jbj's spec)
503- upgrade to 4.3.28
504
505* Thu Jul 14 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-5
506- re-enable db4-java
507
508* Tue May 17 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-4
509- /usr/lib/tls/ix86 dirs (#151371)
510
511* Mon Apr 25 2005 Bill Nottingham <notting@redhat.com> 4.3.27-3
512- add libdb_cxx.so link (#149191)
513
514* Fri Mar  4 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-2
515- rebuild with gcc4.
516
517* Sat Jan  1 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-1
518- upgrade to 4.3.27.
519
520* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 4.3.21-1
521- upgrade to 4.3.21, no db4-java for the moment again again.
522
523* Tue Sep 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.2.52-6
524- on %%{ix86} systems, make the availability of an NPTL-requiring libdb match
525  the availability of an NPTL libpthread in glibc > 2.3.3-48
526- run ldconfig in db4-java's %%post/%%postun
527- when building java support, assume that libgcj is equivalent enough to 1.3
528
529* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
530- rebuilt
531
532* Mon Jun  7 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-4
533- remove dangling symlinks (#123721 et al).
534- remove db_cxx.so and db_tcl.so symlinks, versioned equivs exist.
535- apply 2 patches from sleepycat.
536- resurrect db4-java using sun jvm-1.4.2.
537- cripple autoconf sufficiently to build db4-java with gcj, without jvm.
538- check javac first, gcj34 next, then gcj-ssa, finally gcj.
539- add ed build dependency (#125180).
540
541* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
542- rebuilt
543
544* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
545- rebuilt
546
547* Fri Jan 16 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-2
548- fix: automake *.lo wrapper, not elf, files included in *.a (#113572).
549
550* Thu Dec 11 2003 Jeff Johnson <jbj@jbj.org> 4.2.52-1
551- upgrade to db-4.2.52, no db4-java for the moment.
552
553* Fri Nov 28 2003 Paul Nasrat <pauln@truemesh.com> 4.2.41-0.2
554- Add build requires tcl-devel
555
556* Fri Oct 24 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-14
557- symlink from %%{_libdir}/tls/libdb-4.1.so to the copy in /%%{_lib}/tls, so
558  that the run-time linker can find the right copy for of apps which use an
559  RPATH to point at %%{_libdir}/libdb-4.1.so
560
561* Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-13
562- add another section to the ABI note for the TLS libdb so that it's marked as
563  not needing an executable stack (from Arjan Van de Ven)
564
565* Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com>
566- build both with and without support for shared mutex locks, which require NPTL
567- make behavior wrt where we put libdb the same for all OSs
568- revert changes making tcl optional - nesting %%if tcl and %%ifarch nptl
569  doesn't work
570- fix dangling HREFs in utility docs (pointed to main docs dir, while they're
571  actually in the -utils docs dir)
572- run ldconfig when installing/removing the -utils subpackage, as it contains
573  shared libraries
574
575* Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-11
576- fix multiple-inclusion problem of startup files when building shlibs without
577  the -nostdlib flag
578
579* Tue Oct 14 2003 Nalin Dahyabhai <nalin@redhat.com>
580- link shared libraries without -nostdlib, which created an unresolvable dep
581  on a hidden symbol
582
583* Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
584- allow compiling without tcl dependency
585
586* Sat Sep 20 2003 Jeff Johnson <jbj@jbj.org> 4.2.42-0.1
587- update to 4.2.42.
588- build in build_unix subdir.
589- eliminate --enable-dump185, db_dump185.c no longer compiles for libdb*.
590- create db4-tcl sub-pkg to isolate libtcl dependencies.
591
592* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-9
593- rebuild
594
595* Tue Aug 19 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-8
596- add missing tcl-devel buildrequires (#101814)
597
598* Tue Jul 15 2003 Joe Orton <jorton@redhat.com> 4.1.25-7
599- rebuild
600
601* Fri Jun 27 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-6
602- build with libtool-1.5, which can't recognize the .so in libfoo*.so atm.
603- whack out libtool predep_objects wonkiness.
604
605* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-5
606- rebuild.
607
608* Tue Jun 24 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-4
609- hack out O_DIRECT support in db4 for now.
610
611* Tue Jun 24 2003 Nalin Dahyabhai <nalin@redhat.com>
612- replace libtool.ac with current libtool.m4 so that running libtoolize doesn't
613  cause a mismatch
614
615* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
616- rebuilt
617
618* Wed Jun  4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-2
619- change configure to only warn if JNI includes aren't found, assuming that
620  the C compiler can find them
621- remove build requirement on jdkgcj -- gcj is sufficient
622
623* Mon May  5 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-1
624- upgrade to 4.1.25, crypto version.
625- enable posix mutexes using nptl on all arches.
626
627* Mon Mar  3 2003 Thoams Woerner <twoerner@redhat.com> 4.0.14-21
628- enabled db4-java for x86_64
629
630* Wed Feb  5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-20
631- add dynamic libdb-4.0.so link back to %%{_libdir} so that dynamically
632  linking with -ldb-4.0 will work again
633
634* Tue Feb  4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-19
635- rebuild to use link the shared object with the same libraries we use
636  for the bundled utils, should pull in libpthread when needed
637- move libdb.so from /%%{_lib} to %%{_libdir} where the linker can find it
638
639* Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-18
640- add java for s390x
641
642* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.0.14-17
643- rebuilt
644
645* Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-16
646- add java for s390
647
648* Tue Oct  8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-15
649- add java bits back in for x86 boxes
650
651* Fri Sep 20 2002 Than Ngo <than@redhat.com> 4.0.14-14.1
652- Added better fix for s390/s390x/x86_64
653
654* Thu Sep 05 2002 Arjan van de Ven
655- remove java bits for x86-64
656
657* Tue Aug 27 2002 Jeff Johnson <jbj@redhat.com> 4.0.14-14
658- include libdb_tcl-4.1.a library.
659- obsolete db1 packages.
660
661* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-13
662- include patch to avoid db_recover (#70362)
663
664* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
665- rebuilt with gcc-3.2 (we hope)
666
667* Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-11
668- own %%{_includedir}/%{name}
669
670* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.0.14-10
671- build using gcc-3.2-0.1
672
673* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
674- automated rebuild
675
676* Wed Jun 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.0.14-8
677- Add java bindings
678- Fix C++ bindings
679
680* Thu May 23 2002 Tim Powers <timp@redhat.com>
681- automated rebuild
682
683* Thu May  9 2002 Jeff Johnson <jbj@redhat.com>
684- re-enable db.h symlink creation, db_util names, and db[23]-devel obsoletes.
685- make sure that -ldb is functional.
686
687* Thu Feb 21 2002 Jeff Johnson <jbj@redhat.com>
688- avoid db_util name collisions with multiple versions installed.
689
690* Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-3
691- remove relocatability stuffs
692- swallow a local copy of db1 and build db185_dump statically with it, to
693  remove the build dependency and simplify bootstrapping new arches
694
695* Mon Jan 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-2
696- have subpackages obsolete their db3 counterparts, because they conflict anyway
697
698* Tue Jan  8 2002 Jeff Johnson <jbj@redhat.com> db4-4.0.14-1
699- upgrade to 4.0.14.
700
701* Sun Aug  5 2001 Nalin Dahyabhai <nalin@redhat.com>
702- fix dangling docs symlinks
703- fix dangling doc HREFs (#33328)
704- apply the two patches listed at http://www.sleepycat.com/update/3.2.9/patch.3.2.9.html
705
706* Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
707- turn off --enable-debug
708
709* Thu May 10 2001 Than Ngo <than@redhat.com>
710- fixed to build on s390x
711
712* Mon Mar 19 2001 Jeff Johnson <jbj@redhat.com>
713- update to 3.2.9.
714
715* Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
716- rebuild to remove 777 directories.
717
718* Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
719- don't build with --enable-diagnostic.
720- add build prereq on tcl.
721- default value for %%_lib macro if not found.
722
723* Tue Oct 17 2000 Jeff Johnson <jbj@redhat.com>
724- add /usr/lib/libdb-3.1.so symlink to %%files.
725- remove dangling tags symlink from examples.
726
727* Mon Oct  9 2000 Jeff Johnson <jbj@redhat.com>
728- rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
729- turn off --enable-diagnostic for performance.
730
731* Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
732- update to 3.1.17.
733- disable posix mutexes Yet Again.
734
735* Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
736- add c++ and posix mutex support.
737
738* Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
739- put nss_db into a separate package
740
741* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
742- rebuild to cope with glibc locale binary incompatibility, again
743
744* Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
745- remove redundant strip of libnss_db* that is nuking symbols.
746- change location in /usr/lib/libdb-3.1.la to point to /lib (#16776).
747
748* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
749- summaries from specspo.
750- all of libdb_tcl* (including symlinks) in db3-utils, should be db3->tcl?
751
752* Wed Aug 16 2000 Jakub Jelinek <jakub@redhat.com>
753- temporarily build nss_db in this package, should be moved
754  into separate nss_db package soon
755
756* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
757- rebuild to cope with glibc locale binary incompatibility
758
759* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
760- automatic rebuild
761
762* Sun Jun 11 2000 Jeff Johnson <jbj@redhat.com>
763- upgrade to 3.1.14.
764- create db3-utils sub-package to hide tcl dependency, enable tcl Yet Again.
765- FHS packaging.
766
767* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
768- disable tcl Yet Again, base packages cannot depend on libtcl.so.
769
770* Sat Jun  3 2000 Jeff Johnson <jbj@redhat.com>
771- enable tcl, rebuild against tcltk 8.3.1 (w/o pthreads).
772
773* Tue May 30 2000 Matt Wilson <msw@redhat.com>
774- include /lib/libdb.so in the devel package
775
776* Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
777- put in "System Environment/Libraries" per msw instructions.
778
779* Tue May  9 2000 Jeff Johnson <jbj@redhat.com>
780- install shared library in /lib, not /usr/lib.
781- move API docs to db3-devel.
782
783* Mon May  8 2000 Jeff Johnson <jbj@redhat.com>
784- don't rename db_* to db3_*.
785
786* Tue May  2 2000 Jeff Johnson <jbj@redhat.com>
787- disable --enable-test --enable-debug_rop --enable-debug_wop.
788- disable --enable-posixmutexes --enable-tcl as well, to avoid glibc-2.1.3
789  problems.
790
791* Mon Apr 24 2000 Jeff Johnson <jbj@redhat.com>
792- add 3.0.55.1 alignment patch.
793- add --enable-posixmutexes (linux threads has not pthread_*attr_setpshared).
794- add --enable-tcl (needed -lpthreads).
795
796* Sat Apr  1 2000 Jeff Johnson <jbj@redhat.com>
797- add --enable-debug_{r,w}op for now.
798- add variable to set shm perms.
799
800* Sat Mar 25 2000 Jeff Johnson <jbj@redhat.com>
801- update to 3.0.55
802
803* Tue Dec 29 1998 Jeff Johnson <jbj@redhat.com>
804- Add --enable-cxx to configure.
805
806* Thu Jun 18 1998 Jeff Johnson <jbj@redhat.com>
807- Create.
Note: See TracBrowser for help on using the repository browser.