source: projects/specs/branches/6/d/db4/db4-vl.spec @ 2211

Revision 2211, 29.9 KB checked in by tomop, 13 years ago (diff)

new upstream release.

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# the set of arches on which libgcj provides gcj and libgcj-javac-placeholder.sh
4%define java_arches %{ix86} alpha ia64 ppc s390 s390x sparc sparcv9 x86_64
5
6##VINE##
7%undefine java_arches
8
9%define __soversion     4.8
10%define _libdb_a        libdb-%{__soversion}.a
11%define _libcxx_a       libdb_cxx-%{__soversion}.a
12
13Summary: The Berkeley DB database library (version 4) for C
14Name: db4
15Version: 4.8.30
16Release: 1%{?_dist_release}
17
18Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
19Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
20
21# patches for db1.85
22Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
23Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
24Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
25Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
26
27Patch20: db-1.85-errno.patch
28Patch22: db-4.6.21-1.85-compat.patch
29Patch24: db-4.5.20-jni-include-dir.patch
30
31URL: http://www.oracle.com/database/berkeley-db/
32License: BSD-style
33Group: System Environment/Libraries
34Obsoletes: db1, db2, db3
35BuildRequires: perl, libtool, ed, tcl >= 8.4.4
36#BuildRequires: util-linux-ng
37%ifarch %{java_arches}
38BuildRequires: gcc-java
39BuildRequires: java-1.5.0-gcj
40BuildRequires: java-1.5.0-gcj-devel
41%endif
42BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
43
44
45%description
46The Berkeley Database (Berkeley DB) is a programmatic toolkit that
47provides embedded database support for both traditional and
48client/server applications. The Berkeley DB includes B+tree, Extended
49Linear Hashing, Fixed and Variable-length record access methods,
50transactions, locking, logging, shared memory caching, and database
51recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
52used by many applications, including Python and Perl, so this should
53be installed on all systems.
54
55
56%package -n compat32-%{name}
57Summary: The Berkeley DB database library (version 4) for C.
58Group: System Environment/Libraries
59Requires: db4 = %{version}-%{release}
60
61%description -n compat32-%{name}
62The Berkeley Database (Berkeley DB) is a programmatic toolkit that
63provides embedded database support for both traditional and
64client/server applications. The Berkeley DB includes B+tree, Extended
65Linear Hashing, Fixed and Variable-length record access methods,
66transactions, locking, logging, shared memory caching, and database
67recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
68used by many applications, including Python and Perl, so this should
69be installed on all systems.
70
71
72%package cxx
73Summary: The Berkeley DB database library (version 4) for C++
74Group: System Environment/Libraries
75
76%description cxx
77The Berkeley Database (Berkeley DB) is a programmatic toolkit that
78provides embedded database support for both traditional and
79client/server applications. The Berkeley DB includes B+tree, Extended
80Linear Hashing, Fixed and Variable-length record access methods,
81transactions, locking, logging, shared memory caching, and database
82recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
83used by many applications, including Python and Perl, so this should
84be installed on all systems.
85
86
87%package -n compat32-%{name}-cxx
88Summary: The Berkeley DB database library (version 4) for C++
89Group: System Environment/Libraries
90
91%description -n compat32-%{name}-cxx
92The Berkeley Database (Berkeley DB) is a programmatic toolkit that
93provides embedded database support for both traditional and
94client/server applications. The Berkeley DB includes B+tree, Extended
95Linear Hashing, Fixed and Variable-length record access methods,
96transactions, locking, logging, shared memory caching, and database
97recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
98used by many applications, including Python and Perl, so this should
99be installed on all systems.
100
101
102%package utils
103Summary: Command line tools for managing Berkeley DB (version 4) databases
104Group: Applications/System
105Requires: db4 = %{version}-%{release}
106Obsoletes: db1-utils, db2-utils, db3-utils
107
108%description utils
109The Berkeley Database (Berkeley DB) is a programmatic toolkit that
110provides embedded database support for both traditional and
111client/server applications. Berkeley DB includes B+tree, Extended
112Linear Hashing, Fixed and Variable-length record access methods,
113transactions, locking, logging, shared memory caching, and database
114recovery. DB supports C, C++, Java and Perl APIs.
115
116
117%package devel
118Summary: C development files for the Berkeley DB (version 4) library
119Group: Development/Libraries
120Requires: db4 = %{version}-%{release}
121Obsoletes: db1-devel, db2-devel, db3-devel
122
123%description devel
124The Berkeley Database (Berkeley DB) is a programmatic toolkit that
125provides embedded database support for both traditional and
126client/server applications. This package contains the header files,
127libraries, and documentation for building programs which use the
128Berkeley DB.
129
130
131%package -n compat32-%{name}-devel
132Summary: Development files for the Berkeley DB (version 4) library.
133Group: Development/Libraries
134Requires: compat32-%{name} = %{version}-%{release}
135Requires: %{name}-devel    = %{version}-%{release}
136
137%description -n compat32-%{name}-devel
138The Berkeley Database (Berkeley DB) is a programmatic toolkit that
139provides embedded database support for both traditional and
140client/server applications. This package contains the header files,
141libraries, and documentation for building programs which use the
142Berkeley DB.
143
144
145%package tcl
146Summary: Development files for using the Berkeley DB (version 4) with tcl
147Group: Development/Libraries
148Requires: %{name} = %{version}-%{release}
149
150%description tcl
151The Berkeley Database (Berkeley DB) is a programmatic toolkit that
152provides embedded database support for both traditional and
153client/server applications. This package contains the libraries
154for building programs which use the Berkeley DB in Tcl.
155
156
157%package -n compat32-%{name}-tcl
158Summary: Development files for using the Berkeley DB (version 4) with tcl.
159Group: Development/Libraries
160Requires: compat32-%{name} = %{version}-%{release}
161Requires: %{name}-tcl      = %{version}-%{release}
162
163%description -n compat32-%{name}-tcl
164The Berkeley Database (Berkeley DB) is a programmatic toolkit that
165provides embedded database support for both traditional and
166client/server applications. This package contains the libraries
167for building programs which use the Berkeley DB in Tcl.
168
169
170%package java
171Summary: Development files for using the Berkeley DB (version 4) with Java
172Group: Development/Libraries
173Requires: %{name} = %{version}-%{release}
174
175%description java
176The Berkeley Database (Berkeley DB) is a programmatic toolkit that
177provides embedded database support for both traditional and
178client/server applications. This package contains the libraries
179for building programs which use the Berkeley DB in Java.
180
181
182%prep
183%setup -q -n db-%{version} -a 1
184
185pushd db.1.85/PORT/linux
186%patch10 -p0 -b .1.1
187popd
188pushd db.1.85
189%patch11 -p0 -b .1.2
190%patch12 -p0 -b .1.3
191%patch13 -p0 -b .1.4
192%patch20 -p1 -b .errno
193popd
194
195%patch22 -p1 -b .185compat
196%patch24 -p1 -b .4.5.20.jni
197
198# Remove tags files which we don't need.
199find . -name tags | xargs rm -f
200# Define a shell function for fixing HREF references in the docs, which
201# would otherwise break when we split the docs up into subpackages.
202fixup_href() {
203    for doc in $@ ; do
204        chmod u+w ${doc}
205        sed -e 's,="../api_c/,="../../%{name}-devel-%{version}/api_c/,g' \
206            -e 's,="api_c/,="../%{name}-devel-%{version}/api_c/,g' \
207            -e 's,="../api_cxx/,="../../%{name}-devel-%{version}/api_cxx/,g' \
208            -e 's,="api_cxx/,="../%{name}-devel-%{version}/api_cxx/,g' \
209            -e 's,="../api_tcl/,="../../%{name}-devel-%{version}/api_tcl/,g' \
210            -e 's,="api_tcl/,="../%{name}-devel-%{version}/api_tcl/,g' \
211            -e 's,="../java/,="../../%{name}-devel-%{version}/java/,g' \
212            -e 's,="java/,="../%{name}-devel-%{version}/java/,g' \
213            -e 's,="../examples_c/,="../../%{name}-devel-%{version}/examples_c/,g' \
214            -e 's,="examples_c/,="../%{name}-devel-%{version}/examples_c/,g' \
215            -e 's,="../examples_cxx/,="../../%{name}-devel-%{version}/examples_cxx/,g' \
216            -e 's,="examples_cxx/,="../%{name}-devel-%{version}/examples_cxx/,g' \
217            -e 's,="../ref/,="../../%{name}-devel-%{version}/ref/,g' \
218            -e 's,="ref/,="../%{name}-devel-%{version}/ref/,g' \
219            -e 's,="../images/,="../../%{name}-devel-%{version}/images/,g' \
220            -e 's,="images/,="../%{name}-devel-%{version}/images/,g' \
221            -e 's,="../utility/,="../../%{name}-utils-%{version}/utility/,g' \
222            -e 's,="utility/,="../%{name}-utils-%{version}/utility/,g' ${doc} > ${doc}.new
223        touch -r ${doc} ${doc}.new
224        cat ${doc}.new > ${doc}
225        touch -r ${doc}.new ${doc}
226        rm -f ${doc}.new
227    done
228}
229
230set +x  # XXX painful to watch
231# Fix all of the HTML files.
232fixup_href `find . -name "*.html"`
233set -x  # XXX painful to watch
234
235cd dist
236./s_config
237
238
239%build
240CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"; export CFLAGS
241
242# Build the old db-185 libraries.
243make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
244
245build() {
246        test -d dist/$1 || mkdir dist/$1
247        # Static link db_dump185 with old db-185 libraries.
248        /bin/sh libtool --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c db_dump185/db_dump185.c -o dist/$1/db_dump185.lo
249        /bin/sh libtool --mode=link    %{__cc} -o dist/$1/db_dump185 dist/$1/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
250
251        pushd dist/$1
252        ln -sf ../configure .
253        # XXX --enable-diagnostic should be disabled for production (but is
254        # useful).
255        # XXX --enable-debug_{r,w}op should be disabled for production.
256        %configure -C \
257                --enable-compat185 --enable-dump185 \
258                --enable-shared --enable-static \
259                --enable-tcl --with-tcl=%{_libdir} \
260                --enable-cxx \
261%ifarch %{java_arches}
262                --enable-java \
263%else
264                --disable-java \
265%endif
266                --enable-test \
267                # --enable-diagnostic \
268                # --enable-debug --enable-debug_rop --enable-debug_wop \
269
270        # Remove libtool predep_objects and postdep_objects wonkiness so that
271        # building without -nostdlib doesn't include them twice.  Because we
272        # already link with g++, weird stuff happens if you don't let the
273        # compiler handle this.
274        perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
275        perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
276        perl -pi -e 's/-shared -nostdlib/-shared/' libtool
277
278        make    %{?_smp_mflags}
279
280        # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
281        LDBJ=./.libs/libdb_java-%{__soversion}.la
282        if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
283            sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
284        fi
285
286        popd
287}
288
289build dist-tls
290
291
292%install
293rm -rf ${RPM_BUILD_ROOT}
294mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
295mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
296
297%makeinstall -C dist/dist-tls
298
299# XXX Nuke non-versioned archives and symlinks
300rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a}
301rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb-4.so
302rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_cxx-4.so
303rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl-4.so
304rm -f ${RPM_BUILD_ROOT}%{_libdir}/libdb_tcl.so
305
306chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
307
308# Move the main shared library from /usr/lib* to /lib* directory.
309if [ "%{_libdir}" != "/%{_lib}" ]; then
310  mkdir -p $RPM_BUILD_ROOT/%{_lib}/
311  mv $RPM_BUILD_ROOT/%{_libdir}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_lib}/
312
313# Leave relative symlinks in %{_libdir}.
314  touch $RPM_BUILD_ROOT/rootfile
315  root=..
316  while [ ! -e $RPM_BUILD_ROOT/%{_libdir}/${root}/rootfile ] ; do
317    root=${root}/..
318  done
319  rm $RPM_BUILD_ROOT/rootfile
320
321  ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb.so
322  ln -sf ${root}/%{_lib}/libdb-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/
323  ln -sf libdb_cxx-%{__soversion}.so $RPM_BUILD_ROOT/%{_libdir}/libdb_cxx.so
324fi
325
326# Move the header files to a subdirectory, in case we're deploying on a
327# system with multiple versions of DB installed.
328mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/db4
329mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/db4/
330
331# Create symlinks to includes so that "use <db.h> and link with -ldb" works.
332for i in db.h db_cxx.h db_185.h; do
333        ln -s db4/$i ${RPM_BUILD_ROOT}%{_includedir}
334done
335
336%ifarch %{java_arches}
337# Move java jar file to the correct place
338mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
339mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
340%endif
341
342# Eliminate installed doco
343rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
344
345# XXX Avoid Permission denied. strip when building as non-root.
346chmod u+w ${RPM_BUILD_ROOT}%{_bindir}
347
348
349%clean
350rm -rf ${RPM_BUILD_ROOT}
351
352
353%post -p /sbin/ldconfig
354
355%postun -p /sbin/ldconfig
356
357%post -n compat32-%{name} -p /sbin/ldconfig
358
359%postun -n compat32-%{name} -p /sbin/ldconfig
360
361%post -p /sbin/ldconfig cxx
362
363%postun -p /sbin/ldconfig cxx
364
365%post -n compat32-%{name}-cxx -p /sbin/ldconfig
366
367%postun -n compat32-%{name}-cxx -p /sbin/ldconfig
368
369%post -p /sbin/ldconfig tcl
370
371%postun -p /sbin/ldconfig tcl
372
373%post -n compat32-%{name}-tcl -p /sbin/ldconfig
374
375%postun -n compat32-%{name}-tcl -p /sbin/ldconfig
376
377%post -p /sbin/ldconfig java
378
379%postun -p /sbin/ldconfig java
380
381
382%files
383%defattr(-,root,root)
384%doc LICENSE README
385/%{_lib}/libdb-%{__soversion}.so
386%{_libdir}/libdb-%{__soversion}.so
387
388
389%files cxx
390%defattr(-,root,root)
391%{_libdir}/libdb_cxx-%{__soversion}.so
392
393
394%files utils
395%defattr(-,root,root)
396%doc    docs/utility
397%{_bindir}/db*_archive
398%{_bindir}/db*_checkpoint
399%{_bindir}/db*_deadlock
400%{_bindir}/db*_dump*
401%{_bindir}/db*_load
402%{_bindir}/db*_printlog
403%{_bindir}/db*_recover
404%{_bindir}/db*_stat
405%{_bindir}/db*_upgrade
406%{_bindir}/db*_verify
407%{_bindir}/db*_hotbackup
408%{_bindir}/db*_sql
409
410
411%files devel
412%defattr(-,root,root)
413%doc    docs/api_c docs/api_cxx docs/api_tcl docs/index.html
414%doc    docs/ref docs/images
415%doc    examples_c examples_cxx
416%{_libdir}/libdb.so
417%{_libdir}/libdb-%{__soversion}.la
418%{_libdir}/%{_libdb_a}
419%{_libdir}/libdb_cxx.so
420%{_libdir}/libdb_cxx-%{__soversion}.la
421%{_libdir}/%{_libcxx_a}
422%dir %{_includedir}/%{name}
423%{_includedir}/%{name}/db.h
424%{_includedir}/%{name}/db_185.h
425%{_includedir}/%{name}/db_cxx.h
426%{_includedir}/db.h
427%{_includedir}/db_185.h
428%{_includedir}/db_cxx.h
429
430
431%files tcl
432%defattr(-,root,root)
433%{_libdir}/libdb_tcl-%{__soversion}.a
434%{_libdir}/libdb_tcl-%{__soversion}.la
435%{_libdir}/libdb_tcl-%{__soversion}.so
436
437
438%ifarch %{java_arches}
439%files java
440%defattr(-,root,root)
441%doc docs/java
442%doc examples_java
443%{_libdir}/libdb_java*
444%{_datadir}/java/*.jar
445%endif
446
447%if %{build_compat32}
448%files -n compat32-%{name}
449%defattr(-,root,root)
450/%{_lib}/libdb-%{__soversion}.so
451%{_libdir}/libdb-%{__soversion}.so
452
453
454%files -n compat32-%{name}-cxx
455%defattr(-,root,root)
456%{_libdir}/libdb_cxx-%{__soversion}.so
457
458
459%files -n compat32-%{name}-devel
460%defattr(-,root,root)
461%{_libdir}/libdb.so
462%{_libdir}/libdb-%{__soversion}.la
463%{_libdir}/libdb_cxx-%{__soversion}.la
464%{_libdir}/%{_libdb_a}
465%{_libdir}/%{_libcxx_a}
466
467
468%files -n compat32-%{name}-tcl
469%defattr(-,root,root)
470%{_libdir}/libdb_tcl-%{__soversion}.a
471%{_libdir}/libdb_tcl-%{__soversion}.la
472%{_libdir}/libdb_tcl-%{__soversion}.so
473%endif
474
475
476%changelog
477* Mon Nov 15 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.8.30-1
478- new upstream release.
479
480* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.8.26-2
481- rebuilt with gcc-4.4.3-3 on ppc
482
483* Mon Feb 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.8.26-1
484- update to 4.8.26
485- remove '--enable-rpc'
486  - rpc support is removed from db4
487
488* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.6.21-6
489- initial build of db-4.6.21 on Vine Linux
490- temporarily commented out "libtoolize" and "s_config" lines
491  until Vine's autotools get updated (maybe?)
492
493* Fri Apr  3 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-5
494- add upstream patch to fix a race condition between checkpoint
495  and DB->close which can result in the checkpoint thread self-deadlocking
496
497* Mon Mar 10 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-4
498- don't list headers twice in filelist (#436701)
499
500* Mon Feb 25 2008 Jindrich Novy <jnovy@redhat.com> 4.6.21-3
501- manual rebuild because of gcc-4.3 (#434185)
502
503* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.6.21-2
504- Autorebuild for GCC 4.3
505
506* Thu Oct 11 2007 Jindrich Novy <jnovy@redhat.com> 4.6.21-1
507- update to 4.6.21
508- own %%{_includedir}/db4 (#274251)
509
510* Mon Sep  3 2007 Jindrich Novy <jnovy@redhat.com> 4.6.19-1
511- update to 4.6.19 (#273461)
512
513* Thu Aug 29 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-2
514- rebuild for BuildID
515- BR util-linux-ng
516
517* Mon Jul 30 2007 Jindrich Novy <jnovy@redhat.com> 4.6.18-1
518- update to 4.6.18
519- drop upstream patches for 4.5.20 and gcj patch
520- remove nptl-abi-note.S, useless as we are definitely
521  running kernel >= 2.4.20 (#245416)
522- move C++ stuff to subpackages to reduce dependency bloat (#220484)
523- package db_codegen
524- correct open() calls so that new db4 compiles with the new glibc
525
526* Sat Mar 24 2007 Thomas Fitzsimmons <fitzsim@redhat.com> 4.5.20-5
527- Require java-1.5.0-gcj and java-1.5.0-gcj-devel for build.
528
529* Mon Dec  4 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-4
530- apply upstream patches for 4.5.20
531  (Java API <-> core API related fixes)
532
533* Fri Dec  1 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-3
534- temporarily remove ppc64 from java arches
535
536* Sun Nov 26 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-2
537- sync db4 and compat-db licenses to BSD-style as the result of
538  consultation with legal department
539- fix some rpmlint warnings
540
541* Fri Nov 10 2006 Jindrich Novy <jnovy@redhat.com> 4.5.20-1
542- update to db-4.5.20 (#198038)
543- fix BuildRoot
544- drop .64bit patch
545- patch/source URLs now point to correct location
546
547* Tue Sep 12 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-9
548- rebuild
549
550* Wed Sep  6 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-8
551- revert the previous fix, it crashes OOo help
552
553* Sun Sep  3 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-7.fc6
554- fix memleak caused by SET_TXN macro in xa_db.c, when opening
555  database created with DB_XA_CREATE flag (#204920)
556
557* Wed Jul 19 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-6
558- fix sparc64 build (#199358)
559
560* Mon Jul 17 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-5
561- rebuild because of gnu_hash
562
563* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-4.1
564- rebuild
565
566* Fri Mar 24 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-4
567- drop useless java, lfs patches
568
569* Mon Mar 13 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-3
570- apply x86_64 fix from Henrik Nordstrom (#184588)
571- don't nuke non-versioned archives twice
572
573* Wed Feb 15 2006 Jindrich Novy <jnovy@redhat.com> 4.3.29-2
574- don't package /usr/share/doc/images in the main db4 package
575  and move it to db4-devel (#33328)
576- make db4 LFS capable (#33849)
577- move db4-devel, db4-tcl, db4-java to Development/Libraries
578  group instead of System Environment/Libraries (#54320)
579- BuildPrereq -> BuildRequires
580- don't use RPM_SOURCE_DIR
581- Obsoletes db3, db2
582
583* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2.1
584- bump again for double-long bug on ppc(64)
585
586* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.3.29-1.2
587- rebuilt for new gcc4.1 snapshot and glibc changes
588
589* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
590- rebuilt
591
592* Fri Oct 07 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.29-1
593- New upstream release
594
595* Fri Sep 30 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-4
596- Re-enable java for ppc64
597
598* Wed Sep 21 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-3
599- Add fno-strict-aliasing for java (#168965)
600
601* Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-2
602- no java for ppc64 for now (#166657)
603
604* Tue Sep 20 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.28-1
605- FC5 is nptl only (derived from jbj's spec)
606- upgrade to 4.3.28
607
608* Thu Jul 14 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-5
609- re-enable db4-java
610
611* Tue May 17 2005 Paul Nasrat <pnasrat@redhat.com> 4.3.27-4
612- /usr/lib/tls/ix86 dirs (#151371)
613
614* Mon Apr 25 2005 Bill Nottingham <notting@redhat.com> 4.3.27-3
615- add libdb_cxx.so link (#149191)
616
617* Fri Mar  4 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-2
618- rebuild with gcc4.
619
620* Sat Jan  1 2005 Jeff Johnson <jbj@jbj.org> 4.3.27-1
621- upgrade to 4.3.27.
622
623* Thu Nov 11 2004 Jeff Johnson <jbj@jbj.org> 4.3.21-1
624- upgrade to 4.3.21, no db4-java for the moment again again.
625
626* Tue Sep 21 2004 Nalin Dahyabhai <nalin@redhat.com> 4.2.52-6
627- on %%{ix86} systems, make the availability of an NPTL-requiring libdb match
628  the availability of an NPTL libpthread in glibc > 2.3.3-48
629- run ldconfig in db4-java's %%post/%%postun
630- when building java support, assume that libgcj is equivalent enough to 1.3
631
632* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
633- rebuilt
634
635* Mon Jun  7 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-4
636- remove dangling symlinks (#123721 et al).
637- remove db_cxx.so and db_tcl.so symlinks, versioned equivs exist.
638- apply 2 patches from sleepycat.
639- resurrect db4-java using sun jvm-1.4.2.
640- cripple autoconf sufficiently to build db4-java with gcj, without jvm.
641- check javac first, gcj34 next, then gcj-ssa, finally gcj.
642- add ed build dependency (#125180).
643
644* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
645- rebuilt
646
647* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
648- rebuilt
649
650* Fri Jan 16 2004 Jeff Johnson <jbj@jbj.org> 4.2.52-2
651- fix: automake *.lo wrapper, not elf, files included in *.a (#113572).
652
653* Thu Dec 11 2003 Jeff Johnson <jbj@jbj.org> 4.2.52-1
654- upgrade to db-4.2.52, no db4-java for the moment.
655
656* Fri Nov 28 2003 Paul Nasrat <pauln@truemesh.com> 4.2.41-0.2
657- Add build requires tcl-devel
658
659* Fri Oct 24 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-14
660- symlink from %%{_libdir}/tls/libdb-4.1.so to the copy in /%%{_lib}/tls, so
661  that the run-time linker can find the right copy for of apps which use an
662  RPATH to point at %%{_libdir}/libdb-4.1.so
663
664* Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-13
665- add another section to the ABI note for the TLS libdb so that it's marked as
666  not needing an executable stack (from Arjan Van de Ven)
667
668* Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com>
669- build both with and without support for shared mutex locks, which require NPTL
670- make behavior wrt where we put libdb the same for all OSs
671- revert changes making tcl optional - nesting %%if tcl and %%ifarch nptl
672  doesn't work
673- fix dangling HREFs in utility docs (pointed to main docs dir, while they're
674  actually in the -utils docs dir)
675- run ldconfig when installing/removing the -utils subpackage, as it contains
676  shared libraries
677
678* Wed Oct 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-11
679- fix multiple-inclusion problem of startup files when building shlibs without
680  the -nostdlib flag
681
682* Tue Oct 14 2003 Nalin Dahyabhai <nalin@redhat.com>
683- link shared libraries without -nostdlib, which created an unresolvable dep
684  on a hidden symbol
685
686* Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
687- allow compiling without tcl dependency
688
689* Sat Sep 20 2003 Jeff Johnson <jbj@jbj.org> 4.2.42-0.1
690- update to 4.2.42.
691- build in build_unix subdir.
692- eliminate --enable-dump185, db_dump185.c no longer compiles for libdb*.
693- create db4-tcl sub-pkg to isolate libtcl dependencies.
694
695* Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-9
696- rebuild
697
698* Tue Aug 19 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-8
699- add missing tcl-devel buildrequires (#101814)
700
701* Tue Jul 15 2003 Joe Orton <jorton@redhat.com> 4.1.25-7
702- rebuild
703
704* Fri Jun 27 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-6
705- build with libtool-1.5, which can't recognize the .so in libfoo*.so atm.
706- whack out libtool predep_objects wonkiness.
707
708* Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-5
709- rebuild.
710
711* Tue Jun 24 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-4
712- hack out O_DIRECT support in db4 for now.
713
714* Tue Jun 24 2003 Nalin Dahyabhai <nalin@redhat.com>
715- replace libtool.ac with current libtool.m4 so that running libtoolize doesn't
716  cause a mismatch
717
718* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
719- rebuilt
720
721* Wed Jun  4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.1.25-2
722- change configure to only warn if JNI includes aren't found, assuming that
723  the C compiler can find them
724- remove build requirement on jdkgcj -- gcj is sufficient
725
726* Mon May  5 2003 Jeff Johnson <jbj@redhat.com> 4.1.25-1
727- upgrade to 4.1.25, crypto version.
728- enable posix mutexes using nptl on all arches.
729
730* Mon Mar  3 2003 Thoams Woerner <twoerner@redhat.com> 4.0.14-21
731- enabled db4-java for x86_64
732
733* Wed Feb  5 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-20
734- add dynamic libdb-4.0.so link back to %%{_libdir} so that dynamically
735  linking with -ldb-4.0 will work again
736
737* Tue Feb  4 2003 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-19
738- rebuild to use link the shared object with the same libraries we use
739  for the bundled utils, should pull in libpthread when needed
740- move libdb.so from /%%{_lib} to %%{_libdir} where the linker can find it
741
742* Sun Feb 02 2003 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-18
743- add java for s390x
744
745* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.0.14-17
746- rebuilt
747
748* Wed Nov 20 2002 Florian La Roche <Florian.LaRoche@redhat.de> 4.0.14-16
749- add java for s390
750
751* Tue Oct  8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-15
752- add java bits back in for x86 boxes
753
754* Fri Sep 20 2002 Than Ngo <than@redhat.com> 4.0.14-14.1
755- Added better fix for s390/s390x/x86_64
756
757* Thu Sep 05 2002 Arjan van de Ven
758- remove java bits for x86-64
759
760* Tue Aug 27 2002 Jeff Johnson <jbj@redhat.com> 4.0.14-14
761- include libdb_tcl-4.1.a library.
762- obsolete db1 packages.
763
764* Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-13
765- include patch to avoid db_recover (#70362)
766
767* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
768- rebuilt with gcc-3.2 (we hope)
769
770* Tue Jul 23 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-11
771- own %%{_includedir}/%{name}
772
773* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 4.0.14-10
774- build using gcc-3.2-0.1
775
776* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
777- automated rebuild
778
779* Wed Jun 12 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.0.14-8
780- Add java bindings
781- Fix C++ bindings
782
783* Thu May 23 2002 Tim Powers <timp@redhat.com>
784- automated rebuild
785
786* Thu May  9 2002 Jeff Johnson <jbj@redhat.com>
787- re-enable db.h symlink creation, db_util names, and db[23]-devel obsoletes.
788- make sure that -ldb is functional.
789
790* Thu Feb 21 2002 Jeff Johnson <jbj@redhat.com>
791- avoid db_util name collisions with multiple versions installed.
792
793* Mon Feb 18 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-3
794- remove relocatability stuffs
795- swallow a local copy of db1 and build db185_dump statically with it, to
796  remove the build dependency and simplify bootstrapping new arches
797
798* Mon Jan 27 2002 Nalin Dahyabhai <nalin@redhat.com> 4.0.14-2
799- have subpackages obsolete their db3 counterparts, because they conflict anyway
800
801* Tue Jan  8 2002 Jeff Johnson <jbj@redhat.com> db4-4.0.14-1
802- upgrade to 4.0.14.
803
804* Sun Aug  5 2001 Nalin Dahyabhai <nalin@redhat.com>
805- fix dangling docs symlinks
806- fix dangling doc HREFs (#33328)
807- apply the two patches listed at http://www.sleepycat.com/update/3.2.9/patch.3.2.9.html
808
809* Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
810- turn off --enable-debug
811
812* Thu May 10 2001 Than Ngo <than@redhat.com>
813- fixed to build on s390x
814
815* Mon Mar 19 2001 Jeff Johnson <jbj@redhat.com>
816- update to 3.2.9.
817
818* Tue Dec 12 2000 Jeff Johnson <jbj@redhat.com>
819- rebuild to remove 777 directories.
820
821* Sat Nov 11 2000 Jeff Johnson <jbj@redhat.com>
822- don't build with --enable-diagnostic.
823- add build prereq on tcl.
824- default value for %%_lib macro if not found.
825
826* Tue Oct 17 2000 Jeff Johnson <jbj@redhat.com>
827- add /usr/lib/libdb-3.1.so symlink to %%files.
828- remove dangling tags symlink from examples.
829
830* Mon Oct  9 2000 Jeff Johnson <jbj@redhat.com>
831- rather than hack *.la (see below), create /usr/lib/libdb-3.1.so symlink.
832- turn off --enable-diagnostic for performance.
833
834* Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
835- update to 3.1.17.
836- disable posix mutexes Yet Again.
837
838* Tue Sep 26 2000 Jeff Johnson <jbj@redhat.com>
839- add c++ and posix mutex support.
840
841* Thu Sep 14 2000 Jakub Jelinek <jakub@redhat.com>
842- put nss_db into a separate package
843
844* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
845- rebuild to cope with glibc locale binary incompatibility, again
846
847* Wed Aug 23 2000 Jeff Johnson <jbj@redhat.com>
848- remove redundant strip of libnss_db* that is nuking symbols.
849- change location in /usr/lib/libdb-3.1.la to point to /lib (#16776).
850
851* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
852- summaries from specspo.
853- all of libdb_tcl* (including symlinks) in db3-utils, should be db3->tcl?
854
855* Wed Aug 16 2000 Jakub Jelinek <jakub@redhat.com>
856- temporarily build nss_db in this package, should be moved
857  into separate nss_db package soon
858
859* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
860- rebuild to cope with glibc locale binary incompatibility
861
862* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
863- automatic rebuild
864
865* Sun Jun 11 2000 Jeff Johnson <jbj@redhat.com>
866- upgrade to 3.1.14.
867- create db3-utils sub-package to hide tcl dependency, enable tcl Yet Again.
868- FHS packaging.
869
870* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
871- disable tcl Yet Again, base packages cannot depend on libtcl.so.
872
873* Sat Jun  3 2000 Jeff Johnson <jbj@redhat.com>
874- enable tcl, rebuild against tcltk 8.3.1 (w/o pthreads).
875
876* Tue May 30 2000 Matt Wilson <msw@redhat.com>
877- include /lib/libdb.so in the devel package
878
879* Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
880- put in "System Environment/Libraries" per msw instructions.
881
882* Tue May  9 2000 Jeff Johnson <jbj@redhat.com>
883- install shared library in /lib, not /usr/lib.
884- move API docs to db3-devel.
885
886* Mon May  8 2000 Jeff Johnson <jbj@redhat.com>
887- don't rename db_* to db3_*.
888
889* Tue May  2 2000 Jeff Johnson <jbj@redhat.com>
890- disable --enable-test --enable-debug_rop --enable-debug_wop.
891- disable --enable-posixmutexes --enable-tcl as well, to avoid glibc-2.1.3
892  problems.
893
894* Mon Apr 24 2000 Jeff Johnson <jbj@redhat.com>
895- add 3.0.55.1 alignment patch.
896- add --enable-posixmutexes (linux threads has not pthread_*attr_setpshared).
897- add --enable-tcl (needed -lpthreads).
898
899* Sat Apr  1 2000 Jeff Johnson <jbj@redhat.com>
900- add --enable-debug_{r,w}op for now.
901- add variable to set shm perms.
902
903* Sat Mar 25 2000 Jeff Johnson <jbj@redhat.com>
904- update to 3.0.55
905
906* Tue Dec 29 1998 Jeff Johnson <jbj@redhat.com>
907- Add --enable-cxx to configure.
908
909* Thu Jun 18 1998 Jeff Johnson <jbj@redhat.com>
910- Create.
Note: See TracBrowser for help on using the repository browser.