source: projects/specs/branches/6/d/dante/dante-vl.spec @ 6108

Revision 6108, 8.6 KB checked in by tomop, 12 years ago (diff)

linux-igd-1.0-2, dante-1.3.2-1

Line 
1%define _localstatedir /var
2Summary: A free Socks v4/v5 client implementation
3Summary(ja): Socks v4/v5 クライアントのフリーな実装
4Name: dante
5Version: 1.3.2
6# define for pre-releases, undefine for normal releases.
7%undefine pre
8Release: 1%{?_dist_release}
9License: BSD-type
10Group: Applications/Internet
11URL: http://www.inet.no/dante/
12%define distname %{name}-%{version}%{?pre:-%{pre}}
13Source: ftp://ftp.inet.no/pub/socks/%{distname}.tar.gz
14Source1: sockd.conf
15Source2: sockd.init
16Vendor: Project Vine
17Distribution: Vine Linux
18Buildroot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: pam-devel tcp_wrappers
20Requires: pam
21
22%description
23Dante is a free implementation of the proxy protocols socks version 4,
24socks version 5 (rfc1928) and msproxy. It can be used as a firewall
25between networks. It is being developed by Inferno Nettverk A/S, a
26Norwegian consulting company. Commercial support is available.
27
28This package contains the dynamic libraries required to "socksify"
29existing applications to become socks clients.
30
31%description -l ja
32dante は proxy プロトコルである socks バージョン4,socks バージョン5
33(rfc1928), mxproxy のフリー実装です.ネットワーク間のファイアーウォールと
34して使うことが出来ます.開発はノルウェーのコンサルタント会社である
35Inferno Netverk A/S で行われています.コマーシャルサポートもあります.
36
37このパッケージには,既存のアプリケーションを socks クライアントに
38するのに必要なダイナミックライブラリが収められています.
39
40%package server
41Summary: A free Socks v4/v5 server implementation
42Summary(ja): Socks v4/v5 サーバのフリーな実装
43Group: System Environment/Daemons
44Requires: dante = %{version}
45Requires(pre): /sbin/chkconfig
46
47%description server
48This package contains the socks proxy daemon and its documentation.
49The sockd is the server part of the Dante socks proxy package and
50allows socks clients to connect through it to the network.
51
52%description server -l ja
53このパッケージには socks プロキシデーモンとそのドキュメントが
54収められています.sockd は Dante socks プロキシパッケージの
55サーバ部分で,socks クライアントは sockd サーバを介することにより
56ネットワークに接続出来ます.
57
58%package devel
59Summary: development libraries for socks
60Summary(ja): socks 用開発ライブラリ
61Group: Development/Libraries
62Requires: dante = %{version}
63
64%description devel
65Additional libraries required to compile programs that use socks.
66
67%description devel -l ja
68socks を使うプログラムをコンパイルするのに必要な追加ライブラリです.
69
70%prep
71%setup -q -n %{distname}
72
73# no need to preload libdl.so explicitly.
74%{__sed} -e 's/@SOCKSIFY_PRELOAD_LIBS@//' bin/socksify.in >bin/socksify.in.new
75%{__mv} bin/socksify.in.new bin/socksify.in
76
77# This file is embedded here instead of being another source in order
78# to the prefix directory
79cat >sockd.init <<EOF
80#!/bin/sh
81#
82# sockd         This shell script takes care of starting and stopping
83#               the Dante server.
84#
85# chkconfig: 2345 65 35
86# description: sockd implements a socks v4/v5 proxy server
87
88# Source function library.
89. /etc/rc.d/init.d/functions
90
91# Source networking configuration.
92. /etc/sysconfig/network
93
94# Check that networking is up.
95[ \${NETWORKING} = "no" ] && exit 0
96
97[ -f %{_sbindir}/sockd ] || exit 0
98[ -f %{_sysconfdir}/sockd.conf ] || exit 0
99
100# See how we were called.
101case "\$1" in
102  start)
103        # Start daemons.
104        echo -n "Starting sockd: "
105        daemon %{_sbindir}/sockd -D
106        echo
107        touch %{_var}/lock/subsys/sockd
108        ;;
109  stop)
110        # Stop daemons.
111        echo -n "Shutting down sockd: "
112        killproc sockd
113        echo
114        rm -f %{_var}/lock/subsys/sockd
115        ;;
116  restart)
117        \$0 stop
118        \$0 start
119        ;;
120  status)
121        status sockd
122        ;;
123  *)
124        echo "Usage: sockd {start|stop|restart|status}"
125        exit 1
126esac
127
128exit 0
129EOF
130
131%build
132%configure \
133%if %{?_dist_release} != "vl7"
134  --without-glibc-secure
135%endif
136
137%{__make}
138
139%install
140%{__rm} -rf %{buildroot}
141%{makeinstall}
142
143#set library as executable - prevent ldd from complaining
144%{__chmod} +x %{buildroot}%{_libdir}/*.so.*.*
145%{__install}  -d %{buildroot}%{_sysconfdir}/rc.d/init.d %{buildroot}%{_bindir}
146%{__install} -m 644 example/socks-simple.conf %{buildroot}%{_sysconfdir}/socks.conf
147%{__install} -m 644 %{_sourcedir}/sockd.conf %{buildroot}%{_sysconfdir}
148%{__install} -m 755 %{SOURCE2} %{buildroot}%{_sysconfdir}/rc.d/init.d/sockd
149
150## remove unuse files
151rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
152
153
154%clean
155%{__rm} -rf %{buildroot}
156
157
158%post -p /sbin/ldconfig
159%postun -p /sbin/ldconfig
160
161%post server
162/sbin/chkconfig --add sockd
163
164%preun server
165if [ "$1" = 0 ]; then
166        service sockd stop >/dev/null 2>&1
167        /sbin/chkconfig --del sockd
168fi
169
170%postun server
171if [ "$1" -ge "1" ]; then
172        service sockd condrestart > /dev/null 2>&1
173fi
174
175%files
176%defattr(-,root,root)
177%doc BUGS CREDITS INSTALL LICENSE NEWS README README.ldap SUPPORT UPGRADE VERSION
178%doc doc/README* doc/rfc* doc/SOCKS4*protocol
179%doc example/sock*
180%{_libdir}/libsocks.so.*
181%{_libdir}/libdsocks.so*
182%{_bindir}/socksify
183%{_mandir}/man5/socks.conf.5*
184%{_mandir}/man1/socksify.1*
185%config(noreplace) %{_sysconfdir}/socks.conf
186
187
188%files server
189%defattr(-,root,root)
190%{_mandir}/man8/sockd.8*
191%{_sbindir}/sockd
192%{_mandir}/man5/sockd.conf.5*
193%config(noreplace) %{_sysconfdir}/sockd.conf
194%config %{_sysconfdir}/rc.d/init.d/sockd
195
196
197%files devel
198%defattr(-,root,root)
199%{_libdir}/libsocks.so
200%{_libdir}/libsocks.a
201%{_includedir}/socks.h
202
203
204%changelog
205* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
206- new upstream release.
207
208* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.14-1vl5
209- applied new versioning policy, spec in utf-8
210- removed *.la
211
212* Mon May 10 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
213- 1.1.14-0vl1: built for VineSeed
214- use/change macros for dirs (/etc, /var)
215- re-enable chkconfig and add stop/restart on uninstall/upgrade
216- include our sockd.conf (Source1) based on example/sockd-basic.conf
217
218* Mon Nov 24 2003 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
219- 1.1.14-0vl0.26.0: new upstream release
220- remove preloading libdl.so (in glibc-devel) from socksify
221
222* Mon Dec 02 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
223- 1.1.13-0vl0.26.0: built for Vine Linux 2.5/2.6
224
225* Mon Dec 02 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
226- 1.1.13-0vl0.21.0: built for Vine Linux 2.1.x
227- new upstream release:
228  dante-config_parse.patch and dante-recvmsg.patch are incorporated.
229- set noreplace flag to sock{s,d}.conf
230- remove BuildPreReq: flex
231
232* Mon May 13 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
233- 1.1.12-0vl7: built for Vine Linux 2.5
234
235* Mon May 13 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
236- 1.1.12-0vl6: built for Vine Linux 2.1.x
237- change dante-recvmsg.patch to fix core dump with libdsocks
238
239* Wed Apr 24 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
240- 1.1.12-0vl5: built for Vine Linux 2.5
241
242* Sat Apr 20 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
243- 1.1.12-0vl4: built for Vine Linux 2.1.x
244- replaced source with full-release of 1.1.12.
245- replaced dante-recvmsg.patch with one from original author
246- added dependencies (pam, tcp_wrappers)
247
248* Sun Mar 31 2002 Jun Nishii <jun@vinelinux.org>
249- 1.1.12-0vl3: rebuild for Vine Linux 2.5
250
251* Mon Mar 18 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
252- 1.1.12-0vl2: patch to include/{common,sockd}.h
253
254* Thu Feb 14 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
255- 1.1.12-0vl1: updated to 1.1.12-pre1 and modified spec for pre-releases
256
257* Mon Feb 11 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
258- 1.1.11-0vl2: patch to lib/config_parse.y
259
260* Fri Dec 14 2001 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
261- 1.1.11-0vl1
262
263* Sat Nov 10 2001 akira yamada <akira@vinelinux.org> 1.1.10-0vl2
264- moved libsocs.so to dante-devel from dante.
265- added defattr for dante-devel.
266- added BuildPreReq: flex
267
268* Thu Sep 06 2001 Toru Sagami <sagami@vinelinux.org>
269- 1.1.10-0vl1: updated to 1.1.10 with a bit better macros and minor spec fixes
270- fixed Group
271
272* Fri May 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
273- 1.1.9-1vl1
274- based on 1.1.9-1 generated from original tarball (by rpm -ts)
275- rebuilt for Vine Linux
276- modified spec file
277
278* Thu Oct 12 2000 Karl-Andre' Skevik <karls@inet.no>
279-use of macros for directory locations/paths
280-explicitly name documentation files
281-run chkconfig --del before files are deleted on uninstall
282
283* Wed Mar 10 1999 Karl-Andre' Skevik <karls@inet.no>
284- Integrated into CVS
285- socksify patch no longer needed
286
287* Thu Mar 04 1999 Oren Tirosh <oren@hishome.net>
288- configurable %{prefix}, fixed daemon init script
289- added /lib/libdl.so to socksify
290
291* Wed Mar 03 1999 Oren Tirosh <oren@hishome.net>
292- First spec file for Dante
Note: See TracBrowser for help on using the repository browser.