source: projects/specs/branches/6/c/cvs/cvs-vl.spec @ 5616

Revision 5616, 10.7 KB checked in by iwamoto, 12 years ago (diff)

cvs: fix CVE-2012-0804

Line 
1%define version 1.12.13
2
3Summary: A version control system.
4Summary(ja): バージョン管理システム
5Name: cvs
6Version: %{version}
7Release: 5%{?_dist_release}
8License: GPL
9Group: Development/Tools
10URL: http://www.cvshome.org/
11Source0: http://ftp.cvshome.org/release/feature/cvs-%{version}/cvs-%{version}.tar.bz2
12Source100: filter-requires-getopts-pl.sh
13Patch2: cvs-1.12.13-authserver.patch
14Patch3: cvs-1.11.2-cvspass.patch
15Patch5: cvs-1.11.2-install.patch
16Patch101: can-2005-2693.patch
17Patch102: cvs-1.12.13_CVE-2012-0804.patch
18
19Requires(pre): install-info
20Prefix: %{_prefix}
21Buildroot: %{_tmppath}/%{name}-%{version}-root
22Requires: perl, zlib
23BuildRequires: zlib-devel
24BuildRequires: openssl-devel
25BuildRequires: vim
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30# for perl
31%define __find_requires %{SOURCE100}
32
33%description
34CVS (Concurrent Version System) is a version control system which can
35record the history of your files (usually, but not always, source
36code). CVS only stores the differences between versions, instead of
37every version of every file you've ever created. CVS also keeps a log
38of who, when and why changes occurred.
39
40CVS is very helpful for managing releases and controlling the
41concurrent editing of source files among multiple authors. Instead of
42providing version control for a collection of files in a single
43directory, CVS provides version control for a hierarchical collection
44of directories consisting of revision controlled files. These
45directories and files can then be combined together to form a software
46release.
47
48Install the cvs package if you need to use a version control system.
49#'
50
51%description -l ja
52CVS (Concurrent Version System) はバージョン管理システムで,
53ファイル (必ずしもそうとは限りませんが多くの場合ソースコード) の
54変更履歴を記録することが出来ます.CVS はファイルの全バージョンを
55保存しておくのではなく,バージョン間の変更差分だけを保存します.
56CVS はまた誰が何故変更を行ったのかのログも記録します.
57
58CVS は,ソースファイルを複数の開発者が同時に編集する際のリリース管理に
59非常に役立ちます.
60
61バージョン管理システムが必要なら cvs パッケージをインストールして下さい.
62
63
64%prep
65%setup -q
66%patch2 -p1 -b .authserver
67%patch3 -p1 -b .cvspass
68%patch5 -p1 -b .install
69%patch101 -p1 -b .can-2005-2693
70%patch102 -p1 -b .CVE-2012-0804
71
72%build
73%configure --with-external-zlib
74
75make %{?_smp_mflags}
76make -C doc info
77
78
79%install
80[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
81
82%{makeinstall}
83gzip %{buildroot}%{_infodir}/cvs* || true
84
85
86%clean
87[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
88
89
90%post
91/sbin/install-info /%{_infodir}/cvs.info.gz /%{_infodir}/dir
92/sbin/install-info /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
93
94
95%preun
96if [ $1 = 0 ]; then
97    /sbin/install-info --delete /%{_infodir}/cvs.info.gz /%{_infodir}/dir
98    /sbin/install-info --delete /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
99fi
100
101
102%files
103%defattr(-,root,root)
104%doc AUTHORS BUGS COPYING COPYING.LIB ChangeLog ChangeLog.zoo DEVEL-CVS HACKING FAQ INSTALL MINOR-BUGS NEWS PROJECTS TODO README README.VMS
105%doc doc/*.pdf
106%{_bindir}/cvs
107%{_bindir}/cvsbug
108%{_bindir}/rcs2log
109%{_mandir}/man1/cvs.1*
110%{_mandir}/man5/cvs.5*
111%{_mandir}/man8/cvsbug.8*
112%{_infodir}/cvs*
113%{_datadir}/cvs
114
115%changelog
116* Fri Feb 10 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>1.12.13-5vl6
117- add patch102 for fix CVE-2012-0804 (heap overflow in the CVS client)
118- add Vendor / Distri Tags
119
120* Sat Apr  2 2011 IWAI, Masaharu <iwai@alib.jp> 1.12.13-4vl6
121- build with krb5-libs 1.8.2
122- add doc/*.pdf in %%doc
123
124* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.13-3
125- rebuild with openssl-1.0.0c
126- add BuildRequires: openssl-devel, vim
127
128* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.13-2
129- spec in utf-8
130
131* Sat Apr 26 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.12.13-1
132- rebuild with perl-5.10.0-1vl5
133- add filter-requires-getopts-pl.sh (Source100)
134
135* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.13-0vl1
136- new upstream release
137- drop Patch100 which are merged in upstream.
138
139* Mon Jan 30 2006 Shu KONNO <owa@bg.wakwak.com> 1.12.9-0vl4
140- rebuilt with VineSeed
141
142* Fri Aug 26 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3.1
143- added a security patch for CAN-2005-2693 (CVS temporary file issue).
144
145* Wed Apr 27 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3
146- added a security patch for can-2005-0753 (Buffer Overflow and DoS).
147
148* Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl2
149- remove unneeded dependency
150- change Prereq: info to install-info
151- add %%{_smp_mflags} to make option
152
153* Thu Jun 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl1
154- new upstream release
155- security update
156  This release fixes several serious security issues in the CVS server
157  executable. It also contains one minor bug fix and the cvs log' and cvs ls'
158  commands now output times in the client's local timezone.
159
160* Thu May 20 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.8-0vl1
161- new upstream release
162- security update
163  This release fixes a serious security issue in the CVS server executable.
164
165* Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl2
166- fixed typo in description
167
168* Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl1
169- new upstream release
170- security update
171  This release fixes serious security issues in both the client and
172  server executables. It also contains many bug fixes and support for
173  accessing CVS pservers via intervening HTTP proxies.
174- fixed broken description
175- changed Source0 URL
176
177* Sat Dec 20 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl2
178- fixed typo in changelog
179
180* Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl1
181- new upstream release
182- added "--with-external-zlib2" to configure option
183        -- dropped patch4
184
185* Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.11.11-0vl1
186- new upstream release
187- security update
188  pserver can no longer be configured to run as root via the
189  $CVSROOT/CVSROOT/passwd file, so if your passwd file is compromised, it no
190  longer leads directly to a root hack.  Attempts to root will also be logged
191  via the syslog.
192
193* Tue Dec 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.10-0vl1
194- new upstream release
195- security update
196  This release fixes a security issue with no known exploits that could cause
197  previous versions of CVS to attempt to create files and directories in the
198  filesystem root.
199
200* Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11.9-0vl1
201- new upstream release
202
203* Wed Jan 22 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.11.5-0vl1
204- updated to new upstream release (security update)
205
206* Mon Dec 30 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.4-0vl1
207- new upstream version
208        -- Some minor changes to allow the code to compile on Windows platforms.
209        -- NEWS: Add dummy entry for since 1.11.3.
210        -- configure.in: Update to dev version 1.11.3.
211        -- configure: Regenerated.
212
213* Sat Dec 28 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.3-0vl1
214- new upstream version
215        -- When waiting for another user's lock, the message timestamps are now
216        in UTC rather than the server's local time.
217        -- The options.h file is no longer used.  This fixes a bug that occurred        when 1.11.2 was compiled on Windows platforms.
218        -- standardized on Automake version 1.6.3 and Autoconf version 2.53.
219
220- dropped kbr4 patch
221
222* Thu May 09 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl2
223- clean up patch files
224- added some documents files
225
226* Tue May 07 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl1
227- updated cvs-1.11.2
228        -- updated cvs-1.11.2-mktemp.patch
229       
230* Tue Mar 12 2002 Toru Sagami <sagami@vinelinux.org> 1.11.1p1-7vl1
231- paches are taken from RHSA-2002:026-35 1.11.1p1-7 with its fixes.
232  The most notable feature is: build with an external zlib
233
234* Mon May 21 2001 Satoshi MACHINO <machino@vinelinux.org> 1.11.1p1-0vl1
235- updated cvs-1.11.1p1
236- removed some patches
237- changed contrib dir to /usr/share from /usr/lib
238
239* Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
240- 1.11-0vl2
241- rebuilt with new %%{_mandir} definition
242- added Japanese summary and description
243
244* Tue Nov 21 2000 Satoshi MACHINO <machino@vinelinux.org> 1.11-0vl1
245- updated 1.11
246- removed auth.patch
247- added errno.patch from rawhide's cvs-1.11-1
248- partially used rpmmacros
249
250* Fri Sep 08 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
251- 1.10.8-0vl3
252- fixed %post and %preun section
253
254- 1.10.8-0vl2
255- removed gzip and strip in %install
256
257* Tue Jul 04 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
258- updated 1.10.8
259- switch to using the system's zlib instead of built-in
260- removed kerberos
261
262* Wed Mar  1 2000 Nalin Dahyabhai <nalin@redhat.com>
263- make kerberos support conditional at build-time
264
265* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
266- integrate kerberos support into main tree
267
268* Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
269- build with gssapi auth (--with-gssapi, --with-encryption)
270- apply patch to update libs to krb5 1.1.1
271
272* Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
273- fix the damn info pages too while we're at it.
274- fix description
275- man pages are compressed
276- make sure %post and %preun work okay
277
278* Sun Jan 9 2000  Jim Kingdon <http://bugzilla.redhat.com/bugzilla>
279- update to 1.10.7.
280
281* Wed Jul 14 1999 Jim Kingdon <http://developer.redhat.com>
282- add the patch to make 1.10.6 usable
283  (http://www.cyclic.com/cvs/dev-known.html).
284
285* Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
286- update to 1.10.6.
287
288* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
289- auto rebuild in the new build environment (release 2)
290
291* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
292- updated text in spec file.
293
294* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
295- update to 1.10.5.
296
297* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
298- update to 1.10.4.
299
300* Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
301- update to 1.10.3.
302
303* Mon Sep 28 1998 Jeff Johnson <jbj@redhat.com>
304- update to 1.10.2.
305
306* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
307- remove trailing characters from rcs2log mktemp args
308
309* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
310- update to 1.10.1
311
312* Mon Aug 31 1998 Jeff Johnson <jbj@redhat.com>
313- fix race conditions in cvsbug/rcs2log
314
315* Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
316- update to 1.10.
317
318* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
319- update to 1.9.30.
320
321* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
322- translations modified for de, fr
323
324* Mon Jun  8 1998 Jeff Johnson <jbj@redhat.com>
325- build root
326- update to 1.9.28
327
328* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
329- translations modified for de, fr, tr
330
331* Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
332- added install-info stuff
333- added changelog section
334
Note: See TracBrowser for help on using the repository browser.