source: projects/specs/branches/6/c/curl/curl-vl.spec @ 9066

Revision 9066, 12.7 KB checked in by iwamoto, 10 years ago (diff)

curl: CVE-2014-3707

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.32.0
7Release: 7%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12
13Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
14
15# make sure that NSS is initialized prior to calling PK11_GenerateRandom()
16Patch1: 0001-curl-7.32.0-204126a5.patch
17# avoid delay if FTP is aborted in CURLOPT_HEADERFUNCTION callback (#1005686)
18Patch2: 0002-curl-7.32.0-c639d725.patch
19# patch making libcurl multilib ready
20Patch101: 0101-curl-7.32.0-multilib.patch
21# prevent configure script from discarding -g in CFLAGS (#496778)
22Patch102: 0102-curl-7.32.0-debug.patch
23# make the curl tool link SSL libraries also used by src/tool_metalink.c
24Patch103: 0103-curl-7.32.0-metalink.patch
25
26# use localhost6 instead of ip6-localhost in the curl test-suite
27Patch104: 0104-curl-7.19.7-localhost6.patch
28# disable valgrind for certain test-cases (libssh2 problem)
29Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
30# work around valgrind bug (#678518)
31Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
32
33# Fix character encoding of docs, which are of mixed encoding originally so
34# a simple iconv can't fix them
35Patch108: 0108-curl-7.32.0-utf8.patch
36
37# Security fixes
38Patch200: curl-7.32.0_CVE-2013-4545.patch
39Patch210: http://curl.haxx.se/cve-2013-6422.patch
40Patch220: curl-7.32.0_CVE-2014-0015.patch
41Patch230: curl-7.32.0_CVE-2014-0138.patch
42Patch240: http://curl.haxx.se/libcurl-reject-cert-ip-wildcards.patch
43Patch250: curl-7.32.0_CVE-2014-3613.patch
44Patch260: curl-7.32.0_CVE-2014-3620.patch
45Patch270: curl-7.32.0_CVE-2014-3707.patch
46
47BuildRoot: %{_tmppath}/%{name}-%{version}-root
48BuildRequires: openssl-devel libidn-devel zlib-devel
49BuildRequires: openldap-devel gnutls-devel
50BuildRequires: openssh-server
51BuildRequires: openssh-clients
52BuildRequires: pkgconfig
53%if "%{?_dist_release}" != "vl6"
54BuildRequires: libssh2-devel
55%endif
56Requires: ca-certificates
57
58Vendor: Project Vine
59Distribution: Vine Linux
60Packager: daisuke
61
62%description
63cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
64Dict servers, using any of the supported protocols. cURL is designed
65to work without user interaction or any kind of interactivity. cURL
66offers many useful capabilities, like proxy support, user
67authentication, FTP upload, HTTP post, and file transfer resume.
68
69%package devel
70Summary: Files needed for building applications with libcurl.
71Group: Development/Libraries
72Requires: %{name} = %{version}-%{release}
73Requires: openssl-devel libidn-devel zlib-devel
74
75%description devel
76cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
77Dict servers, using any of the supported protocols. The curl-devel
78package includes files needed for developing applications which can
79use cURL's capabilities internally.
80#'
81
82
83## to build compat32 for x86_64 architecture support
84%package -n compat32-%{name}
85Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
86Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
87Group: System Environment/Libraries
88
89%description -n compat32-%{name}
90cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
91Dict servers, using any of the supported protocols. cURL is designed
92to work without user interaction or any kind of interactivity. cURL
93offers many useful capabilities, like proxy support, user
94authentication, FTP upload, HTTP post, and file transfer resume.
95
96%package -n compat32-%{name}-devel
97Summary: Files needed for building applications with libcurl.
98Group: Development/Libraries
99
100%description -n compat32-%{name}-devel
101cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
102Dict servers, using any of the supported protocols. The curl-devel
103package includes files needed for developing applications which can
104use cURL's capabilities internally.
105#'
106
107%prep
108%setup -q
109
110# upstream patches
111%patch1 -p1
112%patch2 -p1
113
114# Fedora patches
115%patch101 -p1
116%patch102 -p1
117%patch103 -p1
118%patch104 -p1
119%patch106 -p1
120%patch107 -p1
121%patch108 -p1
122
123# Security fixes
124%patch200 -p1 -b .CVE-2013-4545
125%patch210 -p1 -b .CVE-2013-6422
126%patch220 -p1 -b .CVE-2014-0015
127%patch230 -p1 -b .CVE-2014-0138
128%patch240 -p1 -b .CVE-2014-0139
129%patch250 -p1 -b .CVE-2014-3613
130%patch260 -p1 -b .CVE-2014-3620
131%patch270 -p1 -b .CVE-2014-3707
132
133%build
134%configure \
135  --with-ssl=%{_prefix} \
136  --with-gnutls \
137  --with-libidn \
138  --enable-ipv6 \
139  --enable-threaded-resolver \
140  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
141%if "%{?_dist_release}" != "vl6"
142  --with-libssh2 \
143%endif
144  --enable-ldaps \
145  --disable-static
146
147make %{?_smp_mflags}
148
149%install
150rm -rf $RPM_BUILD_ROOT
151make DESTDIR=$RPM_BUILD_ROOT install
152
153rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%post -p /sbin/ldconfig
159
160%postun -p /sbin/ldconfig
161
162%files
163%defattr(-,root,root)
164%doc CHANGES COPYING README
165%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
166%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
167%doc docs/TheArtOfHttpScripting docs/TODO
168%{_bindir}/curl
169#{_datadir}/curl/*
170%{_libdir}/*.so.*
171%{_mandir}/man1/*.1*
172
173%files devel
174%defattr(-,root,root)
175%{_bindir}/curl-config
176%{_includedir}/curl
177%{_libdir}/*.so
178%{_libdir}/pkgconfig/*.pc
179%{_mandir}/man1/curl-config.1*
180%{_mandir}/man3/*
181
182
183## to build compat32 for x86_64 architecture support
184%if %{build_compat32}
185%files -n compat32-%{name}
186%defattr(-,root,root)
187%{_libdir}/*.so.*
188
189%files -n compat32-%{name}-devel
190%defattr(-,root,root)
191%{_libdir}/*.so
192%{_libdir}/pkgconfig/*.pc
193%endif
194
195%changelog
196* Sat Nov  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-7
197- add patch270 for fix CVE-2014-3707
198  (This pacth is from fc20, thanks)
199
200* Sun Sep 14 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-6
201- add patch250 for fix CVE-2014-3613
202- add patch260 for fix CVE-2014-3620
203
204* Tue Apr 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-5
205- add patch230 for fix CVE-2014-0138 (wrong re-use of connections)
206  this patch is frem fc20, thanks.
207- add patch240 for fix CVE-2014-0139 (IP address wildcard)
208
209* Sat Feb  1 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-4
210- add patch212 for fix CVE-2014-0015 (NTLM auth)
211
212* Fri Dec 20 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-3
213- add patch210 for fix CVE-2013-6422 (certificate CN or SAN name field)
214
215* Tue Dec  3 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-2
216- add patch200 for fix CVE-2013-4545 (cert name check ignore)
217
218* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
219- new upstream release
220- import upstream/fedora patches
221- disable libssh2 on Vine Linux 6
222
223* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
224- new upstream reelase
225
226* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
227- update to 7.28.0
228- add configure options
229  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
230- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
231 
232- use ca-certificates package
233  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
234  - R: ca-certificates
235
236* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
237- new upstream release
238
239* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
240- add patch100 for fix CVE-2011-2192 (gssapi)
241- add Vendor/Distri tags
242
243* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
244- rebuild with openssl-1.0.0c
245
246* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
247- rebuilt with rpm-4.8.1 for pkg-config
248
249* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
250- new upstream release
251
252* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
253- new upstream release with security fix
254
255* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
256- added compat32 subpackages
257
258* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
259- new upstream release
260- use "_smp_mflags" flag
261
262* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
263- rebuild with openldap-2.4.11
264- add BR: openldap-devel
265- remove static library
266
267* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
268- new upstream release with security fix (CVE-2009-0037)
269
270* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
271- new upstream release
272
273* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
274- new upstream release
275
276* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
277- new upstream release
278
279* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
280- new upstream release
281
282* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
283- new upstream release
284
285* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
286- rebuilt with openssl-0.9.8e
287
288* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
289- new upstream release
290
291* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
292- new upstream release
293
294* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
295- new upstream release
296- add pkgconfig file to devel package
297
298* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
299- new upstream release
300
301* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
302- new upstream release
303
304* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
305- new upstream release
306
307* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
308- added libidn, zlib in Requires
309- added libidn-devel, zlib-devel in BuildPrereq
310- added zlib-devel in curl-devel's Requires
311
312* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
313- added openssl-devel, libidn-devel in curl-devel's Requires
314
315* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
316- new upstream release
317
318* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
319- new upstream release
320- rebuild with openssl-0.9.7d
321
322* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
323- upstream release
324
325* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
326- add %%{_datadir}/curl/* to %%files section
327
328* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
329- source upgrade
330
331* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
332- source upgrade
333- add PreReq: ldconfig
334- add %%{_libdir}/*.la to %%files devel section
335
336* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
337- build for VineSeed
338- add Requires: openssl
339
340* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
341- automated rebuild
342
343* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
344- 7.9.2
345
346* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
347- include curl-config in curl-devel
348- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
349
350* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
351- added openssl-devel build req
352
353* Mon May 21 2001 Tim Powers <timp@redhat.com>
354- built for the distro
355
356* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
357- upgrade to curl-7.7.2.
358- enable IPv6.
359
360* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
361- rebuilt against openssl-0.9.6-1
362
363* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
364- fixed mising ldconfigs
365- updated to 7.5.2, bug fixes
366
367* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
368- updated to 7.5.1
369
370* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
371- update to 7.4.1 to fix bug #20337, problems with curl -c
372- not using patch anymore, it's included in the new source. Keeping
373  for reference
374
375* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
376- fix bogus req in -devel package
377
378* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
379- devel package needed defattr so that root owns the files
380
381* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
382- update to 7.3
383- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
384
385* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
386- enable SSL support
387- fix packager tag
388- move buildroot to %%{_tmppath}
389
390* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
391- fixed vendor tag for bug #15028
392
393* Mon Jul 24 2000 Prospector <prospector@redhat.com>
394- rebuilt
395
396* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
397- workaround alpha build problems with optimizations
398
399* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
400- rebuilt
401
402* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
403- put man pages in correct place
404- use %%makeinstall
405
406* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
407- updated to 6.5.2
408
409* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
410- updated sources to 6.2
411- gzip man page
412
413* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
414- changed group
415
416* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
417- changelog started
418- general cleanups, changed prefix to /usr, added manpage to files section
419- including in Powertools
Note: See TracBrowser for help on using the repository browser.