source: projects/specs/branches/6/c/curl/curl-vl.spec @ 8226

Revision 8226, 11.8 KB checked in by iwamoto, 11 years ago (diff)

curl: fix CVE-2013-0015

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.32.0
7Release: 4%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12
13Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
14
15# make sure that NSS is initialized prior to calling PK11_GenerateRandom()
16Patch1: 0001-curl-7.32.0-204126a5.patch
17# avoid delay if FTP is aborted in CURLOPT_HEADERFUNCTION callback (#1005686)
18Patch2: 0002-curl-7.32.0-c639d725.patch
19# patch making libcurl multilib ready
20Patch101: 0101-curl-7.32.0-multilib.patch
21# prevent configure script from discarding -g in CFLAGS (#496778)
22Patch102: 0102-curl-7.32.0-debug.patch
23# make the curl tool link SSL libraries also used by src/tool_metalink.c
24Patch103: 0103-curl-7.32.0-metalink.patch
25
26# use localhost6 instead of ip6-localhost in the curl test-suite
27Patch104: 0104-curl-7.19.7-localhost6.patch
28# disable valgrind for certain test-cases (libssh2 problem)
29Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
30# work around valgrind bug (#678518)
31Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
32
33# Fix character encoding of docs, which are of mixed encoding originally so
34# a simple iconv can't fix them
35Patch108: 0108-curl-7.32.0-utf8.patch
36
37# Security fixes
38Patch200: curl-7.32.0_CVE-2013-4545.patch
39Patch210: http://curl.haxx.se/cve-2013-6422.patch
40Patch220: curl-7.32.0_CVE-2014-0015.patch
41
42BuildRoot: %{_tmppath}/%{name}-%{version}-root
43BuildRequires: openssl-devel libidn-devel zlib-devel
44BuildRequires: openldap-devel gnutls-devel
45BuildRequires: openssh-server
46BuildRequires: openssh-clients
47BuildRequires: pkgconfig
48%if "%{?_dist_release}" != "vl6"
49BuildRequires: libssh2-devel
50%endif
51Requires: ca-certificates
52
53Vendor: Project Vine
54Distribution: Vine Linux
55Packager: daisuke
56
57%description
58cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
59Dict servers, using any of the supported protocols. cURL is designed
60to work without user interaction or any kind of interactivity. cURL
61offers many useful capabilities, like proxy support, user
62authentication, FTP upload, HTTP post, and file transfer resume.
63
64%package devel
65Summary: Files needed for building applications with libcurl.
66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
68Requires: openssl-devel libidn-devel zlib-devel
69
70%description devel
71cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
72Dict servers, using any of the supported protocols. The curl-devel
73package includes files needed for developing applications which can
74use cURL's capabilities internally.
75#'
76
77
78## to build compat32 for x86_64 architecture support
79%package -n compat32-%{name}
80Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
81Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
82Group: System Environment/Libraries
83
84%description -n compat32-%{name}
85cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
86Dict servers, using any of the supported protocols. cURL is designed
87to work without user interaction or any kind of interactivity. cURL
88offers many useful capabilities, like proxy support, user
89authentication, FTP upload, HTTP post, and file transfer resume.
90
91%package -n compat32-%{name}-devel
92Summary: Files needed for building applications with libcurl.
93Group: Development/Libraries
94
95%description -n compat32-%{name}-devel
96cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
97Dict servers, using any of the supported protocols. The curl-devel
98package includes files needed for developing applications which can
99use cURL's capabilities internally.
100#'
101
102%prep
103%setup -q
104
105# upstream patches
106%patch1 -p1
107%patch2 -p1
108
109# Fedora patches
110%patch101 -p1
111%patch102 -p1
112%patch103 -p1
113%patch104 -p1
114%patch106 -p1
115%patch107 -p1
116%patch108 -p1
117
118# Security fixes
119%patch200 -p1 -b .CVE-2013-4545
120%patch210 -p1 -b .CVE-2013-6422
121%patch220 -p1 -b .CVE-2014-0015
122
123%build
124%configure \
125  --with-ssl=%{_prefix} \
126  --with-gnutls \
127  --with-libidn \
128  --enable-ipv6 \
129  --enable-threaded-resolver \
130  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
131%if "%{?_dist_release}" != "vl6"
132  --with-libssh2 \
133%endif
134  --enable-ldaps \
135  --disable-static
136
137make %{?_smp_mflags}
138
139%install
140rm -rf $RPM_BUILD_ROOT
141make DESTDIR=$RPM_BUILD_ROOT install
142
143rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post -p /sbin/ldconfig
149
150%postun -p /sbin/ldconfig
151
152%files
153%defattr(-,root,root)
154%doc CHANGES COPYING README
155%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
156%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
157%doc docs/TheArtOfHttpScripting docs/TODO
158%{_bindir}/curl
159#{_datadir}/curl/*
160%{_libdir}/*.so.*
161%{_mandir}/man1/*.1*
162
163%files devel
164%defattr(-,root,root)
165%{_bindir}/curl-config
166%{_includedir}/curl
167%{_libdir}/*.so
168%{_libdir}/pkgconfig/*.pc
169%{_mandir}/man1/curl-config.1*
170%{_mandir}/man3/*
171
172
173## to build compat32 for x86_64 architecture support
174%if %{build_compat32}
175%files -n compat32-%{name}
176%defattr(-,root,root)
177%{_libdir}/*.so.*
178
179%files -n compat32-%{name}-devel
180%defattr(-,root,root)
181%{_libdir}/*.so
182%{_libdir}/pkgconfig/*.pc
183%endif
184
185%changelog
186* Sat Feb  1 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-4
187- add patch212 for fix CVE-2014-0015 (NTLM auth)
188
189* Fri Dec 20 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-3
190- add patch210 for fix CVE-2013-6422 (certificate CN or SAN name field)
191
192* Tue Dec  3 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-2
193- add patch200 for fix CVE-2013-4545 (cert name check ignore)
194
195* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
196- new upstream release
197- import upstream/fedora patches
198- disable libssh2 on Vine Linux 6
199
200* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
201- new upstream reelase
202
203* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
204- update to 7.28.0
205- add configure options
206  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
207- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
208 
209- use ca-certificates package
210  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
211  - R: ca-certificates
212
213* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
214- new upstream release
215
216* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
217- add patch100 for fix CVE-2011-2192 (gssapi)
218- add Vendor/Distri tags
219
220* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
221- rebuild with openssl-1.0.0c
222
223* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
224- rebuilt with rpm-4.8.1 for pkg-config
225
226* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
227- new upstream release
228
229* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
230- new upstream release with security fix
231
232* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
233- added compat32 subpackages
234
235* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
236- new upstream release
237- use "_smp_mflags" flag
238
239* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
240- rebuild with openldap-2.4.11
241- add BR: openldap-devel
242- remove static library
243
244* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
245- new upstream release with security fix (CVE-2009-0037)
246
247* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
248- new upstream release
249
250* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
251- new upstream release
252
253* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
254- new upstream release
255
256* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
257- new upstream release
258
259* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
260- new upstream release
261
262* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
263- rebuilt with openssl-0.9.8e
264
265* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
266- new upstream release
267
268* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
269- new upstream release
270
271* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
272- new upstream release
273- add pkgconfig file to devel package
274
275* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
276- new upstream release
277
278* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
279- new upstream release
280
281* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
282- new upstream release
283
284* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
285- added libidn, zlib in Requires
286- added libidn-devel, zlib-devel in BuildPrereq
287- added zlib-devel in curl-devel's Requires
288
289* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
290- added openssl-devel, libidn-devel in curl-devel's Requires
291
292* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
293- new upstream release
294
295* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
296- new upstream release
297- rebuild with openssl-0.9.7d
298
299* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
300- upstream release
301
302* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
303- add %%{_datadir}/curl/* to %%files section
304
305* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
306- source upgrade
307
308* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
309- source upgrade
310- add PreReq: ldconfig
311- add %%{_libdir}/*.la to %%files devel section
312
313* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
314- build for VineSeed
315- add Requires: openssl
316
317* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
318- automated rebuild
319
320* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
321- 7.9.2
322
323* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
324- include curl-config in curl-devel
325- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
326
327* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
328- added openssl-devel build req
329
330* Mon May 21 2001 Tim Powers <timp@redhat.com>
331- built for the distro
332
333* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
334- upgrade to curl-7.7.2.
335- enable IPv6.
336
337* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
338- rebuilt against openssl-0.9.6-1
339
340* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
341- fixed mising ldconfigs
342- updated to 7.5.2, bug fixes
343
344* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
345- updated to 7.5.1
346
347* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
348- update to 7.4.1 to fix bug #20337, problems with curl -c
349- not using patch anymore, it's included in the new source. Keeping
350  for reference
351
352* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
353- fix bogus req in -devel package
354
355* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
356- devel package needed defattr so that root owns the files
357
358* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
359- update to 7.3
360- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
361
362* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
363- enable SSL support
364- fix packager tag
365- move buildroot to %%{_tmppath}
366
367* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
368- fixed vendor tag for bug #15028
369
370* Mon Jul 24 2000 Prospector <prospector@redhat.com>
371- rebuilt
372
373* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
374- workaround alpha build problems with optimizations
375
376* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
377- rebuilt
378
379* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
380- put man pages in correct place
381- use %%makeinstall
382
383* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
384- updated to 6.5.2
385
386* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
387- updated sources to 6.2
388- gzip man page
389
390* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
391- changed group
392
393* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
394- changelog started
395- general cleanups, changed prefix to /usr, added manpage to files section
396- including in Powertools
Note: See TracBrowser for help on using the repository browser.