source: projects/specs/branches/6/c/curl/curl-vl.spec @ 6117

Revision 6117, 9.4 KB checked in by iwamoto, 12 years ago (diff)

curl: fix CVE-2012-0036

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.20.1
7Release: 5%{?_dist_release}
8License: MIT/X
9Group: Applications/Internet
10Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
11URL: http://curl.haxx.se/
12# Security
13Patch100: curl-7.19.6_CVE-2011-2192.patch
14Patch110: curl-7.20.1_CVE-2012-0036.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: openssl-devel libidn-devel zlib-devel
18BuildRequires: openldap-devel gnutls-devel
19Requires: openssl libidn zlib
20
21Vendor: Project Vine
22Distribution: Vine Linux
23
24%description
25cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
26Dict servers, using any of the supported protocols. cURL is designed
27to work without user interaction or any kind of interactivity. cURL
28offers many useful capabilities, like proxy support, user
29authentication, FTP upload, HTTP post, and file transfer resume.
30
31%package devel
32Summary: Files needed for building applications with libcurl.
33Group: Development/Libraries
34Requires: %{name} = %{version}-%{release}
35Requires: openssl-devel libidn-devel zlib-devel
36
37%description devel
38cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
39Dict servers, using any of the supported protocols. The curl-devel
40package includes files needed for developing applications which can
41use cURL's capabilities internally.
42#'
43
44
45## to build compat32 for x86_64 architecture support
46%package -n compat32-%{name}
47Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
48Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
49Group: System Environment/Libraries
50
51%description -n compat32-%{name}
52cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
53Dict servers, using any of the supported protocols. cURL is designed
54to work without user interaction or any kind of interactivity. cURL
55offers many useful capabilities, like proxy support, user
56authentication, FTP upload, HTTP post, and file transfer resume.
57
58%package -n compat32-%{name}-devel
59Summary: Files needed for building applications with libcurl.
60Group: Development/Libraries
61
62%description -n compat32-%{name}-devel
63cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
64Dict servers, using any of the supported protocols. The curl-devel
65package includes files needed for developing applications which can
66use cURL's capabilities internally.
67#'
68
69%prep
70%setup -q
71%patch100 -p1 -b .CVE-2011-2192
72%patch110 -p1 -b .CVE-2012-0036
73
74%build
75%configure --with-ssl=%{_prefix} --with-gnutls --with-libidn --enable-ipv6 --disable-static
76%ifarch alpha
77make %{?_smp_mflags} CFLAGS=""
78%else
79make %{?_smp_mflags}
80%endif
81
82%install
83rm -rf $RPM_BUILD_ROOT
84make DESTDIR=$RPM_BUILD_ROOT install
85
86rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post -p /sbin/ldconfig
92
93%postun -p /sbin/ldconfig
94
95%files
96%defattr(-,root,root)
97%doc CHANGES COPYING README
98%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
99%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
100%doc docs/TheArtOfHttpScripting docs/TODO
101%{_bindir}/curl
102#{_datadir}/curl/*
103%{_libdir}/*.so.*
104%{_mandir}/man1/curl.1*
105
106%files devel
107%defattr(-,root,root)
108%{_bindir}/curl-config
109%{_includedir}/curl
110%{_libdir}/*.so
111%{_libdir}/pkgconfig/*.pc
112%{_mandir}/man1/curl-config.1*
113%{_mandir}/man3/*
114
115
116## to build compat32 for x86_64 architecture support
117%if %{build_compat32}
118%files -n compat32-%{name}
119%defattr(-,root,root)
120%{_libdir}/*.so.*
121
122%files -n compat32-%{name}-devel
123%defattr(-,root,root)
124%{_libdir}/*.so
125%{_libdir}/pkgconfig/*.pc
126%endif
127
128%changelog
129* Wed May  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-5
130- add patch110 for fix CVE-2012-0036 (input sanitis)
131
132* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
133- add patch100 for fix CVE-2011-2192 (gssapi)
134- add Vendor/Distri tags
135
136* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
137- rebuild with openssl-1.0.0c
138
139* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
140- rebuilt with rpm-4.8.1 for pkg-config
141
142* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
143- new upstream release
144
145* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
146- new upstream release with security fix
147
148* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
149- added compat32 subpackages
150
151* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
152- new upstream release
153- use "_smp_mflags" flag
154
155* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
156- rebuild with openldap-2.4.11
157- add BR: openldap-devel
158- remove static library
159
160* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
161- new upstream release with security fix (CVE-2009-0037)
162
163* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
164- new upstream release
165
166* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
167- new upstream release
168
169* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
170- new upstream release
171
172* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
173- new upstream release
174
175* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
176- new upstream release
177
178* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
179- rebuilt with openssl-0.9.8e
180
181* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
182- new upstream release
183
184* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
185- new upstream release
186
187* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
188- new upstream release
189- add pkgconfig file to devel package
190
191* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
192- new upstream release
193
194* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
195- new upstream release
196
197* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
198- new upstream release
199
200* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
201- added libidn, zlib in Requires
202- added libidn-devel, zlib-devel in BuildPrereq
203- added zlib-devel in curl-devel's Requires
204
205* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
206- added openssl-devel, libidn-devel in curl-devel's Requires
207
208* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
209- new upstream release
210
211* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
212- new upstream release
213- rebuild with openssl-0.9.7d
214
215* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
216- upstream release
217
218* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
219- add %%{_datadir}/curl/* to %%files section
220
221* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
222- source upgrade
223
224* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
225- source upgrade
226- add PreReq: ldconfig
227- add %%{_libdir}/*.la to %%files devel section
228
229* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
230- build for VineSeed
231- add Requires: openssl
232
233* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
234- automated rebuild
235
236* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
237- 7.9.2
238
239* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
240- include curl-config in curl-devel
241- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
242
243* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
244- added openssl-devel build req
245
246* Mon May 21 2001 Tim Powers <timp@redhat.com>
247- built for the distro
248
249* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
250- upgrade to curl-7.7.2.
251- enable IPv6.
252
253* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
254- rebuilt against openssl-0.9.6-1
255
256* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
257- fixed mising ldconfigs
258- updated to 7.5.2, bug fixes
259
260* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
261- updated to 7.5.1
262
263* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
264- update to 7.4.1 to fix bug #20337, problems with curl -c
265- not using patch anymore, it's included in the new source. Keeping
266  for reference
267
268* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
269- fix bogus req in -devel package
270
271* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
272- devel package needed defattr so that root owns the files
273
274* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
275- update to 7.3
276- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
277
278* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
279- enable SSL support
280- fix packager tag
281- move buildroot to %%{_tmppath}
282
283* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
284- fixed vendor tag for bug #15028
285
286* Mon Jul 24 2000 Prospector <prospector@redhat.com>
287- rebuilt
288
289* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
290- workaround alpha build problems with optimizations
291
292* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
293- rebuilt
294
295* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
296- put man pages in correct place
297- use %%makeinstall
298
299* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
300- updated to 6.5.2
301
302* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
303- updated sources to 6.2
304- gzip man page
305
306* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
307- changed group
308
309* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
310- changelog started
311- general cleanups, changed prefix to /usr, added manpage to files section
312- including in Powertools
Note: See TracBrowser for help on using the repository browser.