source: projects/specs/branches/6/c/curl/curl-vl.spec @ 10711

Revision 10711, 11.7 KB checked in by tomop, 8 years ago (diff)

curl-7.50.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.50.0
11Release: 1%{?_dist_release}
12
13License: MIT
14Group: Applications/Internet
15URL: http://curl.haxx.se/
16Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
17
18# patch making libcurl multilib ready
19Patch101: 0101-curl-7.32.0-multilib.patch
20# prevent configure script from discarding -g in CFLAGS (#496778)
21Patch102: 0102-curl-7.36.0-debug.patch
22# use localhost6 instead of ip6-localhost in the curl test-suite
23Patch104: 0104-curl-7.19.7-localhost6.patch
24# work around valgrind bug (#678518)
25Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: openssl-devel libidn-devel zlib-devel
29BuildRequires: openldap-devel gnutls-devel
30BuildRequires: openssh-server
31BuildRequires: openssh-clients
32BuildRequires: pkgconfig
33%if "%{?_dist_release}" != "vl6"
34BuildRequires: libssh2-devel
35%endif
36%if 0%{?with_http2}
37BuildRequires: libnghttp2-devel
38%endif
39
40Requires: ca-certificates
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: daisuke
45
46%description
47cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
48Dict servers, using any of the supported protocols. cURL is designed
49to work without user interaction or any kind of interactivity. cURL
50offers many useful capabilities, like proxy support, user
51authentication, FTP upload, HTTP post, and file transfer resume.
52
53%package devel
54Summary: Files needed for building applications with libcurl.
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: openssl-devel libidn-devel zlib-devel
58
59%description devel
60cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
61Dict servers, using any of the supported protocols. The curl-devel
62package includes files needed for developing applications which can
63use cURL's capabilities internally.
64#'
65
66
67## to build compat32 for x86_64 architecture support
68%package -n compat32-%{name}
69Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
70Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
71Group: System Environment/Libraries
72
73%description -n compat32-%{name}
74cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
75Dict servers, using any of the supported protocols. cURL is designed
76to work without user interaction or any kind of interactivity. cURL
77offers many useful capabilities, like proxy support, user
78authentication, FTP upload, HTTP post, and file transfer resume.
79
80%package -n compat32-%{name}-devel
81Summary: Files needed for building applications with libcurl.
82Group: Development/Libraries
83
84%description -n compat32-%{name}-devel
85cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
86Dict servers, using any of the supported protocols. The curl-devel
87package includes files needed for developing applications which can
88use cURL's capabilities internally.
89#'
90
91%prep
92%setup -q
93
94# Fedora patches
95%patch101 -p1
96%patch102 -p1
97%patch104 -p1
98%patch107 -p1
99
100%build
101%configure \
102  --with-ssl=%{_prefix} \
103  --with-gnutls \
104  --with-libidn \
105  --enable-ipv6 \
106  --enable-threaded-resolver \
107  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
108%if "%{?_dist_release}" != "vl6"
109  --with-libssh2 \
110%endif
111%if 0%{?with_http2}
112  --with-nghttp2 \
113%endif
114  --enable-ldaps \
115  --disable-static \
116  --enable-hidden-symbols
117
118make %{?_smp_mflags}
119
120%install
121rm -rf $RPM_BUILD_ROOT
122make DESTDIR=$RPM_BUILD_ROOT install
123
124rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%files
134%defattr(-,root,root)
135%{!?_licensedir:%global license %%doc}
136%license COPYING
137%doc CHANGES README
138%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
139%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
140%doc docs/TheArtOfHttpScripting docs/TODO
141%{_bindir}/curl
142#{_datadir}/curl/*
143%{_libdir}/*.so.*
144%{_mandir}/man1/*.1*
145
146%files devel
147%defattr(-,root,root)
148%{_bindir}/curl-config
149%{_includedir}/curl
150%{_libdir}/*.so
151%{_libdir}/pkgconfig/*.pc
152%{_mandir}/man1/curl-config.1*
153%{_mandir}/man3/*
154%{_datadir}/aclocal/libcurl.m4
155
156
157## to build compat32 for x86_64 architecture support
158%if %{build_compat32}
159%files -n compat32-%{name}
160%defattr(-,root,root)
161%{_libdir}/*.so.*
162
163%files -n compat32-%{name}-devel
164%defattr(-,root,root)
165%{_libdir}/*.so
166%{_libdir}/pkgconfig/*.pc
167%endif
168
169%changelog
170* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
171- new upstream release.
172- disabled HTTP/2 on Vine6.
173
174* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
175- added HTTP/2 support.
176
177* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
178- new upstream release with security fix.
179
180* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
181- new upstream release.
182
183* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
184- new upstream release
185- built with openssl 1.0.2g
186
187* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
188- new upstream release with security fix .
189- removed Patch108 (fixed in upstream).
190
191* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
192- new upstream release with security fix
193
194* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
195- new upstream release
196- add libcurl.m4 to -devel package
197
198* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
199- new upstream release
200- import upstream/fedora patches
201- disable libssh2 on Vine Linux 6
202
203* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
204- new upstream reelase
205
206* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
207- update to 7.28.0
208- add configure options
209  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
210- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
211 
212- use ca-certificates package
213  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
214  - R: ca-certificates
215
216* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
217- new upstream release
218
219* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
220- add patch100 for fix CVE-2011-2192 (gssapi)
221- add Vendor/Distri tags
222
223* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
224- rebuild with openssl-1.0.0c
225
226* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
227- rebuilt with rpm-4.8.1 for pkg-config
228
229* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
230- new upstream release
231
232* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
233- new upstream release with security fix
234
235* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
236- added compat32 subpackages
237
238* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
239- new upstream release
240- use "_smp_mflags" flag
241
242* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
243- rebuild with openldap-2.4.11
244- add BR: openldap-devel
245- remove static library
246
247* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
248- new upstream release with security fix (CVE-2009-0037)
249
250* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
251- new upstream release
252
253* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
254- new upstream release
255
256* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
257- new upstream release
258
259* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
260- new upstream release
261
262* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
263- new upstream release
264
265* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
266- rebuilt with openssl-0.9.8e
267
268* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
269- new upstream release
270
271* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
272- new upstream release
273
274* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
275- new upstream release
276- add pkgconfig file to devel package
277
278* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
279- new upstream release
280
281* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
282- new upstream release
283
284* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
285- new upstream release
286
287* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
288- added libidn, zlib in Requires
289- added libidn-devel, zlib-devel in BuildPrereq
290- added zlib-devel in curl-devel's Requires
291
292* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
293- added openssl-devel, libidn-devel in curl-devel's Requires
294
295* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
296- new upstream release
297
298* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
299- new upstream release
300- rebuild with openssl-0.9.7d
301
302* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
303- upstream release
304
305* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
306- add %%{_datadir}/curl/* to %%files section
307
308* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
309- source upgrade
310
311* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
312- source upgrade
313- add PreReq: ldconfig
314- add %%{_libdir}/*.la to %%files devel section
315
316* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
317- build for VineSeed
318- add Requires: openssl
319
320* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
321- automated rebuild
322
323* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
324- 7.9.2
325
326* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
327- include curl-config in curl-devel
328- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
329
330* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
331- added openssl-devel build req
332
333* Mon May 21 2001 Tim Powers <timp@redhat.com>
334- built for the distro
335
336* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
337- upgrade to curl-7.7.2.
338- enable IPv6.
339
340* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
341- rebuilt against openssl-0.9.6-1
342
343* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
344- fixed mising ldconfigs
345- updated to 7.5.2, bug fixes
346
347* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
348- updated to 7.5.1
349
350* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
351- update to 7.4.1 to fix bug #20337, problems with curl -c
352- not using patch anymore, it's included in the new source. Keeping
353  for reference
354
355* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
356- fix bogus req in -devel package
357
358* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
359- devel package needed defattr so that root owns the files
360
361* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
362- update to 7.3
363- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
364
365* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
366- enable SSL support
367- fix packager tag
368- move buildroot to %%{_tmppath}
369
370* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
371- fixed vendor tag for bug #15028
372
373* Mon Jul 24 2000 Prospector <prospector@redhat.com>
374- rebuilt
375
376* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
377- workaround alpha build problems with optimizations
378
379* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
380- rebuilt
381
382* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
383- put man pages in correct place
384- use %%makeinstall
385
386* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
387- updated to 6.5.2
388
389* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
390- updated sources to 6.2
391- gzip man page
392
393* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
394- changed group
395
396* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
397- changelog started
398- general cleanups, changed prefix to /usr, added manpage to files section
399- including in Powertools
Note: See TracBrowser for help on using the repository browser.