source: projects/specs/branches/6/c/curl/curl-vl.spec @ 8985

Revision 8985, 12.5 KB checked in by iwamoto, 10 years ago (diff)

curl: CVE-2014-3613,3620

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.32.0
7Release: 6%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12
13Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
14
15# make sure that NSS is initialized prior to calling PK11_GenerateRandom()
16Patch1: 0001-curl-7.32.0-204126a5.patch
17# avoid delay if FTP is aborted in CURLOPT_HEADERFUNCTION callback (#1005686)
18Patch2: 0002-curl-7.32.0-c639d725.patch
19# patch making libcurl multilib ready
20Patch101: 0101-curl-7.32.0-multilib.patch
21# prevent configure script from discarding -g in CFLAGS (#496778)
22Patch102: 0102-curl-7.32.0-debug.patch
23# make the curl tool link SSL libraries also used by src/tool_metalink.c
24Patch103: 0103-curl-7.32.0-metalink.patch
25
26# use localhost6 instead of ip6-localhost in the curl test-suite
27Patch104: 0104-curl-7.19.7-localhost6.patch
28# disable valgrind for certain test-cases (libssh2 problem)
29Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
30# work around valgrind bug (#678518)
31Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
32
33# Fix character encoding of docs, which are of mixed encoding originally so
34# a simple iconv can't fix them
35Patch108: 0108-curl-7.32.0-utf8.patch
36
37# Security fixes
38Patch200: curl-7.32.0_CVE-2013-4545.patch
39Patch210: http://curl.haxx.se/cve-2013-6422.patch
40Patch220: curl-7.32.0_CVE-2014-0015.patch
41Patch230: curl-7.32.0_CVE-2014-0138.patch
42Patch240: http://curl.haxx.se/libcurl-reject-cert-ip-wildcards.patch
43Patch250: curl-7.32.0_CVE-2014-3613.patch
44Patch260: curl-7.32.0_CVE-2014-3620.patch
45
46BuildRoot: %{_tmppath}/%{name}-%{version}-root
47BuildRequires: openssl-devel libidn-devel zlib-devel
48BuildRequires: openldap-devel gnutls-devel
49BuildRequires: openssh-server
50BuildRequires: openssh-clients
51BuildRequires: pkgconfig
52%if "%{?_dist_release}" != "vl6"
53BuildRequires: libssh2-devel
54%endif
55Requires: ca-certificates
56
57Vendor: Project Vine
58Distribution: Vine Linux
59Packager: daisuke
60
61%description
62cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
63Dict servers, using any of the supported protocols. cURL is designed
64to work without user interaction or any kind of interactivity. cURL
65offers many useful capabilities, like proxy support, user
66authentication, FTP upload, HTTP post, and file transfer resume.
67
68%package devel
69Summary: Files needed for building applications with libcurl.
70Group: Development/Libraries
71Requires: %{name} = %{version}-%{release}
72Requires: openssl-devel libidn-devel zlib-devel
73
74%description devel
75cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
76Dict servers, using any of the supported protocols. The curl-devel
77package includes files needed for developing applications which can
78use cURL's capabilities internally.
79#'
80
81
82## to build compat32 for x86_64 architecture support
83%package -n compat32-%{name}
84Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
85Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
86Group: System Environment/Libraries
87
88%description -n compat32-%{name}
89cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
90Dict servers, using any of the supported protocols. cURL is designed
91to work without user interaction or any kind of interactivity. cURL
92offers many useful capabilities, like proxy support, user
93authentication, FTP upload, HTTP post, and file transfer resume.
94
95%package -n compat32-%{name}-devel
96Summary: Files needed for building applications with libcurl.
97Group: Development/Libraries
98
99%description -n compat32-%{name}-devel
100cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
101Dict servers, using any of the supported protocols. The curl-devel
102package includes files needed for developing applications which can
103use cURL's capabilities internally.
104#'
105
106%prep
107%setup -q
108
109# upstream patches
110%patch1 -p1
111%patch2 -p1
112
113# Fedora patches
114%patch101 -p1
115%patch102 -p1
116%patch103 -p1
117%patch104 -p1
118%patch106 -p1
119%patch107 -p1
120%patch108 -p1
121
122# Security fixes
123%patch200 -p1 -b .CVE-2013-4545
124%patch210 -p1 -b .CVE-2013-6422
125%patch220 -p1 -b .CVE-2014-0015
126%patch230 -p1 -b .CVE-2014-0138
127%patch240 -p1 -b .CVE-2014-0139
128%patch250 -p1 -b .CVE-2014-3613
129%patch260 -p1 -b .CVE-2014-3620
130
131%build
132%configure \
133  --with-ssl=%{_prefix} \
134  --with-gnutls \
135  --with-libidn \
136  --enable-ipv6 \
137  --enable-threaded-resolver \
138  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
139%if "%{?_dist_release}" != "vl6"
140  --with-libssh2 \
141%endif
142  --enable-ldaps \
143  --disable-static
144
145make %{?_smp_mflags}
146
147%install
148rm -rf $RPM_BUILD_ROOT
149make DESTDIR=$RPM_BUILD_ROOT install
150
151rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%post -p /sbin/ldconfig
157
158%postun -p /sbin/ldconfig
159
160%files
161%defattr(-,root,root)
162%doc CHANGES COPYING README
163%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
164%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
165%doc docs/TheArtOfHttpScripting docs/TODO
166%{_bindir}/curl
167#{_datadir}/curl/*
168%{_libdir}/*.so.*
169%{_mandir}/man1/*.1*
170
171%files devel
172%defattr(-,root,root)
173%{_bindir}/curl-config
174%{_includedir}/curl
175%{_libdir}/*.so
176%{_libdir}/pkgconfig/*.pc
177%{_mandir}/man1/curl-config.1*
178%{_mandir}/man3/*
179
180
181## to build compat32 for x86_64 architecture support
182%if %{build_compat32}
183%files -n compat32-%{name}
184%defattr(-,root,root)
185%{_libdir}/*.so.*
186
187%files -n compat32-%{name}-devel
188%defattr(-,root,root)
189%{_libdir}/*.so
190%{_libdir}/pkgconfig/*.pc
191%endif
192
193%changelog
194* Sun Sep 14 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-6
195- add patch250 for fix CVE-2014-3613
196- add patch260 for fix CVE-2014-3620
197
198* Tue Apr 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-5
199- add patch230 for fix CVE-2014-0138 (wrong re-use of connections)
200  this patch is frem fc20, thanks.
201- add patch240 for fix CVE-2014-0139 (IP address wildcard)
202
203* Sat Feb  1 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-4
204- add patch212 for fix CVE-2014-0015 (NTLM auth)
205
206* Fri Dec 20 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-3
207- add patch210 for fix CVE-2013-6422 (certificate CN or SAN name field)
208
209* Tue Dec  3 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-2
210- add patch200 for fix CVE-2013-4545 (cert name check ignore)
211
212* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
213- new upstream release
214- import upstream/fedora patches
215- disable libssh2 on Vine Linux 6
216
217* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
218- new upstream reelase
219
220* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
221- update to 7.28.0
222- add configure options
223  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
224- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
225 
226- use ca-certificates package
227  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
228  - R: ca-certificates
229
230* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
231- new upstream release
232
233* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
234- add patch100 for fix CVE-2011-2192 (gssapi)
235- add Vendor/Distri tags
236
237* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
238- rebuild with openssl-1.0.0c
239
240* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
241- rebuilt with rpm-4.8.1 for pkg-config
242
243* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
244- new upstream release
245
246* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
247- new upstream release with security fix
248
249* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
250- added compat32 subpackages
251
252* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
253- new upstream release
254- use "_smp_mflags" flag
255
256* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
257- rebuild with openldap-2.4.11
258- add BR: openldap-devel
259- remove static library
260
261* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
262- new upstream release with security fix (CVE-2009-0037)
263
264* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
265- new upstream release
266
267* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
268- new upstream release
269
270* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
271- new upstream release
272
273* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
274- new upstream release
275
276* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
277- new upstream release
278
279* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
280- rebuilt with openssl-0.9.8e
281
282* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
283- new upstream release
284
285* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
286- new upstream release
287
288* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
289- new upstream release
290- add pkgconfig file to devel package
291
292* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
293- new upstream release
294
295* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
296- new upstream release
297
298* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
299- new upstream release
300
301* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
302- added libidn, zlib in Requires
303- added libidn-devel, zlib-devel in BuildPrereq
304- added zlib-devel in curl-devel's Requires
305
306* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
307- added openssl-devel, libidn-devel in curl-devel's Requires
308
309* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
310- new upstream release
311
312* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
313- new upstream release
314- rebuild with openssl-0.9.7d
315
316* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
317- upstream release
318
319* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
320- add %%{_datadir}/curl/* to %%files section
321
322* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
323- source upgrade
324
325* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
326- source upgrade
327- add PreReq: ldconfig
328- add %%{_libdir}/*.la to %%files devel section
329
330* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
331- build for VineSeed
332- add Requires: openssl
333
334* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
335- automated rebuild
336
337* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
338- 7.9.2
339
340* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
341- include curl-config in curl-devel
342- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
343
344* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
345- added openssl-devel build req
346
347* Mon May 21 2001 Tim Powers <timp@redhat.com>
348- built for the distro
349
350* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
351- upgrade to curl-7.7.2.
352- enable IPv6.
353
354* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
355- rebuilt against openssl-0.9.6-1
356
357* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
358- fixed mising ldconfigs
359- updated to 7.5.2, bug fixes
360
361* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
362- updated to 7.5.1
363
364* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
365- update to 7.4.1 to fix bug #20337, problems with curl -c
366- not using patch anymore, it's included in the new source. Keeping
367  for reference
368
369* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
370- fix bogus req in -devel package
371
372* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
373- devel package needed defattr so that root owns the files
374
375* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
376- update to 7.3
377- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
378
379* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
380- enable SSL support
381- fix packager tag
382- move buildroot to %%{_tmppath}
383
384* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
385- fixed vendor tag for bug #15028
386
387* Mon Jul 24 2000 Prospector <prospector@redhat.com>
388- rebuilt
389
390* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
391- workaround alpha build problems with optimizations
392
393* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
394- rebuilt
395
396* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
397- put man pages in correct place
398- use %%makeinstall
399
400* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
401- updated to 6.5.2
402
403* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
404- updated sources to 6.2
405- gzip man page
406
407* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
408- changed group
409
410* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
411- changelog started
412- general cleanups, changed prefix to /usr, added manpage to files section
413- including in Powertools
Note: See TracBrowser for help on using the repository browser.