source: projects/specs/branches/6/c/curl/curl-vl.spec @ 8357

Revision 8357, 12.2 KB checked in by iwamoto, 10 years ago (diff)

curl: CVE-2014-0138,0139

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.32.0
7Release: 5%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12
13Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
14
15# make sure that NSS is initialized prior to calling PK11_GenerateRandom()
16Patch1: 0001-curl-7.32.0-204126a5.patch
17# avoid delay if FTP is aborted in CURLOPT_HEADERFUNCTION callback (#1005686)
18Patch2: 0002-curl-7.32.0-c639d725.patch
19# patch making libcurl multilib ready
20Patch101: 0101-curl-7.32.0-multilib.patch
21# prevent configure script from discarding -g in CFLAGS (#496778)
22Patch102: 0102-curl-7.32.0-debug.patch
23# make the curl tool link SSL libraries also used by src/tool_metalink.c
24Patch103: 0103-curl-7.32.0-metalink.patch
25
26# use localhost6 instead of ip6-localhost in the curl test-suite
27Patch104: 0104-curl-7.19.7-localhost6.patch
28# disable valgrind for certain test-cases (libssh2 problem)
29Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
30# work around valgrind bug (#678518)
31Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
32
33# Fix character encoding of docs, which are of mixed encoding originally so
34# a simple iconv can't fix them
35Patch108: 0108-curl-7.32.0-utf8.patch
36
37# Security fixes
38Patch200: curl-7.32.0_CVE-2013-4545.patch
39Patch210: http://curl.haxx.se/cve-2013-6422.patch
40Patch220: curl-7.32.0_CVE-2014-0015.patch
41Patch230: curl-7.32.0_CVE-2014-0138.patch
42Patch240: http://curl.haxx.se/libcurl-reject-cert-ip-wildcards.patch
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-root
45BuildRequires: openssl-devel libidn-devel zlib-devel
46BuildRequires: openldap-devel gnutls-devel
47BuildRequires: openssh-server
48BuildRequires: openssh-clients
49BuildRequires: pkgconfig
50%if "%{?_dist_release}" != "vl6"
51BuildRequires: libssh2-devel
52%endif
53Requires: ca-certificates
54
55Vendor: Project Vine
56Distribution: Vine Linux
57Packager: daisuke
58
59%description
60cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
61Dict servers, using any of the supported protocols. cURL is designed
62to work without user interaction or any kind of interactivity. cURL
63offers many useful capabilities, like proxy support, user
64authentication, FTP upload, HTTP post, and file transfer resume.
65
66%package devel
67Summary: Files needed for building applications with libcurl.
68Group: Development/Libraries
69Requires: %{name} = %{version}-%{release}
70Requires: openssl-devel libidn-devel zlib-devel
71
72%description devel
73cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74Dict servers, using any of the supported protocols. The curl-devel
75package includes files needed for developing applications which can
76use cURL's capabilities internally.
77#'
78
79
80## to build compat32 for x86_64 architecture support
81%package -n compat32-%{name}
82Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
83Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
84Group: System Environment/Libraries
85
86%description -n compat32-%{name}
87cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
88Dict servers, using any of the supported protocols. cURL is designed
89to work without user interaction or any kind of interactivity. cURL
90offers many useful capabilities, like proxy support, user
91authentication, FTP upload, HTTP post, and file transfer resume.
92
93%package -n compat32-%{name}-devel
94Summary: Files needed for building applications with libcurl.
95Group: Development/Libraries
96
97%description -n compat32-%{name}-devel
98cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
99Dict servers, using any of the supported protocols. The curl-devel
100package includes files needed for developing applications which can
101use cURL's capabilities internally.
102#'
103
104%prep
105%setup -q
106
107# upstream patches
108%patch1 -p1
109%patch2 -p1
110
111# Fedora patches
112%patch101 -p1
113%patch102 -p1
114%patch103 -p1
115%patch104 -p1
116%patch106 -p1
117%patch107 -p1
118%patch108 -p1
119
120# Security fixes
121%patch200 -p1 -b .CVE-2013-4545
122%patch210 -p1 -b .CVE-2013-6422
123%patch220 -p1 -b .CVE-2014-0015
124%patch230 -p1 -b .CVE-2014-0138
125%patch240 -p1 -b .CVE-2014-0139
126
127%build
128%configure \
129  --with-ssl=%{_prefix} \
130  --with-gnutls \
131  --with-libidn \
132  --enable-ipv6 \
133  --enable-threaded-resolver \
134  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
135%if "%{?_dist_release}" != "vl6"
136  --with-libssh2 \
137%endif
138  --enable-ldaps \
139  --disable-static
140
141make %{?_smp_mflags}
142
143%install
144rm -rf $RPM_BUILD_ROOT
145make DESTDIR=$RPM_BUILD_ROOT install
146
147rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%post -p /sbin/ldconfig
153
154%postun -p /sbin/ldconfig
155
156%files
157%defattr(-,root,root)
158%doc CHANGES COPYING README
159%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
160%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
161%doc docs/TheArtOfHttpScripting docs/TODO
162%{_bindir}/curl
163#{_datadir}/curl/*
164%{_libdir}/*.so.*
165%{_mandir}/man1/*.1*
166
167%files devel
168%defattr(-,root,root)
169%{_bindir}/curl-config
170%{_includedir}/curl
171%{_libdir}/*.so
172%{_libdir}/pkgconfig/*.pc
173%{_mandir}/man1/curl-config.1*
174%{_mandir}/man3/*
175
176
177## to build compat32 for x86_64 architecture support
178%if %{build_compat32}
179%files -n compat32-%{name}
180%defattr(-,root,root)
181%{_libdir}/*.so.*
182
183%files -n compat32-%{name}-devel
184%defattr(-,root,root)
185%{_libdir}/*.so
186%{_libdir}/pkgconfig/*.pc
187%endif
188
189%changelog
190* Tue Apr 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-5
191- add patch230 for fix CVE-2014-0138 (wrong re-use of connections)
192  this patch is frem fc20, thanks.
193- add patch240 for fix CVE-2014-0139 (IP address wildcard)
194
195* Sat Feb  1 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-4
196- add patch212 for fix CVE-2014-0015 (NTLM auth)
197
198* Fri Dec 20 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-3
199- add patch210 for fix CVE-2013-6422 (certificate CN or SAN name field)
200
201* Tue Dec  3 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-2
202- add patch200 for fix CVE-2013-4545 (cert name check ignore)
203
204* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
205- new upstream release
206- import upstream/fedora patches
207- disable libssh2 on Vine Linux 6
208
209* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
210- new upstream reelase
211
212* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
213- update to 7.28.0
214- add configure options
215  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
216- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
217 
218- use ca-certificates package
219  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
220  - R: ca-certificates
221
222* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
223- new upstream release
224
225* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
226- add patch100 for fix CVE-2011-2192 (gssapi)
227- add Vendor/Distri tags
228
229* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
230- rebuild with openssl-1.0.0c
231
232* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
233- rebuilt with rpm-4.8.1 for pkg-config
234
235* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
236- new upstream release
237
238* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
239- new upstream release with security fix
240
241* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
242- added compat32 subpackages
243
244* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
245- new upstream release
246- use "_smp_mflags" flag
247
248* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
249- rebuild with openldap-2.4.11
250- add BR: openldap-devel
251- remove static library
252
253* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
254- new upstream release with security fix (CVE-2009-0037)
255
256* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
257- new upstream release
258
259* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
260- new upstream release
261
262* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
263- new upstream release
264
265* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
266- new upstream release
267
268* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
269- new upstream release
270
271* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
272- rebuilt with openssl-0.9.8e
273
274* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
275- new upstream release
276
277* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
278- new upstream release
279
280* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
281- new upstream release
282- add pkgconfig file to devel package
283
284* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
285- new upstream release
286
287* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
288- new upstream release
289
290* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
291- new upstream release
292
293* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
294- added libidn, zlib in Requires
295- added libidn-devel, zlib-devel in BuildPrereq
296- added zlib-devel in curl-devel's Requires
297
298* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
299- added openssl-devel, libidn-devel in curl-devel's Requires
300
301* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
302- new upstream release
303
304* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
305- new upstream release
306- rebuild with openssl-0.9.7d
307
308* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
309- upstream release
310
311* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
312- add %%{_datadir}/curl/* to %%files section
313
314* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
315- source upgrade
316
317* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
318- source upgrade
319- add PreReq: ldconfig
320- add %%{_libdir}/*.la to %%files devel section
321
322* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
323- build for VineSeed
324- add Requires: openssl
325
326* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
327- automated rebuild
328
329* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
330- 7.9.2
331
332* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
333- include curl-config in curl-devel
334- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
335
336* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
337- added openssl-devel build req
338
339* Mon May 21 2001 Tim Powers <timp@redhat.com>
340- built for the distro
341
342* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
343- upgrade to curl-7.7.2.
344- enable IPv6.
345
346* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
347- rebuilt against openssl-0.9.6-1
348
349* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
350- fixed mising ldconfigs
351- updated to 7.5.2, bug fixes
352
353* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
354- updated to 7.5.1
355
356* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
357- update to 7.4.1 to fix bug #20337, problems with curl -c
358- not using patch anymore, it's included in the new source. Keeping
359  for reference
360
361* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
362- fix bogus req in -devel package
363
364* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
365- devel package needed defattr so that root owns the files
366
367* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
368- update to 7.3
369- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
370
371* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
372- enable SSL support
373- fix packager tag
374- move buildroot to %%{_tmppath}
375
376* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
377- fixed vendor tag for bug #15028
378
379* Mon Jul 24 2000 Prospector <prospector@redhat.com>
380- rebuilt
381
382* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
383- workaround alpha build problems with optimizations
384
385* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
386- rebuilt
387
388* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
389- put man pages in correct place
390- use %%makeinstall
391
392* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
393- updated to 6.5.2
394
395* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
396- updated sources to 6.2
397- gzip man page
398
399* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
400- changed group
401
402* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
403- changelog started
404- general cleanups, changed prefix to /usr, added manpage to files section
405- including in Powertools
Note: See TracBrowser for help on using the repository browser.