source: projects/specs/branches/6/c/ctpl/ctpl-vl.spec @ 2562

Revision 2562, 4.9 KB checked in by kudoh, 13 years ago (diff)
Line 
1%global ctpl_docdir %{_defaultdocdir}/ctpl-%{version}
2
3Name:           ctpl
4Version:        0.3.2
5Release:        1%{?_dist_release}
6Summary:        Template engine library written in C
7Summary(ja):    C で書かれたテンプレートエンジンライブラリ
8
9Group:          Development/Tools
10License:        GPLv3+
11URL:            http://ctpl.tuxfamily.org/
12Source0:        http://download.tuxfamily.org/ctpl/releases/ctpl-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires:  glib2-devel >= 2.10
16Requires:       ctpl-libs = %{version}-%{release}
17
18%description
19CTPL is a template library written in C. It allows fast and easy parsing of
20templates from many sources (including in-memory data and local and remote
21streaming, thanks to GIO) and fine control over template parsing environment.
22
23CTPL has following features:
24* It is a library, then it can be easily used from programs
25* Separated lexer and parser
26* It is written in portable C
27* Simple syntax
28* Fast and strict parsing
29* Possible in-memory parsing, allowing non-file data parsing and avoiding
30  I/O-latency, through GIO's GMemoryInputStream and GMemoryOutputStream
31
32
33%package libs
34Summary: Template library written in C
35Summary(ja):  C で書かれたテンプレートライブラリ
36Group:     Development/Tools
37
38%description libs
39This package contains the CTPL library.
40
41%post libs -p /sbin/ldconfig
42%postun libs -p /sbin/ldconfig
43
44
45%package devel
46Summary: Development headers of the template library written in C
47Summary(ja):  C で書かれたテンプレートライブラリの開発ヘッダ
48Group:     Development/Tools
49Requires:  ctpl-libs = %{version}-%{release}
50
51%description devel
52This package contains the development headers of the CTPL library.
53
54
55%package doc
56Summary:   Documentation for the CTPL library
57Summary:   CTPL ライブラリのドキュメント
58Group:     Development/Tools
59Requires:  ctpl-libs = %{version}-%{release}
60Requires:  gtk-doc
61
62BuildArch: noarch
63
64
65%description doc
66This package contains the HTML documentation reference for the CTPL library.
67
68
69%prep
70%setup -q
71
72# remove waf since this isn't needed for the build, we're building the
73# package with autotools
74rm -f waf
75rm -f wscript
76
77
78%build
79%configure --docdir %{ctpl_docdir}
80sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
81sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
82make %{?_smp_mflags}
83
84
85%install
86rm -rf $RPM_BUILD_ROOT
87make install DESTDIR=$RPM_BUILD_ROOT
88
89# Seems the --docdir flag is not working correctly, working around this here
90# for now
91install -d $RPM_BUILD_ROOT%{ctpl_docdir}
92install -Dpm0644 AUTHORS COPYING NEWS HACKING TODO README THANKS $RPM_BUILD_ROOT%{ctpl_docdir}
93
94rm -f $RPM_BUILD_ROOT%{_libdir}/libctpl.a
95rm -f $RPM_BUILD_ROOT%{_libdir}/libctpl.la
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100
101%files
102%defattr(-,root,root,-)
103%doc %{_mandir}/man1/%{name}.1.*
104%{_bindir}/%{name}
105
106
107%files libs
108%defattr(-,root,root,-)
109%dir %{ctpl_docdir}
110%doc %{ctpl_docdir}/AUTHORS
111%doc %{ctpl_docdir}/COPYING
112%doc %{ctpl_docdir}/NEWS
113%{_libdir}/lib%{name}.so.*
114
115
116%files devel
117%defattr(-,root,root,-)
118%doc %{ctpl_docdir}/HACKING
119%doc %{ctpl_docdir}/TODO
120%{_libdir}/lib%{name}.so
121%{_includedir}/%{name}/
122%{_libdir}/pkgconfig/%{name}.pc
123
124
125%files doc
126%defattr(-,root,root,-)
127%doc %{ctpl_docdir}/README
128%doc %{ctpl_docdir}/THANKS
129%doc %{_datadir}/gtk-doc/html/%{name}
130
131
132%changelog
133* Sun Jan 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.2-1
134- new upstream release
135
136* Tue Dec 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.1-1
137- new upstream release
138
139* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.2-2
140- rebuilt with rpm-4.8.1 for pkg-config
141
142* Sun Aug 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.2-1
143- initial build for VineSeed
144
145* Sat Jul 17 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-4
146- fix rpmlint binary-or-shlib-defines-rpath error
147- fix rpmlint library-without-ldconfig-* errors
148- make the -doc package noarch
149- remove the -bin subpackage, the binary files will now be installed with the
150  main package, thus when typing 'yum install ctpl'
151- require gtk-doc for the -doc package
152- ctpl-libs now owns /usr/share/doc/ctpl-0.2.2
153- fix redundant file listings
154- require -libs package with fully qualified version for the binary package
155
156* Fri Jul 16 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-3
157- move the %%{_libdir}/lib%%{name}.so back to the -devel package where it
158  belongs to
159
160* Fri Jul 16 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-2
161- rename subpackage lib to libs
162- add Requires on the libs package to -bin, -devel and -doc package
163- install %%{_libdir}/lib%%{name}.so with a -static package
164- install manpage only with the binary
165- install HACKING and TODO only with the -devel package
166- install README and THANKS only with the -doc package
167- fix the installation path for documentation files
168
169* Thu Jul 15 2010 Dominic Hopf <dmaphy@fedoraproject.org> - 0.2.2-1
170- initial specfile
Note: See TracBrowser for help on using the repository browser.