source: projects/specs/branches/6/c/cryptsetup/cryptsetup-vl.spec @ 521

Revision 521, 5.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A utility for setting up encrypted filesystems
2Name: cryptsetup
3Version: 1.0.5
4Release: 8%{?_dist_release}
5License: GPLv2
6Group: Applications/System
7URL: http://luks.endorphin.org/
8Source: http://luks.endorphin.org/source/cryptsetup-%{version}.tar.bz2
9Patch: cryptsetup-luks-1.0.1-proto.patch
10Patch1: cryptsetup-1.0.5-readonly_detection.patch
11Patch3: cryptsetup-1.0.5-luksInit_header.patch
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13BuildRequires: libgcrypt-devel, popt, device-mapper-devel
14BuildRequires: libgpg-error-devel, e2fsprogs-devel
15#BuildRequires: recode
16Provides: cryptsetup-luks = %{version}-%{release}
17Obsoletes: cryptsetup-luks
18
19
20%description
21This package contains cryptsetup, a utility for setting up
22encrypted filesystems using Device Mapper and the dm-crypt target.
23
24
25%package devel
26Group: Development/Libraries
27Requires: %{name} = %{version}-%{release}
28Requires: libgcrypt-devel > 1.1.42, device-mapper-devel, e2fsprogs-devel
29Summary: Headers and libraries for using encrypted filesystems
30
31
32%description devel
33The cryptsetup-luks-devel package contain libraries and header files
34used for writing code that makes use of encrypted filesystems.
35
36
37%prep
38%setup -q -n cryptsetup-%{version}
39%patch -p1
40%patch3 -p1
41#recode latin1..utf-8 ChangeLog
42
43
44%build
45%configure --sbindir=/sbin --libdir=/%{_lib}
46make %{?_smp_mflags}
47
48
49%install
50rm -rf $RPM_BUILD_ROOT
51make install DESTDIR=$RPM_BUILD_ROOT
52rm -rf  $RPM_BUILD_ROOT/%{_lib}/*.la $RPM_BUILD_ROOT/%{_lib}/cryptsetup
53
54# move libcryptsetup.so to %{_libdir}
55pushd $RPM_BUILD_ROOT/%{_lib}
56rm libcryptsetup.so
57mkdir -p $RPM_BUILD_ROOT/%{_libdir}
58ln -s ../../%{_lib}/$(ls libcryptsetup.so.?.?.?) $RPM_BUILD_ROOT/%{_libdir}/libcryptsetup.so
59popd
60%find_lang cryptsetup
61
62
63%post -p /sbin/ldconfig
64
65
66%postun -p /sbin/ldconfig
67
68
69%files -f cryptsetup.lang
70%defattr(-,root,root,-)
71%doc COPYING ChangeLog AUTHORS TODO
72%{_mandir}/man8/cryptsetup.8.gz
73/sbin/cryptsetup
74/%{_lib}/libcryptsetup.so.*
75
76
77%files devel
78%defattr(-,root,root,-)
79%{_includedir}/libcryptsetup.h
80%{_libdir}/libcryptsetup.so
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84
85%changelog
86* Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.5-8vl5
87- applied new versioning policy
88
89* Sun Dec  9 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0.5-7vl1
90- initial build for VineSeed
91
92* Thu Aug 30 2007 Till Maas <opensource till name> - 1.0.5-7
93- update URL
94- update license tag
95- recode ChangeLog from latin1 to uf8
96- add smp_mflags to make
97
98* Fri Aug 24 2007 Till Maas <opensource till name> - 1.0.5-6
99- cleanup BuildRequires:
100- removed versions, packages in Fedora are new enough
101- changed popt to popt-devel
102
103* Thu Aug 23 2007 Till Maas <opensource till name> - 1.0.5-5
104- fix devel subpackage requires
105- remove empty NEWS README
106- remove uneeded INSTALL
107- remove uneeded ldconfig requires
108- add readonly detection patch
109
110* Wed Aug 08 2007 Till Maas <opensource till name> - 1.0.5-4
111- disable patch2, libsepol is now detected by configure
112- move libcryptsetup.so to %%{_libdir} instead of /%%{_lib}
113
114* Fri Jul 27 2007 Till Maas <opensource till name> - 1.0.5-3
115- Use /%%{_lib} instead of /lib to use /lib64 on 64bit archs
116
117* Thu Jul 26 2007 Till Maas <opensource till name> - 1.0.5-2
118- Use /lib as libdir (#243228)
119- sync header and library (#215349)
120- do not use %%makeinstall (recommended by PackageGuidelines)
121- select sbindir with %%configure instead with make
122- add TODO
123
124* Wed Jun 13 2007 Jeremy Katz <katzj@redhat.com> - 1.0.5-1
125- update to 1.0.5
126
127* Mon Jun 04 2007 Peter Jones <pjones@redhat.com> - 1.0.3-5
128- Don't build static any more.
129
130* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.3-4
131- Add build dependency on new device-mapper-devel package.
132- Add preun and post ldconfig requirements.
133- Update BuildRoot.
134
135* Wed Nov  1 2006 Peter Jones <pjones@redhat.com> - 1.0.3-3
136- Require newer libselinux (#213414)
137
138* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.3-2.1
139- rebuild
140
141* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 1.0.3-2
142- put shared libs in the right subpackages
143
144* Fri Apr  7 2006 Bill Nottingham <notting@redhat.com> 1.0.3-1
145- update to final 1.0.3
146
147* Wed Feb 27 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc2
148- update to 1.0.3rc2, fixes bug with HAL & encrypted devices (#182658)
149
150* Wed Feb 22 2006 Bill Nottingham <notting@redhat.com> 1.0.3-0.rc1
151- update to 1.0.3rc1, reverts changes to default encryption type
152
153* Tue Feb 21 2006 Bill Nottingham <notting@redhat.com> 1.0.2-1
154- update to 1.0.2, fix incompatiblity with old cryptsetup (#176726)
155
156* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 1.0.1-5
157- BuildRequires: libselinux-devel
158
159* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
160- bump again for double-long bug on ppc(64)
161
162* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
163- rebuilt for new gcc4.1 snapshot and glibc changes
164
165* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
166- rebuilt
167
168* Mon Dec  5 2005 Bill Nottingham <notting@redhat.com> 1.0.1-4
169- rebuild against new libdevmapper
170
171* Thu Oct 13 2005 Florian La Roche <laroche@redhat.com>
172- add -lsepol to rebuild on current fc5
173
174* Mon Aug 22 2005 Karel Zak <kzak@redhat.com> 1.0.1-2
175- fix cryptsetup help for isLuks action
176
177* Fri Jul  1 2005 Bill Nottingham <notting@redhat.com> 1.0.1-1
178- update to 1.0.1 - fixes incompatiblity with previous cryptsetup for
179  piped passwords
180
181* Thu Jun 16 2005 Bill Nottingham <notting@redhat.com> 1.0-2
182- add patch for 32/64 bit compatibility (#160445, <redhat@paukstadt.de>)
183
184* Tue Mar 29 2005 Bill Nottingham <notting@redhat.com> 1.0-1
185- update to 1.0
186
187* Thu Mar 10 2005 Bill Nottingham <notting@redhat.com> 0.993-1
188- switch to cryptsetup-luks, for LUKS support
189
190* Tue Oct 12 2004 Bill Nottingham <notting@redhat.com> 0.1-4
191- oops, make that *everything* static (#129926)
192
193* Tue Aug 31 2004 Bill Nottingham <notting@redhat.com> 0.1-3
194- link some things static, move to /sbin (#129926)
195
196* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
197- rebuilt
198
199* Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> 0.1-1
200- initial packaging
Note: See TracBrowser for help on using the repository browser.