source: projects/specs/branches/6/c/cppunit/cppunit-vl.spec @ 6309

Revision 6309, 4.0 KB checked in by inagaki, 12 years ago (diff)

update: PyQt?, cppunit, commoncpp2

Line 
1Name: cppunit
2Summary: C++ unit testing framework
3Summary(ja): C++ 単体テストフレームワーク
4Version: 1.12.1
5Release: 4%{?_dist_release}
6
7License: LGPL
8Group: Development/Tools
9URL: http://cppunit.sourceforge.net/
10
11Source: http://downloads.sourceforge.net/cppunit/cppunit-%{version}.tar.gz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: doxygen, graphviz
15
16%description
17CppUnit is the C++ port of the famous JUnit framework for unit testing.
18Test output is in XML for automatic testing and GUI based for supervised tests.
19
20%package devel
21Summary: Libraries and headers for cppunit development
22Summary(ja): cppunit 開発用ファイル
23Group: Development/Libraries
24Requires: pkgconfig, automake
25Requires: %{name} = %{version}-%{release}
26
27%description devel
28This package contains the libraries and headers necessary for developing
29programs that use cppunit.
30
31%package doc
32Summary: HTML formatted API documention for cppunit
33Summary(ja): cppunit の API ドキュメント (HTMLフォーマット)
34Group: Applications/Documentation
35Requires: %{name} = %{version}-%{release}
36
37%description doc
38The cppunit-doc package contains HTML formatted API documention generated by
39the popular doxygen documentation generation tool.
40
41
42%prep
43%setup -q
44
45%build
46%configure --enable-doxygen --disable-static
47make %{?_smp_mflags}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51make install DESTDIR=$RPM_BUILD_ROOT
52rm $RPM_BUILD_ROOT%{_libdir}/*.la
53# remove double of doc
54rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/cppunit
55
56# clean up examples
57rm -rf dist-examples dist-examples-dir
58cp -a examples dist-examples
59make -C dist-examples distclean
60# Makefile.am files are left as documentation
61find dist-examples \( -name Makefile.in -o -name .cvsignore \) -exec rm {} \;
62mkdir dist-examples-dir
63mv dist-examples dist-examples-dir/examples
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%post -p /sbin/ldconfig
69
70%postun -p /sbin/ldconfig
71
72%files
73%defattr(-,root,root,-)
74%doc AUTHORS COPYING NEWS README THANKS ChangeLog TODO BUGS doc/FAQ
75%{_bindir}/DllPlugInTester
76%{_libdir}/libcppunit*.so.*
77
78%files devel
79%defattr(-,root,root,-)
80%{_bindir}/cppunit-config
81%{_includedir}/cppunit
82%{_libdir}/libcppunit.so
83%{_datadir}/aclocal/cppunit.m4
84%{_mandir}/man1/cppunit-config.1*
85%{_libdir}/pkgconfig/cppunit.pc
86
87%files doc
88%defattr(-,root,root,-)
89%doc dist-examples-dir/examples/
90%doc doc/html/
91
92%changelog
93* Sat Jun  9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-4
94- rebuilt with rpm-4.8.1-3
95
96* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 1.12.1-3
97- rebuilt with rpm-4.8.1 for pkg-config
98
99* Tue Mar 23 2010 Shu KONNO <owa@bg.wakwak.com> 1.12.1-2
100- built with new toolchain
101- changed source url
102
103* Sat Nov  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.1-1
104- new upstream release
105- applied new versioning policy
106- spec in UTF-8
107
108* Tue Jul 31 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.0-3vl3
109- rebuilt fot VineSeed
110
111* Tue Jul 31 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.12.0-3vl2
112- changed Group to Development/Tools
113- changed doc Group to Applications/Documentation
114- rebuilt fot VinePlus/4.0
115
116* Thu May 31 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.12.0-3vl1
117- updated to 1.12.0 release based on FC package
118
119  - Fri Aug  1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.8.0-0vl2
120  - Rebuild for new Vine.
121
122  - Mon Jun 23 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 1.8.0-0vl1
123  - Initial build.
124
125
126* Mon Jan 29 2007 Patrice Dumas <pertusus@free.fr> 1.12.0-3
127- add rightly files to -devel (#224106)
128- add necessary requires for -devel (#224106)
129- ship examples
130
131* Sun Sep 10 2006 Patrice Dumas <pertusus@free.fr> 1.12.0-2
132- rebuild for FC6
133
134* Wed Jul  5 2006 Patrice Dumas <pertusus@free.fr> 1.12.0-1
135- update to 1.12
136
137* Sun May 21 2006 Patrice Dumas <pertusus@free.fr> 1.11.6-1
138- update to 1.11.6
139
140* Wed Dec 21 2005 Patrice Dumas <pertusus@free.fr> 1.11.4-1
141- update
142
143* Mon Aug 15 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.11.0-2
144- various cleanups
145
146* Mon Jul  4 2005 Patrice Dumas <pertusus@free.fr> 1.11.0-1
147- update using the fedora template
148 
149* Sat Apr 14 2001 Bastiaan Bakker <bastiaan.bakker@lifeline.nl>
150- Initial release
Note: See TracBrowser for help on using the repository browser.