source: projects/specs/branches/6/c/courier-authlib/courier-authlib-vl.spec @ 3282

Revision 3282, 7.9 KB checked in by tomop, 13 years ago (diff)

courier-authlib-0.63.0-2

Line 
1Summary: Courier authentication library.
2Summary(ja): Courier 認証ライブラリ
3Name: courier-authlib
4Version: 0.63.0
5Release: 2%{?_dist_release}
6License: GPL
7Group: System Environment/Daemons
8URL: http://www.courier-mta.org
9Source0: %{name}-%{version}.tar.bz2
10Patch: %{name}-apop.patch
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: libtool
13BuildRequires: openldap-devel
14BuildRequires: MySQL-devel zlib-devel
15BuildRequires: postgresql-devel
16BuildRequires: gdbm-devel
17BuildRequires: pam-devel
18BuildRequires: expect
19
20Requires(post): /sbin/chkconfig
21Requires(preun): /sbin/chkconfig
22
23Vendor: Project Vine
24Distribution: Vine Linux
25Packager: tomop
26
27%description
28The Courier authentication library provides authentication services for
29other Courier applications.
30
31%description -l ja
32Courier 認証ライブラリは他の Courier アプリケーションへ認証サービスを
33提供します。
34
35
36%package devel
37Summary: Development libraries for the Courier authentication library.
38Summary(ja): Courier 認証ライブラリの開発ライブラリ
39Group: Development/Libraries
40Requires: courier-authlib = %{version}-%{release}
41
42%description devel
43This package contains the development libraries and files needed to compile
44Courier packages that use this authentication library.  Install this
45package in order to build the rest of the Courier packages.  After they are
46built and installed this package can be removed.  Files in this package
47are not needed at runtime.
48
49%description -l ja devel
50認証ライブラリを必要とする Courier パッケージのコンパイルに必要な開発
51ライブラリです。他の Courier パッケージを作成するならインストールして
52ください。作成したパッケージのインストール後は不要ですので削除しても構
53いません。このパッケージに含まれるファイルは実行時には必要ありません。
54
55
56%package ldap
57Summary: LDAP support for the Courier authentication library.
58Summary(ja): Courier 認証ライブラリの LDAP サポート
59Group: System Environment/Daemons
60Requires: courier-authlib = %{version}-%{release}
61Requires: openldap
62
63%description ldap
64This package installs LDAP support for the Courier authentication library.
65Install this package in order to be able to authenticate using LDAP.
66
67%description -l ja ldap
68Courier 認証ライブラリの LDAP サポートパッケージです。LDAP を使った認証を
69行なう場合にインストールしてください。
70
71
72%package pgsql
73Summary: PostgreSQL support for the Courier authentication library.
74Summary(ja): Courier 認証ライブラリの PostgreSQL サポート
75Group: System Environment/Daemons
76Requires: courier-authlib = %{version}-%{release}
77Requires: postgresql-libs, postgresql
78
79%description pgsql
80This package installs PostgreSQL support for the Courier authentication
81library.
82Install this package in order to be able to authenticate using PostgreSQL.
83
84%description -l ja pgsql
85Courier 認証ライブラリの PostgreSQL サポートパッケージです。PostgreSQL を
86使った認証を行なう場合にインストールしてください。
87
88
89%package mysql
90Summary: MySQL support for the Courier authentication library.
91Summary(ja): Courier 認証ライブラリの MySQL サポート
92Group: System Environment/Daemons
93Requires: courier-authlib = %{version}-%{release}
94
95%description mysql
96This package installs MySQL support for the Courier authentication library.
97Install this package in order to be able to authenticate using MySQL.
98
99%description -l ja mysql
100Courier 認証ライブラリの MySQL サポートパッケージです。MySQL を使った認証を
101行なう場合にインストールしてください。
102
103%prep
104%setup -q
105%patch -p1 -b .orig
106
107%build
108#%configure --without-authldap --without-authpgsql
109%configure
110make
111
112%install
113rm -rf %{buildroot}
114make install DESTDIR=%{buildroot}
115rm -f %{buildroot}/%{_libdir}/%{name}/*.a
116install -m 555 sysconftool %{buildroot}/%{_libexecdir}/%{name}
117install -m 555 authmigrate %{buildroot}/%{_libexecdir}/%{name}
118
119#./courierauthconfig --configfiles >configtmp
120#. configtmp
121
122./authmksock %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
123touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid.lock || exit 1
124touch %{buildroot}/%{_localstatedir}/spool/authdaemon/pid || exit 1
125chmod 777 %{buildroot}/%{_localstatedir}/spool/authdaemon/socket || exit 1
126
127mkdir -p %{buildroot}/%{_initdir}
128install -m 555 courier-authlib.sysvinit %{buildroot}/%{_initdir}/courier-authlib
129
130%post
131%{_libexecdir}/%{name}/authmigrate >/dev/null
132%{_libexecdir}/%{name}/sysconftool %{_sysconfdir}/authlib/*.dist >/dev/null
133
134/sbin/chkconfig --del courier-authlib
135/sbin/chkconfig --add courier-authlib
136
137%preun
138if test -x %{_sbindir}/authdaemond
139then
140        %{_sbindir}/authdaemond >/dev/null 2>&1 || /bin/true
141fi
142
143if test "$1" = "0"
144then
145        /sbin/chkconfig --del courier-authlib
146fi
147
148%clean
149rm -rf %{buildroot}
150
151%files
152%defattr(-,root,root)
153%doc README README*html README.authmysql.myownquery README.ldap
154%doc NEWS COPYING* AUTHORS ChangeLog authldap.schema
155%doc README.apop
156/etc/rc.d/init.d/*
157%ghost %attr(600,root,root) %{_localstatedir}/spool/authdaemon/pid.lock
158%ghost %attr(644,root,root) %{_localstatedir}/spool/authdaemon/pid
159%ghost %attr(-,root,root) %{_localstatedir}/spool/authdaemon/socket
160%{_mandir}/man1/*
161%{_mandir}/man8/*
162%defattr(-,daemon,daemon)
163%dir %{_sysconfdir}/authlib
164%{_sysconfdir}/authlib/authdaemonrc.dist
165%{_libexecdir}/%{name}
166%dir %{_libdir}/%{name}
167%{_libdir}/%{name}/libauthcustom*
168%{_libdir}/%{name}/libauthpam*
169%{_libdir}/%{name}/libauthpipe*
170%{_libdir}/%{name}/libauthuser*
171%{_libdir}/%{name}/libcourierauth*
172%dir %attr(750,daemon,daemon) %{_localstatedir}/spool/authdaemon
173%{_sbindir}/*
174
175%files devel
176%defattr(-,root,root)
177%{_bindir}/courierauthconfig
178%{_includedir}/*
179%{_mandir}/man3/*
180%doc authlib.html auth_*.html
181
182%files ldap
183%defattr(-,root,root)
184%{_sysconfdir}/authlib/authldaprc.dist
185%{_libdir}/%{name}/libauthldap*
186
187%files pgsql
188%defattr(-,root,root)
189%{_sysconfdir}/authlib/authpgsqlrc.dist
190%{_libdir}/%{name}/libauthpgsql*
191
192%files mysql
193%defattr(-,root,root)
194%{_sysconfdir}/authlib/authmysqlrc.dist
195%{_libdir}/%{name}/libauthmysql*
196
197
198%changelog
199* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-2
200- Rebuilt with new toolchain.
201
202* Sun Feb 07 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.63.0-1
203- new upstream release.
204- replaced "BuildPreReq:" with "BuilldRequires:".
205
206* Sun Nov 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.62.4-1
207- new upstream release.
208- removed "Requires: MySQL-shared".
209- updated APOP patch.
210
211* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.59.3-2
212- rebuilt with MySQL-shared-5.1.34.
213
214* Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-1vl5
215- applied new versioning policy, and spec in utf-8
216- rebuilt with postgresql-8.3.3
217
218* Sun Jan 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl3
219- rebuilt
220
221* Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.59.3-0vl2
222- rebuilt with postgresql-8.2.6
223
224* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.59.3-0vl1
225- new upstream release
226- rebuilt with postgresql 8.2.5
227
228* Sat Nov 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.56-0vl4
229- rebuilt with MySQL 5.0.27
230- included /usr/lib/courier-authlib/libauthpipe.*
231
232* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.56-0vl3
233- rebuilt with openldap-2.3.27-0vl1
234
235* Sun May 22 2005 UECHI Yasumasa <uechi@potaway.net> 0.56-0vl2
236- new upstream release
237
238* Mon Mar 28 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl4
239- add ldap, postgresql, mysql packages
240
241* Thu Mar 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.55-0vl1
242- new upstream release
243
244* Thu Feb 17 2005 UECHI Yasumasa <uechi@potaway.net> 0.54-0vl1
245- new upstream release
246
247* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.53-0vl1
248- new upstream release
249
250* Wed Jan 12 2005 UECHI Yasumasa <uechi@potaway.net> 0.52-0vl1
251- simplify a spec for Vine
252- add apop patch
253
254* Sun Oct  3 2004 Mr. Sam <sam@email-scan.com> - 0.50-1
255- Initial build.
Note: See TracBrowser for help on using the repository browser.