source: projects/specs/branches/6/c/coreutils/coreutils-vl.spec @ 7503

Revision 7503, 25.4 KB checked in by iwamoto, 11 years ago (diff)

coreutils: add security patch

Line 
1Summary: The GNU core utilities: a set of tools commonly used in shell scripts
2Summary(ja): GNU コアユーティリティ: シェルスクリプトで用いるツール集
3Name:    coreutils
4Version: 8.10
5Release: 3%{?_dist_release}
6License: GPL
7Group:   System Environment/Base
8Url:     http://www.gnu.org/software/coreutils/
9
10Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
11Source101:  coreutils-DIR_COLORS
12Source102:  coreutils-DIR_COLORS.xterm
13Source103:  coreutils-DIR_COLORS.256color
14Source105:  coreutils-colorls.sh
15Source106:  coreutils-colorls.csh
16Source200:  coreutils-su.pamd
17Source201:  coreutils-runuser.pamd
18Source202:  coreutils-su-l.pamd
19Source203:  coreutils-runuser-l.pamd
20
21# Vine sources
22Source1000: coreutils-8.10-ja.po
23
24# From upstream
25
26# Fedora patches
27#general patch to workaround koji build system issues
28Patch100: coreutils-6.10-configuration.patch
29#add note about no difference between binary/text mode on Linux - md5sum manpage
30Patch101: coreutils-6.10-manpages.patch
31#temporarily workaround probable kernel issue with TCSADRAIN(#504798)
32Patch102: coreutils-7.4-sttytcsadrain.patch
33#do display processor type for uname -p/-i based on uname(2) syscall
34Patch103: coreutils-8.2-uname-processortype.patch
35#df --direct
36Patch104: coreutils-df-direct.patch
37#add jar-like archives to colored ones
38Patch106: coreutils-8.5-dircolors.patch
39
40# sh-utils
41#Patch703: sh-utils-2.0.11-dateman.patch
42Patch704: sh-utils-1.16-paths.patch
43# RMS will never accept the PAM patch because it removes his historical
44# rant about Twenex and the wheel group, so we'll continue to maintain
45# it here indefinitely.
46Patch706: coreutils-8.5-pam.patch
47Patch713: coreutils-4.5.3-langinfo.patch
48
49# (sb) lin18nux/lsb compliance
50Patch800: coreutils-8.10-i18n.patch
51
52#Call setsid() in su under some circumstances (bug #173008).
53Patch900: coreutils-setsid.patch
54#make runuser binary based on su.c
55Patch907: coreutils-8.7-runuser.patch
56#getgrouplist() patch from Ulrich Drepper.
57Patch908: coreutils-getgrouplist.patch
58#Prevent buffer overflow in who(1) (bug #158405).
59Patch912: coreutils-overflow.patch
60#compile su with pie flag and RELRO protection
61Patch917: coreutils-8.4-su-pie.patch
62
63#security fix
64Patch1000: coreutils-8.10_CVE-2013-0221_2_3.patch
65
66BuildRoot: %{_tmppath}/%{name}-%{version}-root
67BuildRequires:  gettext libtermcap-devel bison
68%{?!nopam:BuildRequires: pam-devel}
69BuildRequires: texinfo >= 4.3
70BuildRequires: autoconf >= 2.58, automake >= 1.10
71%{?!nopam:Requires: pam >= 0.66-12}
72BuildRequires: libcap-devel
73BuildRequires: libattr-devel
74BuildRequires: libacl-devel
75BuildRequires: gmp-devel
76
77Requires(pre):         install-info
78Requires(preun):      install-info
79Requires(post):        install-info, grep, findutils
80
81# Require a C library that doesn't put LC_TIME files in our way.
82Conflicts: glibc < 2.2
83
84Provides:       fileutils = %version, sh-utils = %version, stat, textutils = %version
85Obsoletes:      fileutils sh-utils stat textutils
86Provides:       mktemp = %version
87Obsoletes:      mktemp
88
89Vendor: Project Vine
90Distribution: Vine Linux
91
92%description
93These are the GNU core utilities.  This package is the combination of
94the old GNU fileutils, sh-utils, and textutils packages.
95
96%description -l ja
97このパッケージには GNU のコアユーティリティが収録されています。
98コアユーティリティ(coreutilsパッケージ)は従来の fileutils,
99sh-utils, textutils を統合したパッケージです。
100
101
102%prep
103%setup -q
104
105# From upstream
106
107
108# Fedora patches
109%patch100 -p1 -b .chgrp
110%patch101 -p1 -b .manpages
111%patch102 -p1 -b .tcsadrain
112%patch103 -p1 -b .sysinfo
113%patch104 -p1 -b .dfdirect
114%patch106 -p1 -b .java
115
116# sh-utils
117#%patch703 -p1 -b .dateman
118%patch704 -p1 -b .paths
119%patch706 -p1 -b .pam
120%patch713 -p1 -b .langinfo
121
122# li18nux/lsb
123%patch800 -p1 -b .i18n
124
125# Coreutils
126%patch900 -p1 -b .setsid
127%patch907 -p1 -b .runuser
128%patch908 -p1 -b .getgrouplist
129%patch912 -p1 -b .overflow
130%patch917 -p1 -b .pie
131
132# security fixes
133%patch1000 -p1 -b .CVE-2013-0221_2_3
134
135# copy updated ja.po
136mv po/ja.po po/ja.po.orig
137cp -f %{SOURCE1000} po/ja.po
138
139%build
140export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fpic"
141%{expand:%%global optflags %{optflags} -D_GNU_SOURCE=1}
142touch aclocal.m4 configure config.hin Makefile.in */Makefile.in
143aclocal -I m4
144autoconf --force
145automake --copy --force --add-missing
146%configure --enable-largefile --with-afs %{?!nopam:--enable-pam} \
147           --enable-install-program=su,hostname,arch \
148           --with-tty-group \
149           DEFAULT_POSIX2_VERSION=200112 alternative=199209 || :
150
151touch man/*.x
152
153%__make all %{?_smp_mflags} \
154        %{?!nopam:CPPFLAGS="-DUSE_PAM"} \
155        su_LDFLAGS="-pie %{?!nopam:-lpam -lpam_misc}"
156
157%__make -C po update-gmo
158
159[[ -f ChangeLog && -f ChangeLog.bz2  ]] || bzip2 -9f ChangeLog
160
161# XXX docs should say /var/run/[uw]tmp not /etc/[uw]tmp
162perl -pi -e 's,/etc/utmp,/var/run/utmp,g;s,/etc/wtmp,/var/run/wtmp,g' doc/coreutils.texi
163
164
165%install
166rm -rf $RPM_BUILD_ROOT
167%makeinstall
168
169# man pages are not installed with make install
170%__make mandir=$RPM_BUILD_ROOT%{_mandir} install-man
171
172# fix japanese catalog file
173if [ -d $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC/LC_MESSAGES ]; then
174   mkdir -p $RPM_BUILD_ROOT/%{_datadir}/locale/ja/LC_MESSAGES
175   mv $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC/LC_MESSAGES/*mo \
176                $RPM_BUILD_ROOT/%{_datadir}/locale/ja/LC_MESSAGES
177   rm -rf $RPM_BUILD_ROOT/%{_datadir}/locale/ja_JP.EUC
178fi
179
180# let be compatible with old fileutils, sh-utils and textutils packages :
181mkdir -p $RPM_BUILD_ROOT{/bin,%_bindir,%_sbindir,/sbin}
182%{?!nopam:mkdir -p $RPM_BUILD_ROOT%_sysconfdir/pam.d}
183for f in basename cat chgrp chmod chown cp cut date dd df echo env false \
184         link ln ls mkdir mknod mktemp mv nice pwd rm rmdir sleep sort \
185         stty sync touch true uname unlink
186do
187        mv $RPM_BUILD_ROOT/{%_bindir,bin}/$f
188done
189
190# chroot was in /usr/sbin :
191mv $RPM_BUILD_ROOT/{%_bindir,%_sbindir}/chroot
192# {cat,sort,cut} were previously moved from bin to /usr/bin and linked into
193for i in env cut; do ln -sf ../../bin/$i $RPM_BUILD_ROOT/usr/bin; done
194
195mkdir -p $RPM_BUILD_ROOT/etc/profile.d
196install -p -c -m644 %SOURCE101 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS
197install -p -c -m644 %SOURCE102 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.lightbgcolor
198install -p -c -m644 %SOURCE103 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.256color
199install -p -c -m644 %SOURCE105 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.sh
200install -p -c -m644 %SOURCE106 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.csh
201
202# su
203install -m 4755 src/su $RPM_BUILD_ROOT/bin
204install -m 755 src/runuser $RPM_BUILD_ROOT/sbin
205
206# These come from util-linux and/or procps.
207for i in hostname uptime kill ; do
208        rm -f $RPM_BUILD_ROOT{%_bindir/$i,%_mandir/man1/$i.1}
209done
210
211%{?!nopam:install -p -m 644 %SOURCE200 $RPM_BUILD_ROOT%_sysconfdir/pam.d/su}
212%{?!nopam:install -p -m 644 %SOURCE202 $RPM_BUILD_ROOT%_sysconfdir/pam.d/su-l}
213%{?!nopam:install -p -m 644 %SOURCE201 $RPM_BUILD_ROOT%_sysconfdir/pam.d/runuser}
214%{?!nopam:install -p -m 644 %SOURCE203 $RPM_BUILD_ROOT%_sysconfdir/pam.d/runuser-l}
215
216bzip2 -f9 old/*/C* || :
217
218%find_lang %name
219
220# (sb) Deal with Installed (but unpackaged) file(s) found
221rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
222
223# FIXME: remove readlink which conflict with tetex's.
224#rm -f $RPM_BUILD_ROOT%{_bindir}/readlink
225#rm -f $RPM_BUILD_ROOT%{_mandir}/man1/readlink*
226
227
228%clean
229rm -rf $RPM_BUILD_ROOT
230
231%pre
232# Remove these old glibc files on upgrade (bug #84090).
233for file in $(find /usr/share/locale -type f -name LC_TIME); do
234        [ -x /bin/rm ] && /bin/rm -f "$file"
235done
236
237# We must desinstall theses info files since they're merged in
238# coreutils.info. else their postun'll be runned too last
239# and install-info'll faill badly because of doubles
240for file in sh-utils.info textutils.info fileutils.info; do
241        if [ -f /usr/share/info/$file.bz2 ]; then
242                /sbin/install-info /usr/share/info/$file.bz2 --dir=/usr/share/info/dir --remove &> /dev/null
243        fi
244done
245
246%preun
247if [ $1 = 0 ]; then
248    [ -f %{_infodir}/%{name}.info.gz ] && \
249      /sbin/install-info --delete %{_infodir}/%{name}.info.gz \
250        %{_infodir}/dir || :
251fi
252
253%post
254/bin/grep -v '(sh-utils)\|(fileutils)\|(textutils)' %{_infodir}/dir > \
255  %{_infodir}/dir.rpmmodify || exit 0
256    /bin/mv -f %{_infodir}/dir.rpmmodify %{_infodir}/dir
257[ -f %{_infodir}/%{name}.info.gz ] && \
258  /sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
259
260%files -f %{name}.lang
261%defattr(-,root,root)
262%config(noreplace) %{_sysconfdir}/DIR_COLORS*
263%config(noreplace) %{_sysconfdir}/profile.d/*
264%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/su}
265%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/su-l}
266%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/runuser}
267%{?!nopam:%config(noreplace) %{_sysconfdir}/pam.d/runuser-l}
268%doc COPYING ABOUT-NLS ChangeLog.bz2 NEWS README THANKS TODO old/*
269/bin/*
270%{_bindir}/*
271%{_libdir}/coreutils
272%{_infodir}/coreutils*
273%{_mandir}/man*/*
274%{_sbindir}/chroot
275/sbin/runuser
276
277%changelog
278* Wed Feb 20 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.10-3
279- add patch1000 for fix CVE-2013-0221,22,23 (join, uniq, sort)
280- add Vendor/Distri Tags
281
282* Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-2
283- update ja.po
284- add BR: libcap-devel, gmp-devel, libattr-devel, libacl-devel
285
286* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-1
287- update to 8.10
288
289* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.11-2
290- rebuilt against curent toolchain
291- spec in UTF-8
292
293* Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 6.11-1
294- new upstream release
295- drop obsolete patches
296- import some patched from fedora-devel
297- add Obsoletes/Provides mktemp
298
299* Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.96-0vl1
300- new upstream release
301
302* Mon May 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.95-0vl1
303- new upstream release
304
305* Thu May 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.94-0vl1
306- new upstream release
307- drop opsolete patches
308- import some patches from FC
309
310* Sun Nov 13 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-40vl5
311- now readlink is kept as it is, since tetex-3.0 don't have readlink.
312
313* Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2.1-40vl4
314- updated ja.po
315
316* Sat Feb 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl3
317- remove selinux related pam-module from /etc/pam.d/su
318
319* Fri Feb 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl2
320- update ja.po
321
322* Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl1
323- initial build for Vine Linux
324  - some modifications are merged from fileutils-4.1-10.1vl4
325- disable make check
326
327* Sat Feb  5 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-40
328- Undo last change (bug #145266).
329
330* Fri Feb  4 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-38
331- Special case for ia32e in uname (bug #145266).
332
333* Thu Jan 13 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-37
334- Fixed zh_CN translation (bug #144845).  Patch from Mitrophan Chin.
335
336* Mon Dec 28 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-36
337- Fix to only setdefaultfilecon if not overridden by command line
338
339* Mon Dec 27 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-35
340- Change install to restorecon if it can
341
342* Wed Dec 15 2004 Tim Waugh <twaugh@redhat.com>
343- Fixed small bug in i18n patch.
344
345* Mon Dec  6 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-34
346- Don't set fs uid until after pam_open_session (bug #77791).
347
348* Thu Nov 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-33
349- Fixed colorls.csh (bug #139988).  Patch from Miloslav Trmac.
350
351* Mon Nov  8 2004 Tim Waugh <twaugh@redhat.com>
352- Updated URL (bug #138279).
353
354* Mon Oct 25 2004 Steve Grubb <sgrubb@redhat.com> 5.2.1-32
355- Handle the return code of function calls in runcon.
356
357* Mon Oct 18 2004 Tim Waugh <twaugh@redhat.com>
358- Prevent compiler warning in coreutils-i18n.patch (bug #136090).
359
360* Tue Oct  5 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-31
361- getgrouplist() patch from Ulrich Drepper.
362- The selinux patch should be applied last.
363
364* Mon Oct  4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-30
365- Mv runuser to /sbin
366
367* Mon Oct  4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-28
368- Fix runuser man page.
369
370* Mon Oct  4 2004 Tim Waugh <twaugh@redhat.com>
371- Fixed build.
372
373* Fri Sep 24 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-26
374- Add runuser as similar to su, but only runable by root
375
376* Fri Sep 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-25
377- chown(1) patch from Ulrich Drepper.
378
379* Tue Sep 14 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-24
380- SELinux patch fix: don't display '(null)' if getfilecon() fails
381  (bug #131196).
382
383* Fri Aug 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-23
384- Fixed colorls.csh quoting (bug #102412).
385- Fixed another join LSB test failure (bug #121153).
386
387* Mon Aug 16 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-22
388- Fixed sort -t LSB test failure (bug #121154).
389- Fixed join LSB test failure (bug #121153).
390
391* Wed Aug 11 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-21
392- Apply upstream patch to fix 'cp -a' onto multiply-linked files (bug #128874).
393- SELinux patch fix: don't error out if lgetfilecon() returns ENODATA.
394
395* Tue Aug 10 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-20
396- Added 'konsole' TERM to DIR_COLORS (bug #129544).
397
398* Wed Aug  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-19
399- Added 'gnome' TERM to DIR_COLORS (bug #129112).
400- Worked around a bash bug #129128.
401- Fixed an i18n patch bug in cut (bug #129114).
402
403* Tue Aug  3 2004 Tim Waugh <twaugh@redhat.com>
404- Fixed colorls.{sh,csh} so that the l. and ll aliases are always defined
405  (bug #128948).
406
407* Tue Jul 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-18
408- Fixed field extraction in sort (bug #127694).
409
410* Fri Jun 25 2004 Tim Waugh <twaugh@redhat.com>
411- Added 'TERM screen.linux' to DIR_COLORS (bug #78816).
412
413* Wed Jun 23 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-17
414- Move pam-xauth to after pam-selinux
415
416* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
417- rebuilt
418
419* Mon Jun  7 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-15
420- Fix ls -Z (bug #125447).
421
422* Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com>
423- Build requires bison (bug #125290).
424
425* Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-14
426- Fix selinux patch causing problems with ls --format=... (bug #125238).
427
428* Thu Jun 3 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-13
429- Change su to use pam_selinux open and pam_selinux close
430
431* Wed Jun  2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-12
432- Don't call access() on symlinks about to be removed (bug #124699).
433
434* Wed Jun  2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-11
435- Fix ja translation (bug #124862).
436
437* Tue May 18 2004 Jeremy Katz <katzj@redhat.com> 5.2.1-10
438- rebuild
439
440* Mon May 17 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-9
441- Mention pam in the info for su (bug #122592).
442- Remove wheel group rant again (bug #122886).
443- Change default behaviour for chgrp/chown (bug #123263).  Patch from
444  upstream.
445
446* Mon May 17 2004 Thomas Woerner <twoerner@redhat.com> 5.2.1-8
447- compiling su PIE
448
449* Wed May 12 2004 Tim Waugh <twaugh@redhat.com>
450- Build requires new versions of autoconf and automake (bug #123098).
451
452* Tue May  4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-7
453- Fix join -t (bug #122435).
454
455* Tue Apr 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-6
456- Fix 'ls -Z' displaying users/groups if stat() failed (bug #121292).
457
458* Fri Apr 9 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-5
459- Add ls -LZ fix
460- Fix chcon to handle "."
461
462* Wed Mar 17 2004 Tim Waugh <twaugh@redhat.com>
463- Apply upstream fix for non-zero seconds for --date="10:00 +0100".
464
465* Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-3
466- If preserve fails, report as warning unless user requires preserve
467
468* Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-2
469- Make mv default to preserve on context
470
471* Sat Mar 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-1
472- 5.2.1.
473
474* Fri Mar 12 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-9
475- Add '-Z' to 'ls --help' output (bug #118108).
476
477* Fri Mar  5 2004 Tim Waugh <twaugh@redhat.com>
478- Fix deref-args test case for rebuilding under SELinux (bug #117556).
479
480* Wed Feb 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-8
481- kill(1) offloaded to util-linux altogether.
482
483* Tue Feb 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-7
484- Ship the real '[', not a symlink.
485
486* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-6
487- Apply Paul Eggert's chown patch (bug #116536).
488- Merged chdir patch into pam patch where it belongs.
489
490* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-5
491- Fixed i18n patch bug causing sort -M not to work (bug #116575).
492
493* Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-4
494- Reinstate kill binary, just not its man page (bug #116463).
495
496* Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-3
497- Updated ls-stat patch.
498
499* Fri Feb 20 2004 Dan Walsh <dwalsh@redhat.com> 5.2.0-2
500- fix chcon to ignore . and .. directories for recursing
501
502* Fri Feb 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-1
503- Patch ls so that failed stat() is handled gracefully (Ulrich Drepper).
504- 5.2.0.
505
506* Thu Feb 19 2004 Tim Waugh <twaugh@redhat.com>
507- More AFS patch tidying.
508
509* Wed Feb 18 2004 Dan Walsh <dwalsh@redhat.com> 5.1.3-0.2
510- fix chcon to handle -h qualifier properly, eliminate potential crash
511
512* Wed Feb 18 2004 Tim Waugh <twaugh@redhat.com>
513- Stop 'sort -g' leaking memory (i18n patch bug #115620).
514- Don't ship kill, since util-linux already does.
515- Tidy AFS patch.
516
517* Mon Feb 16 2004 Tim Waugh <twaugh@redhat.com> 5.1.3-0.1
518- 5.1.3.
519- Patches ported forward or removed.
520
521* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 5.0-40
522- rebuilt
523
524* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-39
525- Change /etc/pam.d/su to remove preservuser and add multiple
526
527* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-38
528- Change is_selinux_enabled to is_selinux_enabled > 0
529
530* Tue Jan  20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-37
531- Add pam_selinux to pam file to allow switching of roles within selinux
532
533* Fri Jan 16 2004 Tim Waugh <twaugh@redhat.com>
534- The textutils-2.0.17-mem.patch is no longer needed.
535
536* Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 5.0-36
537- Fixed autoconf test causing builds to fail.
538
539* Tue Dec  9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-35
540- Fix copying to non xattr files
541
542* Thu Dec  4 2003 Tim Waugh <twaugh@redhat.com> 5.0-34.sel
543- Fix column widths problems in ls.
544
545* Tue Dec  2 2003 Tim Waugh <twaugh@redhat.com> 5.0-33.sel
546- Speed up md5sum by disabling speed-up asm.
547
548* Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-32.sel
549- Try again
550
551* Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-31.sel
552- Fix move on non SELinux kernels
553
554* Fri Nov 14 2003 Tim Waugh <twaugh@redhat.com> 5.0-30.sel
555- Fixed useless acl dependencies (bug #106141).
556
557* Fri Oct 24 2003 Dan Walsh <dwalsh@redhat.com> 5.0-29.sel
558- Fix id -Z
559
560* Tue Oct 21 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28.sel
561- Turn on SELinux
562- Fix chcon error handling
563
564* Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28
565- Turn off SELinux
566
567* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27.sel
568- Turn on SELinux
569
570* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27
571- Turn off SELinux
572
573* Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-26.sel
574- Turn on SELinux
575
576* Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
577- allow compiling without pam support
578
579* Fri Oct 10 2003 Tim Waugh <twaugh@redhat.com> 5.0-23
580- Make split(1) handle large files (bug #106700).
581
582* Thu Oct  9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-22
583- Turn off SELinux
584
585* Wed Oct  8 2003 Dan Walsh <dwalsh@redhat.com> 5.0-21.sel
586- Cleanup SELinux patch
587
588* Fri Oct  3 2003 Tim Waugh <twaugh@redhat.com> 5.0-20
589- Restrict ACL support to only those programs needing it (bug #106141).
590- Fix default PATH for LSB (bug #102567).
591
592* Thu Sep 11 2003 Dan Walsh <dwalsh@redhat.com> 5.0-19
593- Turn off SELinux
594
595* Wed Sep 10 2003 Dan Walsh <dwalsh@redhat.com> 5.0-18.sel
596- Turn on SELinux
597
598* Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 5.0-17
599- Turn off SELinux
600
601* Tue Sep 2 2003 Dan Walsh <dwalsh@redhat.com> 5.0-16.sel
602- Only call getfilecon if the user requested it.
603- build with selinux
604
605* Wed Aug 20 2003 Tim Waugh <twaugh@redhat.com> 5.0-14
606- Documentation fix (bug #102697).
607
608* Tue Aug 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-13
609- Made su use pam again (oops).
610- Fixed another i18n bug causing sort --month-sort to fail.
611- Don't run dubious stty test, since it fails when backgrounded
612  (bug #102033).
613- Re-enable make check.
614
615* Fri Aug  8 2003 Tim Waugh <twaugh@redhat.com> 5.0-12
616- Don't run 'make check' for this build (build environment problem).
617- Another uninitialized variable in i18n (from bug #98683).
618
619* Wed Aug 6 2003 Dan Walsh <dwalsh@redhat.com> 5.0-11
620- Internationalize runcon
621- Update latest chcon from NSA
622
623* Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com>
624- Re-enable make check.
625
626* Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-9
627- Don't run 'make check' for this build (build environment problem).
628
629* Mon Jul 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-8
630- Actually use the ACL patch (bug #100519).
631
632* Wed Jul 18 2003 Dan Walsh <dwalsh@redhat.com> 5.0-7
633- Convert to SELinux
634
635* Mon Jun  9 2003 Tim Waugh <twaugh@redhat.com>
636- Removed samefile patch.  Now the test suite passes.
637
638* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
639- rebuilt
640
641* Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-5
642- Both kon and kterm support colours (bug #83701).
643- Fix 'ls -l' alignment in zh_CN locale (bug #88346).
644
645* Mon May 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-4
646- Prevent file descriptor leakage in du (bug #90563).
647- Build requires recent texinfo (bug #90439).
648
649* Wed Apr 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-3
650- Allow obsolete options unless POSIXLY_CORRECT is set.
651
652* Sat Apr 12 2003 Tim Waugh <twaugh@redhat.com>
653- Fold bug was introduced by i18n patch; fixed there instead.
654
655* Fri Apr 11 2003 Matt Wilson <msw@redhat.com> 5.0-2
656- fix segfault in fold (#88683)
657
658* Sat Apr  5 2003 Tim Waugh <twaugh@redhat.com> 5.0-1
659- 5.0.
660
661* Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com>
662- Use _smp_mflags.
663
664* Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-2
665- Remove overwrite patch.
666- No longer seem to need nolibrt, errno patches.
667
668* Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com>
669- No longer seem to need danglinglink, prompt, lug, touch_errno patches.
670
671* Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-1
672- 4.5.11.
673- Use packaged readlink.
674
675* Wed Mar 19 2003 Tim Waugh <twaugh@redhat.com> 4.5.10-1
676- 4.5.10.
677- Update lug, touch_errno, acl, utmp, printf-ll, i18n, test-bugs patches.
678- Drop fr_fix, LC_TIME, preserve, regex patches.
679
680* Wed Mar 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-21
681- Fixed another i18n patch bug (bug #82032).
682
683* Tue Mar 11 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-20
684- Fix sort(1) efficiency in multibyte encoding (bug #82032).
685
686* Tue Feb 18 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-19
687- Ship readlink(1) (bug #84200).
688
689* Thu Feb 13 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-18
690- Deal with glibc < 2.2 in %%pre scriplet (bug #84090).
691
692* Wed Feb 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-16
693- Require glibc >= 2.2 (bug #84090).
694
695* Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 4.5.3-15
696- fix group (#84095)
697
698* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.5.3-14
699- rebuilt
700
701* Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com>
702- Fix rm(1) man page.
703
704* Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-13
705- Fix re_compile_pattern check.
706- Fix su hang (bug #81653).
707
708* Tue Jan 14 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-11
709- Fix memory size calculation.
710
711* Tue Dec 17 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-10
712- Fix mv error message (bug #79809).
713
714* Mon Dec 16 2002 Tim Powers <timp@redhat.com> 4.5.3-9
715- added PreReq on grep
716
717* Fri Dec 13 2002 Tim Waugh <twaugh@redhat.com>
718- Fix cp --preserve with multiple arguments.
719
720* Thu Dec 12 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-8
721- Turn on colorls for screen (bug #78816).
722
723* Mon Dec  9 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-7
724- Fix mv (bug #79283).
725- Add patch27 (nogetline).
726
727* Sun Dec  1 2002 Tim Powers <timp@redhat.com> 4.5.3-6
728- use the su.pamd from sh-utils since it works properly with multilib systems
729
730* Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-5
731- Fix test suite quoting problems.
732
733* Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-4
734- Fix scriplets.
735- Fix i18n patch so it doesn't break uniq.
736- Fix several other patches to either make the test suite pass or
737  not run the relevant tests.
738- Run 'make check'.
739- Fix file list.
740
741* Thu Nov 28 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-3
742- Adapted for Red Hat Linux.
743- Self-host for help2man.
744- Don't ship readlink just yet (maybe later).
745- Merge patches from fileutils and sh-utils (textutils ones are already
746  merged it seems).
747- Keep the binaries where the used to be (in particular, id and stat).
748
749* Sun Nov 17 2002 Stew Benedict <sbenedict@mandrakesoft.com> 4.5.3-2mdk
750- LI18NUX/LSB compliance (patch800)
751- Installed (but unpackaged) file(s) - /usr/share/info/dir
752
753* Thu Oct 31 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.3-1mdk
754- new release
755- rediff patch 180
756- merge patch 150 into 180
757
758* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-6mdk
759- move su back to /bin
760
761* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-5mdk
762- patch 0 : lg locale is illegal and must be renamed lug (pablo)
763
764* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-4mdk
765- fix conflict with procps
766
767* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-3mdk
768- patch 105 : fix install -s
769
770* Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-2mdk
771- fix build
772- don't chmode two times su
773- build with large file support
774- fix description
775- various spec cleanups
776- fix chroot installation
777- fix missing /bin/env
778- add old fileutils, sh-utils & textutils ChangeLogs
779
780* Fri Oct 11 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-1mdk
781- initial release (merge fileutils, sh-utils & textutils)
782- obsoletes/provides: sh-utils/fileutils/textutils
783- fileutils stuff go in 1xx range
784- sh-utils stuff go in 7xx range
785- textutils stuff go in 5xx range
786- drop obsoletes patches 1, 2, 10 (somes files're gone but we didn't ship
787  most of them)
788- rediff patches 103, 105, 111, 113, 180, 706
789- temporary disable patch 3 & 4
790- fix fileutils url
Note: See TracBrowser for help on using the repository browser.