source: projects/specs/branches/6/c/conky/conky-vl.spec @ 4228

Revision 4228, 6.4 KB checked in by munepi, 13 years ago (diff)

updated conky-vl.spec; added tolua++-vl/spec

Line 
1# TODO: - make libXNVCtrl-devel
2#       - with --enable-lua-imlib2
3
4%define with_alsa 0
5%define with_audacious 0
6%define with_imlib 1
7%define with_lua 1
8%define with_lua_cairo 1
9%define with_lua_imlib 1
10%define with_moc 1
11%define with_mpd 0
12%define with_nvidia 0
13%define with_rss 1
14%define with_smapi 0
15%define with_ibm 0
16%define with_wlan 0
17
18Name:           conky
19Version:        1.8.1
20Release:        1%{?_dist_release}
21Summary:        A lightweight system monitor for X
22Summary(ja):    X 用軽量システムモニタ
23Group:          User Interface/X
24License:        GPLv3+
25URL:            http://conky.sf.net/
26Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29BuildRequires:  glib2-devel
30BuildRequires:  libxml2-devel
31BuildRequires:  libXft-devel
32BuildRequires:  libXt-devel
33BuildRequires:  libXdamage-devel
34BuildRequires:  libXext-devel
35%if %{with_alsa}
36BuildRequires: alsa-lib-devel
37%endif
38%if %{with_imlib}
39BuildRequires: imlib2-devel
40%endif
41%if %{with_lua}
42BuildRequires: lua-devel
43%endif
44%if %{with_lua_cairo}
45BuildRequires: cairo-devel tolua++-devel
46%endif
47%if %{with_lua_imlib}
48BuildRequires: imlib2-devel tolua++-devel
49%endif
50%if %{with_audacious}
51BuildRequires:  audacious-devel
52BuildRequires:  dbus-glib-devel
53%endif
54%if %{with_nvidia}
55BuildRequires: libXNVCtrl-devel
56%endif
57%if %{with_rss}
58BuildRequires: curl-devel
59%endif
60%if %{with_wlan}
61BuildRequires: wireless-tools-devel
62%endif
63
64%description
65A system monitor for X originally based on the torsmo code. but more kickass.
66It just keeps on given'er. Yeah.
67#'
68
69%description -l ja
70torsmo をベースにした X 用のシステムモニタです。
71
72%prep
73%setup -q
74
75for i in AUTHORS ChangeLog; do
76    iconv -f iso8859-1 -t utf8 -o ${i}{_,} && touch -r ${i}{,_} && mv -f ${i}{_,}
77done
78
79%build
80#sh autogen.sh
81%configure \
82    --disable-rpath \
83    %if !%{with_alsa}
84    --disable-alsa \
85    %endif
86    %if %{with_audacious}
87    --enable-audacious=yes \
88    %endif
89    %if %{with_imlib}
90    --enable-imlib2 \
91    %endif
92    %if !%{with_lua}
93    --disable-lua \
94    %endif
95    %if %{with_lua_cairo}
96    --enable-lua-cairo \
97    %endif
98    %if %{with_lua_imlib}
99    --enable-lua-imlib2 \
100    %endif
101    %if !%{with_moc}
102    --disable-moc \
103    %endif
104    %if !%{with_mpd}
105    --disable-mpd \
106    %endif
107    %if %{with_nvidia}
108    --enable-nvidia \
109    %endif
110    %if %{with_rss}
111    --enable-rss \
112    %endif
113    %if %{with_ibm}
114    --enable-ibm \
115    %endif
116    %if %{with_smapi}
117    --enable-smapi \
118    %endif
119    %if %{with_wlan}
120    --enable-wlan \
121    %endif
122    ;
123
124# don't use rpath
125%__sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
126%__sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
127
128%__make %{?_smp_mflags}
129
130
131%install
132%__rm -rf $RPM_BUILD_ROOT
133%__make install DESTDIR=$RPM_BUILD_ROOT
134
135%__rm -f $RPM_BUILD_ROOT%{_sysconfdir}/conky/conky_no_x11.conf
136%__rm -f $RPM_BUILD_ROOT%{_libdir}/conky/*.{la,a}
137
138%clean
139%__rm -rf $RPM_BUILD_ROOT
140
141
142%files
143%defattr(-,root,root,-)
144%doc AUTHORS ChangeLog COPYING TODO README NEWS extras/* doc/docs.html
145%dir %{_sysconfdir}/%{name}
146%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
147%{_bindir}/%{name}
148%if %{with_lua_cairo} || %{with_lua_imlib}
149%{_libdir}/conky
150%endif
151%{_mandir}/man1/*
152
153
154%changelog
155* Sun Jun 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.8.1-1
156- new upstream release
157
158* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.7.2-1
159- new upstream release
160- enable lua, lua-cairo
161- added BuildRequires: glib2-devel
162
163* Mon Feb 15 2010 Miroslav Lichvar <mlichvar@redhat.com> - 1.7.2-2
164- fix building with new audacious (#556317)
165
166* Tue Aug 25 2009 Miroslav Lichvar <mlichvar@redhat.com> - 1.7.2-1
167- Update to 1.7.2
168
169* Thu Jul 30 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.7.1.1-1
170- new upstream release
171
172* Sat Nov 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.6.1-1
173- initial build based on Fedora package
174 - applied conky-1.6.0-rdtsc.patch, conky-1.6.1-ifaddrs.patch
175
176* Tue Aug 26 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.6.1-1
177- Update to 1.6.1
178- Fix buffer overflow when reading interface addresses
179
180* Tue Jul 22 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.6.0-1
181- Update to 1.6.0
182- Fix freq_dyn on x86_64
183
184* Tue Apr 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.5.1-1
185- Update to 1.5.1
186
187* Sun Mar 23 2008 Miroslav Lichvar <mlichvar@redhat.com> - 1.5.0-1
188- Update to 1.5.0
189- Convert doc files to UTF-8
190
191* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.9-2
192- Autorebuild for GCC 4.3
193
194* Tue Nov 27 2007 Miroslav Lichvar <mlichvar@redhat.com> - 1.4.9-1
195- Update to 1.4.9
196- Enable support for Audacious 1.4.0
197
198* Sun Oct 21 2007 Miroslav Lichvar <mlichvar@redhat.com> - 1.4.8-1
199- Update to 1.4.8
200- Enable mpd, rss and wireless support
201- Update license tag
202
203* Wed Apr 18 2007 Michael Rice <errr[AT]errr-online.com> - 1.4.5-4
204- Rebuild to match audacious lib in fc6 bug: 236989
205
206* Mon Apr 09 2007 Michael Rice <errr[AT]errr-online.com> - 1.4.5-3
207- Rebuild for devel
208
209* Thu Dec 14 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-2
210- Ship NEWS
211- Add patch for license of timed_thread and NEWS
212
213* Tue Dec 12 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.5-1
214- version bump
215- change group
216 
217* Wed Dec 06 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-3
218- rebuild for new audacious lib version
219
220* Thu Nov 30 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-2
221- Move nano and vim files into docs
222- remove unneeded BR's
223
224* Tue Nov 21 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.4-1
225- Version bump
226- Add vim and nano syntax files to package
227
228* Thu Oct 05 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.3-1
229- Version bump
230- Remove Install file from docs
231
232* Mon Oct 02 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-4
233- moved to configure macro from ./configure
234- clean up changelog and make more informative entrys
235- Fixed sumary in spec file
236- remove NEWS file since it was empty
237- remove xmms support due to possible security issue
238- remove bmp support due to possible security issue
239- add missing BR for libXext-devel and remove unneeded libX11-devel 
240
241* Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-3
242- use the GPL as licence since the whole package is GPL
243
244* Thu Sep 28 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-2
245- remove unneeded deps
246
247* Tue Sep 26 2006 Michael Rice <errr[AT]errr-online.com> - 1.4.2-1
248- Initial RPM release
Note: See TracBrowser for help on using the repository browser.