source: projects/specs/branches/6/c/commoncpp2/commoncpp2-vl.spec @ 6309

Revision 6309, 3.5 KB checked in by inagaki, 12 years ago (diff)

update: PyQt?, cppunit, commoncpp2

Line 
1Summary: GNU Common C++ class framework
2Name: commoncpp2
3Version: 1.8.0
4Release: 2%{?_dist_release}
5
6License: GPLv2+ with exceptions
7Group: System Environment/Libraries
8URL: http://www.gnu.org/software/commoncpp/
9
10Source0: http://www.gnutelephony.org/dist/tarballs/commoncpp2-%{version}.tar.gz
11#Patch0: commoncpp2-1.7.3-gcc44.patch
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: libxml2-devel
15BuildRequires: zlib-devel
16BuildRequires: doxygen
17
18%description
19GNU Common C++ is a portable and highly optimized class framework for writing
20C++ applications that need to use threads, sockets, XML parsing,
21serialization, config files, etc. This framework offers a class foundation
22that hides platform differences from your C++ application so that you need
23not write platform specific code. GNU Common C++ has been ported to compile
24natively on most platforms which support posix threads.
25
26%package devel
27Summary: Header files and libraries for %{name} development
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}
30Requires: pkgconfig
31Requires: libxml2-devel
32Requires: zlib-devel
33Requires(post): /sbin/install-info
34Requires(preun): /sbin/install-info
35
36%description devel
37The %{name}-devel package contains the header files and libraries needed
38to develop programs that use the %{name} library.
39
40
41%prep
42%setup -q
43#patch0 -p1
44
45%build
46%configure \
47        --disable-static \
48        --disable-dependency-tracking
49%{__make} #%%{?_smp_mflags} smp building disabled
50
51%install
52rm -rf $RPM_BUILD_ROOT
53make install DESTDIR=%{buildroot}
54rm -f %{buildroot}%{_infodir}/dir
55find %{buildroot} -name '*.la' -exec rm -f {} \;
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%post -p /sbin/ldconfig
61
62%post -n %{name}-devel
63/sbin/install-info %{_infodir}/commoncpp2.info %{_infodir}/dir || :
64
65%preun -n %{name}-devel
66if [ $1 = 0 ]; then
67    /sbin/install-info --delete %{_infodir}/commoncpp2.info %{_infodir}/dir || :
68fi
69
70%postun -p /sbin/ldconfig
71
72%files
73%defattr(-,root,root,-)
74%doc COPYING README ChangeLog
75%{_libdir}/*.so.*
76
77%files devel
78%defattr(-,root,root,-)
79%doc doc/html
80%dir %{_includedir}/cc++
81%{_includedir}/cc++/*
82%{_bindir}/ccgnu2-config
83%{_libdir}/*.so
84%{_libdir}/pkgconfig/libccext2.pc
85%{_libdir}/pkgconfig/libccgnu2.pc
86%{_datadir}/aclocal/ost_check2.m4
87%{_infodir}/commoncpp2.info*
88
89%changelog
90* Sun Jun  3 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.8.0-2
91- rebuilt with rpm-4.8.1-3
92
93* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.8.0-1
94- Initial build for Vine Linux
95
96* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.3-2
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
98
99* Mon Apr 06 2009 Andreas Thienemann <andreas@bawue.net> - 1.7.3-1
100- Updated to new upstream version 1.7.3
101
102* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-3
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
104
105* Tue Jul 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.1-2
106- fix license tag
107
108* Wed Feb 06 2008 Andreas Thienemann <andreas@bawue.net> - 1.6.1-1
109- Updated to new upstream version 1.6.1
110- Reverted the ld-check patch as it's no longer needed
111
112* Fri Nov 10 2006 Andreas Thienemann <andreas@bawue.net> - 1.5.0-1
113- Updated package to 1.5.0
114
115* Sun May 28 2006 Andreas Thienemann <andreas@bawue.net> - 1.4.2-1
116- Updated to 1.4.2
117
118* Sun May 28 2006 Andreas Thienemann <andreas@bawue.net> - 1.4.1-1
119- Updated to 1.4.1
120
121* Sun Feb 05 2006 Andreas Thienemann <andreas@bawue.net> - 1.3.23-1
122- Incorporated suggestions for extras
123
124* Fri Feb 03 2006 Andreas Thienemann <andreas@bawue.net> - 1.3.22-1
125- Initial spec.
Note: See TracBrowser for help on using the repository browser.