source: projects/specs/branches/6/c/color-mate/color-mate-vl.spec @ 6058

Revision 6058, 5.8 KB checked in by munepi, 12 years ago (diff)

new upstream release; dropped supporting xemacs

Line 
1%define prereq_ge()     %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1 | grep -v "is not")
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4Summary:      colorize emacsens' window
5Name:         color-mate
6Version:      10.6.4
7Release:      1%{?_dist_release}
8Group:        Applications/Editors/Emacs
9License:      distributable
10Url:          http://www.netlab.is.tsukuba.ac.jp/~yokota/izumi/color_mate/
11Source0:      color-mate-%{version}.tar.gz
12Source1:      cm_select.sh
13Source2:      emacs-color.sh
14Patch0:       color-mate-fontset.patch
15Patch1:       color-mate-10.6.3-color-mate-fontset-emacs.patch
16Patch2:       color-mate-10.6.3-color-mate-fontset-xemacs.patch
17Patch3:       color-mate-face-nound.patch
18Patch4:       color-mate-SunnyDay-LCD.patch
19Patch5:       color-mate-10.6.3-tail.patch
20
21Source10:     color-mate-install.sh
22Source11:     color-mate-remove.sh
23
24BuildArch:    noarch
25Buildroot:    %{_tmppath}/%{name}-%{version}-root
26
27Requires:       emacsen
28BuildRequires:  emacsen-common
29%prereq_ge    emacsen-common
30Requires(post): make
31Obsoletes:    color-mate-emacs, color-mate-xemacs
32
33Vendor:       Project Vine
34Distribution: Vine Linux
35
36%description
37Color-Mate is a colorize tool for emacs/xemacs.
38
39%description -l ja
40Color-Mate とは、 emacs/xemacs のカラー表示機能を使ってXウィンドウ版
41emacs/xemacs 画面を見やすくするものです。
42
43
44%prep
45%setup -q
46%patch0 -p0
47%patch1 -p1
48%patch2 -p1
49%patch3 -p0
50%patch4 -p1
51%patch5 -p1
52
53%build
54
55#just adding annoying file to the rpm filelist
56./configure
57
58%install
59[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
60
61mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/color-mate
62#mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/install
63#mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/remove
64mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/install
65mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/remove
66
67# install el files
68cp -ar Makefile* configure* *.el *.pl install-sh* kanakan-cursor contrib theme/\
69        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/color-mate
70
71# install contrib
72mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
73install -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_bindir}/cm_select
74install -m 755 %{SOURCE2} ${RPM_BUILD_ROOT}%{_bindir}/emacs-color
75# pushd ${RPM_BUILD_ROOT}%{_bindir}/
76# ln -s emacs-color xemacs-color
77# popd
78
79# prepare docs
80mv contrib/README README.cm_select
81
82## install script (bytecompile el and install elc, remove elc)
83
84%_installemacsenscript color-mate %{SOURCE10}
85
86%_removeemacsenscript  color-mate %{SOURCE11}
87
88
89%clean
90[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
91
92
93%post
94
95## bytecompile el and install elc
96
97if [ "$1" = 2 ] ; then
98
99%_emacsenPackageRemove color-mate
100
101fi
102
103%_addemacsenlist color-mate
104
105%_emacsenPackageInstall color-mate
106
107
108%preun
109
110if [ "$1" = 0 ] ; then
111
112%_emacsenPackageRemove color-mate
113
114%_removeemacsenlist color-mate
115
116fi
117
118
119%files
120%defattr(-,root,root)
121%doc Q_and_A.color-mate QuickStart.color-mate README.color-mate*
122%doc Customize* ChangeLog Dot*
123%doc kanakan-cursor/org-doc/* kanakan-cursor/README* contrib/
124%{_bindir}/cm_select
125%{_bindir}/emacs-color
126#%{_bindir}/xemacs-color
127%{_datadir}/emacs/site-lisp/color-mate/
128#/usr/lib/emacsen-common/packages/*/*
129%{emacsen_pkgdir}/*/*
130
131
132%changelog
133* Fri Apr 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 10.6.4-1
134- new upstream release
135- dropped supporting xemacs
136
137* Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 10.6.3-1vl5
138- applied new versioning policy, spec in utf-8
139- added macro %%emacsen_pkgdir
140
141* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.6.3-0vl3
142- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
143
144* Sun Aug 13 2006 IWAI, Masaharu <iwai@alib.jp> 10.6.3-0vl2
145- update color-mate-install.sh for Emacs 22
146- using Licenes tag
147- add tail option patch ( Patch5 )
148
149* Wed Apr  9 2003 IWAI Masaharu <iwai@alib.jp> 10.6.3-0vl1
150- version up to 10.6.3
151- update color-mate-fontset-emacs.patch (Patch1)
152- update color-mate-fontset-xemacs.patch (Patch2)
153
154* Fri Mar 29 2002 Jun Nishii <jun@vinelinux.org> 10.1.1-0vl8
155- fix color-mate-{install,remove}.sh
156
157* Fri Mar 29 2002 Jun Nishii <jun@vinelinux.org> 10.1.1-0vl7
158- install missing .X files
159- use symlink for color-xemacs
160- update cm_select
161
162* Sun Dec 16 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.1.1-0vl6
163- install script (SOURCE10) modified a little
164
165* Sun Dec 16 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.1.1-0vl5
166- emacsen-common aware
167
168* Sun Dec 03 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
169- 10.1.1-0vl4
170- fixed description
171- added BuildRequires and %%{emacs} / %%{xemacs} for each package to be
172  built on anti-BuildRequired host (both set to be 1 by default).
173- cp -a for egg-cursor.el to work around with emacs's murmur :-)
174
175* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
176- 10.1.1-0vl3
177- with egg-cursor
178
179* Wed Sep 20 2000 Jun Nishii <jun@vinelinux.org>
180- 10.1.1-0vl2
181- modify emacs-color
182
183* Fri Sep 15 2000 Jun Nishii <jun@vinelinux.org>
184- 9.1.1-0vl1
185- enable to set default fontset in .emacs
186- obsletes SunnyDay-LCD 12
187- added cm_select in bins
188- added emacs-color, xemacs-color
189
190* Mon Sep 11 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
191- 10.0.1-8
192- added SunnyDay-LCD 12 dots fontset theme
193
194* Fri Feb 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
195- 10.0.1-7
196- added %defattr(-,root,root)
197- added %clean section
198
199* Wed Jan 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
200- 10.0.1-6
201- fixed SunnyDay-LCD.el for "wrong type argument" problem
202
203* Fri Dec  3 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
204- 10.0.1-5
205- %files xemacs section modified for correct load-path
206  to /usr/lib/xemacs/site-packages/lisp/color-mate
207
208* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
209- change Group to Applications/Editors/EmacsLisp
210
211* Wed Nov 17 1999 Jun NISHII <jun@vinelinux.org>
212- build for Vine-2.0
Note: See TracBrowser for help on using the repository browser.