source: projects/specs/branches/6/c/cmake/cmake-vl.spec @ 2604

Revision 2604, 5.2 KB checked in by inagaki, 13 years ago (diff)

update: cmake

Line 
1# Set to bcond_with or use --without gui to disable qt4 gui build
2%bcond_without gui
3
4Name: cmake
5Summary: Cross-platform make system
6Summary(ja): クロスプラットフォームな Make システム
7Version: 2.8.3
8Release: 1%{?_dist_release}
9
10Group: Development/Tools
11License: BSD
12URL: http://www.cmake.org/
13
14Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
15Source1: macros.cmake
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18#BuildRequires: curl-devel
19#BuildRequires: expat-devel
20BuildRequires: libidn-devel
21BuildRequires: ncurses-devel
22BuildRequires: openssl-devel
23#BuildRequires: zlib-devel
24%if %{with gui}
25BuildRequires: qt4-devel, desktop-file-utils
26%define qt_gui --qt-gui
27%else
28%define qt_gui --no-qt-gui
29%endif
30
31Vendor: Project Vine
32Distribution: Vine Linux
33
34%description
35CMake is used to control the software compilation process using simple
36platform and compiler independent configuration files. CMake generates
37native makefiles and workspaces that can be used in the compiler
38environment of your choice. CMake is quite sophisticated: it is possible
39to support complex environments requiring system configuration, pre-processor
40generation, code generation, and template instantiation.
41
42%package        gui
43Summary:        Qt GUI for %{name}
44Group:          Development/Tools
45Requires:       %{name} = %{version}-%{release}
46Requires(post): desktop-file-utils, shared-mime-info
47Requires(postun): desktop-file-utils, shared-mime-info
48
49%description    gui
50The %{name}-gui package contains the Qt based GUI for CMake.
51
52
53%prep
54%setup -q
55# Fixup permissions
56find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
57
58%build
59./bootstrap \
60    --prefix=%{_prefix} \
61    --datadir=/share/%{name} \
62    --mandir=/share/man \
63    --no-system-libs \
64    %{?qt_gui}
65
66%if %{?_dist_release} == "vl5"
67sed -i 's/HAVE_SYS_WAIT_H:INTERNAL=/HAVE_SYS_WAIT_H:INTERNAL=1/' CMakeCache.txt
68%endif
69
70make VERBOSE=1 %{?_smp_mflags}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make install DESTDIR=$RPM_BUILD_ROOT
75
76find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
77rm -rf $RPM_BUILD_ROOT/usr/doc
78
79# RPM macros
80install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
81sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
82touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
83
84%if %{with gui}
85# Desktop file
86desktop-file-install --delete-original \
87  --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
88  $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
89%endif
90
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%if %{with gui}
96%post gui
97update-desktop-database &> /dev/null || :
98update-mime-database %{_datadir}/mime &> /dev/null || :
99
100%postun gui
101update-desktop-database &> /dev/null || :
102update-mime-database %{_datadir}/mime &> /dev/null || :
103%endif
104
105
106%files
107%defattr(-,root,root)
108%doc CMakeLogo.gif ChangeLog.* Copyright.txt
109%doc Docs/*
110%doc Example/
111%config(noreplace) %{_sysconfdir}/rpm/macros.cmake
112%{_bindir}/ccmake
113%{_bindir}/cmake
114%{_bindir}/cpack
115%{_bindir}/ctest
116%{_datadir}/%{name}/
117%{_mandir}/man1/*
118
119%if %{with gui}
120%files gui
121%defattr(-,root,root,-)
122%{_bindir}/cmake-gui
123%{_datadir}/applications/CMake.desktop
124%{_datadir}/mime/packages/cmakecache.xml
125%{_datadir}/pixmaps/CMakeSetup32.png
126%endif
127
128
129%changelog
130* Sat Jan  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
131- new upstream release
132- used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
133
134* Sun Sep  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
135- fixed typo (not --with-system-libs, but --system-libs)
136- added BR: curl-devel, expat-devel, zlib-devel
137
138* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
139- add BuildRequires: ncurses-devel
140
141* Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
142- generate gui package
143- renamed module directory
144
145* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
146- new upstream release
147
148* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
149- rebuilt with new toolchain
150
151* Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
152- imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
153
154* Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
155- new upstream release
156- added Vendor/Distribution tag
157
158* Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
159- new upstream release
160
161* Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
162- new upstream release
163
164* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
165- new upstream release
166
167* Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
168- new upstream release
169
170* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
171- new upstream release
172- drop Patch100
173- use bootstrap script instead of configure
174- delete caches from %%doc
175
176* Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
177- rebuilt with new toolchain
178
179* Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
180- new upstream release
181- delete duped docs
182
183* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
184- added Patch100 (especially for ppc to solve ppc/powerpc issue)
185
186* Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
187- source version up
188
189* Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
190- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.