source: projects/specs/branches/6/c/cluster-glue/cluster-glue-vl.spec @ 3022

Revision 3022, 11.6 KB checked in by Takemikaduchi, 13 years ago (diff)

libxml++: rebuild vine5 package, others: rebuild with openssl-1.0.0d

Line 
1%global gname haclient
2%global uname hacluster
3%global nogroup nobody
4
5# When downloading directly from Mercurial, it will automatically add this prefix
6# Invoking 'hg archive' wont but you can add one with: hg archive -t tgz -p "Reusable-Cluster-Components-" -r $upstreamversion $upstreamversion.tar.gz
7%global specversion 1
8%global upstreamprefix Reusable-Cluster-Components-
9%global upstreamversion aa1f9dee2793
10
11# Keep around for when/if required
12#global alphatag %{upstreamversion}.hg
13
14Name:           cluster-glue
15Summary:        Reusable cluster components
16Summary(ja):    再利用可能なクラスタコンポーネント
17Version:        1.0.2
18Release:        3%{?_dist_release}
19License:        GPLv2+ and LGPLv2+
20Url:            http://linux-ha.org/wiki/Cluster_Glue
21Group:          System Environment/Base
22Source0:        http://hg.linux-ha.org/glue/archive/%{upstreamversion}.tar.bz2
23
24Provides:       stonith = 3.0.0-1
25Provides:       pils = 3.0.0-1
26Obsoletes:      stonith < 3.0.0-1
27Obsoletes:      pils < 3.0.0-1
28
29## Setup/build bits
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
32
33# Build dependencies
34Requires: perl-TimeDate
35BuildRequires: automake autoconf libtool pkgconfig chrpath libtool-ltdl-devel
36BuildRequires: bzip2-devel glib2-devel python-devel libxml2-devel
37BuildRequires: libuuid-devel
38
39# For documentation
40BuildRequires: libxslt docbook-style-xsl
41
42# For additional Stonith plugins
43BuildRequires: net-snmp-devel OpenIPMI-devel openhpi-devel curl-devel
44
45%if 0%{?fedora} > 11 || 0%{?rhel} > 5
46BuildRequires: libuuid-devel
47%else
48BuildRequires: e2fsprogs-devel
49%endif
50
51%prep
52%setup -q -n %{upstreamprefix}%{upstreamversion}
53
54./autogen.sh
55
56%{configure}    CFLAGS="${CFLAGS} $(echo '%{optflags}')" \
57                --enable-fatal-warnings=no   \
58                --localstatedir=%{_var}      \
59                --with-daemon-group=%{gname} \
60                --with-daemon-user=%{uname}
61
62%build
63make %{_smp_mflags}
64
65%install
66rm -rf %{buildroot}
67make install DESTDIR=%{buildroot}
68
69## tree fix up
70# Dont package static libs
71find %{buildroot} -name '*.a' -exec rm {} \;
72find %{buildroot} -name '*.la' -exec rm {} \;
73
74# Don't package things we wont support
75rm -f %{buildroot}/%{_libdir}/stonith/plugins/stonith2/rhcs.*
76
77%clean
78rm -rf %{buildroot}
79
80# cluster-glue
81
82%description
83A collection of common tools that are useful for writing cluster managers
84such as Pacemaker.
85Provides a local resource manager that understands the OCF and LSB
86standards, and an interface to common STONITH devices.
87
88%files
89%defattr(-,root,root)
90%{_sbindir}/ha_logger
91%{_sbindir}/hb_report
92%{_sbindir}/lrmadmin
93%{_sbindir}/meatclient
94%{_sbindir}/sbd
95%{_sbindir}/stonith
96%{_sysconfdir}/init.d/logd
97
98%dir %{_libdir}/heartbeat
99%dir %{_libdir}/heartbeat/plugins
100%dir %{_libdir}/heartbeat/plugins/RAExec
101%dir %{_libdir}/heartbeat/plugins/InterfaceMgr
102%{_libdir}/heartbeat/lrmd
103%{_libdir}/heartbeat/ha_logd
104%{_libdir}/heartbeat/plugins/RAExec/*.so
105%{_libdir}/heartbeat/plugins/InterfaceMgr/*.so
106
107%dir %{_libdir}/stonith
108%dir %{_libdir}/stonith/plugins
109%dir %{_libdir}/stonith/plugins/stonith2
110%{_datadir}/cluster-glue/ha_log.sh
111%{_libdir}/stonith/plugins/external
112%{_libdir}/stonith/plugins/stonith2/*.so
113%{_libdir}/stonith/plugins/stonith2/*.py*
114%{_libdir}/stonith/plugins/xen0-ha-dom0-stonith-helper
115
116%dir %{_datadir}/cluster-glue
117%{_datadir}/cluster-glue/ha_cf_support.sh
118%{_datadir}/cluster-glue/openais_conf_support.sh
119%{_datadir}/cluster-glue/utillib.sh
120%{_datadir}/cluster-glue/combine-logs.pl
121
122%dir %{_var}/lib/heartbeat
123%dir %{_var}/lib/heartbeat/cores
124%dir %attr (0700, root, root)           %{_var}/lib/heartbeat/cores/root
125%dir %attr (0700, nobody, %{nogroup})   %{_var}/lib/heartbeat/cores/nobody
126%dir %attr (0700, %{uname}, %{gname})   %{_var}/lib/heartbeat/cores/%{uname}
127
128%doc %{_datadir}/doc/cluster-glue/stonith
129%doc %{_mandir}/man1/*
130%doc %{_mandir}/man8/*
131%doc AUTHORS
132%doc COPYING
133
134# cluster-glue-libs
135
136%package -n cluster-glue-libs
137Summary:        Reusable cluster libraries
138Summary(ja):    Reusable cluster libraries
139Group:          Development/Libraries
140Requires:       %{name} = %{version}-%{release}
141
142%description -n cluster-glue-libs
143A collection of libraries that are useful for writing cluster managers
144such as Pacemaker.
145
146%pre
147getent group %{gname} >/dev/null || groupadd -r %{gname}
148getent passwd %{uname} >/dev/null || \
149useradd -r -g %{gname} -d %{_var}/lib/heartbeat/cores/hacluster -s /sbin/nologin \
150-c "heartbeat user" %{uname}
151exit 0
152
153%post -n cluster-glue-libs -p /sbin/ldconfig
154
155%postun -n cluster-glue-libs -p /sbin/ldconfig
156
157%files -n cluster-glue-libs
158%defattr(-,root,root)
159%{_libdir}/lib*.so.*
160%doc AUTHORS
161%doc COPYING.LIB
162
163# cluster-glue-libs-devel
164
165%package -n cluster-glue-libs-devel
166Summary:        Headers and libraries for writing cluster managers
167Summary(ja):    Headers and libraries for writing cluster managers
168Group:          Development/Libraries
169Requires:       cluster-glue-libs = %{version}-%{release}
170
171%description -n cluster-glue-libs-devel
172Headers and shared libraries for a useful for writing cluster managers
173such as Pacemaker.
174
175%files -n cluster-glue-libs-devel
176%defattr(-,root,root)
177%dir %{_libdir}/heartbeat
178%dir %{_libdir}/heartbeat/plugins
179%dir %{_libdir}/heartbeat/plugins/test
180%dir %{_datadir}/cluster-glue
181%{_libdir}/lib*.so
182%{_libdir}/heartbeat/ipctest
183%{_libdir}/heartbeat/ipctransientclient
184%{_libdir}/heartbeat/ipctransientserver
185%{_libdir}/heartbeat/transient-test.sh
186%{_libdir}/heartbeat/base64_md5_test
187%{_libdir}/heartbeat/logtest
188%{_includedir}/clplumbing
189%{_includedir}/heartbeat
190%{_includedir}/stonith
191%{_includedir}/pils
192%{_datadir}/cluster-glue/lrmtest
193%{_libdir}/heartbeat/plugins/test/test.so
194
195%doc AUTHORS
196%doc COPYING
197%doc COPYING.LIB
198
199%changelog
200* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-3
201- rebuild with openssl-1.0.0d
202- add BuildRequires: libuuid-devel
203
204* Mon Jul 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.2-2
205- Obsoletes/Provides: stonith, pils
206
207* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.2-1
208- initial build for Vine Linux
209
210* Mon Jan 11 2010 Andrew Beekhof <andrew@beekhof.net> - 1.0.2-1
211- Suppress unsupported stonith plugins
212- Update to latest upstream release: aa1f9dee2793
213  + High: stonith: add ha_log.sh for external plugins (LF 1971)
214  + High: stonith: external plugins log using ha_log.sh (LF 2294)
215  + High: stonith: external/dracmc-telnet: new stonith plugin for Dell Drac/MC Blade Enclosure and Cyclades terminal server
216  + High: stonith: external/riloe: workaround for the iLO double close of RIBCL element (bnc#553340)
217  + High: stonith: external: log messages immediately on manage and status calls
218  + High: stonith: external: log output of plugins (bnc#548699,553340)
219  + Medium: LRM: lrmd: log outcome of monitor once an hour
220  + Medium: LRM: lrmd: remove operation history on client unregister and flushing all operations (LF 2161)
221  + Medium: LRM: lrmd: restore reset scheduler for children (bnc#551971, lf#2296)
222  + Medium: LRM: raexec: close the logd fd too when executing agents (LF 2267)
223  + Medium: Tools: hb_report: add -V (version) option and add support for corosync
224  + Medium: external STONITH plugins: remove dependency on .ocf-shellfuncs (LF2249)
225  + Medium: stonith: cyclades: fix for support for newer PM10 firmware (LF 1938)
226  + Medium: stonith: external/ipmi: add explanation on reset and power off (LF 2071)
227  + Medium: stonith: external/riloe: make sure that host is turned on after power off/on reset (LF 2282)
228  + Medium: stonith: meatclient: add -w option to wait until it can connect
229  + Medium: stonith: print complete metadata for -m (LF 2279)
230  + Medium: stonith: stonith: add -m option to display metadata
231
232* Mon Nov 23 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.12.b79635605337.hg
233- Correctly select libuuid for building on rhel >=6
234
235* Mon Oct 12 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.11.b79635605337.hg
236- Add install dependancy on perl-TimeDate for hb_report
237- Update to upstream version b79635605337
238  + Build: fix defines for pacemaker-pygui compatibility.
239  + High: Tools: hb_report: log/events combining
240  + High: doc: new README for wti_mpc
241  + High: hb_report: add man page hb_report.8
242  + High: hb_report: extract important events from the logs
243  + High: stonith: external/ibmrsa-telnet: add support for later RSA cards
244  + High: stonith: wti_mpc: support for MIB versions 1 and 3
245  + Logd: Start/stop priorities are not created by configure
246  + Med: sbd: Fix definition of size_t.
247  + Med: sbd: Nodename comparison should be case insensitive (bnc#534445)
248  + Med: wti_nps: add support for internet power switch model (bnc#539912)
249  + Medium (LF 2194): LRM: fix return code on RA exec failure
250  + Medium: Tools: hb_report: add -v option (debugging)
251  + Medium: Tools: hb_report: options -C and -D are obsoleted
252  + ha_logd: Fix a compile error/warning.
253  + hb_report: report corosync packages too.
254  + sbd: Accept -h (bnc#529574)
255  + sbd: really fix the sector_size type.
256
257* Fri Oct  9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0-0.10.d97b9dea436e.hg.1
258- rebuild with new net-snmp
259
260* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-0.9.d97b9dea436e.hg.1
261- rebuilt with new openssl
262
263* Mon Aug 17 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.9.d97b9dea436e.hg
264- Include relevant provides: and obsoletes: directives for heartbeat
265- Update the tarball from upstream to version d97b9dea436e
266  + Include license files
267  + Fix error messages in autogen.sh
268  + High (bnc#501723): Tools: hb_report: collect archived logs too
269  + Medium: clplumbing: check input when creating IPC channels
270  + Medium (bnc#510299): stonith: set G_SLICE to always-malloc to avoid bad interaction with the threaded openhpi
271  + Med: hb_report: report on more packages and with more state.
272  + The -E option to lrmadmin does not take an argument
273  + Provide a default value for docdir and ensure it is expanded
274  + Low: clplumbing: fix a potential resource leak in cl_random (bnc#525393).
275  + Med: hb_report: Include dlm_tool debugging information if available.
276  + hb_report: Include more possible error output.
277  + Medium: logd: add init script and example configuration file.
278  + High: logd: Fix init script. Remove apphbd references.
279  + logd: configuration file is optional.
280  + logd: print status on finished operations.
281  + High: sbd: actually install the binary.
282  + Medium: stonith: remove references to heartbeat artifacts.
283  + High: hb_report: define HA_NOARCHBIN
284  + hb_report: correct syntax error.
285  + hb_report: Include details about more packages even.
286  + hb_report: report corosync packages too.
287
288* Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 1.0-0.8.75cab275433e.hg
289- Use bzipped upstream tarball.
290
291* Tue Jul  28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.7.75cab275433e.hg
292- Add a leading zero to the revision when alphatag is used
293
294* Tue Jul  28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.6.75cab275433e.hg
295- Incorporate results of Fedora review
296  - Use global instead of define
297  - Remove unused rpm variable
298  - Remove redundant configure options
299  - Change version to 1.0.0 pre-release and include Mercurial tag in version
300
301* Mon Jul  27 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-5
302- Use linux-ha.org for Source0
303- Remove Requires: $name from -devel as its implied
304- Instead of 'daemon', use the user and group from Heartbeat and create it
305  if necessary
306
307* Fri Jul  24 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-4
308- Update the tarball from upstream to version 75cab275433e
309- Include an AUTHORS and license file in each package
310- Change the library package name to cluster-glue-libs to be more
311  Fedora compliant
312
313* Mon Jul  20 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-3
314- Package the project AUTHORS file
315- Have Source0 reference the upstream Mercurial repo
316
317* Tue Jul  14 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-2
318- More cleanups
319
320* Fri Jul  3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.9-1
321- Fedora-ize the spec file
322
323* Fri Jun  5 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-0
324- Initial checkin
Note: See TracBrowser for help on using the repository browser.