source: projects/specs/branches/6/c/cln/cln-vl.spec @ 1916

Revision 1916, 5.6 KB checked in by inagaki, 14 years ago (diff)

rebuilt with rpm-4.8.1: arts, cln, dotconf, dbusmenu-qt, dbus-python, eet, eigen2, kdegraphics, kdebindings, lcms
updated: dbus-python, eigen2, lcms

Line 
1Name:           cln
2Summary:        Class Library for Numbers
3Version:        1.3.1
4Release:        2%{?_dist_release}
5
6Group:          System Environment/Libraries
7License:        GPLv2+
8URL:            http://www.ginac.de/CLN/
9Source0:        http://www.ginac.de/CLN/%{name}-%{version}.tar.bz2
10Patch0:         cln-1.2.2-s390x.patch
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  gmp-devel
14BuildRequires:  texinfo
15#BuildRequires:  texi2html texinfo
16Requires(post): /sbin/install-info
17Requires(preun): /sbin/install-info
18
19%description
20A collection of C++ math classes and functions, which are designed for
21memory and speed efficiency, and enable type safety and algebraic
22syntax.
23
24%package devel
25Summary:        Development files for programs using the CLN library
26Group:          Development/Libraries
27Requires:       %{name} = %{version}-%{release}
28
29%description devel
30A collection of C++ math classes and functions, which are designed for
31memory and speed efficiency, and enable type safety and algebraic
32syntax.
33
34This package is necessary if you wish to develop software based on
35the CLN library.
36
37%prep
38%setup -q
39%patch0 -p1 -b .s390x
40
41%build
42%configure --disable-static
43make %{?_smp_mflags}
44make pdf
45make html
46
47%install
48rm -rf %{buildroot}
49make DESTDIR=%{buildroot} install
50
51mkdir -p %{buildroot}%{_docdir}/%{name}-devel-%{version}
52cp -p doc/cln.pdf doc/cln.html %{buildroot}%{_docdir}/%{name}-devel-%{version}/
53
54find %{buildroot} -type f -name "*.la" -exec rm -f {} ';'
55rm -f %{buildroot}%{_infodir}/dir
56rm -rf %{buildroot}%{_bindir} %{buildroot}%{_mandir}/man1/pi.*
57
58%check
59make %{?_smp_mflags} check
60
61%clean
62rm -rf %{buildroot}
63
64%post -p /sbin/ldconfig
65
66%postun -p /sbin/ldconfig
67
68%post devel
69/sbin/install-info --section="Math" %{_infodir}/cln.info.gz %{_infodir}/dir 2>/dev/null || :
70
71%preun devel
72if [ "$1" = 0 ]; then
73  /sbin/install-info --delete %{_infodir}/cln.info.gz %{_infodir}/dir 2>/dev/null || :
74fi
75
76%files
77%defattr(-,root,root)
78%doc COPYING ChangeLog NEWS README TODO*
79%{_libdir}/*.so.*
80
81%files devel
82%defattr(-,root,root)
83%{_libdir}/*.so
84%{_libdir}/pkgconfig/cln.pc
85%{_includedir}/cln
86%{_infodir}/*.info*
87%{_docdir}/%{name}-devel-%{version}
88
89%changelog
90* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-2
91- rebuilt with rpm-4.8.1 for pkg-config
92
93* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-1
94- new upstream release
95- built with new toolchain
96
97* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.0-3
98- Initial build for Vine Linux
99
100* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-2
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
102
103* Thu Jul 02 2009 Deji Akingunola <dakingun@gmail.com> - 1.3.0-1
104- Update to latest upstream release 1.3.0
105
106* Thu May 28 2009 Dan Horak <dan[at]danny.cz> - 1.2.2-5
107- fix build on s390x
108- run the test-suite during build
109
110* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-4
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
112
113* Wed Feb 04 2009 Deji Akingunola <dakingun@gmail.com> - 1.2.2-3
114- Add upstream patch to build with gcc-4.4
115
116* Fri Jan 16 2009 Rakesh Pandit <rakesh@fedoraproject.org> 1.2.2-2
117- Bump to solve dependency for ginac-devel
118
119* Tue Apr 29 2008 Quentin Spencer <qspencer@users.sf.net> 1.2.2-1
120- Update to 1.2.2.
121
122* Mon Feb 25 2008 Quentin Spencer <qspencer@users.sf.net> 1.2.0-1
123- Update to 1.2.0.
124- Update License tag.
125
126* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.13-5
127- Autorebuild for GCC 4.3
128
129* Thu Sep 13 2007 Quentin Spencer <qspencer@users.sf.net> 1.1.13-4
130- Add pkgconfig as a dependency of -devel.
131
132* Tue Aug 21 2007 Quentin Spencer <qspencer@users.sf.net> 1.1.13-3
133- Rebuild for F8.
134
135* Mon Aug 28 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.13-2
136- Rebuild for FC-6.
137
138* Thu Aug 17 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.13-1
139- New release.
140
141* Mon Feb 13 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-5
142- Disable static build.
143- Enable parallel build.
144
145* Mon Feb 13 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-4
146- Rebuild for Fedora Extras 5.
147- Remove /usr/share/info/dir after install.
148- Exclude static libs.
149
150* Mon Jan 16 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-3
151- Exclude /usr/share/info/dir from package (bug 178660).
152
153* Mon Jan 16 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-2
154- Update source URL.
155
156* Mon Jan 16 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-1
157- New upstream release.
158
159* Mon Oct 31 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.10-1
160- New upstream release, incorporating previous patch.
161
162* Mon Jun 20 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-8
163- Rebuild
164
165* Mon Jun 13 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-4
166- Patched include/cln/string.h to correctly compile on gcc-c++-4.0.0-9
167
168* Fri May 27 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-3
169- Added gmp-devel to Requires for devel
170
171* Fri May 20 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-2
172- Added dist tag.
173
174* Wed May 11 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-1
175- Excluded .la file
176
177* Fri Apr 22 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-1
178- Added gmp-devel in BuildRequires, fixes in files
179- Added release to name in Requires for devel
180
181* Mon Mar 21 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-1
182- Adapted spec file for Fedora Extras
183
184* Thu Nov 20 2003 Christian Bauer <Christian.Bauer@uni-mainz.de>
185  Added pkg-config metadata file to devel package
186
187* Wed Nov  6 2002 Christian Bauer <Christian.Bauer@uni-mainz.de>
188  Added HTML and DVI docs to devel package
189
190* Tue Nov  5 2001 Christian Bauer <Christian.Bauer@uni-mainz.de>
191  Added Packager
Note: See TracBrowser for help on using the repository browser.