source: projects/specs/branches/6/c/chromium13/chromium13-vl.spec @ 4348

Revision 4348, 28.4 KB checked in by munepi, 13 years ago (diff)

updated chromum; NEW chromium13

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_icu 1
8#% define with_system_v8 1
9
10#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
11#     libvpx doesn't currently supply a pkg-config file, so we assume that
12#     -lvpx is sufficient.
13%define with_system_vpx 1
14
15Name:           chromium13
16#Name:           chromium
17Summary:        Google's opens source browser project
18Summary(ja):    Googleのオープンソースウェブブラウザ
19#'
20Version:        13.0.782.88
21Release:        1%{?_dist_release}
22License:        BSD
23Group:          Applications/Internet
24Source0:        %{pkgname}-%{version}.tar.xz
25# Script used to create the %{pkgname}-%{version}.tar.xz archive from
26# a official tarball:
27# http://build.chromium.org/official/chromium-13.0.782.XXX.tar.bz2
28Source3:        pack_chromium13_source-vine.sh
29# Official ffmpeg headers
30Source8:        ffmpeg-0.6-headers.tar.xz
31# Patch template which adds vendor to user agent
32##!!Source20:       chromium-vendor.patch.in
33Source20:       chromium-vendor-vine.patch.in
34# Set default prefs
35##!!Source30:       master_preferences
36Source30:       master_preferences.vine
37##!!Source31:       default_bookmarks.html
38#Source31:       default_bookmarks.html.vine
39Source99:       chrome-wrapper
40##!!Source100:      chromium-browser.sh
41Source100:      chromium-browser-vine.sh
42##!!Source101:      chromium-browser.desktop
43Source101:      chromium-browser-vine.desktop
44Source102:      chromium-browser.xml
45Source103:      chromium-browser-rpmlintrc
46##!!Source104:      chromium-icons.tar.bz2
47
48%{?nosrc:NoSource: 0}
49
50Provides:       chromium-unstable = %{version}
51Conflicts:      chromium-stable
52
53## Start Patches
54# OpenSuse and Fedora
55# Many changes to the gyp systems so we can use system libraries
56#Patch1:         chromium-gcc46.patch
57Patch4:         chromium-no-sqlite-debug.patch
58Patch8:         chromium-codechanges-zlib.patch
59Patch12:        chromium-no-test-sources.patch
60Patch13:        chromium-no-courgette.patch
61Patch14:        chromium-master-prefs-path.patch
62Patch17:        chromium-system-glew.patch
63Patch18:        chromium-system-expat.patch
64Patch19:        chromium-system-zlib.patch
65Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
66Patch21:        chromium-7.0.542.0-media-probe.patch
67Patch25:        tcmalloc-factory.patch
68Patch26:        chromium-remoting-build-fix.diff
69Patch28:        chromium-7.0.500.0-system-speex.patch
70Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
71Patch32:        chromium-7.0.542.0-system-libvpx.patch
72Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
73Patch62:        chromium-norpath.patch
74Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
75
76# Vine
77Patch100:       chromium-13.0.782.13-no-tests.patch
78
79
80##!!BuildRequires:  Mesa-devel
81BuildRequires:  mesa-libGLU-devel
82##!!BuildRequires:  alsa-devel
83BuildRequires:  alsa-lib-devel
84BuildRequires:  bison
85BuildRequires:  cups-devel
86BuildRequires:  desktop-file-utils
87BuildRequires:  fdupes
88BuildRequires:  flex
89BuildRequires:  freetype2-devel
90BuildRequires:  gcc gcc-c++
91BuildRequires:  gperf
92BuildRequires:  hunspell-devel
93##!!BuildRequires:  libbz2-devel
94BuildRequires:  bzip2-devel
95BuildRequires:  libevent
96##!!BuildRequires:  libexpat-devel
97BuildRequires:  expat-devel
98##!!BuildRequires:  libgnutls-devel
99BuildRequires:  gnutls-devel
100BuildRequires:  libjpeg-devel
101BuildRequires:  libpng-devel
102BuildRequires:  libstdc++-devel >= 4.4
103%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
104BuildRequires:  libxslt-devel
105BuildRequires:  libzip-devel
106##!!BuildRequires:  lzma
107BuildRequires:  xz
108##!!BuildRequires:  mozilla-nspr-devel
109BuildRequires:  nspr-devel
110##!!BuildRequires:  mozilla-nss-devel
111BuildRequires:  nss-devel
112BuildRequires:  openssl-devel
113BuildRequires:  pam-devel
114##!!BuildRequires:  perl(Switch)
115BuildRequires:  perl
116##!!BuildRequires:  pkg-config
117BuildRequires:  cairo-devel >= 1.6
118BuildRequires:  dbus-devel
119##!!BuildRequires:  gconf2-devel
120BuildRequires:  GConf2-devel
121BuildRequires:  glib2-devel
122BuildRequires:  gtk2-devel
123BuildRequires:  libxml2-devel
124BuildRequires:  python
125##!!BuildRequires:  python-xml
126BuildRequires:  python-pyxml
127BuildRequires:  sqlite3-devel
128##!!BuildRequires:  update-desktop-files
129%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
130##!!BuildRequires:  wdiff
131BuildRequires:  zlib-devel
132
133BuildRequires:  libgnome-keyring-devel
134BuildRequires:  python-devel
135
136#BuildRequires:  glew-devel
137BuildRequires:  libevent-devel
138%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
139#BuildRequires:  libjingle-devel >= 0.4.0-7
140#BuildRequires:  srtp-devel
141BuildRequires:  speex-devel
142
143##Vine Linux
144#BuildRequires:  libpaper-devel
145BuildRequires:  libXScrnSaver-devel
146BuildRequires:  libXtst-devel
147BuildRequires:  libXdamage-devel
148BuildRequires:  libXt-devel
149%ifarch x86_64
150Requires:  nspluginwrapper
151%endif
152
153##!!Requires:       alsa
154Requires:       alsa-lib
155Requires:       xdg-utils
156%{?with_system_v8:Requires:       v8 = %{v8_ver}}
157
158BuildRoot:      %{_tmppath}/%{name}-%{version}-root
159
160%description
161Chromium is the open-source project behind Google Chrome.
162We invite you to join us in our effort to help build a safer, faster,
163and more stable way for all Internet users to experience the web,
164and to create a powerful platform for developing a new generation of
165web applications.
166
167%description -l ja
168Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
169ウェブを体験しているすべてのインターネットユーザに対して
170より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
171そして、ウェブアプリケーションの新しい世代を発展させ、
172強力なプラットホームを作成するために、
173私たちの取り組みにぜひ参加してください。
174
175
176%prep
177#%setup -q
178[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
179xz -dc %{SOURCE0} | %__tar -xf - || exit 1
180%setup -D -T -n %{pkgname}-%{version}
181
182#%patch1 -p1
183%patch62 -p1
184%{?with_system_v8:%patch63 -p1}
185%patch100 -p1 -b .vine
186%patch4 -p1
187%patch8 -p1
188%patch12 -p1
189%patch13 -p1
190%patch14 -p1
191%patch17 -p1
192%patch18 -p1
193%patch19 -p1
194%patch20 -p1
195%patch21 -p1
196%patch25 -p1
197%patch26 -p1
198%patch28 -p1
199%patch29 -p1
200%{?with_system_vpx:%patch32 -p1}
201%{?with_system_v8:%patch34 -p1}
202
203pushd src/third_party/ffmpeg/
204%__tar xf %{SOURCE8} || exit 1
205## built header file: avconfig.h
206[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
207cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
208/* Generated by ffconf */
209#ifndef AVUTIL_AVCONFIG_H
210#define AVUTIL_AVCONFIG_H
211#define AV_HAVE_BIGENDIAN 0
212#endif /* AVUTIL_AVCONFIG_H */
213EOF
214popd
215
216#%__rm -rf src/third_party/libvpx/
217%__rm -rf src/third_party/speex/
218%__rm -rf src/third_party/nss src/third_party/nspr
219
220# apply vendor patch after substitution
221%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
222
223%build
224
225## create make files
226
227PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
228for i in src/build/common.gypi; do
229        %__sed -i "s|'-march=pentium4',||g" $i
230        %__sed -i "s|'-mfpmath=sse',||g" $i
231        %__sed -i "s|'-O<(debug_optimize)',||g" $i
232        %__sed -i "s|'-m32',||g" $i
233        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
234        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
235done
236# '
237
238pushd src
239
240./build/gyp_chromium -f make build/all.gyp \
241    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
242    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
243    -Duse_openssl=0 \
244    -Duse_system_ffmpeg=1 \
245    -Duse_system_zlib=1 \
246    -Duse_system_libpng=1 \
247    -Duse_system_bzip2=1 \
248    -Duse_system_libbz2=1 \
249    -Duse_system_libjpeg=1 \
250    -Duse_system_libxml=1 \
251    -Duse_system_libxslt=1 \
252    -Duse_system_libevent=1 \
253    %{?with_system_vpx:-Duse_system_vpx=1} \
254    %{!?with_system_vpx:-Duse_system_vpx=0} \
255    -Dremove_webcore_debug_symbols=1 \
256    %{?with_system_v8:-Duse_system_v8=1} \
257    %{!?with_system_v8:-Duse_system_v8=0} \
258    %{?with_system_icu:-Duse_system_icu=1} \
259    %{!?with_system_icu:-Duse_system_icu=0} \
260    %{?_with_shared_library:-Dlibrary=shared_library} \
261    -Dproprietary_codecs=1 \
262    -Djavascript_engine=v8 \
263    -Dlinux_fpic=1 \
264    %ifarch %{ix86}
265        -Dtarget_arch=ia32 \
266        -Ddisable_sse2=1 \
267    %endif
268    %ifarch x86_64
269        -Dtarget_arch=x64 \
270    %endif
271    -Dno_strict_aliasing=1 \
272    -Drelease_extra_cflags=-fPIC \
273    %if %{?_dist_release} == "vl6"
274        -Dgcc_version=44 \
275    %endif
276    ;
277
278#%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
279%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release
280
281popd
282
283%install
284%{__rm} -rf %{buildroot}
285
286%__mkdir -p %{buildroot}%{_bindir}
287%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
288# x86_64 capable systems need this
289%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
290%__mkdir -p %{buildroot}%{_libdir}/chromium/
291%__mkdir -p %{buildroot}%{_mandir}/man1/
292pushd src/out/Release
293%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
294%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
295%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
296%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
297%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
298%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
299%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
300fdupes %{buildroot}%{_mandir}/man1/
301popd
302
303%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
304%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
305for i in 16 22 24 32 48 64 128 256; do
306    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
307    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
308done
309
310%__mkdir_p %{buildroot}%{_datadir}/applications/
311desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
312
313%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
314%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
315
316# # link to browser plugin path.  Plugin patch doesn't work. Why?
317# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
318# pushd %{buildroot}%{_libdir}/%{pkgname}
319# %{__ln_s} %{_libdir}/browser-plugins plugins
320# popd
321pushd %{buildroot}%{_libdir}/%{pkgname}
322%ifarch x86_64
323%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
324%else
325%{__ln_s} %{_libdir}/mozilla/plugins plugins
326%endif
327
328## support ffmpeg libs
329touch %{buildroot}%{_libdir}/libavcodec.so.52
330%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
331touch %{buildroot}%{_libdir}/libavformat.so.52
332%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
333touch %{buildroot}%{_libdir}/libavutil.so.50
334%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
335popd
336
337# Install the master_preferences file
338%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
339#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
340%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
341#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
342
343%clean
344%{__rm} -rf %{buildroot}
345
346%post
347touch --no-create %{_datadir}/icons/hicolor
348if [ -x %{_bindir}/gtk-update-icon-cache ]; then
349  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
350fi
351%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
352
353%postun
354%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
355touch --no-create %{_datadir}/icons/hicolor
356if [ -x %{_bindir}/gtk-update-icon-cache ]; then
357  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
358fi || :
359
360
361%files
362%defattr(-,root,root,-)
363%config %{_sysconfdir}/%{pkgname}
364%dir %{_datadir}/gnome-control-center
365%dir %{_datadir}/gnome-control-center/default-apps
366%dir %{_libdir}/chromium/
367%{_bindir}/chromium
368%{_libdir}/chromium/chromium
369%{_libdir}/chromium/plugins/
370%{_libdir}/chromium/resources/
371%{_libdir}/chromium/xdg-settings
372%{_mandir}/man1/chrom*
373%{_datadir}/pixmaps/chromium-browser.png
374%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
375%{_datadir}/applications/*.desktop
376%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
377#%{_datadir}/icons/oxygen/
378%{_libdir}/chromium/chrome.pak
379%{_libdir}/chromium/resources.pak
380%{_libdir}/chromium/locales/
381%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
382%{_libdir}/chromium/libavcodec.so.52
383%{_libdir}/chromium/libavutil.so.50
384%{_libdir}/chromium/libavformat.so.52
385%exclude %{_libdir}/libavcodec.so.52
386%exclude %{_libdir}/libavutil.so.50
387%exclude %{_libdir}/libavformat.so.52
388
389%changelog
390* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
391- updated to 13.0.782.88
392- added BuildRequires: libzip-devel
393- added Provides: chromium-unstable = %%{version}
394- added Conflicts: chromium-stable
395
396* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
397- fix user-agent string (chromium-vendor-vine.patch.in)
398  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
399
400* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
401- updated to 12.0.742.93
402- fixed icon field of chromium-browser-vine.desktop
403
404* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
405- updated to 12.0.742.91
406
407* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
408- updated to 12.0.742.77
409
410* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
411- updated to 12.0.742.63
412
413* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
414- updated to 12.0.742.42
415
416* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
417- updated to 12.0.742.6
418- dropped/upstreamed patches
419- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
420
421* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
422- updated to 11.0.696.50
423- dropped some Patches for MeeGo Netbook
424
425* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
426- updated to 11.0.696.35
427
428* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
429- updated to 11.0.696.29
430- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
431
432* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
433- updated to 11.0.696.22
434- improved chromium-browser-vine.sh
435  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
436
437* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
438- updated to 11.0.696.20
439- improved chromium-browser-vine.desktop
440
441* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
442- updated to 11.0.696.17
443
444* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
445- updated to 11.0.696.15
446  - ready for Vine Linux 6 release
447- dropped BuildRequires: v8-devel, libicu-devel
448
449* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
450- updated to 11.0.696.5 with v8 3.2.0
451- added BuildRequires: pam-devel
452
453* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
454- rebuilt with libevent-2.0.10
455
456* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
457- updated to 10.0.651.0 with v8 3.0.12
458- added BuildRequires:
459  - libpaper-devel
460  - python-devel
461- added built header file: libavutil/avconfig.h %%prep
462- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
463
464* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
465- updated to 10.0.622.0
466- added BuildRequires: libXt-devel
467
468* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
469- updated to 10.0.605.0
470- added BuildRequires:
471  - libXdamage-devel
472  - hunspell-devel
473
474* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
475- updated to 9.0.598
476
477* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
478- updated to 9.0.593
479
480* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
481- updated to 9.0.582
482- added Requires: xdg-utils
483
484* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
485- updated to 9.0.578
486
487* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
488- updated to 9.0.569
489
490  * Mon Oct 25 2010 tittiatcoke@gmail.com
491  - Update to 9.0.564 build
492    * Added specific patches for MeeGo.
493    * We are now using shared libraries for Chromium
494    * Spec-file cleanup (Thanks to prusnak)
495
496* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
497- updated to snapshot 8.0.556
498
499* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
500- updated to snapshot 8.0.551
501
502* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
503- updated to snapshot 7.0.527
504
505* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
506- updated to snapshot 7.0.519
507
508* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
509- updated to snapshot 7.0.513
510  - updated chromium-vendor-vine.patch.in
511
512* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
513- updated to snapshot 7.0.507
514
515* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
516- updated to snapshot 7.0.498
517
518* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
519- updated to snapshot 6.0.493
520- used with_system_icu (for vl6)
521  - added BuildRequires: libicu-devel
522
523* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
524- build for Vine Linux 5.x
525  - add BuildRequires: gnome-keyring-devel
526
527* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
528- updated to snapshot 6.0.454
529- added BuildRequires:
530  - sqlite3-devel
531  - gnutls-devel
532  - libgnome-keyring-devel
533
534* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
535- updated to snapshot 6.0.431.0 r49253
536- added BuildRequires: cups-devel
537
538* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
539- updated to snapshot 6.0.405.0 r47263
540
541* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
542- unused with_system_icu (for vl6)
543  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
544
545* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
546- updated to snapshot 5.0.378.0 r44472
547  - used with_system_icu (for vl6)
548  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
549
550* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
551- updated to snapshot 5.0.372.0 r43947
552- added BuildRequires: glew-devel
553- changed Group tag to Applications/Internet
554- added Summary(ja) and %%description -l ja
555
556* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
557- updated to snapshot 5.0.365.0 r42966
558- merged 5.0.353.0-4vl5
559 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
560 - build on Vine Linux 5.1
561   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
562
563* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
564- updated to snapshot 5.0.364.0 r42779
565
566* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
567- updated to snapshot 5.0.359.0 r42116
568- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
569
570* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
571- fixed master_preferences.vine, little
572
573* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
574- fixed to install master_preferences
575- dropped chromium-5.0.353-no-ffmpeg-vine.patch
576
577* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
578- applied chromium-5.0.353-no-ffmpeg-vine.patch
579
580* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
581- updated to snapshot 5.0.353.0 r41449
582  * Wed Mar 10 2010 bgmerrell@novell.com
583  - Add master_preferences source file and install it to /etc/chromium.
584  - Create a new patch (chromium-master-prefs-path.patch) which tells
585    chromium to look in /etc/chromium for the master_preferences file
586    (instead of looking in the default directory, which is the same
587    directory as the 'chrome' binary).
588
589* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
590- updated to snapshot 5.0.335.0 r39556
591
592* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
593- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
594
595* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
596- updated to snapshot 5.0.330.0 r39074
597
598* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
599- use_system_ffmpeg
600
601* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
602- added Requires:  nspluginwrapper
603- fixed a symbolic link of plugins directory with nspluginwrapper
604
605* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
606- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
607
608* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
609- added BuildRequires: mesa-libGLU-devel
610- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
611
612* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
613- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
614
615  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
616  - Update to 4.0.260
617  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
618  - Update to 4.0.259
619  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
620  - Update to 4.0.258
621  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
622  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
623    changed to having an built-in v8
624  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
625  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
626  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
627  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
628  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
629  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
630  - update to newer svn snapshot
631    + Obsoletes fwrite patch (included upstream)
632  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
633  - update to newer svn snapshot
634    + Requires newer version of v8
635  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
636  - do not force SSE on x86 (drop-sse.patch)
637  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
638  - Update to newer svn snapshot
639  - Fixed spec file in order to build
640  - Included patch to build with system zlib
641  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
642  - package renamed to chromium
643  - cleaned up spec file
644  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
645  - v8 is now built as a separate package, and is required
646  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
647  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
648  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
649  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
650  - initial build
651
652#% changelog
653* Sun Jan 24 2010 prusnak@suse.cz
654- added vendor to user agent (chromium-vendor.patch.in)
655* Sun Nov 29 2009 prusnak@suse.cz
656- added --enable-sync to wrapper to enable bookmark sync
657* Sun Nov 29 2009 tittiatcoke@gmail.com 
658- Update to 4.0.260
659* Fri Nov 27 2009 tittiatcoke@gmail.com 
660- Update to 4.0.259
661* Thu Nov 26 2009 tittiatcoke@gmail.com 
662- Update to 4.0.258
663* Tue Nov 24 2009 tittatcoke@gmai.com 
664- In order to complete prevent the wrong v8 version to be used,
665  the Chromium build has been changed to having an built-in v8
666* Tue Nov 24 2009 dbuck@example.com 
667- Re-base patches.
668- Fixed a few patch errors.
669- Rename some patches to better correspond with function.
670- Removed some patches.
671- Minor SPEC changes.
672- I changed the v8 requirement to be exact, instead of greater than a specific version.
673* Fri Nov 13 2009 tittiatcoke@gmail.com
674- update to 247.0 svn 31928
675* Fri Oct 30 2009 tittiatcoke@gmail.com
676- update to 229.0 svn 30454
677  + Fix regression where popups and app frames lost their titlebars.
678  + Makes it so that when a folder is open on the bookmark bar
679    and the mouse moves over another folder, the menu for that
680    folder is shown.
681  + Lazily create the find bar.
682  + Polish to the gmail checker sample.
683  * New, crisper icons that are exactly 19x19
684  * Add a loading animation at the beginning before Gmail
685    responds.
686  * Fix a bug where we sometimes don't update the UI after a
687    logout/login cycle.
688  + Refactor widget methods to support desktop notifications,
689    including GTK stubs.
690  + Find-in-page should not ding while deleting characters.
691  + Add SSL wrapper for linux and mac.  This allows notifier to
692    use chrome's SSL layer instead of OpenSSL.
693  + Add three of the six extensions to PAC that Internet Explorer supports.
694  + WebSocket support in chromium. (Run with --enable-web-sockets
695    enables WebSocket features.)
696  + Do not allow GTK File Chooser dialogs to return directories.
697  + Fix the notifier SSL layer to make notifications work for
698    Linux Bookmark sync.
699  + linux: don't override mouse selection behavior in omnibox
700* Sun Oct 25 2009 tittiatcoke@gmail.com
701- Update to 224.4 svn 30027
702  + First cut at new page and browser action docs based
703    on new API. Deleted old stuff.
704  + Add suppression for new memory leak caused by WebKit merge 49830:49844
705  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
706  + Minimize dependency of user scripts
707  + Fixup the flip_framer eof-handling semantics now that we have
708    the FIN bit in place
709  + app depends on x11 because of active_window_watcher_x
710  + Adding two images for the new Extension managment UI
711  + Removing hard-coded Chrome Frame output path
712  + Rearrange clipboard code
713  + Fix crash bug when attempting to download a url with unsupported scheme,
714    e.g. 'data:', by 'Alt + Click'
715  + GTK: Change text for extension download UI
716  + Ignore invalid urls on command line
717  + Make dropped tabs animate from where they were dropped.
718  + Make room for the full width of the tab placeholder.
719  + Make tab dragging as smooth as glass.
720  + Remove an annoying NOTIMPLEMNETED
721  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
722  + If we're in the middle of a drag, don't allow the user to middle
723    click to close or right click for the context menu
724  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
725  + Remove +x bit from files that shouldn't have it
726  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
727  + Adding new image needed for the managment UI
728  + Fix a race bug where content scripts would not apply to the first page load
729  + Make escape remove a bookmark if it's just been added (but not if it already existed)
730  + Fix bubbles deactivating the opaque frame
731  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
732  + ake all pepper plugins default to windowless and transparent
733  + Add styles for printing
734  + Implement the new extension management UI
735  + Add support for to automation interface load install and load extensions
736  + GTK: theme the info bar border
737  + Update V8 to version 1.3.16.1
738  + Introduce WebSecurityPolicy for security related methods
739  + New button scheme...borders are separate from the inner contents so
740    that they can be highlighted / depressed independently
741  + When opening Chrome maximized with an application window already
742    running, the Chrome window was not activated
743  + Fix compatibility problems with FileZilla FTP Server
744  + Remove the extension shelf on Linux
745  + Fix the proxy host and port string to start with http:// if it does not already
746  + Enable HTML5 databases for all extension renderer processes
747* Sat Oct 24 2009 prusnak@opensuse.org 
748- don't create desktop files in wrapper
749- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
750* Tue Oct 20 2009 tittiatcoke@gmail.com 
751- update to newer svn snapshot
752  + Obsoletes fwrite patch (included upstream)
753* Fri Oct 16 2009 tittiatcoke@gmail.com 
754- update to newer svn snapshot
755  + Requires newer version of v8
756* Thu Oct 15 2009 prusnak@suse.cz 
757- do not force SSE on x86 (drop-sse.patch)
758* Tue Oct 13 2009 tittiatcoke@gmail.com 
759- Update to newer svn snapshot
760- Fixed spec file in order to build
761- Included patch to build with system zlib
762* Mon Oct 12 2009 prusnak@suse.cz 
763- package renamed to chromium
764- cleaned up spec file
765* Tue Oct  6 2009 dbuck@example.com 
766- v8 is now built as a separate package, and is required
767- included many patches to use system libraries:
768    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
769* Thu Oct  1 2009 dbuck@example.com 
770- included a newer DEP than is in svn, native_client@823
771- things should compile cleanly now
772* Mon Aug 31 2009 dbuck@example.com 
773- initial build
Note: See TracBrowser for help on using the repository browser.