source: projects/specs/branches/6/c/chromium/chromium19-vl.spec @ 6327

Revision 6327, 32.5 KB checked in by munepi, 12 years ago (diff)

updated to 19.0.1084.57

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_jpeg 1
8
9#% define with_system_icu 1
10#% define with_system_v8 1
11%define with_system_vpx 1
12
13#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
14# There's a couple key GYP variables that control how FFmpeg is built:
15#   ffmpeg_branding
16#     Controls whether we build the Chromium or Google Chrome version of
17#     FFmpeg.  The Google Chrome version contains additional codecs.
18#     Typical values are Chromium, Chrome, ChromiumOS, and ChromeOS.
19#   use_system_ffmpeg
20#     When set to non-zero will build Chromium against the system FFmpeg
21#     headers via pkg-config.  When Chromium is launched it will assume that
22#     FFmpeg is present in the system library path.  Default value is 0.
23#   build_ffmpegsumo
24#     When set to zero will build Chromium against the patched ffmpegsumo
25#     headers, but not build ffmpegsumo itself.  Users are expected to build
26#     and provide their own version of ffmpegsumo.  Default value is 1.
27%define with_system_ffmpeg 1
28
29%global chrome_sandbox %{_prefix}/lib/chrome_sandbox
30
31#Name:           chromium19
32Name:           chromium
33Summary:        Google's opens source browser project
34Summary(ja):    Googleのオープンソースウェブブラウザ
35#'
36Version:        19.0.1084.57
37Release:        1%{?_dist_release}
38License:        BSD-3-Clause, LGPL-2.1+
39Group:          Applications/Internet
40Source0:        %{pkgname}-%{version}.tar.xz
41# Script used to create the %{pkgname}-%{version}.tar.xz archive from
42# a official tarball:
43# http://gsdview.appspot.com/chromium-browser-official/chromium-19.0.1084.XXX.tar.bz2
44Source3:        pack_chromium19_source-vine.sh
45# Patch template which adds vendor to user agent
46##!!Source20:       chromium-vendor.patch.in
47Source20:       chromium-vendor-vine.patch.in
48# Set default prefs
49##!!Source30:       master_preferences
50Source30:       master_preferences.vine
51##!!Source31:       default_bookmarks.html
52#Source31:       default_bookmarks.html.vine
53Source99:       chrome-wrapper
54##!!Source100:      chromium-browser.sh
55Source100:      chromium-browser-vine.sh
56##!!Source101:      chromium-browser.desktop
57Source101:      chromium-browser-vine.desktop
58Source102:      chromium-browser.xml
59#Source103:      chromium-browser-rpmlintrc
60##!!Source104:      chromium-icons.tar.bz2
61
62%{?nosrc:NoSource: 0}
63
64# Provides:       chromium-unstable = %{version}-%{release}
65# Obsoletes:      chromium13 chromium14 chromium15
66# Conflicts:      chromium-stable
67Provides:       chromium-stable = %{version}-%{release}
68Conflicts:      chromium-unstable
69
70## Start Patches
71# OpenSuse and Fedora
72# Many changes to the gyp systems so we can use system libraries
73Patch1:         chromium-gcc46.patch
74Patch8:         chromium-codechanges-zlib.patch
75Patch13:        chromium-no-courgette.patch
76Patch14:        chromium-master-prefs-path.patch
77Patch17:        chromium-system-glew.patch
78Patch18:        chromium-system-expat.patch
79Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
80Patch25:        tcmalloc-factory.patch
81Patch26:        chromium-remoting-build-fix.diff
82Patch28:        chromium-7.0.500.0-system-speex.patch
83Patch32:        chromium-7.0.542.0-system-libvpx.patch
84Patch62:        chromium-norpath.patch
85Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
86Patch64:        chromium-more-codec-aliases.patch
87Patch66:        chromium-sandbox-pie.patch
88
89
90# Vine
91#Patch100:       chromium-15.0.874.116-no-tests.patch
92
93
94##!!BuildRequires:  Mesa-devel
95BuildRequires:  mesa-libGLU-devel
96##!!BuildRequires:  alsa-devel
97BuildRequires:  alsa-lib-devel
98BuildRequires:  pulseaudio-libs-devel
99BuildRequires:  bison
100BuildRequires:  cups-devel
101BuildRequires:  desktop-file-utils
102BuildRequires:  fdupes
103BuildRequires:  flex
104BuildRequires:  freetype2-devel
105BuildRequires:  gcc
106BuildRequires:  gcc-c++
107BuildRequires:  gperf
108BuildRequires:  hunspell-devel
109##!!BuildRequires:  libbz2-devel
110BuildRequires:  bzip2-devel
111BuildRequires:  libevent
112##!!BuildRequires:  libexpat-devel
113BuildRequires:  expat-devel
114##!!BuildRequires:  libgnutls-devel
115BuildRequires:  gnutls-devel
116%{?with_system_jpeg:BuildRequires:  libjpeg-devel}
117BuildRequires:  libpng-devel
118BuildRequires:  libstdc++-devel >= 4.4
119%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
120BuildRequires:  libxslt-devel
121BuildRequires:  libzip-devel
122##!!BuildRequires:  lzma
123BuildRequires:  xz
124##!!BuildRequires:  mozilla-nspr-devel
125BuildRequires:  nspr-devel
126##!!BuildRequires:  mozilla-nss-devel
127BuildRequires:  nss-devel
128BuildRequires:  krb5-devel
129BuildRequires:  openssl-devel
130BuildRequires:  pam-devel
131##!!BuildRequires:  pkg-config
132##!!BuildRequires:  perl(Switch)
133BuildRequires:  perl
134BuildRequires:  cairo-devel >= 1.6
135BuildRequires:  dbus-devel
136BuildRequires:  dbus-glib-devel
137##!!BuildRequires:  gconf2-devel
138BuildRequires:  GConf2-devel
139BuildRequires:  glib2-devel
140BuildRequires:  gtk2-devel
141BuildRequires:  libxml2-devel
142BuildRequires:  python
143##!!BuildRequires:  python-xml
144BuildRequires:  python-pyxml
145BuildRequires:  sqlite3-devel
146##!!BuildRequires:  update-desktop-files
147%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
148##!!BuildRequires:  wdiff
149BuildRequires:  zlib-devel
150##!!BuildRequires:  libpulse-devel
151BuildRequires:  pulseaudio-libs-devel
152##!!BuildRequires:  libelf-devel
153BuildRequires:  elfutils-libelf-devel
154BuildRequires:  libgnome-keyring-devel
155BuildRequires:  python-devel
156#BuildRequires:  glew-devel
157BuildRequires:  libevent-devel
158%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
159#BuildRequires:  libjingle-devel >= 0.4.0-7
160#BuildRequires:  srtp-devel
161BuildRequires:  speex-devel
162BuildRequires:  libudev-devel
163
164##Vine Linux
165#BuildRequires:  libpaper-devel
166BuildRequires:  libXScrnSaver-devel
167BuildRequires:  libXtst-devel
168BuildRequires:  libXdamage-devel
169BuildRequires:  libXt-devel
170%ifarch x86_64
171Requires:  nspluginwrapper
172%endif
173
174##!!Requires:       alsa
175Requires:       alsa-lib
176Requires:       pulseaudio-libs
177Requires:       xdg-utils
178%{?with_system_v8:Requires:       v8 = %{v8_ver}}
179
180BuildRoot:      %{_tmppath}/%{name}-%{version}-root
181
182%description
183Chromium is the open-source project behind Google Chrome.
184We invite you to join us in our effort to help build a safer, faster,
185and more stable way for all Internet users to experience the web,
186and to create a powerful platform for developing a new generation of
187web applications.
188
189%description -l ja
190Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
191ウェブを体験しているすべてのインターネットユーザに対して
192より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
193そして、ウェブアプリケーションの新しい世代を発展させ、
194強力なプラットホームを作成するために、
195私たちの取り組みにぜひ参加してください。
196
197
198%prep
199#%setup -q
200[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
201xz -dc %{SOURCE0} | %__tar -xf - || exit 1
202%setup -D -T -n %{pkgname}-%{version}
203
204%if %{?_dist_release} == "vl7"
205%patch1 -p1
206%endif
207%patch62 -p1
208%{?with_system_v8:%patch63 -p1}
209%patch64
210#%patch65 -p1
211#%patch100 -p1 -b .vine
212%patch8 -p1
213%patch13 -p1
214%patch14 -p1
215%patch17 -p1
216%patch18 -p1
217%{?with_system_ffmpeg:%patch20 -p1}
218#%patch25 -p1
219%patch26 -p1
220%patch28 -p1
221%{?with_system_vpx:%patch32 -p1}
222%patch66 -p1
223
224
225# apply vendor patch after substitution
226%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
227
228# Make sure that the requires legal files can be found
229%__cp -a src/AUTHORS src/LICENSE . || exit 1
230
231%build
232
233## create make files
234
235PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
236for i in src/build/common.gypi; do
237        %__sed -i "s|'-march=pentium4',||g" $i
238        %__sed -i "s|'-mfpmath=sse',||g" $i
239        %__sed -i "s|'-O<(debug_optimize)',||g" $i
240        %__sed -i "s|'-m32',||g" $i
241        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
242        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
243done
244# '
245
246pushd src
247
248./build/gyp_chromium -f make build/all.gyp \
249    -Dlinux_sandbox_path=%{chrome_sandbox} \
250    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium \
251    -Duse_openssl=0 \
252    %{?with_system_ffmpeg:-Duse_system_ffmpeg=1} \
253    %{!?with_system_ffmpeg:-Duse_system_ffmpeg=0} \
254    -Dbuild_ffmpegsumo=1 \
255    -Duse_system_zlib=1 \
256    -Duse_system_libpng=1 \
257    -Duse_system_bzip2=1 \
258    -Duse_system_libbz2=1 \
259    %{?with_system_jpeg:-Duse_system_libjpeg=1} \
260    %{!?with_system_jpeg:-Duse_system_libjpeg=0} \
261    -Duse_system_libxml=1 \
262    -Duse_system_libxslt=1 \
263    -Duse_system_libevent=1 \
264    %{?with_system_vpx:-Duse_system_vpx=1} \
265    %{!?with_system_vpx:-Duse_system_vpx=0} \
266    -Dremove_webcore_debug_symbols=1 \
267    %{?with_system_v8:-Duse_system_v8=1} \
268    %{!?with_system_v8:-Duse_system_v8=0} \
269    %{?with_system_icu:-Duse_system_icu=1} \
270    %{!?with_system_icu:-Duse_system_icu=0} \
271    %{?_with_shared_library:-Dlibrary=shared_library} \
272    -Dproprietary_codecs=1 \
273    -Ddisable_nacl=1 \
274    -Dlinux_use_gold_flags=0 \
275    -Dlinux_use_gold_binary=0 \
276    -Djavascript_engine=v8 \
277    -Dlinux_fpic=1 \
278    -Ddisable_sse2=1 \
279    %ifarch %{ix86}
280        -Dtarget_arch=ia32 \
281    %endif
282    %ifarch x86_64
283        -Dtarget_arch=x64 \
284    %endif
285    -Dno_strict_aliasing=1 \
286    -Drelease_extra_cflags=-fPIC \
287    %if %{?_dist_release} == "vl6"
288        -Dgcc_version=44 \
289    %endif
290    ;
291
292%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release disable_nacl=1
293
294# Build the required SUID_SANDBOX helper
295%__make -r %{?_smp_mflags} chrome_sandbox V=1 BUILDTYPE=Release disable_nacl=1
296
297popd
298
299%install
300%{__rm} -rf %{buildroot}
301
302%__mkdir -p %{buildroot}%{_bindir}
303%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
304%ifarch x86_64
305mkdir -p %{buildroot}%{_prefix}/lib/
306%endif
307# x86_64 capable systems need this
308%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
309%__mkdir -p %{buildroot}%{_libdir}/chromium/
310%__mkdir -p %{buildroot}%{_mandir}/man1/
311pushd src/out/Release
312%__cp -a chrome_sandbox %{buildroot}%{_prefix}/lib/
313%__cp -a chrome.pak locales resources xdg-mime xdg-settings %{buildroot}%{_libdir}/chromium/
314%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
315%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
316%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
317%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
318%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
319%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
320fdupes %{buildroot}%{_mandir}/man1/
321popd
322
323%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
324%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
325for i in 16 22 24 32 48 64 128 256; do
326    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
327    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
328done
329
330%__mkdir_p %{buildroot}%{_datadir}/applications/
331desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
332
333%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
334%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
335
336# # link to browser plugin path.  Plugin patch doesn't work. Why?
337# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
338# pushd %{buildroot}%{_libdir}/%{pkgname}
339# %{__ln_s} %{_libdir}/browser-plugins plugins
340# popd
341pushd %{buildroot}%{_libdir}/%{pkgname}
342%ifarch x86_64
343%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
344%else
345%{__ln_s} %{_libdir}/mozilla/plugins plugins
346%endif
347popd
348
349# Install the master_preferences file
350%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
351#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
352%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
353#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
354
355%clean
356%{__rm} -rf %{buildroot}
357
358%post
359touch --no-create %{_datadir}/icons/hicolor
360if [ -x %{_bindir}/gtk-update-icon-cache ]; then
361  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
362fi
363%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
364
365%postun
366%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
367touch --no-create %{_datadir}/icons/hicolor
368if [ -x %{_bindir}/gtk-update-icon-cache ]; then
369  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
370fi || :
371
372
373%files
374%defattr(-,root,root,-)
375%config %{_sysconfdir}/%{pkgname}
376%dir %{_datadir}/gnome-control-center
377%dir %{_datadir}/gnome-control-center/default-apps
378%dir %{_libdir}/chromium/
379%{_bindir}/chromium
380%{_libdir}/chromium/chromium
381%{_libdir}/chromium/plugins/
382%{_libdir}/chromium/resources/
383%attr(755,root,root) %{_libdir}/chromium/xdg-settings
384%attr(755,root,root) %{_libdir}/chromium/xdg-mime
385%{_mandir}/man1/chrom*
386%{_datadir}/pixmaps/chromium-browser.png
387%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
388%{_datadir}/applications/*.desktop
389%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
390#%{_datadir}/icons/oxygen/
391%{_libdir}/chromium/chrome.pak
392%{_libdir}/chromium/resources.pak
393%{_libdir}/chromium/locales/
394%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
395%attr(4755,root,root) %{chrome_sandbox}
396
397%changelog
398* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 19.0.1084.57-1
399-updated to 19.0.1084.57
400
401* Sat Jun  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 19.0.1084.53-1
402- updated to 19.0.1084.53
403
404* Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 19.0.1084.50-1
405- updated to 19.0.1084.50
406
407* Tue May  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.169-1
408- updated to 18.0.1025.169
409
410* Sat Apr 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.166-1
411- updated to 18.0.1025.166
412
413* Sat Apr 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.163-1
414- updated to 18.0.1025.163
415
416* Tue Apr  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.148-1
417- updated to 18.0.1025.148
418
419* Wed Mar 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.145-1
420- updated to 18.0.1025.145
421
422* Sun Mar 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.140-1
423- updated to 18.0.1025.140
424
425* Thu Mar 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.130-1
426- updated to 18.0.1025.130
427
428* Tue Mar 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.114-1
429- updated to 18.0.1025.114
430
431* Tue Mar 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.81-1
432- updated to 17.0.963.81
433
434* Fri Mar  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.78-1
435- updated to 17.0.963.78
436
437* Sat Mar  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.65-1
438- updated to 17.0.963.65
439
440* Wed Feb 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.60-1
441- updated to 17.0.963.60
442
443* Fri Feb 17 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.57-1
444- updated to 17.0.963.57
445
446* Sun Feb 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.54-1
447- updated to 17.0.963.54
448
449* Sat Feb 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.52-1
450- updated to 17.0.963.52
451
452* Sat Feb  4 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.77-1
453- updated to 16.0.912.77
454
455* Sun Jan  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.75-1
456- updated to 16.0.912.75
457
458* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.63-1
459- updated to 16.0.912.63
460
461* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.57-1
462- updated to 16.0.912.57
463
464* Sat Oct 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 15.0.874.116-1
465- updated to 15.0.874.116
466
467* Wed Oct 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.204-1
468- updated to 14.0.835.204
469- added BuildRequires: dbus-glib-devel
470
471* Sat Sep 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.186-1
472- updated to 14.0.835.186
473
474* Sun Sep 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.163-1
475- updated to 14.0.835.163
476
477* Tue Sep 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.157-1
478- updated to 14.0.835.157
479
480* Sat Aug 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.102-1
481- updated to 14.0.835.102
482
483* Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
484- updated to 14.0.835.89
485- added Obsoletes: chromium-unstable < %{version}-%{release}
486
487* Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
488- updated to 14.0.835.35
489- added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
490- changed to Name: chromium14
491  - Provides:  chromium-unstable = %%{version}
492  - Conflicts: chromium-stable
493
494* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
495- changed to Name: chromium
496- updated to 13.0.782.107
497
498* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
499- updated to 13.0.782.88
500- added BuildRequires: libzip-devel
501- added Provides: chromium-unstable = %%{version}
502- added Conflicts: chromium-stable
503
504* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
505- fix user-agent string (chromium-vendor-vine.patch.in)
506  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
507
508* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
509- updated to 12.0.742.93
510- fixed icon field of chromium-browser-vine.desktop
511
512* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
513- updated to 12.0.742.91
514
515* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
516- updated to 12.0.742.77
517
518* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
519- updated to 12.0.742.63
520
521* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
522- updated to 12.0.742.42
523
524* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
525- updated to 12.0.742.6
526- dropped/upstreamed patches
527- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
528
529* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
530- updated to 11.0.696.50
531- dropped some Patches for MeeGo Netbook
532
533* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
534- updated to 11.0.696.35
535
536* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
537- updated to 11.0.696.29
538- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
539
540* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
541- updated to 11.0.696.22
542- improved chromium-browser-vine.sh
543  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
544
545* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
546- updated to 11.0.696.20
547- improved chromium-browser-vine.desktop
548
549* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
550- updated to 11.0.696.17
551
552* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
553- updated to 11.0.696.15
554  - ready for Vine Linux 6 release
555- dropped BuildRequires: v8-devel, libicu-devel
556
557* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
558- updated to 11.0.696.5 with v8 3.2.0
559- added BuildRequires: pam-devel
560
561* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
562- rebuilt with libevent-2.0.10
563
564* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
565- updated to 10.0.651.0 with v8 3.0.12
566- added BuildRequires:
567  - libpaper-devel
568  - python-devel
569- added built header file: libavutil/avconfig.h %%prep
570- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
571
572* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
573- updated to 10.0.622.0
574- added BuildRequires: libXt-devel
575
576* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
577- updated to 10.0.605.0
578- added BuildRequires:
579  - libXdamage-devel
580  - hunspell-devel
581
582* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
583- updated to 9.0.598
584
585* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
586- updated to 9.0.593
587
588* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
589- updated to 9.0.582
590- added Requires: xdg-utils
591
592* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
593- updated to 9.0.578
594
595* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
596- updated to 9.0.569
597
598  * Mon Oct 25 2010 tittiatcoke@gmail.com
599  - Update to 9.0.564 build
600    * Added specific patches for MeeGo.
601    * We are now using shared libraries for Chromium
602    * Spec-file cleanup (Thanks to prusnak)
603
604* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
605- updated to snapshot 8.0.556
606
607* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
608- updated to snapshot 8.0.551
609
610* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
611- updated to snapshot 7.0.527
612
613* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
614- updated to snapshot 7.0.519
615
616* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
617- updated to snapshot 7.0.513
618  - updated chromium-vendor-vine.patch.in
619
620* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
621- updated to snapshot 7.0.507
622
623* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
624- updated to snapshot 7.0.498
625
626* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
627- updated to snapshot 6.0.493
628- used with_system_icu (for vl6)
629  - added BuildRequires: libicu-devel
630
631* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
632- build for Vine Linux 5.x
633  - add BuildRequires: gnome-keyring-devel
634
635* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
636- updated to snapshot 6.0.454
637- added BuildRequires:
638  - sqlite3-devel
639  - gnutls-devel
640  - libgnome-keyring-devel
641
642* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
643- updated to snapshot 6.0.431.0 r49253
644- added BuildRequires: cups-devel
645
646* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
647- updated to snapshot 6.0.405.0 r47263
648
649* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
650- unused with_system_icu (for vl6)
651  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
652
653* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
654- updated to snapshot 5.0.378.0 r44472
655  - used with_system_icu (for vl6)
656  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
657
658* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
659- updated to snapshot 5.0.372.0 r43947
660- added BuildRequires: glew-devel
661- changed Group tag to Applications/Internet
662- added Summary(ja) and %%description -l ja
663
664* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
665- updated to snapshot 5.0.365.0 r42966
666- merged 5.0.353.0-4vl5
667 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
668 - build on Vine Linux 5.1
669   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
670
671* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
672- updated to snapshot 5.0.364.0 r42779
673
674* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
675- updated to snapshot 5.0.359.0 r42116
676- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
677
678* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
679- fixed master_preferences.vine, little
680
681* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
682- fixed to install master_preferences
683- dropped chromium-5.0.353-no-ffmpeg-vine.patch
684
685* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
686- applied chromium-5.0.353-no-ffmpeg-vine.patch
687
688* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
689- updated to snapshot 5.0.353.0 r41449
690  * Wed Mar 10 2010 bgmerrell@novell.com
691  - Add master_preferences source file and install it to /etc/chromium.
692  - Create a new patch (chromium-master-prefs-path.patch) which tells
693    chromium to look in /etc/chromium for the master_preferences file
694    (instead of looking in the default directory, which is the same
695    directory as the 'chrome' binary).
696
697* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
698- updated to snapshot 5.0.335.0 r39556
699
700* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
701- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
702
703* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
704- updated to snapshot 5.0.330.0 r39074
705
706* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
707- use_system_ffmpeg
708
709* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
710- added Requires:  nspluginwrapper
711- fixed a symbolic link of plugins directory with nspluginwrapper
712
713* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
714- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
715
716* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
717- added BuildRequires: mesa-libGLU-devel
718- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
719
720* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
721- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
722
723  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
724  - Update to 4.0.260
725  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
726  - Update to 4.0.259
727  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
728  - Update to 4.0.258
729  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
730  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
731    changed to having an built-in v8
732  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
733  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
734  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
735  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
736  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
737  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
738  - update to newer svn snapshot
739    + Obsoletes fwrite patch (included upstream)
740  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
741  - update to newer svn snapshot
742    + Requires newer version of v8
743  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
744  - do not force SSE on x86 (drop-sse.patch)
745  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
746  - Update to newer svn snapshot
747  - Fixed spec file in order to build
748  - Included patch to build with system zlib
749  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
750  - package renamed to chromium
751  - cleaned up spec file
752  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
753  - v8 is now built as a separate package, and is required
754  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
755  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
756  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
757  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
758  - initial build
759
760#% changelog
761* Sun Jan 24 2010 prusnak@suse.cz
762- added vendor to user agent (chromium-vendor.patch.in)
763* Sun Nov 29 2009 prusnak@suse.cz
764- added --enable-sync to wrapper to enable bookmark sync
765* Sun Nov 29 2009 tittiatcoke@gmail.com 
766- Update to 4.0.260
767* Fri Nov 27 2009 tittiatcoke@gmail.com 
768- Update to 4.0.259
769* Thu Nov 26 2009 tittiatcoke@gmail.com 
770- Update to 4.0.258
771* Tue Nov 24 2009 tittatcoke@gmai.com 
772- In order to complete prevent the wrong v8 version to be used,
773  the Chromium build has been changed to having an built-in v8
774* Tue Nov 24 2009 dbuck@example.com 
775- Re-base patches.
776- Fixed a few patch errors.
777- Rename some patches to better correspond with function.
778- Removed some patches.
779- Minor SPEC changes.
780- I changed the v8 requirement to be exact, instead of greater than a specific version.
781* Fri Nov 13 2009 tittiatcoke@gmail.com
782- update to 247.0 svn 31928
783* Fri Oct 30 2009 tittiatcoke@gmail.com
784- update to 229.0 svn 30454
785  + Fix regression where popups and app frames lost their titlebars.
786  + Makes it so that when a folder is open on the bookmark bar
787    and the mouse moves over another folder, the menu for that
788    folder is shown.
789  + Lazily create the find bar.
790  + Polish to the gmail checker sample.
791  * New, crisper icons that are exactly 19x19
792  * Add a loading animation at the beginning before Gmail
793    responds.
794  * Fix a bug where we sometimes don't update the UI after a
795    logout/login cycle.
796  + Refactor widget methods to support desktop notifications,
797    including GTK stubs.
798  + Find-in-page should not ding while deleting characters.
799  + Add SSL wrapper for linux and mac.  This allows notifier to
800    use chrome's SSL layer instead of OpenSSL.
801  + Add three of the six extensions to PAC that Internet Explorer supports.
802  + WebSocket support in chromium. (Run with --enable-web-sockets
803    enables WebSocket features.)
804  + Do not allow GTK File Chooser dialogs to return directories.
805  + Fix the notifier SSL layer to make notifications work for
806    Linux Bookmark sync.
807  + linux: don't override mouse selection behavior in omnibox
808* Sun Oct 25 2009 tittiatcoke@gmail.com
809- Update to 224.4 svn 30027
810  + First cut at new page and browser action docs based
811    on new API. Deleted old stuff.
812  + Add suppression for new memory leak caused by WebKit merge 49830:49844
813  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
814  + Minimize dependency of user scripts
815  + Fixup the flip_framer eof-handling semantics now that we have
816    the FIN bit in place
817  + app depends on x11 because of active_window_watcher_x
818  + Adding two images for the new Extension managment UI
819  + Removing hard-coded Chrome Frame output path
820  + Rearrange clipboard code
821  + Fix crash bug when attempting to download a url with unsupported scheme,
822    e.g. 'data:', by 'Alt + Click'
823  + GTK: Change text for extension download UI
824  + Ignore invalid urls on command line
825  + Make dropped tabs animate from where they were dropped.
826  + Make room for the full width of the tab placeholder.
827  + Make tab dragging as smooth as glass.
828  + Remove an annoying NOTIMPLEMNETED
829  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
830  + If we're in the middle of a drag, don't allow the user to middle
831    click to close or right click for the context menu
832  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
833  + Remove +x bit from files that shouldn't have it
834  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
835  + Adding new image needed for the managment UI
836  + Fix a race bug where content scripts would not apply to the first page load
837  + Make escape remove a bookmark if it's just been added (but not if it already existed)
838  + Fix bubbles deactivating the opaque frame
839  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
840  + ake all pepper plugins default to windowless and transparent
841  + Add styles for printing
842  + Implement the new extension management UI
843  + Add support for to automation interface load install and load extensions
844  + GTK: theme the info bar border
845  + Update V8 to version 1.3.16.1
846  + Introduce WebSecurityPolicy for security related methods
847  + New button scheme...borders are separate from the inner contents so
848    that they can be highlighted / depressed independently
849  + When opening Chrome maximized with an application window already
850    running, the Chrome window was not activated
851  + Fix compatibility problems with FileZilla FTP Server
852  + Remove the extension shelf on Linux
853  + Fix the proxy host and port string to start with http:// if it does not already
854  + Enable HTML5 databases for all extension renderer processes
855* Sat Oct 24 2009 prusnak@opensuse.org 
856- don't create desktop files in wrapper
857- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
858* Tue Oct 20 2009 tittiatcoke@gmail.com 
859- update to newer svn snapshot
860  + Obsoletes fwrite patch (included upstream)
861* Fri Oct 16 2009 tittiatcoke@gmail.com 
862- update to newer svn snapshot
863  + Requires newer version of v8
864* Thu Oct 15 2009 prusnak@suse.cz 
865- do not force SSE on x86 (drop-sse.patch)
866* Tue Oct 13 2009 tittiatcoke@gmail.com 
867- Update to newer svn snapshot
868- Fixed spec file in order to build
869- Included patch to build with system zlib
870* Mon Oct 12 2009 prusnak@suse.cz 
871- package renamed to chromium
872- cleaned up spec file
873* Tue Oct  6 2009 dbuck@example.com 
874- v8 is now built as a separate package, and is required
875- included many patches to use system libraries:
876    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
877* Thu Oct  1 2009 dbuck@example.com 
878- included a newer DEP than is in svn, native_client@823
879- things should compile cleanly now
880* Mon Aug 31 2009 dbuck@example.com 
881- initial build
Note: See TracBrowser for help on using the repository browser.