source: projects/specs/branches/6/c/chromium/chromium18-vl.spec @ 6066

Revision 6066, 32.5 KB checked in by munepi, 12 years ago (diff)

new upstream release

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_jpeg 1
8
9#% define with_system_icu 1
10#% define with_system_v8 1
11%define with_system_vpx 1
12
13#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
14# There's a couple key GYP variables that control how FFmpeg is built:
15#   ffmpeg_branding
16#     Controls whether we build the Chromium or Google Chrome version of
17#     FFmpeg.  The Google Chrome version contains additional codecs.
18#     Typical values are Chromium, Chrome, ChromiumOS, and ChromeOS.
19#   use_system_ffmpeg
20#     When set to non-zero will build Chromium against the system FFmpeg
21#     headers via pkg-config.  When Chromium is launched it will assume that
22#     FFmpeg is present in the system library path.  Default value is 0.
23#   build_ffmpegsumo
24#     When set to zero will build Chromium against the patched ffmpegsumo
25#     headers, but not build ffmpegsumo itself.  Users are expected to build
26#     and provide their own version of ffmpegsumo.  Default value is 1.
27%define with_system_ffmpeg 1
28
29%global chrome_sandbox %{_prefix}/lib/chrome_sandbox
30
31#Name:           chromium18
32Name:           chromium
33Summary:        Google's opens source browser project
34Summary(ja):    Googleのオープンソースウェブブラウザ
35#'
36Version:        18.0.1025.166
37Release:        1%{?_dist_release}
38License:        BSD-3-Clause, LGPL-2.1+
39Group:          Applications/Internet
40Source0:        %{pkgname}-%{version}.tar.xz
41# Script used to create the %{pkgname}-%{version}.tar.xz archive from
42# a official tarball:
43# http://gsdview.appspot.com/chromium-browser-official/chromium-18.0.1025.XXX.tar.bz2
44Source3:        pack_chromium18_source-vine.sh
45# Official ffmpeg headers
46Source8:        ffmpeg-0.6-headers.tar.xz
47#Source8:        ffmpeg-0.9-headers.tar.xz
48# Patch template which adds vendor to user agent
49##!!Source20:       chromium-vendor.patch.in
50Source20:       chromium-vendor-vine.patch.in
51# Set default prefs
52##!!Source30:       master_preferences
53Source30:       master_preferences.vine
54##!!Source31:       default_bookmarks.html
55#Source31:       default_bookmarks.html.vine
56Source99:       chrome-wrapper
57##!!Source100:      chromium-browser.sh
58Source100:      chromium-browser-vine.sh
59##!!Source101:      chromium-browser.desktop
60Source101:      chromium-browser-vine.desktop
61Source102:      chromium-browser.xml
62#Source103:      chromium-browser-rpmlintrc
63##!!Source104:      chromium-icons.tar.bz2
64
65%{?nosrc:NoSource: 0}
66
67# Provides:       chromium-unstable = %{version}-%{release}
68# Obsoletes:      chromium13 chromium14 chromium15
69# Conflicts:      chromium-stable
70Provides:       chromium-stable = %{version}-%{release}
71Conflicts:      chromium-unstable
72
73## Start Patches
74# OpenSuse and Fedora
75# Many changes to the gyp systems so we can use system libraries
76Patch1:         chromium-gcc46.patch
77Patch8:         chromium-codechanges-zlib.patch
78Patch13:        chromium-no-courgette.patch
79Patch14:        chromium-master-prefs-path.patch
80Patch17:        chromium-system-glew.patch
81Patch18:        chromium-system-expat.patch
82Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
83Patch25:        tcmalloc-factory.patch
84Patch26:        chromium-remoting-build-fix.diff
85Patch28:        chromium-7.0.500.0-system-speex.patch
86Patch32:        chromium-7.0.542.0-system-libvpx.patch
87Patch62:        chromium-norpath.patch
88Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
89Patch64:        chromium-more-codec-aliases.patch
90#Patch65:        chromium-new-glib.patch
91Patch66:        chromium-sandbox-pie.patch
92
93# Vine
94#Patch100:       chromium-15.0.874.116-no-tests.patch
95
96
97##!!BuildRequires:  Mesa-devel
98BuildRequires:  mesa-libGLU-devel
99##!!BuildRequires:  alsa-devel
100BuildRequires:  alsa-lib-devel
101BuildRequires:  pulseaudio-libs-devel
102BuildRequires:  bison
103BuildRequires:  cups-devel
104BuildRequires:  desktop-file-utils
105BuildRequires:  fdupes
106BuildRequires:  flex
107BuildRequires:  freetype2-devel
108BuildRequires:  gcc
109BuildRequires:  gcc-c++
110BuildRequires:  gperf
111BuildRequires:  hunspell-devel
112##!!BuildRequires:  libbz2-devel
113BuildRequires:  bzip2-devel
114BuildRequires:  libevent
115##!!BuildRequires:  libexpat-devel
116BuildRequires:  expat-devel
117##!!BuildRequires:  libgnutls-devel
118BuildRequires:  gnutls-devel
119%{?with_system_jpeg:BuildRequires:  libjpeg-devel}
120BuildRequires:  libpng-devel
121BuildRequires:  libstdc++-devel >= 4.4
122%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
123BuildRequires:  libxslt-devel
124BuildRequires:  libzip-devel
125##!!BuildRequires:  lzma
126BuildRequires:  xz
127##!!BuildRequires:  mozilla-nspr-devel
128BuildRequires:  nspr-devel
129##!!BuildRequires:  mozilla-nss-devel
130BuildRequires:  nss-devel
131BuildRequires:  krb5-devel
132BuildRequires:  openssl-devel
133BuildRequires:  pam-devel
134##!!BuildRequires:  pkg-config
135##!!BuildRequires:  perl(Switch)
136BuildRequires:  perl
137BuildRequires:  cairo-devel >= 1.6
138BuildRequires:  dbus-devel
139BuildRequires:  dbus-glib-devel
140##!!BuildRequires:  gconf2-devel
141BuildRequires:  GConf2-devel
142BuildRequires:  glib2-devel
143BuildRequires:  gtk2-devel
144BuildRequires:  libxml2-devel
145BuildRequires:  python
146##!!BuildRequires:  python-xml
147BuildRequires:  python-pyxml
148BuildRequires:  sqlite3-devel
149##!!BuildRequires:  update-desktop-files
150%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
151##!!BuildRequires:  wdiff
152BuildRequires:  zlib-devel
153##!!BuildRequires:  libpulse-devel
154BuildRequires:  pulseaudio-libs-devel
155##!!BuildRequires:  libelf-devel
156BuildRequires:  elfutils-libelf-devel
157BuildRequires:  libgnome-keyring-devel
158BuildRequires:  python-devel
159#BuildRequires:  glew-devel
160BuildRequires:  libevent-devel
161%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
162#BuildRequires:  libjingle-devel >= 0.4.0-7
163#BuildRequires:  srtp-devel
164BuildRequires:  speex-devel
165BuildRequires:  libudev-devel
166
167##Vine Linux
168#BuildRequires:  libpaper-devel
169BuildRequires:  libXScrnSaver-devel
170BuildRequires:  libXtst-devel
171BuildRequires:  libXdamage-devel
172BuildRequires:  libXt-devel
173%ifarch x86_64
174Requires:  nspluginwrapper
175%endif
176
177##!!Requires:       alsa
178Requires:       alsa-lib
179Requires:       pulseaudio-libs
180Requires:       xdg-utils
181%{?with_system_v8:Requires:       v8 = %{v8_ver}}
182
183BuildRoot:      %{_tmppath}/%{name}-%{version}-root
184
185%description
186Chromium is the open-source project behind Google Chrome.
187We invite you to join us in our effort to help build a safer, faster,
188and more stable way for all Internet users to experience the web,
189and to create a powerful platform for developing a new generation of
190web applications.
191
192%description -l ja
193Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
194ウェブを体験しているすべてのインターネットユーザに対して
195より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
196そして、ウェブアプリケーションの新しい世代を発展させ、
197強力なプラットホームを作成するために、
198私たちの取り組みにぜひ参加してください。
199
200
201%prep
202#%setup -q
203[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
204xz -dc %{SOURCE0} | %__tar -xf - || exit 1
205%setup -D -T -n %{pkgname}-%{version}
206
207%if %{?_dist_release} == "vl7"
208%patch1 -p1
209%endif
210%patch62 -p1
211%{?with_system_v8:%patch63 -p1}
212%patch64
213#%patch65 -p1
214#%patch100 -p1 -b .vine
215%patch8 -p1
216%patch13 -p1
217%patch14 -p1
218%patch17 -p1
219%patch18 -p1
220%patch20 -p1
221#%patch25 -p1
222%patch26 -p1
223%patch28 -p1
224%{?with_system_vpx:%patch32 -p1}
225%patch66 -p1
226
227
228pushd src/third_party/ffmpeg/
229%__tar xf %{SOURCE8} || exit 1
230## built header file: avconfig.h
231[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
232cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
233/* Generated by ffconf */
234#ifndef AVUTIL_AVCONFIG_H
235#define AVUTIL_AVCONFIG_H
236#define AV_HAVE_BIGENDIAN 0
237#define AV_HAVE_FAST_UNALIGNED 1
238#endif /* AVUTIL_AVCONFIG_H */
239EOF
240popd
241
242# apply vendor patch after substitution
243%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
244
245# Make sure that the requires legal files can be found
246%__cp -a src/AUTHORS src/LICENSE . || exit 1
247
248%build
249
250## create make files
251
252PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
253for i in src/build/common.gypi; do
254        %__sed -i "s|'-march=pentium4',||g" $i
255        %__sed -i "s|'-mfpmath=sse',||g" $i
256        %__sed -i "s|'-O<(debug_optimize)',||g" $i
257        %__sed -i "s|'-m32',||g" $i
258        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
259        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
260done
261# '
262
263pushd src
264
265./build/gyp_chromium -f make build/all.gyp \
266    -Dlinux_sandbox_path=%{chrome_sandbox} \
267    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium \
268    -Duse_openssl=0 \
269    %{?with_system_ffmpeg:-Duse_system_ffmpeg=1} \
270    %{!?with_system_ffmpeg:-Duse_system_ffmpeg=0} \
271    -Dbuild_ffmpegsumo=0 \
272    -Duse_system_zlib=1 \
273    -Duse_system_libpng=1 \
274    -Duse_system_bzip2=1 \
275    -Duse_system_libbz2=1 \
276    %{?with_system_jpeg:-Duse_system_libjpeg=1} \
277    %{!?with_system_jpeg:-Duse_system_libjpeg=0} \
278    -Duse_system_libxml=1 \
279    -Duse_system_libxslt=1 \
280    -Duse_system_libevent=1 \
281    %{?with_system_vpx:-Duse_system_vpx=1} \
282    %{!?with_system_vpx:-Duse_system_vpx=0} \
283    -Dremove_webcore_debug_symbols=1 \
284    %{?with_system_v8:-Duse_system_v8=1} \
285    %{!?with_system_v8:-Duse_system_v8=0} \
286    %{?with_system_icu:-Duse_system_icu=1} \
287    %{!?with_system_icu:-Duse_system_icu=0} \
288    %{?_with_shared_library:-Dlibrary=shared_library} \
289    -Dproprietary_codecs=1 \
290    -Ddisable_nacl=1 \
291    -Djavascript_engine=v8 \
292    -Dlinux_fpic=1 \
293    -Ddisable_sse2=1 \
294    %ifarch %{ix86}
295        -Dtarget_arch=ia32 \
296    %endif
297    %ifarch x86_64
298        -Dtarget_arch=x64 \
299    %endif
300    -Dno_strict_aliasing=1 \
301    -Drelease_extra_cflags=-fPIC \
302    %if %{?_dist_release} == "vl6"
303        -Dgcc_version=44 \
304    %endif
305    ;
306
307%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release disable_nacl=1
308
309# Build the required SUID_SANDBOX helper
310%__make -r %{?_smp_mflags} chrome_sandbox V=1 BUILDTYPE=Release disable_nacl=1
311
312popd
313
314%install
315%{__rm} -rf %{buildroot}
316
317%__mkdir -p %{buildroot}%{_bindir}
318%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
319%ifarch x86_64
320mkdir -p %{buildroot}%{_prefix}/lib/
321%endif
322# x86_64 capable systems need this
323%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
324%__mkdir -p %{buildroot}%{_libdir}/chromium/
325%__mkdir -p %{buildroot}%{_mandir}/man1/
326pushd src/out/Release
327%__cp -a chrome_sandbox %{buildroot}%{_prefix}/lib/
328%__cp -a chrome.pak locales resources xdg-mime xdg-settings %{buildroot}%{_libdir}/chromium/
329%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
330%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
331%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
332%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
333%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
334%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
335fdupes %{buildroot}%{_mandir}/man1/
336popd
337
338%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
339%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
340for i in 16 22 24 32 48 64 128 256; do
341    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
342    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
343done
344
345%__mkdir_p %{buildroot}%{_datadir}/applications/
346desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
347
348%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
349%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
350
351# # link to browser plugin path.  Plugin patch doesn't work. Why?
352# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
353# pushd %{buildroot}%{_libdir}/%{pkgname}
354# %{__ln_s} %{_libdir}/browser-plugins plugins
355# popd
356pushd %{buildroot}%{_libdir}/%{pkgname}
357%ifarch x86_64
358%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
359%else
360%{__ln_s} %{_libdir}/mozilla/plugins plugins
361%endif
362popd
363
364# Install the master_preferences file
365%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
366#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
367%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
368#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
369
370%clean
371%{__rm} -rf %{buildroot}
372
373%post
374touch --no-create %{_datadir}/icons/hicolor
375if [ -x %{_bindir}/gtk-update-icon-cache ]; then
376  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
377fi
378%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
379
380%postun
381%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
382touch --no-create %{_datadir}/icons/hicolor
383if [ -x %{_bindir}/gtk-update-icon-cache ]; then
384  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
385fi || :
386
387
388%files
389%defattr(-,root,root,-)
390%config %{_sysconfdir}/%{pkgname}
391%dir %{_datadir}/gnome-control-center
392%dir %{_datadir}/gnome-control-center/default-apps
393%dir %{_libdir}/chromium/
394%{_bindir}/chromium
395%{_libdir}/chromium/chromium
396%{_libdir}/chromium/plugins/
397%{_libdir}/chromium/resources/
398%attr(755,root,root) %{_libdir}/chromium/xdg-settings
399%attr(755,root,root) %{_libdir}/chromium/xdg-mime
400%{_mandir}/man1/chrom*
401%{_datadir}/pixmaps/chromium-browser.png
402%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
403%{_datadir}/applications/*.desktop
404%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
405#%{_datadir}/icons/oxygen/
406%{_libdir}/chromium/chrome.pak
407%{_libdir}/chromium/resources.pak
408%{_libdir}/chromium/locales/
409%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
410%attr(4755,root,root) %{chrome_sandbox}
411
412%changelog
413* Sat Apr 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.166-1
414- updated to 18.0.1025.166
415
416* Sat Apr 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.163-1
417- updated to 18.0.1025.163
418
419* Tue Apr  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.148-1
420- updated to 18.0.1025.148
421
422* Wed Mar 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.145-1
423- updated to 18.0.1025.145
424
425* Sun Mar 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.140-1
426- updated to 18.0.1025.140
427
428* Thu Mar 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.130-1
429- updated to 18.0.1025.130
430
431* Tue Mar 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.114-1
432- updated to 18.0.1025.114
433
434* Tue Mar 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.81-1
435- updated to 17.0.963.81
436
437* Fri Mar  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.78-1
438- updated to 17.0.963.78
439
440* Sat Mar  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.65-1
441- updated to 17.0.963.65
442
443* Wed Feb 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.60-1
444- updated to 17.0.963.60
445
446* Fri Feb 17 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.57-1
447- updated to 17.0.963.57
448
449* Sun Feb 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.54-1
450- updated to 17.0.963.54
451
452* Sat Feb 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.52-1
453- updated to 17.0.963.52
454
455* Sat Feb  4 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.77-1
456- updated to 16.0.912.77
457
458* Sun Jan  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.75-1
459- updated to 16.0.912.75
460
461* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.63-1
462- updated to 16.0.912.63
463
464* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.57-1
465- updated to 16.0.912.57
466
467* Sat Oct 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 15.0.874.116-1
468- updated to 15.0.874.116
469
470* Wed Oct 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.204-1
471- updated to 14.0.835.204
472- added BuildRequires: dbus-glib-devel
473
474* Sat Sep 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.186-1
475- updated to 14.0.835.186
476
477* Sun Sep 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.163-1
478- updated to 14.0.835.163
479
480* Tue Sep 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.157-1
481- updated to 14.0.835.157
482
483* Sat Aug 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.102-1
484- updated to 14.0.835.102
485
486* Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
487- updated to 14.0.835.89
488- added Obsoletes: chromium-unstable < %{version}-%{release}
489
490* Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
491- updated to 14.0.835.35
492- added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
493- changed to Name: chromium14
494  - Provides:  chromium-unstable = %%{version}
495  - Conflicts: chromium-stable
496
497* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
498- changed to Name: chromium
499- updated to 13.0.782.107
500
501* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
502- updated to 13.0.782.88
503- added BuildRequires: libzip-devel
504- added Provides: chromium-unstable = %%{version}
505- added Conflicts: chromium-stable
506
507* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
508- fix user-agent string (chromium-vendor-vine.patch.in)
509  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
510
511* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
512- updated to 12.0.742.93
513- fixed icon field of chromium-browser-vine.desktop
514
515* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
516- updated to 12.0.742.91
517
518* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
519- updated to 12.0.742.77
520
521* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
522- updated to 12.0.742.63
523
524* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
525- updated to 12.0.742.42
526
527* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
528- updated to 12.0.742.6
529- dropped/upstreamed patches
530- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
531
532* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
533- updated to 11.0.696.50
534- dropped some Patches for MeeGo Netbook
535
536* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
537- updated to 11.0.696.35
538
539* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
540- updated to 11.0.696.29
541- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
542
543* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
544- updated to 11.0.696.22
545- improved chromium-browser-vine.sh
546  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
547
548* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
549- updated to 11.0.696.20
550- improved chromium-browser-vine.desktop
551
552* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
553- updated to 11.0.696.17
554
555* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
556- updated to 11.0.696.15
557  - ready for Vine Linux 6 release
558- dropped BuildRequires: v8-devel, libicu-devel
559
560* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
561- updated to 11.0.696.5 with v8 3.2.0
562- added BuildRequires: pam-devel
563
564* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
565- rebuilt with libevent-2.0.10
566
567* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
568- updated to 10.0.651.0 with v8 3.0.12
569- added BuildRequires:
570  - libpaper-devel
571  - python-devel
572- added built header file: libavutil/avconfig.h %%prep
573- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
574
575* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
576- updated to 10.0.622.0
577- added BuildRequires: libXt-devel
578
579* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
580- updated to 10.0.605.0
581- added BuildRequires:
582  - libXdamage-devel
583  - hunspell-devel
584
585* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
586- updated to 9.0.598
587
588* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
589- updated to 9.0.593
590
591* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
592- updated to 9.0.582
593- added Requires: xdg-utils
594
595* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
596- updated to 9.0.578
597
598* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
599- updated to 9.0.569
600
601  * Mon Oct 25 2010 tittiatcoke@gmail.com
602  - Update to 9.0.564 build
603    * Added specific patches for MeeGo.
604    * We are now using shared libraries for Chromium
605    * Spec-file cleanup (Thanks to prusnak)
606
607* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
608- updated to snapshot 8.0.556
609
610* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
611- updated to snapshot 8.0.551
612
613* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
614- updated to snapshot 7.0.527
615
616* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
617- updated to snapshot 7.0.519
618
619* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
620- updated to snapshot 7.0.513
621  - updated chromium-vendor-vine.patch.in
622
623* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
624- updated to snapshot 7.0.507
625
626* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
627- updated to snapshot 7.0.498
628
629* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
630- updated to snapshot 6.0.493
631- used with_system_icu (for vl6)
632  - added BuildRequires: libicu-devel
633
634* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
635- build for Vine Linux 5.x
636  - add BuildRequires: gnome-keyring-devel
637
638* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
639- updated to snapshot 6.0.454
640- added BuildRequires:
641  - sqlite3-devel
642  - gnutls-devel
643  - libgnome-keyring-devel
644
645* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
646- updated to snapshot 6.0.431.0 r49253
647- added BuildRequires: cups-devel
648
649* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
650- updated to snapshot 6.0.405.0 r47263
651
652* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
653- unused with_system_icu (for vl6)
654  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
655
656* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
657- updated to snapshot 5.0.378.0 r44472
658  - used with_system_icu (for vl6)
659  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
660
661* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
662- updated to snapshot 5.0.372.0 r43947
663- added BuildRequires: glew-devel
664- changed Group tag to Applications/Internet
665- added Summary(ja) and %%description -l ja
666
667* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
668- updated to snapshot 5.0.365.0 r42966
669- merged 5.0.353.0-4vl5
670 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
671 - build on Vine Linux 5.1
672   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
673
674* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
675- updated to snapshot 5.0.364.0 r42779
676
677* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
678- updated to snapshot 5.0.359.0 r42116
679- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
680
681* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
682- fixed master_preferences.vine, little
683
684* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
685- fixed to install master_preferences
686- dropped chromium-5.0.353-no-ffmpeg-vine.patch
687
688* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
689- applied chromium-5.0.353-no-ffmpeg-vine.patch
690
691* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
692- updated to snapshot 5.0.353.0 r41449
693  * Wed Mar 10 2010 bgmerrell@novell.com
694  - Add master_preferences source file and install it to /etc/chromium.
695  - Create a new patch (chromium-master-prefs-path.patch) which tells
696    chromium to look in /etc/chromium for the master_preferences file
697    (instead of looking in the default directory, which is the same
698    directory as the 'chrome' binary).
699
700* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
701- updated to snapshot 5.0.335.0 r39556
702
703* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
704- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
705
706* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
707- updated to snapshot 5.0.330.0 r39074
708
709* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
710- use_system_ffmpeg
711
712* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
713- added Requires:  nspluginwrapper
714- fixed a symbolic link of plugins directory with nspluginwrapper
715
716* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
717- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
718
719* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
720- added BuildRequires: mesa-libGLU-devel
721- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
722
723* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
724- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
725
726  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
727  - Update to 4.0.260
728  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
729  - Update to 4.0.259
730  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
731  - Update to 4.0.258
732  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
733  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
734    changed to having an built-in v8
735  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
736  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
737  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
738  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
739  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
740  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
741  - update to newer svn snapshot
742    + Obsoletes fwrite patch (included upstream)
743  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
744  - update to newer svn snapshot
745    + Requires newer version of v8
746  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
747  - do not force SSE on x86 (drop-sse.patch)
748  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
749  - Update to newer svn snapshot
750  - Fixed spec file in order to build
751  - Included patch to build with system zlib
752  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
753  - package renamed to chromium
754  - cleaned up spec file
755  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
756  - v8 is now built as a separate package, and is required
757  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
758  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
759  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
760  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
761  - initial build
762
763#% changelog
764* Sun Jan 24 2010 prusnak@suse.cz
765- added vendor to user agent (chromium-vendor.patch.in)
766* Sun Nov 29 2009 prusnak@suse.cz
767- added --enable-sync to wrapper to enable bookmark sync
768* Sun Nov 29 2009 tittiatcoke@gmail.com 
769- Update to 4.0.260
770* Fri Nov 27 2009 tittiatcoke@gmail.com 
771- Update to 4.0.259
772* Thu Nov 26 2009 tittiatcoke@gmail.com 
773- Update to 4.0.258
774* Tue Nov 24 2009 tittatcoke@gmai.com 
775- In order to complete prevent the wrong v8 version to be used,
776  the Chromium build has been changed to having an built-in v8
777* Tue Nov 24 2009 dbuck@example.com 
778- Re-base patches.
779- Fixed a few patch errors.
780- Rename some patches to better correspond with function.
781- Removed some patches.
782- Minor SPEC changes.
783- I changed the v8 requirement to be exact, instead of greater than a specific version.
784* Fri Nov 13 2009 tittiatcoke@gmail.com
785- update to 247.0 svn 31928
786* Fri Oct 30 2009 tittiatcoke@gmail.com
787- update to 229.0 svn 30454
788  + Fix regression where popups and app frames lost their titlebars.
789  + Makes it so that when a folder is open on the bookmark bar
790    and the mouse moves over another folder, the menu for that
791    folder is shown.
792  + Lazily create the find bar.
793  + Polish to the gmail checker sample.
794  * New, crisper icons that are exactly 19x19
795  * Add a loading animation at the beginning before Gmail
796    responds.
797  * Fix a bug where we sometimes don't update the UI after a
798    logout/login cycle.
799  + Refactor widget methods to support desktop notifications,
800    including GTK stubs.
801  + Find-in-page should not ding while deleting characters.
802  + Add SSL wrapper for linux and mac.  This allows notifier to
803    use chrome's SSL layer instead of OpenSSL.
804  + Add three of the six extensions to PAC that Internet Explorer supports.
805  + WebSocket support in chromium. (Run with --enable-web-sockets
806    enables WebSocket features.)
807  + Do not allow GTK File Chooser dialogs to return directories.
808  + Fix the notifier SSL layer to make notifications work for
809    Linux Bookmark sync.
810  + linux: don't override mouse selection behavior in omnibox
811* Sun Oct 25 2009 tittiatcoke@gmail.com
812- Update to 224.4 svn 30027
813  + First cut at new page and browser action docs based
814    on new API. Deleted old stuff.
815  + Add suppression for new memory leak caused by WebKit merge 49830:49844
816  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
817  + Minimize dependency of user scripts
818  + Fixup the flip_framer eof-handling semantics now that we have
819    the FIN bit in place
820  + app depends on x11 because of active_window_watcher_x
821  + Adding two images for the new Extension managment UI
822  + Removing hard-coded Chrome Frame output path
823  + Rearrange clipboard code
824  + Fix crash bug when attempting to download a url with unsupported scheme,
825    e.g. 'data:', by 'Alt + Click'
826  + GTK: Change text for extension download UI
827  + Ignore invalid urls on command line
828  + Make dropped tabs animate from where they were dropped.
829  + Make room for the full width of the tab placeholder.
830  + Make tab dragging as smooth as glass.
831  + Remove an annoying NOTIMPLEMNETED
832  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
833  + If we're in the middle of a drag, don't allow the user to middle
834    click to close or right click for the context menu
835  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
836  + Remove +x bit from files that shouldn't have it
837  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
838  + Adding new image needed for the managment UI
839  + Fix a race bug where content scripts would not apply to the first page load
840  + Make escape remove a bookmark if it's just been added (but not if it already existed)
841  + Fix bubbles deactivating the opaque frame
842  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
843  + ake all pepper plugins default to windowless and transparent
844  + Add styles for printing
845  + Implement the new extension management UI
846  + Add support for to automation interface load install and load extensions
847  + GTK: theme the info bar border
848  + Update V8 to version 1.3.16.1
849  + Introduce WebSecurityPolicy for security related methods
850  + New button scheme...borders are separate from the inner contents so
851    that they can be highlighted / depressed independently
852  + When opening Chrome maximized with an application window already
853    running, the Chrome window was not activated
854  + Fix compatibility problems with FileZilla FTP Server
855  + Remove the extension shelf on Linux
856  + Fix the proxy host and port string to start with http:// if it does not already
857  + Enable HTML5 databases for all extension renderer processes
858* Sat Oct 24 2009 prusnak@opensuse.org 
859- don't create desktop files in wrapper
860- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
861* Tue Oct 20 2009 tittiatcoke@gmail.com 
862- update to newer svn snapshot
863  + Obsoletes fwrite patch (included upstream)
864* Fri Oct 16 2009 tittiatcoke@gmail.com 
865- update to newer svn snapshot
866  + Requires newer version of v8
867* Thu Oct 15 2009 prusnak@suse.cz 
868- do not force SSE on x86 (drop-sse.patch)
869* Tue Oct 13 2009 tittiatcoke@gmail.com 
870- Update to newer svn snapshot
871- Fixed spec file in order to build
872- Included patch to build with system zlib
873* Mon Oct 12 2009 prusnak@suse.cz 
874- package renamed to chromium
875- cleaned up spec file
876* Tue Oct  6 2009 dbuck@example.com 
877- v8 is now built as a separate package, and is required
878- included many patches to use system libraries:
879    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
880* Thu Oct  1 2009 dbuck@example.com 
881- included a newer DEP than is in svn, native_client@823
882- things should compile cleanly now
883* Mon Aug 31 2009 dbuck@example.com 
884- initial build
Note: See TracBrowser for help on using the repository browser.