source: projects/specs/branches/6/c/chromium/chromium16-vl.spec @ 5379

Revision 5379, 30.9 KB checked in by munepi, 12 years ago (diff)

updated chromium16-vl.spec

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_icu 1
8#% define with_system_v8 1
9
10#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
11#     libvpx doesn't currently supply a pkg-config file, so we assume that
12#     -lvpx is sufficient.
13%define with_system_vpx 1
14
15%global chrome_sandbox %{_prefix}/lib/chrome_sandbox
16
17#Name:           chromium16
18Name:           chromium
19Summary:        Google's opens source browser project
20Summary(ja):    Googleのオープンソースウェブブラウザ
21#'
22Version:        16.0.912.75
23Release:        1%{?_dist_release}
24License:        BSD
25Group:          Applications/Internet
26Source0:        %{pkgname}-%{version}.tar.xz
27# Script used to create the %{pkgname}-%{version}.tar.xz archive from
28# a official tarball:
29# http://gsdview.appspot.com/chromium-browser-official/chromium-16.0.910.XXX.tar.bz2
30Source3:        pack_chromium16_source-vine.sh
31# Official ffmpeg headers
32#Source8:        ffmpeg-0.6-headers.tar.xz
33Source8:        ffmpeg-0.9-headers.tar.xz
34# Patch template which adds vendor to user agent
35##!!Source20:       chromium-vendor.patch.in
36Source20:       chromium-vendor-vine.patch.in
37# Set default prefs
38##!!Source30:       master_preferences
39Source30:       master_preferences.vine
40##!!Source31:       default_bookmarks.html
41#Source31:       default_bookmarks.html.vine
42Source99:       chrome-wrapper
43##!!Source100:      chromium-browser.sh
44Source100:      chromium-browser-vine.sh
45##!!Source101:      chromium-browser.desktop
46Source101:      chromium-browser-vine.desktop
47Source102:      chromium-browser.xml
48#Source103:      chromium-browser-rpmlintrc
49##!!Source104:      chromium-icons.tar.bz2
50
51%{?nosrc:NoSource: 0}
52
53# Provides:       chromium-unstable = %{version}-%{release}
54# Obsoletes:      chromium13 chromium14 chromium15
55# Conflicts:      chromium-stable
56Provides:       chromium-stable = %{version}-%{release}
57Conflicts:      chromium-unstable
58
59## Start Patches
60# OpenSuse and Fedora
61# Many changes to the gyp systems so we can use system libraries
62Patch1:         chromium-gcc46.patch
63Patch4:         chromium-no-sqlite-debug.patch
64Patch8:         chromium-codechanges-zlib.patch
65#Patch12:        chromium-no-test-sources.patch
66Patch13:        chromium-no-courgette.patch
67Patch14:        chromium-master-prefs-path.patch
68Patch17:        chromium-system-glew.patch
69Patch18:        chromium-system-expat.patch
70#Patch19:        chromium-system-zlib.patch
71#Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
72#Patch20:        chromium-16.0.912.63-ffmpeg-no-pkgconfig.patch
73Patch20:        chromium-16.0.912.63-ffmpeg-0.9-no-pkgconfig.patch
74Patch21:        chromium-7.0.542.0-media-probe.patch
75Patch25:        tcmalloc-factory.patch
76Patch26:        chromium-remoting-build-fix.diff
77Patch28:        chromium-7.0.500.0-system-speex.patch
78#Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
79Patch32:        chromium-7.0.542.0-system-libvpx.patch
80#Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
81Patch62:        chromium-norpath.patch
82Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
83
84# Vine
85#Patch100:       chromium-15.0.874.116-no-tests.patch
86
87
88##!!BuildRequires:  Mesa-devel
89BuildRequires:  mesa-libGLU-devel
90##!!BuildRequires:  alsa-devel
91BuildRequires:  alsa-lib-devel
92BuildRequires:  pulseaudio-libs-devel
93BuildRequires:  bison
94BuildRequires:  cups-devel
95BuildRequires:  desktop-file-utils
96BuildRequires:  fdupes
97BuildRequires:  flex
98BuildRequires:  freetype2-devel
99BuildRequires:  gcc gcc-c++
100BuildRequires:  gperf
101BuildRequires:  hunspell-devel
102##!!BuildRequires:  libbz2-devel
103BuildRequires:  bzip2-devel
104BuildRequires:  libevent
105##!!BuildRequires:  libexpat-devel
106BuildRequires:  expat-devel
107##!!BuildRequires:  libgnutls-devel
108BuildRequires:  gnutls-devel
109BuildRequires:  libjpeg-devel
110BuildRequires:  libpng-devel
111BuildRequires:  libstdc++-devel >= 4.4
112%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
113BuildRequires:  libxslt-devel
114BuildRequires:  libzip-devel
115##!!BuildRequires:  lzma
116BuildRequires:  xz
117##!!BuildRequires:  mozilla-nspr-devel
118BuildRequires:  nspr-devel
119##!!BuildRequires:  mozilla-nss-devel
120BuildRequires:  nss-devel
121BuildRequires:  openssl-devel
122BuildRequires:  pam-devel
123##!!BuildRequires:  perl(Switch)
124BuildRequires:  perl
125##!!BuildRequires:  pkg-config
126BuildRequires:  cairo-devel >= 1.6
127BuildRequires:  dbus-devel
128BuildRequires:  dbus-glib-devel
129##!!BuildRequires:  gconf2-devel
130BuildRequires:  GConf2-devel
131BuildRequires:  glib2-devel
132BuildRequires:  gtk2-devel
133BuildRequires:  libxml2-devel
134BuildRequires:  python
135##!!BuildRequires:  python-xml
136BuildRequires:  python-pyxml
137BuildRequires:  sqlite3-devel
138##!!BuildRequires:  update-desktop-files
139%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
140##!!BuildRequires:  wdiff
141BuildRequires:  zlib-devel
142
143BuildRequires:  libgnome-keyring-devel
144BuildRequires:  python-devel
145
146#BuildRequires:  glew-devel
147BuildRequires:  libevent-devel
148%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
149#BuildRequires:  libjingle-devel >= 0.4.0-7
150#BuildRequires:  srtp-devel
151BuildRequires:  speex-devel
152
153##Vine Linux
154#BuildRequires:  libpaper-devel
155BuildRequires:  libXScrnSaver-devel
156BuildRequires:  libXtst-devel
157BuildRequires:  libXdamage-devel
158BuildRequires:  libXt-devel
159%ifarch x86_64
160Requires:  nspluginwrapper
161%endif
162
163##!!Requires:       alsa
164Requires:       alsa-lib
165Requires:       pulseaudio-libs
166Requires:       xdg-utils
167%{?with_system_v8:Requires:       v8 = %{v8_ver}}
168
169BuildRoot:      %{_tmppath}/%{name}-%{version}-root
170
171%description
172Chromium is the open-source project behind Google Chrome.
173We invite you to join us in our effort to help build a safer, faster,
174and more stable way for all Internet users to experience the web,
175and to create a powerful platform for developing a new generation of
176web applications.
177
178%description -l ja
179Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
180ウェブを体験しているすべてのインターネットユーザに対して
181より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
182そして、ウェブアプリケーションの新しい世代を発展させ、
183強力なプラットホームを作成するために、
184私たちの取り組みにぜひ参加してください。
185
186
187%prep
188#%setup -q
189[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
190xz -dc %{SOURCE0} | %__tar -xf - || exit 1
191%setup -D -T -n %{pkgname}-%{version}
192
193%if %{?_dist_release} == "vl7"
194%patch1 -p1
195%endif
196%patch62 -p1
197%{?with_system_v8:%patch63 -p1}
198#%patch100 -p1 -b .vine
199%patch8 -p1
200#%patch12 -p1
201%patch13 -p1
202%patch14 -p1
203%patch17 -p1
204%patch18 -p1
205#%patch19 -p1
206%patch20 -p1
207%patch21 -p1
208%patch25 -p1
209%patch26 -p1
210%patch28 -p1
211#%patch29 -p1
212%{?with_system_vpx:%patch32 -p1}
213%{?with_system_v8:%patch34 -p1}
214%patch4 -p1
215
216
217pushd src/third_party/ffmpeg/
218%__tar xf %{SOURCE8} || exit 1
219## built header file: avconfig.h
220[ -f ffmpeg-0.9-headers/libavutil/avconfig.h ] && exit 1
221cat > ffmpeg-0.9-headers/libavutil/avconfig.h <<EOF
222/* Generated by ffconf */
223#ifndef AVUTIL_AVCONFIG_H
224#define AVUTIL_AVCONFIG_H
225#define AV_HAVE_BIGENDIAN 0
226#define AV_HAVE_FAST_UNALIGNED 1
227#endif /* AVUTIL_AVCONFIG_H */
228EOF
229popd
230
231#%__rm -rf src/third_party/libvpx/
232%__rm -rf src/third_party/speex/
233%__rm -rf src/third_party/nss src/third_party/nspr
234
235# apply vendor patch after substitution
236%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
237
238# Make sure that the requires legal files can be found
239%__cp -a src/AUTHORS src/LICENSE . || exit 1
240
241%build
242
243## create make files
244
245PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
246for i in src/build/common.gypi; do
247        %__sed -i "s|'-march=pentium4',||g" $i
248        %__sed -i "s|'-mfpmath=sse',||g" $i
249        %__sed -i "s|'-O<(debug_optimize)',||g" $i
250        %__sed -i "s|'-m32',||g" $i
251        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
252        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
253done
254# '
255
256pushd src
257
258./build/gyp_chromium -f make build/all.gyp \
259    -Dlinux_sandbox_path=%{chrome_sandbox} \
260    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium \
261    -Duse_openssl=0 \
262    -Duse_system_ffmpeg=1 \
263    -Duse_system_zlib=1 \
264    -Duse_system_libpng=1 \
265    -Duse_system_bzip2=1 \
266    -Duse_system_libbz2=1 \
267    -Duse_system_libjpeg=1 \
268    -Duse_system_libxml=1 \
269    -Duse_system_libxslt=1 \
270    -Duse_system_libevent=1 \
271    %{?with_system_vpx:-Duse_system_vpx=1} \
272    %{!?with_system_vpx:-Duse_system_vpx=0} \
273    -Dremove_webcore_debug_symbols=1 \
274    %{?with_system_v8:-Duse_system_v8=1} \
275    %{!?with_system_v8:-Duse_system_v8=0} \
276    %{?with_system_icu:-Duse_system_icu=1} \
277    %{!?with_system_icu:-Duse_system_icu=0} \
278    %{?_with_shared_library:-Dlibrary=shared_library} \
279    -Dproprietary_codecs=1 \
280    -Ddisable_nacl=1 \
281    -Djavascript_engine=v8 \
282    -Dlinux_fpic=1 \
283    -Ddisable_sse2=1 \
284    %ifarch %{ix86}
285        -Dtarget_arch=ia32 \
286    %endif
287    %ifarch x86_64
288        -Dtarget_arch=x64 \
289    %endif
290    -Dno_strict_aliasing=1 \
291    -Drelease_extra_cflags=-fPIC \
292    %if %{?_dist_release} == "vl6"
293        -Dgcc_version=44 \
294    %endif
295    ;
296
297%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release disable_nacl=1
298
299# Build the required SUID_SANDBOX helper
300%__make -r %{?_smp_mflags} chrome_sandbox V=1 BUILDTYPE=Release disable_nacl=1
301
302popd
303
304%install
305%{__rm} -rf %{buildroot}
306
307%__mkdir -p %{buildroot}%{_bindir}
308%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
309%ifarch x86_64
310mkdir -p %{buildroot}%{_prefix}/lib/
311%endif
312# x86_64 capable systems need this
313%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
314%__mkdir -p %{buildroot}%{_libdir}/chromium/
315%__mkdir -p %{buildroot}%{_mandir}/man1/
316pushd src/out/Release
317%__cp -a chrome_sandbox %{buildroot}%{_prefix}/lib/
318%__cp -a chrome.pak locales resources xdg-mime xdg-settings %{buildroot}%{_libdir}/chromium/
319%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
320%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
321%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
322%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
323%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
324%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
325fdupes %{buildroot}%{_mandir}/man1/
326popd
327
328%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
329%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
330for i in 16 22 24 32 48 64 128 256; do
331    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
332    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
333done
334
335%__mkdir_p %{buildroot}%{_datadir}/applications/
336desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
337
338%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
339%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
340
341# # link to browser plugin path.  Plugin patch doesn't work. Why?
342# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
343# pushd %{buildroot}%{_libdir}/%{pkgname}
344# %{__ln_s} %{_libdir}/browser-plugins plugins
345# popd
346pushd %{buildroot}%{_libdir}/%{pkgname}
347%ifarch x86_64
348%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
349%else
350%{__ln_s} %{_libdir}/mozilla/plugins plugins
351%endif
352
353## support ffmpeg libs
354touch %{buildroot}%{_libdir}/libavcodec.so.52
355%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
356touch %{buildroot}%{_libdir}/libavformat.so.52
357%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
358touch %{buildroot}%{_libdir}/libavutil.so.50
359%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
360popd
361
362# Install the master_preferences file
363%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
364#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
365%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
366#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
367
368%clean
369%{__rm} -rf %{buildroot}
370
371%post
372touch --no-create %{_datadir}/icons/hicolor
373if [ -x %{_bindir}/gtk-update-icon-cache ]; then
374  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
375fi
376%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
377
378%postun
379%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
380touch --no-create %{_datadir}/icons/hicolor
381if [ -x %{_bindir}/gtk-update-icon-cache ]; then
382  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
383fi || :
384
385
386%files
387%defattr(-,root,root,-)
388%config %{_sysconfdir}/%{pkgname}
389%dir %{_datadir}/gnome-control-center
390%dir %{_datadir}/gnome-control-center/default-apps
391%dir %{_libdir}/chromium/
392%{_bindir}/chromium
393%{_libdir}/chromium/chromium
394%{_libdir}/chromium/plugins/
395%{_libdir}/chromium/resources/
396%attr(755,root,root) %{_libdir}/chromium/xdg-settings
397%attr(755,root,root) %{_libdir}/chromium/xdg-mime
398%{_mandir}/man1/chrom*
399%{_datadir}/pixmaps/chromium-browser.png
400%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
401%{_datadir}/applications/*.desktop
402%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
403#%{_datadir}/icons/oxygen/
404%{_libdir}/chromium/chrome.pak
405%{_libdir}/chromium/resources.pak
406%{_libdir}/chromium/locales/
407%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
408%{_libdir}/chromium/libavcodec.so.52
409%{_libdir}/chromium/libavutil.so.50
410%{_libdir}/chromium/libavformat.so.52
411%exclude %{_libdir}/libavcodec.so.52
412%exclude %{_libdir}/libavutil.so.50
413%exclude %{_libdir}/libavformat.so.52
414%attr(4755,root,root) %{chrome_sandbox}
415
416%changelog
417* Sun Jan  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.75-1
418- updated to 16.0.912.75
419
420* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.63-1
421- updated to 16.0.912.63
422
423* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.57-1
424- updated to 16.0.912.57
425
426* Sat Oct 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 15.0.874.116-1
427- updated to 15.0.874.116
428
429* Wed Oct 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.204-1
430- updated to 14.0.835.204
431- added BuildRequires: dbus-glib-devel
432
433* Sat Sep 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.186-1
434- updated to 14.0.835.186
435
436* Sun Sep 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.163-1
437- updated to 14.0.835.163
438
439* Tue Sep 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.157-1
440- updated to 14.0.835.157
441
442* Sat Aug 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.102-1
443- updated to 14.0.835.102
444
445* Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
446- updated to 14.0.835.89
447- added Obsoletes: chromium-unstable < %{version}-%{release}
448
449* Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
450- updated to 14.0.835.35
451- added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
452- changed to Name: chromium14
453  - Provides:  chromium-unstable = %%{version}
454  - Conflicts: chromium-stable
455
456* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
457- changed to Name: chromium
458- updated to 13.0.782.107
459
460* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
461- updated to 13.0.782.88
462- added BuildRequires: libzip-devel
463- added Provides: chromium-unstable = %%{version}
464- added Conflicts: chromium-stable
465
466* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
467- fix user-agent string (chromium-vendor-vine.patch.in)
468  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
469
470* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
471- updated to 12.0.742.93
472- fixed icon field of chromium-browser-vine.desktop
473
474* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
475- updated to 12.0.742.91
476
477* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
478- updated to 12.0.742.77
479
480* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
481- updated to 12.0.742.63
482
483* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
484- updated to 12.0.742.42
485
486* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
487- updated to 12.0.742.6
488- dropped/upstreamed patches
489- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
490
491* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
492- updated to 11.0.696.50
493- dropped some Patches for MeeGo Netbook
494
495* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
496- updated to 11.0.696.35
497
498* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
499- updated to 11.0.696.29
500- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
501
502* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
503- updated to 11.0.696.22
504- improved chromium-browser-vine.sh
505  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
506
507* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
508- updated to 11.0.696.20
509- improved chromium-browser-vine.desktop
510
511* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
512- updated to 11.0.696.17
513
514* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
515- updated to 11.0.696.15
516  - ready for Vine Linux 6 release
517- dropped BuildRequires: v8-devel, libicu-devel
518
519* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
520- updated to 11.0.696.5 with v8 3.2.0
521- added BuildRequires: pam-devel
522
523* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
524- rebuilt with libevent-2.0.10
525
526* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
527- updated to 10.0.651.0 with v8 3.0.12
528- added BuildRequires:
529  - libpaper-devel
530  - python-devel
531- added built header file: libavutil/avconfig.h %%prep
532- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
533
534* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
535- updated to 10.0.622.0
536- added BuildRequires: libXt-devel
537
538* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
539- updated to 10.0.605.0
540- added BuildRequires:
541  - libXdamage-devel
542  - hunspell-devel
543
544* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
545- updated to 9.0.598
546
547* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
548- updated to 9.0.593
549
550* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
551- updated to 9.0.582
552- added Requires: xdg-utils
553
554* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
555- updated to 9.0.578
556
557* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
558- updated to 9.0.569
559
560  * Mon Oct 25 2010 tittiatcoke@gmail.com
561  - Update to 9.0.564 build
562    * Added specific patches for MeeGo.
563    * We are now using shared libraries for Chromium
564    * Spec-file cleanup (Thanks to prusnak)
565
566* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
567- updated to snapshot 8.0.556
568
569* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
570- updated to snapshot 8.0.551
571
572* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
573- updated to snapshot 7.0.527
574
575* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
576- updated to snapshot 7.0.519
577
578* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
579- updated to snapshot 7.0.513
580  - updated chromium-vendor-vine.patch.in
581
582* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
583- updated to snapshot 7.0.507
584
585* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
586- updated to snapshot 7.0.498
587
588* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
589- updated to snapshot 6.0.493
590- used with_system_icu (for vl6)
591  - added BuildRequires: libicu-devel
592
593* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
594- build for Vine Linux 5.x
595  - add BuildRequires: gnome-keyring-devel
596
597* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
598- updated to snapshot 6.0.454
599- added BuildRequires:
600  - sqlite3-devel
601  - gnutls-devel
602  - libgnome-keyring-devel
603
604* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
605- updated to snapshot 6.0.431.0 r49253
606- added BuildRequires: cups-devel
607
608* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
609- updated to snapshot 6.0.405.0 r47263
610
611* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
612- unused with_system_icu (for vl6)
613  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
614
615* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
616- updated to snapshot 5.0.378.0 r44472
617  - used with_system_icu (for vl6)
618  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
619
620* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
621- updated to snapshot 5.0.372.0 r43947
622- added BuildRequires: glew-devel
623- changed Group tag to Applications/Internet
624- added Summary(ja) and %%description -l ja
625
626* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
627- updated to snapshot 5.0.365.0 r42966
628- merged 5.0.353.0-4vl5
629 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
630 - build on Vine Linux 5.1
631   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
632
633* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
634- updated to snapshot 5.0.364.0 r42779
635
636* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
637- updated to snapshot 5.0.359.0 r42116
638- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
639
640* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
641- fixed master_preferences.vine, little
642
643* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
644- fixed to install master_preferences
645- dropped chromium-5.0.353-no-ffmpeg-vine.patch
646
647* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
648- applied chromium-5.0.353-no-ffmpeg-vine.patch
649
650* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
651- updated to snapshot 5.0.353.0 r41449
652  * Wed Mar 10 2010 bgmerrell@novell.com
653  - Add master_preferences source file and install it to /etc/chromium.
654  - Create a new patch (chromium-master-prefs-path.patch) which tells
655    chromium to look in /etc/chromium for the master_preferences file
656    (instead of looking in the default directory, which is the same
657    directory as the 'chrome' binary).
658
659* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
660- updated to snapshot 5.0.335.0 r39556
661
662* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
663- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
664
665* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
666- updated to snapshot 5.0.330.0 r39074
667
668* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
669- use_system_ffmpeg
670
671* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
672- added Requires:  nspluginwrapper
673- fixed a symbolic link of plugins directory with nspluginwrapper
674
675* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
676- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
677
678* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
679- added BuildRequires: mesa-libGLU-devel
680- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
681
682* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
683- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
684
685  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
686  - Update to 4.0.260
687  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
688  - Update to 4.0.259
689  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
690  - Update to 4.0.258
691  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
692  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
693    changed to having an built-in v8
694  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
695  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
696  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
697  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
698  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
699  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
700  - update to newer svn snapshot
701    + Obsoletes fwrite patch (included upstream)
702  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
703  - update to newer svn snapshot
704    + Requires newer version of v8
705  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
706  - do not force SSE on x86 (drop-sse.patch)
707  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
708  - Update to newer svn snapshot
709  - Fixed spec file in order to build
710  - Included patch to build with system zlib
711  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
712  - package renamed to chromium
713  - cleaned up spec file
714  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
715  - v8 is now built as a separate package, and is required
716  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
717  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
718  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
719  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
720  - initial build
721
722#% changelog
723* Sun Jan 24 2010 prusnak@suse.cz
724- added vendor to user agent (chromium-vendor.patch.in)
725* Sun Nov 29 2009 prusnak@suse.cz
726- added --enable-sync to wrapper to enable bookmark sync
727* Sun Nov 29 2009 tittiatcoke@gmail.com 
728- Update to 4.0.260
729* Fri Nov 27 2009 tittiatcoke@gmail.com 
730- Update to 4.0.259
731* Thu Nov 26 2009 tittiatcoke@gmail.com 
732- Update to 4.0.258
733* Tue Nov 24 2009 tittatcoke@gmai.com 
734- In order to complete prevent the wrong v8 version to be used,
735  the Chromium build has been changed to having an built-in v8
736* Tue Nov 24 2009 dbuck@example.com 
737- Re-base patches.
738- Fixed a few patch errors.
739- Rename some patches to better correspond with function.
740- Removed some patches.
741- Minor SPEC changes.
742- I changed the v8 requirement to be exact, instead of greater than a specific version.
743* Fri Nov 13 2009 tittiatcoke@gmail.com
744- update to 247.0 svn 31928
745* Fri Oct 30 2009 tittiatcoke@gmail.com
746- update to 229.0 svn 30454
747  + Fix regression where popups and app frames lost their titlebars.
748  + Makes it so that when a folder is open on the bookmark bar
749    and the mouse moves over another folder, the menu for that
750    folder is shown.
751  + Lazily create the find bar.
752  + Polish to the gmail checker sample.
753  * New, crisper icons that are exactly 19x19
754  * Add a loading animation at the beginning before Gmail
755    responds.
756  * Fix a bug where we sometimes don't update the UI after a
757    logout/login cycle.
758  + Refactor widget methods to support desktop notifications,
759    including GTK stubs.
760  + Find-in-page should not ding while deleting characters.
761  + Add SSL wrapper for linux and mac.  This allows notifier to
762    use chrome's SSL layer instead of OpenSSL.
763  + Add three of the six extensions to PAC that Internet Explorer supports.
764  + WebSocket support in chromium. (Run with --enable-web-sockets
765    enables WebSocket features.)
766  + Do not allow GTK File Chooser dialogs to return directories.
767  + Fix the notifier SSL layer to make notifications work for
768    Linux Bookmark sync.
769  + linux: don't override mouse selection behavior in omnibox
770* Sun Oct 25 2009 tittiatcoke@gmail.com
771- Update to 224.4 svn 30027
772  + First cut at new page and browser action docs based
773    on new API. Deleted old stuff.
774  + Add suppression for new memory leak caused by WebKit merge 49830:49844
775  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
776  + Minimize dependency of user scripts
777  + Fixup the flip_framer eof-handling semantics now that we have
778    the FIN bit in place
779  + app depends on x11 because of active_window_watcher_x
780  + Adding two images for the new Extension managment UI
781  + Removing hard-coded Chrome Frame output path
782  + Rearrange clipboard code
783  + Fix crash bug when attempting to download a url with unsupported scheme,
784    e.g. 'data:', by 'Alt + Click'
785  + GTK: Change text for extension download UI
786  + Ignore invalid urls on command line
787  + Make dropped tabs animate from where they were dropped.
788  + Make room for the full width of the tab placeholder.
789  + Make tab dragging as smooth as glass.
790  + Remove an annoying NOTIMPLEMNETED
791  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
792  + If we're in the middle of a drag, don't allow the user to middle
793    click to close or right click for the context menu
794  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
795  + Remove +x bit from files that shouldn't have it
796  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
797  + Adding new image needed for the managment UI
798  + Fix a race bug where content scripts would not apply to the first page load
799  + Make escape remove a bookmark if it's just been added (but not if it already existed)
800  + Fix bubbles deactivating the opaque frame
801  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
802  + ake all pepper plugins default to windowless and transparent
803  + Add styles for printing
804  + Implement the new extension management UI
805  + Add support for to automation interface load install and load extensions
806  + GTK: theme the info bar border
807  + Update V8 to version 1.3.16.1
808  + Introduce WebSecurityPolicy for security related methods
809  + New button scheme...borders are separate from the inner contents so
810    that they can be highlighted / depressed independently
811  + When opening Chrome maximized with an application window already
812    running, the Chrome window was not activated
813  + Fix compatibility problems with FileZilla FTP Server
814  + Remove the extension shelf on Linux
815  + Fix the proxy host and port string to start with http:// if it does not already
816  + Enable HTML5 databases for all extension renderer processes
817* Sat Oct 24 2009 prusnak@opensuse.org 
818- don't create desktop files in wrapper
819- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
820* Tue Oct 20 2009 tittiatcoke@gmail.com 
821- update to newer svn snapshot
822  + Obsoletes fwrite patch (included upstream)
823* Fri Oct 16 2009 tittiatcoke@gmail.com 
824- update to newer svn snapshot
825  + Requires newer version of v8
826* Thu Oct 15 2009 prusnak@suse.cz 
827- do not force SSE on x86 (drop-sse.patch)
828* Tue Oct 13 2009 tittiatcoke@gmail.com 
829- Update to newer svn snapshot
830- Fixed spec file in order to build
831- Included patch to build with system zlib
832* Mon Oct 12 2009 prusnak@suse.cz 
833- package renamed to chromium
834- cleaned up spec file
835* Tue Oct  6 2009 dbuck@example.com 
836- v8 is now built as a separate package, and is required
837- included many patches to use system libraries:
838    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
839* Thu Oct  1 2009 dbuck@example.com 
840- included a newer DEP than is in svn, native_client@823
841- things should compile cleanly now
842* Mon Aug 31 2009 dbuck@example.com 
843- initial build
Note: See TracBrowser for help on using the repository browser.