source: projects/specs/branches/6/c/chromium/chromium14-vl.spec @ 4963

Revision 4963, 29.9 KB checked in by munepi, 13 years ago (diff)

updated chromium14-vl.spec

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_icu 1
8#% define with_system_v8 1
9
10#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
11#     libvpx doesn't currently supply a pkg-config file, so we assume that
12#     -lvpx is sufficient.
13%define with_system_vpx 1
14
15#Name:           chromium14
16Name:           chromium
17Summary:        Google's opens source browser project
18Summary(ja):    Googleのオープンソースウェブブラウザ
19#'
20Version:        14.0.835.204
21Release:        1%{?_dist_release}
22License:        BSD
23Group:          Applications/Internet
24Source0:        %{pkgname}-%{version}.tar.xz
25# Script used to create the %{pkgname}-%{version}.tar.xz archive from
26# a official tarball:
27# http://build.chromium.org/official/chromium-14.0.835.XXX.tar.bz2
28Source3:        pack_chromium14_source-vine.sh
29# Official ffmpeg headers
30Source8:        ffmpeg-0.6-headers.tar.xz
31# Patch template which adds vendor to user agent
32##!!Source20:       chromium-vendor.patch.in
33Source20:       chromium-vendor-vine.patch.in
34# Set default prefs
35##!!Source30:       master_preferences
36Source30:       master_preferences.vine
37##!!Source31:       default_bookmarks.html
38#Source31:       default_bookmarks.html.vine
39Source99:       chrome-wrapper
40##!!Source100:      chromium-browser.sh
41Source100:      chromium-browser-vine.sh
42##!!Source101:      chromium-browser.desktop
43Source101:      chromium-browser-vine.desktop
44Source102:      chromium-browser.xml
45Source103:      chromium-browser-rpmlintrc
46##!!Source104:      chromium-icons.tar.bz2
47
48%{?nosrc:NoSource: 0}
49
50# Provides:       chromium-unstable = %{version}-%{release}
51# Obsoletes:      chromium13
52# Conflicts:      chromium-stable
53Provides:       chromium-stable = %{version}-%{release}
54Conflicts:      chromium-unstable
55
56## Start Patches
57# OpenSuse and Fedora
58# Many changes to the gyp systems so we can use system libraries
59#Patch1:         chromium-gcc46.patch
60Patch4:         chromium-no-sqlite-debug.patch
61Patch8:         chromium-codechanges-zlib.patch
62Patch12:        chromium-no-test-sources.patch
63Patch13:        chromium-no-courgette.patch
64Patch14:        chromium-master-prefs-path.patch
65Patch17:        chromium-system-glew.patch
66Patch18:        chromium-system-expat.patch
67Patch19:        chromium-system-zlib.patch
68Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
69Patch21:        chromium-7.0.542.0-media-probe.patch
70Patch25:        tcmalloc-factory.patch
71Patch26:        chromium-remoting-build-fix.diff
72Patch28:        chromium-7.0.500.0-system-speex.patch
73Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
74Patch32:        chromium-7.0.542.0-system-libvpx.patch
75Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
76Patch62:        chromium-norpath.patch
77Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
78
79Patch999:       buildfix.patch
80
81# Vine
82Patch100:       chromium-14.0.835.31-no-tests.patch
83
84
85##!!BuildRequires:  Mesa-devel
86BuildRequires:  mesa-libGLU-devel
87##!!BuildRequires:  alsa-devel
88BuildRequires:  alsa-lib-devel
89BuildRequires:  pulseaudio-libs-devel
90BuildRequires:  bison
91BuildRequires:  cups-devel
92BuildRequires:  desktop-file-utils
93BuildRequires:  fdupes
94BuildRequires:  flex
95BuildRequires:  freetype2-devel
96BuildRequires:  gcc gcc-c++
97BuildRequires:  gperf
98BuildRequires:  hunspell-devel
99##!!BuildRequires:  libbz2-devel
100BuildRequires:  bzip2-devel
101BuildRequires:  libevent
102##!!BuildRequires:  libexpat-devel
103BuildRequires:  expat-devel
104##!!BuildRequires:  libgnutls-devel
105BuildRequires:  gnutls-devel
106BuildRequires:  libjpeg-devel
107BuildRequires:  libpng-devel
108BuildRequires:  libstdc++-devel >= 4.4
109%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
110BuildRequires:  libxslt-devel
111BuildRequires:  libzip-devel
112##!!BuildRequires:  lzma
113BuildRequires:  xz
114##!!BuildRequires:  mozilla-nspr-devel
115BuildRequires:  nspr-devel
116##!!BuildRequires:  mozilla-nss-devel
117BuildRequires:  nss-devel
118BuildRequires:  openssl-devel
119BuildRequires:  pam-devel
120##!!BuildRequires:  perl(Switch)
121BuildRequires:  perl
122##!!BuildRequires:  pkg-config
123BuildRequires:  cairo-devel >= 1.6
124BuildRequires:  dbus-devel
125BuildRequires:  dbus-glib-devel
126##!!BuildRequires:  gconf2-devel
127BuildRequires:  GConf2-devel
128BuildRequires:  glib2-devel
129BuildRequires:  gtk2-devel
130BuildRequires:  libxml2-devel
131BuildRequires:  python
132##!!BuildRequires:  python-xml
133BuildRequires:  python-pyxml
134BuildRequires:  sqlite3-devel
135##!!BuildRequires:  update-desktop-files
136%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
137##!!BuildRequires:  wdiff
138BuildRequires:  zlib-devel
139
140BuildRequires:  libgnome-keyring-devel
141BuildRequires:  python-devel
142
143#BuildRequires:  glew-devel
144BuildRequires:  libevent-devel
145%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
146#BuildRequires:  libjingle-devel >= 0.4.0-7
147#BuildRequires:  srtp-devel
148BuildRequires:  speex-devel
149
150##Vine Linux
151#BuildRequires:  libpaper-devel
152BuildRequires:  libXScrnSaver-devel
153BuildRequires:  libXtst-devel
154BuildRequires:  libXdamage-devel
155BuildRequires:  libXt-devel
156%ifarch x86_64
157Requires:  nspluginwrapper
158%endif
159
160##!!Requires:       alsa
161Requires:       alsa-lib
162Requires:       pulseaudio-libs
163Requires:       xdg-utils
164%{?with_system_v8:Requires:       v8 = %{v8_ver}}
165
166BuildRoot:      %{_tmppath}/%{name}-%{version}-root
167
168%description
169Chromium is the open-source project behind Google Chrome.
170We invite you to join us in our effort to help build a safer, faster,
171and more stable way for all Internet users to experience the web,
172and to create a powerful platform for developing a new generation of
173web applications.
174
175%description -l ja
176Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
177ウェブを体験しているすべてのインターネットユーザに対して
178より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
179そして、ウェブアプリケーションの新しい世代を発展させ、
180強力なプラットホームを作成するために、
181私たちの取り組みにぜひ参加してください。
182
183
184%prep
185#%setup -q
186[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
187xz -dc %{SOURCE0} | %__tar -xf - || exit 1
188%setup -D -T -n %{pkgname}-%{version}
189
190#%patch1 -p1
191%patch62 -p1
192%{?with_system_v8:%patch63 -p1}
193%patch100 -p1 -b .vine
194%patch4 -p1
195%patch8 -p1
196%patch12 -p1
197%patch13 -p1
198%patch14 -p1
199%patch17 -p1
200%patch18 -p1
201%patch19 -p1
202%patch20 -p1
203%patch21 -p1
204%patch25 -p1
205%patch26 -p1
206%patch28 -p1
207%patch29 -p1
208%{?with_system_vpx:%patch32 -p1}
209%{?with_system_v8:%patch34 -p1}
210%patch999 -p1
211
212
213pushd src/third_party/ffmpeg/
214%__tar xf %{SOURCE8} || exit 1
215## built header file: avconfig.h
216[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
217cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
218/* Generated by ffconf */
219#ifndef AVUTIL_AVCONFIG_H
220#define AVUTIL_AVCONFIG_H
221#define AV_HAVE_BIGENDIAN 0
222#endif /* AVUTIL_AVCONFIG_H */
223EOF
224popd
225
226#%__rm -rf src/third_party/libvpx/
227%__rm -rf src/third_party/speex/
228%__rm -rf src/third_party/nss src/third_party/nspr
229
230# apply vendor patch after substitution
231%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
232
233%build
234
235## create make files
236
237PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
238for i in src/build/common.gypi; do
239        %__sed -i "s|'-march=pentium4',||g" $i
240        %__sed -i "s|'-mfpmath=sse',||g" $i
241        %__sed -i "s|'-O<(debug_optimize)',||g" $i
242        %__sed -i "s|'-m32',||g" $i
243        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
244        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
245done
246# '
247
248pushd src
249
250./build/gyp_chromium -f make build/all.gyp \
251    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
252    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
253    -Ddisable_nacl=1 \
254    -Duse_openssl=0 \
255    -Duse_system_ffmpeg=1 \
256    -Duse_system_zlib=1 \
257    -Duse_system_libpng=1 \
258    -Duse_system_bzip2=1 \
259    -Duse_system_libbz2=1 \
260    -Duse_system_libjpeg=1 \
261    -Duse_system_libxml=1 \
262    -Duse_system_libxslt=1 \
263    -Duse_system_libevent=1 \
264    %{?with_system_vpx:-Duse_system_vpx=1} \
265    %{!?with_system_vpx:-Duse_system_vpx=0} \
266    -Dremove_webcore_debug_symbols=1 \
267    %{?with_system_v8:-Duse_system_v8=1} \
268    %{!?with_system_v8:-Duse_system_v8=0} \
269    %{?with_system_icu:-Duse_system_icu=1} \
270    %{!?with_system_icu:-Duse_system_icu=0} \
271    %{?_with_shared_library:-Dlibrary=shared_library} \
272    -Dproprietary_codecs=1 \
273    -Djavascript_engine=v8 \
274    -Dlinux_fpic=1 \
275    -Ddisable_sse2=1 \
276    %ifarch %{ix86}
277        -Dtarget_arch=ia32 \
278    %endif
279    %ifarch x86_64
280        -Dtarget_arch=x64 \
281    %endif
282    -Dno_strict_aliasing=1 \
283    -Drelease_extra_cflags=-fPIC \
284    %if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl7"
285        -Dgcc_version=44 \
286    %endif
287    ;
288
289#%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
290%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release
291
292popd
293
294%install
295%{__rm} -rf %{buildroot}
296
297%__mkdir -p %{buildroot}%{_bindir}
298%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
299# x86_64 capable systems need this
300%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
301%__mkdir -p %{buildroot}%{_libdir}/chromium/
302%__mkdir -p %{buildroot}%{_mandir}/man1/
303pushd src/out/Release
304%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
305%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
306%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
307%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
308%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
309%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
310%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
311fdupes %{buildroot}%{_mandir}/man1/
312popd
313
314%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
315%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
316for i in 16 22 24 32 48 64 128 256; do
317    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
318    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
319done
320
321%__mkdir_p %{buildroot}%{_datadir}/applications/
322desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
323
324%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
325%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
326
327# # link to browser plugin path.  Plugin patch doesn't work. Why?
328# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
329# pushd %{buildroot}%{_libdir}/%{pkgname}
330# %{__ln_s} %{_libdir}/browser-plugins plugins
331# popd
332pushd %{buildroot}%{_libdir}/%{pkgname}
333%ifarch x86_64
334%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
335%else
336%{__ln_s} %{_libdir}/mozilla/plugins plugins
337%endif
338
339## support ffmpeg libs
340touch %{buildroot}%{_libdir}/libavcodec.so.52
341%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
342touch %{buildroot}%{_libdir}/libavformat.so.52
343%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
344touch %{buildroot}%{_libdir}/libavutil.so.50
345%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
346popd
347
348# Install the master_preferences file
349%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
350#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
351%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
352#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
353
354%clean
355%{__rm} -rf %{buildroot}
356
357%post
358touch --no-create %{_datadir}/icons/hicolor
359if [ -x %{_bindir}/gtk-update-icon-cache ]; then
360  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
361fi
362%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
363
364%postun
365%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
366touch --no-create %{_datadir}/icons/hicolor
367if [ -x %{_bindir}/gtk-update-icon-cache ]; then
368  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
369fi || :
370
371
372%files
373%defattr(-,root,root,-)
374%config %{_sysconfdir}/%{pkgname}
375%dir %{_datadir}/gnome-control-center
376%dir %{_datadir}/gnome-control-center/default-apps
377%dir %{_libdir}/chromium/
378%{_bindir}/chromium
379%{_libdir}/chromium/chromium
380%{_libdir}/chromium/plugins/
381%{_libdir}/chromium/resources/
382%{_libdir}/chromium/xdg-settings
383%{_mandir}/man1/chrom*
384%{_datadir}/pixmaps/chromium-browser.png
385%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
386%{_datadir}/applications/*.desktop
387%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
388#%{_datadir}/icons/oxygen/
389%{_libdir}/chromium/chrome.pak
390%{_libdir}/chromium/resources.pak
391%{_libdir}/chromium/locales/
392%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
393%{_libdir}/chromium/libavcodec.so.52
394%{_libdir}/chromium/libavutil.so.50
395%{_libdir}/chromium/libavformat.so.52
396%exclude %{_libdir}/libavcodec.so.52
397%exclude %{_libdir}/libavutil.so.50
398%exclude %{_libdir}/libavformat.so.52
399
400%changelog
401* Wed Oct 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.204-1
402- updated to 14.0.835.204
403- added BuildRequires: dbus-glib-devel
404
405* Sat Sep 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.186-1
406- updated to 14.0.835.186
407
408* Sun Sep 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.163-1
409- updated to 14.0.835.163
410
411* Tue Sep 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.157-1
412- updated to 14.0.835.157
413
414* Sat Aug 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.102-1
415- updated to 14.0.835.102
416
417* Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
418- updated to 14.0.835.89
419- added Obsoletes: chromium-unstable < %{version}-%{release}
420
421* Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
422- updated to 14.0.835.35
423- added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
424- changed to Name: chromium14
425  - Provides:  chromium-unstable = %%{version}
426  - Conflicts: chromium-stable
427
428* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
429- changed to Name: chromium
430- updated to 13.0.782.107
431
432* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
433- updated to 13.0.782.88
434- added BuildRequires: libzip-devel
435- added Provides: chromium-unstable = %%{version}
436- added Conflicts: chromium-stable
437
438* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
439- fix user-agent string (chromium-vendor-vine.patch.in)
440  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
441
442* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
443- updated to 12.0.742.93
444- fixed icon field of chromium-browser-vine.desktop
445
446* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
447- updated to 12.0.742.91
448
449* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
450- updated to 12.0.742.77
451
452* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
453- updated to 12.0.742.63
454
455* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
456- updated to 12.0.742.42
457
458* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
459- updated to 12.0.742.6
460- dropped/upstreamed patches
461- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
462
463* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
464- updated to 11.0.696.50
465- dropped some Patches for MeeGo Netbook
466
467* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
468- updated to 11.0.696.35
469
470* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
471- updated to 11.0.696.29
472- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
473
474* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
475- updated to 11.0.696.22
476- improved chromium-browser-vine.sh
477  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
478
479* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
480- updated to 11.0.696.20
481- improved chromium-browser-vine.desktop
482
483* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
484- updated to 11.0.696.17
485
486* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
487- updated to 11.0.696.15
488  - ready for Vine Linux 6 release
489- dropped BuildRequires: v8-devel, libicu-devel
490
491* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
492- updated to 11.0.696.5 with v8 3.2.0
493- added BuildRequires: pam-devel
494
495* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
496- rebuilt with libevent-2.0.10
497
498* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
499- updated to 10.0.651.0 with v8 3.0.12
500- added BuildRequires:
501  - libpaper-devel
502  - python-devel
503- added built header file: libavutil/avconfig.h %%prep
504- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
505
506* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
507- updated to 10.0.622.0
508- added BuildRequires: libXt-devel
509
510* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
511- updated to 10.0.605.0
512- added BuildRequires:
513  - libXdamage-devel
514  - hunspell-devel
515
516* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
517- updated to 9.0.598
518
519* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
520- updated to 9.0.593
521
522* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
523- updated to 9.0.582
524- added Requires: xdg-utils
525
526* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
527- updated to 9.0.578
528
529* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
530- updated to 9.0.569
531
532  * Mon Oct 25 2010 tittiatcoke@gmail.com
533  - Update to 9.0.564 build
534    * Added specific patches for MeeGo.
535    * We are now using shared libraries for Chromium
536    * Spec-file cleanup (Thanks to prusnak)
537
538* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
539- updated to snapshot 8.0.556
540
541* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
542- updated to snapshot 8.0.551
543
544* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
545- updated to snapshot 7.0.527
546
547* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
548- updated to snapshot 7.0.519
549
550* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
551- updated to snapshot 7.0.513
552  - updated chromium-vendor-vine.patch.in
553
554* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
555- updated to snapshot 7.0.507
556
557* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
558- updated to snapshot 7.0.498
559
560* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
561- updated to snapshot 6.0.493
562- used with_system_icu (for vl6)
563  - added BuildRequires: libicu-devel
564
565* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
566- build for Vine Linux 5.x
567  - add BuildRequires: gnome-keyring-devel
568
569* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
570- updated to snapshot 6.0.454
571- added BuildRequires:
572  - sqlite3-devel
573  - gnutls-devel
574  - libgnome-keyring-devel
575
576* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
577- updated to snapshot 6.0.431.0 r49253
578- added BuildRequires: cups-devel
579
580* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
581- updated to snapshot 6.0.405.0 r47263
582
583* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
584- unused with_system_icu (for vl6)
585  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
586
587* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
588- updated to snapshot 5.0.378.0 r44472
589  - used with_system_icu (for vl6)
590  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
591
592* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
593- updated to snapshot 5.0.372.0 r43947
594- added BuildRequires: glew-devel
595- changed Group tag to Applications/Internet
596- added Summary(ja) and %%description -l ja
597
598* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
599- updated to snapshot 5.0.365.0 r42966
600- merged 5.0.353.0-4vl5
601 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
602 - build on Vine Linux 5.1
603   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
604
605* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
606- updated to snapshot 5.0.364.0 r42779
607
608* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
609- updated to snapshot 5.0.359.0 r42116
610- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
611
612* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
613- fixed master_preferences.vine, little
614
615* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
616- fixed to install master_preferences
617- dropped chromium-5.0.353-no-ffmpeg-vine.patch
618
619* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
620- applied chromium-5.0.353-no-ffmpeg-vine.patch
621
622* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
623- updated to snapshot 5.0.353.0 r41449
624  * Wed Mar 10 2010 bgmerrell@novell.com
625  - Add master_preferences source file and install it to /etc/chromium.
626  - Create a new patch (chromium-master-prefs-path.patch) which tells
627    chromium to look in /etc/chromium for the master_preferences file
628    (instead of looking in the default directory, which is the same
629    directory as the 'chrome' binary).
630
631* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
632- updated to snapshot 5.0.335.0 r39556
633
634* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
635- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
636
637* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
638- updated to snapshot 5.0.330.0 r39074
639
640* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
641- use_system_ffmpeg
642
643* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
644- added Requires:  nspluginwrapper
645- fixed a symbolic link of plugins directory with nspluginwrapper
646
647* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
648- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
649
650* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
651- added BuildRequires: mesa-libGLU-devel
652- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
653
654* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
655- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
656
657  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
658  - Update to 4.0.260
659  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
660  - Update to 4.0.259
661  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
662  - Update to 4.0.258
663  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
664  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
665    changed to having an built-in v8
666  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
667  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
668  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
669  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
670  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
671  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
672  - update to newer svn snapshot
673    + Obsoletes fwrite patch (included upstream)
674  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
675  - update to newer svn snapshot
676    + Requires newer version of v8
677  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
678  - do not force SSE on x86 (drop-sse.patch)
679  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
680  - Update to newer svn snapshot
681  - Fixed spec file in order to build
682  - Included patch to build with system zlib
683  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
684  - package renamed to chromium
685  - cleaned up spec file
686  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
687  - v8 is now built as a separate package, and is required
688  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
689  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
690  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
691  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
692  - initial build
693
694#% changelog
695* Sun Jan 24 2010 prusnak@suse.cz
696- added vendor to user agent (chromium-vendor.patch.in)
697* Sun Nov 29 2009 prusnak@suse.cz
698- added --enable-sync to wrapper to enable bookmark sync
699* Sun Nov 29 2009 tittiatcoke@gmail.com 
700- Update to 4.0.260
701* Fri Nov 27 2009 tittiatcoke@gmail.com 
702- Update to 4.0.259
703* Thu Nov 26 2009 tittiatcoke@gmail.com 
704- Update to 4.0.258
705* Tue Nov 24 2009 tittatcoke@gmai.com 
706- In order to complete prevent the wrong v8 version to be used,
707  the Chromium build has been changed to having an built-in v8
708* Tue Nov 24 2009 dbuck@example.com 
709- Re-base patches.
710- Fixed a few patch errors.
711- Rename some patches to better correspond with function.
712- Removed some patches.
713- Minor SPEC changes.
714- I changed the v8 requirement to be exact, instead of greater than a specific version.
715* Fri Nov 13 2009 tittiatcoke@gmail.com
716- update to 247.0 svn 31928
717* Fri Oct 30 2009 tittiatcoke@gmail.com
718- update to 229.0 svn 30454
719  + Fix regression where popups and app frames lost their titlebars.
720  + Makes it so that when a folder is open on the bookmark bar
721    and the mouse moves over another folder, the menu for that
722    folder is shown.
723  + Lazily create the find bar.
724  + Polish to the gmail checker sample.
725  * New, crisper icons that are exactly 19x19
726  * Add a loading animation at the beginning before Gmail
727    responds.
728  * Fix a bug where we sometimes don't update the UI after a
729    logout/login cycle.
730  + Refactor widget methods to support desktop notifications,
731    including GTK stubs.
732  + Find-in-page should not ding while deleting characters.
733  + Add SSL wrapper for linux and mac.  This allows notifier to
734    use chrome's SSL layer instead of OpenSSL.
735  + Add three of the six extensions to PAC that Internet Explorer supports.
736  + WebSocket support in chromium. (Run with --enable-web-sockets
737    enables WebSocket features.)
738  + Do not allow GTK File Chooser dialogs to return directories.
739  + Fix the notifier SSL layer to make notifications work for
740    Linux Bookmark sync.
741  + linux: don't override mouse selection behavior in omnibox
742* Sun Oct 25 2009 tittiatcoke@gmail.com
743- Update to 224.4 svn 30027
744  + First cut at new page and browser action docs based
745    on new API. Deleted old stuff.
746  + Add suppression for new memory leak caused by WebKit merge 49830:49844
747  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
748  + Minimize dependency of user scripts
749  + Fixup the flip_framer eof-handling semantics now that we have
750    the FIN bit in place
751  + app depends on x11 because of active_window_watcher_x
752  + Adding two images for the new Extension managment UI
753  + Removing hard-coded Chrome Frame output path
754  + Rearrange clipboard code
755  + Fix crash bug when attempting to download a url with unsupported scheme,
756    e.g. 'data:', by 'Alt + Click'
757  + GTK: Change text for extension download UI
758  + Ignore invalid urls on command line
759  + Make dropped tabs animate from where they were dropped.
760  + Make room for the full width of the tab placeholder.
761  + Make tab dragging as smooth as glass.
762  + Remove an annoying NOTIMPLEMNETED
763  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
764  + If we're in the middle of a drag, don't allow the user to middle
765    click to close or right click for the context menu
766  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
767  + Remove +x bit from files that shouldn't have it
768  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
769  + Adding new image needed for the managment UI
770  + Fix a race bug where content scripts would not apply to the first page load
771  + Make escape remove a bookmark if it's just been added (but not if it already existed)
772  + Fix bubbles deactivating the opaque frame
773  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
774  + ake all pepper plugins default to windowless and transparent
775  + Add styles for printing
776  + Implement the new extension management UI
777  + Add support for to automation interface load install and load extensions
778  + GTK: theme the info bar border
779  + Update V8 to version 1.3.16.1
780  + Introduce WebSecurityPolicy for security related methods
781  + New button scheme...borders are separate from the inner contents so
782    that they can be highlighted / depressed independently
783  + When opening Chrome maximized with an application window already
784    running, the Chrome window was not activated
785  + Fix compatibility problems with FileZilla FTP Server
786  + Remove the extension shelf on Linux
787  + Fix the proxy host and port string to start with http:// if it does not already
788  + Enable HTML5 databases for all extension renderer processes
789* Sat Oct 24 2009 prusnak@opensuse.org 
790- don't create desktop files in wrapper
791- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
792* Tue Oct 20 2009 tittiatcoke@gmail.com 
793- update to newer svn snapshot
794  + Obsoletes fwrite patch (included upstream)
795* Fri Oct 16 2009 tittiatcoke@gmail.com 
796- update to newer svn snapshot
797  + Requires newer version of v8
798* Thu Oct 15 2009 prusnak@suse.cz 
799- do not force SSE on x86 (drop-sse.patch)
800* Tue Oct 13 2009 tittiatcoke@gmail.com 
801- Update to newer svn snapshot
802- Fixed spec file in order to build
803- Included patch to build with system zlib
804* Mon Oct 12 2009 prusnak@suse.cz 
805- package renamed to chromium
806- cleaned up spec file
807* Tue Oct  6 2009 dbuck@example.com 
808- v8 is now built as a separate package, and is required
809- included many patches to use system libraries:
810    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
811* Thu Oct  1 2009 dbuck@example.com 
812- included a newer DEP than is in svn, native_client@823
813- things should compile cleanly now
814* Mon Aug 31 2009 dbuck@example.com 
815- initial build
Note: See TracBrowser for help on using the repository browser.