source: projects/specs/branches/6/c/chkconfig/chkconfig-vl.spec @ 10687

Revision 10687, 11.1 KB checked in by tomop, 8 years ago (diff)

chkconfig-1.3.51-3

Line 
1Summary: A system tool for maintaining the /etc/rc*.d hierarchy.
2Summary(ja): /etc/rc.d の階層をメンテナンスするためのシステムツール
3Name: chkconfig
4Version: 1.3.51
5Release: 3%{?_dist_release}
6License: GPL
7Group: System Environment/Base
8Vendor: Project Vine
9Distribution: Vine Linux
10Source: %{name}-%{version}.tar.bz2
11Source2: chkconfig.8
12Source3: ntsysv.8
13Source4: update-alternatives.ja.8
14Patch1: chkconfig-1.3.51-vine.patch
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: newt-devel
17BuildRequires: popt-devel
18Conflicts: initscripts <= 5.30-1
19
20%description
21Chkconfig is a basic system utility.  It updates and queries runlevel
22information for system services.  Chkconfig manipulates the numerous
23symbolic links in /etc/rc.d, to relieve system administrators of some
24of the drudgery of manually editing the symbolic links.
25
26%description -l ja
27chkconfig は基本的なシステムユーティリティである。これはシステムサービスの
28runlevel の情報をアップデートや検証する。chkconfig は /etc/rc.d の
29多数のシンボリックリンクを操作しますので、システム管理者は手動で
30シンボリックリンクをたびたびエディットしなくてもよい。
31
32%package -n ntsysv
33Summary: A tool to set the stop/start of system services in a runlevel.
34Summary(ja): /etc/rc.d 階階層をメンテナンスするシステムツール
35Group: System Environment/Base
36
37%description -n ntsysv
38Ntsysv provides a simple interface for setting which system services
39are started or stopped in various runlevels (instead of directly
40manipulating the numerous symbolic links in /etc/rc.d). Unless you
41specify a runlevel or runlevels on the command line (see the man
42page), ntsysv configures the current runlevel (5 if you're using X).
43
44%description -n ntsysv -l ja
45ntsysv はシステムサービスの runlevel の情報をアップデートや検証する。
46ntsysv は システム管理者が直接/etc/rc.d の多数のシンボリックリンクを
47操作することから解放する。
48
49%package -n alternatives
50Summary: maintain symbolic links determining default commands (from Debian dpkg utilities)
51Summary(ja): コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
52Group: System Environment/Base
53
54%description -n alternatives
55maintain symbolic links determining default commands (from Debian dpkg utilities)
56
57%description -n alternatives -l ja
58コマンドのシンボリックリンクを管理する (Debian dpkg ユーティリティーより)
59
60
61%prep
62%setup -q
63%patch1 -p1
64
65%build
66
67%ifarch sparc
68LIBMHACK=-lm
69%endif
70
71%__make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" LIBMHACK=$LIBMHACK
72
73%install
74rm -rf $RPM_BUILD_ROOT
75%__make DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir} SBINDIR=%{_sbindir} install
76
77mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
78ln -s rc.d/init.d $RPM_BUILD_ROOT/etc/init.d
79for n in 0 1 2 3 4 5 6; do
80    mkdir -p $RPM_BUILD_ROOT/etc/rc.d/rc${n}.d
81    ln -s rc.d/rc${n}.d $RPM_BUILD_ROOT/etc/rc${n}.d
82done
83
84mkdir -p $RPM_BUILD_ROOT%{_mandir}/ja/man8
85cp %SOURCE2 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/ja/man8
86
87# alternatives
88mv -f $RPM_BUILD_ROOT/%{_sbindir}/*alternatives $RPM_BUILD_ROOT/%{_syssbindir}
89mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/alternatives
90mkdir -p $RPM_BUILD_ROOT/var/lib/rpm/alternatives
91install -m644 %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/ja/man8/alternatives.8
92ln -sf alternatives.8.gz $RPM_BUILD_ROOT%{_mandir}/ja/man8/update-alternatives.8.gz
93
94# create compat symlinks
95mkdir -p $RPM_BUILD_ROOT/%{_sbindir}
96for i in alternatives update-alternatives chkconfig
97do
98  ln -sf /sbin/$i $RPM_BUILD_ROOT/%{_sbindir}/$i
99done
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%files
105%defattr(-,root,root)
106/sbin/chkconfig
107%{_sbindir}/chkconfig
108/etc/init.d
109/etc/rc.d/init.d
110/etc/rc[0-6].d
111/etc/rc.d/rc[0-6].d
112%{_mandir}/*/chkconfig*
113%{_mandir}/ja/*/chkconfig*
114%{_localedir}/*/LC_MESSAGES/chkconfig.mo
115
116%files -n ntsysv
117%defattr(-,root,root)
118/usr/sbin/ntsysv
119%{_mandir}/*/ntsysv.8*
120%{_mandir}/ja/*/ntsysv.8*
121
122%files -n alternatives
123%defattr (-, root, root)
124/sbin/alternatives
125/sbin/update-alternatives
126%{_sbindir}/alternatives
127%{_sbindir}/update-alternatives
128%{_sysconfdir}/alternatives
129%{_mandir}/man8/*
130%{_mandir}/ja/man8/*
131/var/lib/rpm/alternatives
132
133
134%changelog
135* Wed Jul 27 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.51-3
136- added symlinks for compatibility.
137
138* Tue Jun 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.51-2
139- change BuildRequires: popt-devel intead of popt
140
141* Fri Apr 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.51-1
142- new upstream release
143- enable fedora version of alternatives
144  - add alternatives subpackage, replace debian's alternatives
145
146* Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.37-1
147- new upstream release
148
149* Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.34-1vl5
150- applied new versioning policy and spec in utf-8
151
152* Fri May 04 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.34-0vl2
153- dropped obsoleted Makefile.x86_64.patch
154
155* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.34-0vl1
156- new upstream release
157
158* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.17-1vl9
159- add Makefile.x86_64.patch
160
161* Wed May 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.17-1vl8
162- add Patch10 to skip xinetd parsing if not exist.
163
164* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.17-1vl7
165- rebuild
166
167* Thu Sep 06 2001 akira yamada <akira@vinelinux.org> 1.2.17-1vl6
168- Requires -> Conflicts.
169  apt-0.3.19.cnc.52-3vl1 can handle Conflicts-field nicely, so
170  Conflicts/Pre-Depends-loop does not happen.
171
172* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl5
173- Oops not PreReq but Requires. Fixed.
174
175* Sun Sep 02 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.17-1vl4
176- change Conflicts: initscripts <= 5.30-1 to PreReq: initscripts > 5.30-1
177  to avoid Conflicts/Pre-Depends loop on apt
178
179* Thu Jun 28 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
180- 1.2.17-1vl3
181- change checkbox color
182
183* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
184- 1.2.17-1vl2
185- rebuilt for VineSeed
186
187* Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org>
188- 1.2.17-1vl1
189
190* Wed Oct 18 2000 Bill Nottingham <notting@redhat.com>
191- ignore .rpmnew files (#18915)
192- fix typo in error message (#17575)
193
194* Wed Aug 30 2000 Nalin Dahyabhai <nalin@redhat.com>
195- make xinetd config files mode 0644, not 644
196
197* Thu Aug 24 2000 Erik Troan <ewt@redhat.com>
198- updated it and es translations
199
200* Sun Aug 20 2000 Bill Nottingham <notting@redhat.com>
201- get man pages in proper packages
202
203* Sun Aug 20 2000 Matt Wilson <msw@redhat.com>
204- new translations
205
206* Tue Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
207- don't worry about extra whitespace on chkconfig: lines (#16150)
208
209* Wed Aug 10 2000 Trond Eivind Glomsr <teg@redhat.com>
210- i18n merge
211
212* Wed Jul 26 2000 Matt Wilson <msw@redhat.com>
213- new translations for de fr it es
214
215* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
216- change prereqs
217
218* Sun Jul 23 2000 Bill Nottingham <notting@redhat.com>
219- fix ntsysv's handling of xinetd/init files with the same name
220
221* Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
222- fix segv when reading malformed files
223
224* Wed Jul 19 2000 Bill Nottingham <notting@redhat.com>
225- put links, rc[0-6].d dirs back, those are necessary
226
227* Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
228- add quick hack support for reading descriptions from xinetd files
229
230* Mon Jul 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
231- don't own the /etc/rc[0-6].d symlinks; they're owned by initscripts
232
233* Sat Jul 15 2000 Matt Wilson <msw@redhat.com>
234- move back to old file layout
235
236* Thu Jul 13 2000 Preston Brown <pbrown@redhat.com>
237- bump copyright date
238
239* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
240- no %pre today. Maybe tomorrow.
241
242* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
243- put initscripts %pre here too
244
245* Mon Jul  3 2000 Bill Nottingham <notting@redhat.com>
246- oops, if we don't prereq initscripts, we *need* to own /etc/rc[0-6].d
247
248* Sun Jul  2 2000 Bill Nottingham <notting@redhat.com>
249- add xinetd support
250
251* Tue Jun 27 2000 Matt Wilson <msw@redhat.com>
252- changed Prereq: initscripts >= 5.18 to Conflicts: initscripts < 5.18
253- fixed sumary and description where a global string replace nuked them
254
255* Mon Jun 26 2000 Matt Wilson <msw@redhat.com>
256- what Bill said, but actually build this version
257
258* Thu Jun 15 2000 Bill Nottingham <notting@redhat.com>
259- don't own /etc/rc.*
260
261* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
262- typo in man page
263
264* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
265- fix description
266
267* Wed Jan 12 2000 Bill Nottingham <notting@redhat.com>
268- link chkconfig statically against popt
269
270* Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
271- fix querying alternate levels
272
273* Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
274- don't use strchr to skip unwanted files, look at extension instead (#4166).
275
276* Thu Aug  5 1999 Bill Nottingham <notting@redhat.com>
277- fix --help, --verson
278
279* Mon Aug  2 1999 Matt Wilson <msw@redhat.com>
280- rebuilt ntsysv against newt 0.50
281
282* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
283- fix i18n problem in usage message (#4233).
284- add --help and --version.
285
286* Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
287- release for Red Hat 6.0
288
289* Thu Apr  8 1999 Matt Wilson <msw@redhat.com>
290- added support for a "hide: true" tag in initscripts that will make
291  services not appear in ntsysv when run with the "--hide" flag
292
293* Thu Apr  1 1999 Matt Wilson <msw@redhat.com>
294- added --hide flag for ntsysv that allows you to hide a service from the
295  user.
296
297* Mon Mar 22 1999 Bill Nottingham <notting@redhat.com>
298- fix glob, once and for all. Really. We mean it.
299
300* Thu Mar 18 1999 Bill Nottingham <notting@redhat.com>
301- revert fix for services@levels, it's broken
302- change default to only edit the current runlevel
303
304* Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
305- don't remove scripts that don't support chkconfig
306
307* Tue Mar 09 1999 Erik Troan <ewt@redhat.com>
308- made glob a bit more specific so xinetd and inetd don't cause improper matches
309
310* Thu Feb 18 1999 Matt Wilson <msw@redhat.com>
311- removed debugging output when starting ntsysv
312
313* Thu Feb 18 1999 Preston Brown <pbrown@redhat.com>
314- fixed globbing error
315- fixed ntsysv running services not at their specified levels.
316
317* Tue Feb 16 1999 Matt Wilson <msw@redhat.com>
318- print the value of errno on glob failures.
319
320* Sun Jan 10 1999 Matt Wilson <msw@redhat.com>
321- rebuilt for newt 0.40 (ntsysv)
322
323* Tue Dec 15 1998 Jeff Johnson <jbj@redhat.com>
324- add ru.po.
325
326* Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
327- build for Raw Hide (slang-1.2.2)
328
329* Wed Oct 14 1998 Cristian Gafton <gafton@redhat.com>
330- translation updates
331
332* Thu Oct 08 1998 Cristian Gafton <gafton@redhat.com>
333- updated czech translation (and use cs instead of cz)
334
335* Tue Sep 22 1998 Arnaldo Carvalho de Melo <acme@conectiva.com.br>
336- added pt_BR translations
337- added more translatable strings
338- support for i18n init.d scripts description
339
340* Sun Aug 02 1998 Erik Troan <ewt@redhat.com>
341- built against newt 0.30
342- split ntsysv into a separate package
343
344* Thu May 07 1998 Erik Troan <ewt@redhat.com>
345- added numerous translations
346
347* Mon Mar 23 1998 Erik Troan <ewt@redhat.com>
348- added i18n support
349
350* Sun Mar 22 1998 Erik Troan <ewt@redhat.com>
351- added --back
Note: See TracBrowser for help on using the repository browser.