source: projects/specs/branches/6/c/cherrytree/cherrytree-vl.spec @ 4354

Revision 4354, 6.6 KB checked in by kudoh, 13 years ago (diff)
Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Summary:   CherryTree - note taking application
4Summary(ja): CherryTree - ノート作成アプリケーション
5Name:      cherrytree
6Version:   0.22.2
7Release:   1%{?_dist_release}
8License:   GPLv2+
9Group:     Applications/Productivity
10URL:       http://www.giuspen.com/cherrytree/
11Source0:   %{name}-%{version}.tar.gz
12#Patch0: setup.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildArch: noarch
16
17BuildRequires:  desktop-file-utils
18BuildRequires:  gettext
19BuildRequires:  python
20BuildRequires:  python-devel
21BuildRequires:  python-setuptools
22Requires:  cairo
23Requires:  pango
24Requires:  python
25Requires:  pygtk2
26Requires:  gtksourceview2
27Requires:  pygtksourceview
28
29#Obsoletes: %name < %version
30
31%description
32A hierarchical note taking application, featuring rich text and syntax highlighting.
33Features:
34- rich text (foreground color, background color and bold)
35- syntax highlighting (only when the rich text is disabled in the current node)
36- find a node, find in current node, find in all nodes
37- replace in node names, replace in current node, replace in all nodes
38- iteration of the latest find, iteration of the latest replace
39
40%description -l ja
41階層型ノートの作成アプリケーションで、リッチテキストや構文の強調表示を備えています。
42特長:
43- リッチテキスト(前景色、背景色、太字)
44- 構文の強調表示(現在のノードではリッチテキストの場合だけ無効)
45- ノードの検出、現在のノードからの検索、すべてのノードからの検索
46- ノードの名前の置換、現在のノードで置換、すべてのノードで置換
47- 最新の検索・置換の繰り返し
48
49%prep
50%setup -q
51#%patch0 -p1
52#chmod +x setup.py
53
54sed -i 's|Comment=Hierarchical Note Taking|Comment=Hierarchical Note Taking\nComment[ja]=階層型ノートの作成|g' \
55       linux/cherrytree.desktop
56
57%build
58
59%install
60rm -rf $RPM_BUILD_ROOT
61%{__python} setup.py install --prefix=$RPM_BUILD_ROOT%{_prefix}
62
63desktop-file-install --vendor="" \
64            --add-category="Utility" \
65            --dir %{buildroot}%_datadir/applications \
66                  %{buildroot}%_datadir/applications/%{name}.desktop
67
68%find_lang %{name}
69
70%clean
71rm -rf %{buildroot}
72
73%post
74update-desktop-database %{_datadir}/applications
75gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
76
77%postun
78update-desktop-database %{_datadir}/applications
79gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
80
81
82%files -f %{name}.lang
83%defattr(-,root,root)
84%doc license
85%{_bindir}/%{name}
86%{_datadir}/application-registry/
87%{_datadir}/applications/
88%{_datadir}/%{name}
89%{_datadir}/icons/
90%{_datadir}/mime/packages/
91%{_datadir}/mime-info/
92%{python_sitelib}/*
93
94
95%changelog
96* Wed Jul 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.22.2-1
97- new upstream release
98
99* Wed Jul 06 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.22.1-1
100- new upstream release
101
102* Sun Jun 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.22-1
103- new upstream release
104- added BuildRequires: desktop-file-utils, python-setuptools
105
106* Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.21.3-1
107- new upstream release
108
109* Fri Apr 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.21.1-1
110- new upstream release
111
112* Tue Jan 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.19.3-1
113- new upstream release
114
115* Thu Jan 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.19.1-1
116- new upstream release
117
118* Sun Jan 2 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.18.1-1
119- new upstream release
120- used python macro
121
122* Sat Dec 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.17.1-1
123- new upstream release
124
125* Thu Dec 2 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.16-1
126- new upstream release
127- dropt Patch0
128
129* Sat Oct 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15-1
130- new upstream release
131- deleted unnecessary code in patch0
132
133* Mon Sep 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.2-1
134- new upstream release
135
136* Wed Sep 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14.1-1
137- new upstream release
138- recreated patch0
139
140* Thu Sep 2 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.14-1
141- new upstream release
142
143* Fri Aug 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13-1
144- new upstream release
145
146* Tue Jul 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12-1
147- new upstream release
148
149* Tue Jul 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.11-1
150- new upstream release
151- changed URL
152- added patch0 to work around install error
153- dropt BuildRequires: ImageMagick
154- added BuildRequires: python, python-devel
155- modified install process
156  - use setup.py in source
157  - modified %%files
158  - changed category to 'Utility'
159
160* Sun Jun 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10-1
161- new upstream release
162- added Requires: cairo, pango
163
164* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.6-1
165- new upstream release
166
167* Sat Mar 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.3-1
168- new upstream release
169- applied new naming policy to spec
170
171* Sun Mar 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.2-1
172- new upstream release
173- added BuildRequires: ImageMagick
174
175* Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.1-1
176- new upstream release
177
178* Mon Feb 15 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9-1
179- new upstream release
180
181* Sat Feb 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.3-2
182- rebuilt with python-2.6.4
183
184* Thu Jan 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.3-1
185- new upstream release
186
187* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.2-1
188- new upstream release
189
190* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
191- new upstream release
192
193* Fri Dec 18 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8-1
194- initial build for Vine Linux
195
196* Sun Dec 13 2009 slick50 <lxgator@gmail.com> 0.7.1-1pclos2010
197- 0.7.1
198
199* Sat Dec 12 2009 slick50 <lxgator@gmail.com> 0.7-1pclos2010
200- 0.7
201
202* Tue Dec 08 2009 slick50 <lxgator@gmail.com> 0.6.3-1pclos2010
203- 0.6.3
204
205* Fri Dec 05 2009 slick50 <lxgator@gmail.com> 0.6.2-1pclos2010
206- 0.6.2
207
208* Thu Nov 26 2009 slick50 <lxgator@gmail.com> 0.6-1pclos2010
209- 0.6
210
211* Fri Nov 20 2009 slick50 <lxgator@gmail.com> 0.5.1-1pclos2010
212- 0.5.1
213
214* Thu Nov 19 2009 slick50 <lxgator@gmail.com> 0.5-1pclos2010
215- 0.5
216
217* Thu Nov 12 2009 slick50 <lxgator@gmail.com> 0.4-1pclos2010
218- 0.4
219
220* Thu Nov 05 2009 slick50 <lxgator@gmail.com> 0.3-1pclos2010
221- 0.3
222
223* Fri Oct 30 2009 slick50 <lxgator@gmail.com> 0.2-1pclos2010
224- 0.2
225
226* Fri Oct 16 2009 Texstar <texstar at gmail.com> 0.1-2pclos2010
227- add missing dependency gnome-python-gtksourceview
228
229* Wed Oct 14 2009 slick50 <lxgator@gmail.com> 0.1-1pclos2010
230- initial pkg
231
Note: See TracBrowser for help on using the repository browser.