source: projects/specs/branches/6/c/cheese/cheese-vl.spec @ 3776

Revision 3776, 6.4 KB checked in by Takemikaduchi, 13 years ago (diff)

cheese: create -devel sub package, others: new upstream release

Line 
1Summary:        A webcam application for snapshots and movies
2Summary(ja):    スナップショットとムービーを撮るためのウェブカメラアプリケーション
3
4Name:           cheese
5Version:        2.32.0
6Release:        2%{?_dist_release}
7
8Group:          Applications/Multimedia
9License:        GPLv2+
10URL:            http://live.gnome.org/Cheese
11Source0:        http://download.gnome.org/sources/cheese/2.32/%{name}-%{version}.tar.bz2
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires: gtk2-devel >= 2.22.0
15BuildRequires: gnome-desktop-devel >= 2.32.0
16BuildRequires: GConf2-devel >= 2.32.0
17BuildRequires: gstreamer-devel >= 0.10.30
18BuildRequires: gstreamer-plugins-base-devel >= 0.10.30
19BuildRequires: evolution-data-server-devel >= 2.32.0
20BuildRequires: cairo-devel >= 1.10.0
21BuildRequires: dbus-devel >= 1.4.0
22BuildRequires: dbus-glib-devel >= 0.88
23BuildRequires: pango-devel >= 1.28.3
24BuildRequires: librsvg2-devel >= 2.32.0
25BuildRequires: desktop-file-utils
26BuildRequires: gettext
27BuildRequires: perl(XML::Parser)
28BuildRequires: gnome-doc-utils
29BuildRequires: autoconf, automake, libtool, intltool
30BuildRequires: libgudev1-devel
31BuildRequires: libcanberra-devel
32
33Requires: gstreamer-plugins-good
34Requires(post): GConf2
35Requires(pre): GConf2
36Requires(preun): GConf2
37
38%description
39Cheese is a Photobooth-inspired GNOME application for taking pictures and
40videos from a webcam. It also includes fancy graphical effects based on the
41gstreamer-backend.
42
43
44%package devel
45Summary:        Development files for cheese
46Group:          Development/Libraries
47License:        GPLv2+
48Requires:       %{name} = %{version}-%{release}
49
50%description devel
51This package contains the libraries and header files that are needed
52for writing applications that require a webcam display widget.
53
54
55%prep
56%setup -q
57
58%build
59%configure --disable-static
60make %{?_smp_mflags}
61
62
63%install
64rm -rf $RPM_BUILD_ROOT
65export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
66make install DESTDIR=$RPM_BUILD_ROOT
67unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
68
69desktop-file-install --delete-original --vendor=""      \
70        --dir=$RPM_BUILD_ROOT%{_datadir}/applications   \
71        $RPM_BUILD_ROOT%{_datadir}/applications/cheese.desktop
72
73rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
74rm -f $RPM_BUILD_ROOT%{_libexecdir}/%{name}/cheese-bugreport.sh
75
76%find_lang %{name} --with-gnome
77
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82
83%pre
84if [ "$1" -gt 1 ]; then
85  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
86  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/cheese.schemas > /dev/null || :
87fi
88
89
90%preun
91if [ "$1" -gt 0 ]; then
92  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
93  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/cheese.schemas > /dev/null || :
94fi
95
96
97%post
98touch --no-create %{_datadir}/icons/hicolor
99if [ -x /usr/bin/gtk-update-icon-cache ]; then
100  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
101fi
102export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
103gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/cheese.schemas > /dev/null || :
104
105
106%postun
107touch --no-create %{_datadir}/icons/hicolor
108if [ -x /usr/bin/gtk-update-icon-cache ]; then
109  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
110fi
111
112
113%files -f %{name}.lang
114%defattr(-,root,root,-)
115%doc AUTHORS COPYING README
116%{_bindir}/cheese
117%{_libdir}/libcheese-gtk*.so.*
118%{_datadir}/applications/cheese.desktop
119%{_datadir}/cheese
120%{_datadir}/icons/hicolor/*/apps/cheese.png
121%{_datadir}/icons/hicolor/scalable/apps/cheese.svg
122%{_datadir}/dbus-1/services/org.gnome.Cheese.service
123%{_sysconfdir}/gconf/schemas/cheese.schemas
124
125%files devel
126%defattr(-,root,root,-)
127%{_includedir}/cheese
128%{_libdir}/libcheese-gtk*.so
129%{_libdir}/pkgconfig
130%{_datadir}/gtk-doc/html/cheese/*
131
132%changelog
133* Mon May 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
134- create -devel sub package
135
136* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
137- new upstream release
138
139* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-2
140- rebuilt with rpm-4.8.1 for pkg-config
141
142* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
143- new upstream release
144
145* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
146- new upstream release
147- remove BuildRequires: hal-devel
148- add BuildRequires: libgudev1-devel, libcanberra-devel
149
150* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
151- new upstream release
152
153* Sat Jul 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
154- new upstream release
155
156* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
157- new upstream release
158
159* Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.0-2
160- changed Group to Applications/Multimedia
161
162* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
163- new upstream release
164
165* Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
166- new upstream release
167
168* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
169- new upstream release
170
171* Mon Aug 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.3-1
172- initial build for Vine Linux
173
174* Tue Aug  5 2008 Matthias Clasen  <mclasen@redhat.com> 2.23.6-1
175- Update to 2.23.6
176
177* Tue Jul 22 2008 Matthias Clasen  <mclasen@redhat.com> 2.23.5-1
178- Update to 2.23.5
179
180* Wed Jun 18 2008 Matthias Clasen  <mclasen@redhat.com> 2.23.4-1
181- Update to 2.23.4
182
183* Tue Jun  3 2008 Matthias Clasen  <mclasen@redhat.com> 2.23.3-1
184- Update to 2.23.3
185
186* Tue May 13 2008 Matthias Clasen  <mclasen@redhat.com> 2.23.2-1
187- Update to 2.23.2
188
189* Fri Apr 25 2008 Matthias Clasen  <mclasen@redhat.com> 2.23.1-1
190- Update to 2.23.1
191
192* Tue Apr 22 2008 Matthias Clasen  <mclasen@redhat.com> 2.22.1-2
193- Fix an invalid free
194
195* Mon Apr  7 2008 Matthias Clasen  <mclasen@redhat.com> 2.22.1-1
196- Update to 2.22.1
197
198* Mon Mar 10 2008 Matthias Clasen  <mclasen@redhat.com> 2.22.0-1
199- Update to 2.22.0
200
201* Tue Feb 26 2008  Matthias Clasen  <mclasen@redhat.com> 2.21.92-1
202- Update to 2.21.92
203
204* Fri Feb 15 2008  Matthias Clasen  <mclasen@redhat.com> 2.21.91-3
205- Fix a locking problem that causes the UI to freeze
206
207* Fri Feb  8 2008  Matthias Clasen  <mclasen@redhat.com> 2.21.91-2
208- Rebuild for gcc 4.3
209
210* Tue Jan 29 2008  Matthias Clasen  <mclasen@redhat.com> 2.21.91-1
211- Update to 2.21.91
212
213* Mon Jan 14 2008  Matthias Clasen  <mclasen@redhat.com> 2.21.5-1
214- Update to 2.21.5
215
216* Mon Dec 24 2007  Matthias Clasen  <mclasen@redhat.com> 0.3.0-1
217- Update to 0.3.0
218
219* Fri Sep  7 2007  Matthias Clasen  <mclasen@redhat.com> 0.2.4-2
220- package review feedback
221
222* Thu Sep  6 2007  Matthias Clasen  <mclasen@redhat.com> 0.2.4-1
223- Initial packages
Note: See TracBrowser for help on using the repository browser.