source: projects/specs/branches/6/c/cfitsio/cfitsio-vl.spec @ 1928

Revision 1928, 8.2 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1Name:           cfitsio
2Version:        3.240
3Release:        2%{?_dist_release}
4Summary:        Library for manipulating FITS data files
5
6Group:          System Environment/Libraries
7License:        GPLv2+
8URL:            http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html
9Source0:        ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/cfitsio3240.tar.gz
10Patch:          cfitsio.patch
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires:     gcc-gfortran
14Requires(post):    /sbin/ldconfig
15Requires(postun):  /sbin/ldconfig
16
17%description
18CFITSIO is a library of C and FORTRAN subroutines for reading and writing
19data files in FITS (Flexible Image Transport System) data format. CFITSIO
20simplifies the task of writing software that deals with FITS files by
21providing an easy to use set of high-level routines that insulate the
22programmer from the internal complexities of the FITS file format. At the
23same time, CFITSIO provides many advanced features that have made it the
24most widely used FITS file programming interface in the astronomical
25community.
26
27%package devel
28Group:  Development/Libraries
29Summary: Headers required when building programs against cfitsio
30Requires: %{name} = %{version}-%{release}
31Requires: pkgconfig
32
33%description devel
34Headers required when building a program against the cfitsio library.
35
36%package static
37Group: Development/Libraries
38Summary: Static cfitsio library
39
40%description static
41Static cfitsio library; avoid use if possible.
42
43%package docs
44Summary: Documentation for cfitsio
45Group:  Development/Libraries
46
47%description docs
48Stand-alone documentation for cfitsio.
49
50%prep
51%setup -q -n cfitsio
52%patch -p1
53
54%build
55FC=f95
56export FC
57export CC=gcc # fixes -O*, -g
58%configure
59make shared %{?_smp_mflags}
60unset FC
61# Manually fix pkgconfig .pc file (BZ 436539)
62sed 's|${exec_prefix}/lib|${exec_prefix}/%{_lib}|' cfitsio.pc >cfitsio.pc.new
63sed 's|${prefix}/include|${prefix}/include/%{name}|' cfitsio.pc.new >cfitsio.pc
64rm -f cfitsio.pc.new
65# Manually correct pkgconfig .pc file version
66sed 's|3.006|%{version}|' cfitsio.pc >cfitsio.pc.new
67mv cfitsio.pc.new cfitsio.pc
68
69%check
70make testprog
71LD_LIBRARY_PATH=. ./testprog > testprog.lis
72cmp -s testprog.lis testprog.out
73cmp -s testprog.fit testprog.std
74
75%install
76rm -rf %{buildroot}
77mkdir -p %{buildroot}
78mkdir -p %{buildroot}%{_libdir}
79mkdir -p %{buildroot}%{_includedir}/%{name}
80make LIBDIR=%{_lib} INCLUDEDIR=include/%{name} CFITSIO_LIB=%{buildroot}%{_libdir} \
81     CFITSIO_INCLUDE=%{buildroot}%{_includedir}/%{name} install
82pushd %{buildroot}%{_libdir}
83ln -s libcfitsio.so.0 libcfitsio.so
84popd
85
86%clean
87rm -rf %{buildroot}
88
89%post -p /sbin/ldconfig
90
91%postun -p /sbin/ldconfig
92
93%files
94%defattr(-,root,root,-)
95%doc README License.txt changes.txt
96%{_libdir}/libcfitsio.so.*
97
98%files devel
99%defattr(-,root,root,-)
100%{_includedir}/%{name}
101%{_libdir}/libcfitsio.so
102%{_libdir}/pkgconfig/cfitsio.pc
103
104%files static
105%defattr(-,root,root,-)
106%{_libdir}/libcfitsio.a
107
108%files docs
109%defattr(-,root,root,-)
110%doc fitsio.doc fitsio.ps cfitsio.doc cfitsio.ps
111
112%changelog
113* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 3.240-2
114- rebuilt with rpm-4.8.1 for pkg-config
115
116* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.240-1
117- new upstream release
118
119* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.140-3
120- Initial build for Vine Linux
121
122* Fri Jul 24 2009 Matthew Truch <matt at truch.net> - 3.140-2
123- Bump to include proper tarball.
124
125* Tue Jul 21 2009 Matthew Truch <matt at truch.net> - 3.140-1
126- Update to upstream 3.140 release.
127- Bump for mass rebuild.
128
129* Wed Jun 17 2009 Matthew Truch <matt at truch.net> - 3.130-5
130- Separate -docs noarch subpackage as per BZ 492438.
131- Explicitly set file attributes correctly. 
132
133* Tue Mar 10 2009 Matthew Truch <matt at truch.net> - 3.130-4
134- Set correct version in pkgconfig .pc file. 
135
136* Sun Feb 22 2009 Matthew Truch <matt at truch.net> - 3.130-3
137- Re-check testprogram output.
138- Build for koji, rpm, gcc upgrade. 
139
140* Thu Feb 5 2009 Matthew Truch <matt at truch.net> - 3.130-2
141- Fix source file naming typo.
142
143* Wed Feb 4 2009 Matthew Truch <matt at truch.net> - 3.130-1
144- Update to 3.130 upstream.
145
146* Sat Sep 20 2008 Matthew Truch <matt at truch.net> - 3.100-2
147- Test library with included test-suite. 
148
149* Fri Sep 19 2008 Matthew Truch <matt at truch.net> - 3.100-1
150- Update to 3.100 upstream.
151  Includes bugfixes and new compression scheme.
152
153* Fri Mar 7 2008 Matthew Truch <matt at truch.net> - 3.060-3
154- Properly indicated include and lib directories in .pc file
155  (BZ 436539)
156- Fix typo in -static descrition.
157
158* Mon Feb 11 2008 Matthew Truch <matt at truch.net> - 3.060-2
159- Bump release for rebuild.
160
161* Fri Nov 9 2007 Matthew Truch <matt at truch.net> - 3.060-1
162- Update to 3.060 bugfix release.
163- Add static package (BZ 372801)
164
165* Tue Aug 21 2007 Matthew Truch <matt at truch.net> - 3.040-3
166- Bump release for rebuild (build-id etc.)
167
168* Thu Aug 2 2007 Matthew Truch <matt at truch.net> - 3.040-2
169- Update License tag
170
171* Mon Jul 9 2007 Matthew Truch <matt at truch.net> - 3.040-1
172- Upgrade to version 3.040 of cfitsio.
173
174* Fri Feb 16 2007 Matthew Truch <matt at truch.net> - 3.030-2
175- Require pkgconfig for -devel.
176- export CC=gcc so we don't clobber $RPM_OPT_FLAGS, thereby
177  ruining any -debuginfo packages. 
178  See RedHat Bugzilla 229041.
179
180* Fri Jan 5 2007 Matthew Truch <matt at truch.net> - 3.030-1
181- Upgrade to version 3.020 of cfitsio.
182
183* Fri Dec 8 2006 Matthew Truch <matt at truch.net> - 3.020-3
184- Commit correct patch to configure and Makefiles.
185
186* Fri Dec 8 2006 Matthew Truch <matt at truch.net> - 3.020-2
187- Modify spec file to install to correct directories.
188- Package cfitsio.pc file in -devel package.
189
190* Wed Dec 6 2006 Matthew Truch <matt at truch.net> - 3.020-1
191- Upgrade to revision 3.020 of cfitsio.
192
193* Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 3.006-6
194- Bump release for rebuild in prep. for FC6.
195
196* Thu Mar 30 2006 Matthew Truch <matt at truch.net> - 3.006-5
197- Include defattr() for devel package as well - bug 187366
198
199* Sun Mar 19 2006 Matthew Truch <matt at truch.net> - 3.006-4
200- Don't use macro {buildroot} in build, only in install as per
201  appended comments to Bugzilla bug 172042
202 
203* Fri Mar 10 2006 Matthew Truch <matt at truch.net> - 3.006-3
204- Point to f95 instead of g95 as per bugzilla bug 185107
205
206* Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.006-2
207- Fix spelling typo in name of License.txt file.
208
209* Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.006-1
210- Use new 3.006 fully official stable (non-beta) upstream package.
211
212* Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.005-0.2.beta
213- Bump release for FC5 extras rebuild.
214
215* Fri Dec 23 2005 Matthew Truch <matt at truch.net> - 3.005-0.1.beta
216- Update to 3.005beta release.
217
218* Mon Nov 14 2005 Matthew Truch <matt at truch.net> - 3.004-0.12.b
219- Put in proper URL and Source addresses.
220- Sync up spec files.
221
222* Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.11.b
223- Clean up unused code in spec file.
224
225* Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.10.b
226- Set environment variables correctly.
227- Include patch so Makefile will put things where they belong.
228
229* Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.9.b
230- Set libdir and includedir correctly for build process.
231
232* Sat Nov 12 2005 Matthew Truch <matt at truch.net> - 3.004-0.8.b
233- unset FC once we are done with the build
234
235* Sat Nov 12 2005 Ed Hill <ed@eh3.com> - 3.004-0.7.b
236- shared libs and small cleanups
237
238* Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.6.b
239- Own include directory created by the devel package.
240
241* Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.5.b
242- Shorten summary.
243- Improve specfile post and postun syntax.
244- Install headers in cfitsio include subdir.
245- Include more documentation provided in tarball.
246
247* Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.4.b
248- Require cfitsio for cfitsio-devel
249
250* Sat Nov 05 2005 Matthew Truch <matt at truch.net> - 3.004-0.3.b
251- Use proper virgin tarball from upstream.
252
253* Sun Oct 30 2005 Matthew Truch <matt at truch.net> - 3.004-0.2.b
254- Include gcc-gfortran build requirment and make sure it gets used.
255- Use macros instead of hard coded paths.
256- Include home page in description
257
258* Sat Oct 29 2005 Matthew Truch <matt at truch.net> - 3.004-0.1.b
259- Initial spec file for Fedora Extras.
260
Note: See TracBrowser for help on using the repository browser.