source: projects/specs/branches/6/c/cdrdao/cdrdao-vl.spec @ 3576

Revision 3576, 4.9 KB checked in by inagaki, 13 years ago (diff)

update: cdrdao

Line 
1Name: cdrdao
2Summary: Writes audio CD-Rs in disk-at-once (DAO) mode.
3Summary(ja): ディスクアットワンス(DAO)モードでオーディオデータを CD-R へ書き込むツール
4Version: 1.2.3
5Release: 2%{?_dist_release}
6
7Group: Applications/Multimedia
8License: GPLv2+
9URL: http://cdrdao.sourceforge.net/
10
11Source0:   http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
12# Missing includes causes failure build
13Patch1: cdrdao-1.2.3-stat.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: gtkmm2-devel
17BuildRequires: libgnomeuimm-devel
18BuildRequires: libsigc++-devel
19BuildRequires: libao-devel
20BuildRequires: libvorbis-devel >= 1.0
21BuildRequires: libSM-devel
22BuildRequires: libICE-devel
23#BuildRequires: pccts >= 1.33mr33
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29Cdrdao records audio CD-Rs in disk-at-once (DAO) mode, based on a
30textual description of the CD contents. Recording in DAO mode writes
31the complete disc (lead-in, one or more tracks, and lead-out) in a
32single step.
33
34%description -l ja
35Cdrdaoはディスクアットワンス(DAO)モードでaudioをCD-Rへ記録します。
36CD中身の原文の説明に基づきます。DAOモードのレコーディングは、一回のステップに完全なディスク(lead-in、一つ以上のトラックとlead-out)を書きます。
37
38
39%package -n gcdmaster
40Summary: Graphical front end to cdrdao for composing audio CDs
41Group: Applications/Multimedia
42Requires: %{name} = %{version}
43Requires(post): shared-mime-info
44Requires(postun): shared-mime-info
45
46%description -n gcdmaster
47gcdmaster allows the creation of toc-files for cdrdao and can control
48the recording process. Its main application is the composition of
49audio CDs from one or more audio files. It supports PQ-channel editing,
50entry of meta data like ISRC codes/CD-TEXT and non destructive cut of
51the audio data.
52
53
54%prep
55%setup -q
56%patch1 -p1 -b .stat
57
58%build
59%configure \
60        --with-xdao \
61        --without-scglib \
62        --without-mp3-support \
63        --without-lame
64# --with-pcctsinc=%{_includedir}/pccts \
65#           --without-lame \
66#           --without-mp3-support
67
68make %{?_smp_mflags}
69
70%install
71rm -rf $RPM_BUILD_ROOT
72
73make install DESTDIR=$RPM_BUILD_ROOT
74
75find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
76
77
78%pre -n gcdmaster
79if [ $1 -gt 1 ]; then
80    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
81    gconftool-2 --makefile-uninstall-rule \
82        %{_sysconfdir}/gconf/schemas/gcdmaster.schemas >& /dev/null ||:
83fi
84
85%post -n gcdmaster
86export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
87gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gcdmaster.schemas >& /dev/null ||:
88
89%posttrans -n gcdmaster
90update-mime-database %{_datadir}/mime >& /dev/null ||:
91
92%preun -n gcdmaster
93if [ $1 -eq 0 ]; then
94    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
95    gconftool-2 --makefile-uninstall-rule \
96        %{_sysconfdir}/gconf/schemas/gcdmaster.schemas >& /dev/null ||:
97fi
98
99%postun -n gcdmaster
100if [ $1 -eq 0 ] ; then
101    update-mime-database %{_datadir}/mime >& /dev/null ||:
102fi
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%files
108%defattr(-,root,root)
109%{_bindir}/cdrdao
110%{_datadir}/cdrdao/*
111%{_bindir}/toc2*
112%{_bindir}/cue2toc
113%{_mandir}/man1/*.gz
114%doc AUTHORS COPYING CREDITS ChangeLog README NEWS README.PlexDAE README.Win32
115
116%files -n gcdmaster
117%defattr(-,root,root)
118%doc AUTHORS COPYING README
119%{_sysconfdir}/gconf/schemas/gcdmaster.schemas
120%{_bindir}/gcdmaster
121%{_datadir}/application-registry/*
122%{_datadir}/applications/*
123%{_datadir}/gcdmaster
124%{_datadir}/mime-info/*
125%{_datadir}/mime/packages/*
126%{_datadir}/pixmaps/*
127
128%changelog
129* Tue Apr 19 2011 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.2.3-2
130- fixed %%changelog
131- added BR: libSM-devel and libICE-devel
132
133* Sat Apr 16 2011 Ryoichi INAGAKI <daisuke@linux.or.jp> 1.2.3-1
134- updated to 1.2.3
135- rebuilt with current VineSeed
136
137* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-4
138- add --without-mp3-support
139
140* Tue Mar 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-3
141- add --without-lame
142- remove BR: libmad-devel
143
144* Sat Oct  4 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-2vl5
145- added BuildRequires: libao-devel, libmad-devel
146
147* Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.2-1vl5
148- applied new versioning policy, spec in utf-8
149- added cdrdao-1.2.2-sigc.patch from mdv
150    * Tue Sep 11 2007 Adam Williamson <awilliamson@mandriva.com> 1.2.2-5mdv2008.0
151    + Revision: 84331
152    - add patch0 to fix compilation issue caused by use of old sigc++ API
153
154* Sat Nov  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-0vl1
155- update to 1.2.2
156- fixed BuildRequires and Prereq
157
158* Mon May 22 2006 TOSHI <vine-jp@mail.goo.ne.jp> 1.1.9-0vl1
159- update to 1.1.9
160- added Requires -> libstdc++2_10,libstdc++2_10-compat
161
162* Mon Jun 10 2002 Tomoya TAKA <taka@vinelinux.org> 1.1.5-7vl2
163- separate gcdmaster into subpackage
164- add /etc/profile.d/gcdmaster.{sh,csh} to exec gcdmaster on C locale
165# end of file
Note: See TracBrowser for help on using the repository browser.