source: projects/specs/branches/6/c/calibre/calibre-vl.spec @ 3017

Revision 3017, 18.7 KB checked in by munepi, 13 years ago (diff)

update calibre-vl.spec

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           calibre
4Version:        0.7.50
5Release:        1%{?_dist_release}
6Summary:        E-book converter and library management
7Group:          Applications/Multimedia
8License:        GPLv3
9URL:            http://calibre-ebook.com/
10
11# SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12
13# Upstream packages some unfree fonts which we cannot redistribute.
14# While we're at it, also delete the liberation fonts which we already have.
15#
16# Download the upstream tarball and invoke this script while in the tarball's
17# directory:
18# ./generate-tarball.sh %{version}
19Source0:        %{name}-%{version}-nofonts.tar.xz
20Source1:        generate-tarball.sh
21Source2:        calibre-mount-helper
22Patch0:         %{name}-manpages.patch
23Patch1:         %{name}-no-update.patch
24#Patch2:         %{name}-0.6.53-mounthelper.patch
25BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
26
27BuildRequires:  python >= 2.6
28BuildRequires:  python-devel >= 2.6
29BuildRequires:  ImageMagick-devel >= 6.5.9
30BuildRequires:  python-setuptools
31BuildRequires:  qt4-devel >= 4.6.0
32BuildRequires:  PyQt4-devel >= 4.7.0
33BuildRequires:  poppler-qt4-devel >= 0.12
34BuildRequires:  podofo-devel
35BuildRequires:  desktop-file-utils
36BuildRequires:  python-mechanize >= 0.1.1
37BuildRequires:  python-lxml >= 2.2.1
38BuildRequires:  python-cssutils >= 0.9.6
39BuildRequires:  python-dateutil >= 1.4.1
40BuildRequires:  python-imaging >= 1.1.6
41BuildRequires:  xdg-utils >= 1.0.2
42BuildRequires:  python-BeautifulSoup >= 3.0.5
43BuildRequires:  xz
44BuildRequires:  unzip
45BuildRequires:  libwmf-devel >= 0.2.8
46BuildRequires:  chmlib-devel >= 0.40
47BuildRequires:  python-cssutils > 0.9.6
48BuildRequires:  sqlite3-devel
49BuildRequires:  libicu-devel
50
51Requires:       PyQt4
52Requires:       pyPdf
53Requires:       python-cherrypy
54Requires:       python-cssutils
55Requires:       ImageMagick
56Requires:       python-odf
57Requires:       python-django-tagging
58Requires:       python-lxml
59Requires:       python-imaging
60Requires:       python-mechanize
61Requires:       python-dateutil
62Requires:       python-genshi
63Requires:       python-BeautifulSoup
64
65## vine
66Requires:       TrueType-liberation
67
68%description
69Calibre is meant to be a complete e-library solution. It includes library
70management, format conversion, news feeds to ebook conversion as well as
71e-book reader sync features.
72
73Calibre is primarily a ebook cataloging program. It manages your ebook
74collection for you. It is designed around the concept of the logical book,
75i.e. a single entry in the database that may correspond to ebooks in several
76formats. It also supports conversion to and from a dozen different ebook
77formats.
78
79Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
80RTF, TXT, PDF and LRS.
81
82%prep
83%setup -q -n %{name}
84
85# don't append calibre1 to the name of the manpages. No need to compress either
86# upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
87%patch0 -p1 -b .manpages
88
89# don't check for new upstream version (that's what packagers do)
90%patch1 -p1 -b .no-update
91
92# dos2unix newline conversion
93%{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
94
95# remove shebangs
96%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
97%{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
98%{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
99%{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
100%{__sed} -i -e '/^#!\//, 1d' src/templite/*.py
101%{__sed} -i -e '/^#!\//, 1d' resources/recipes/*
102%{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
103
104%{__chmod} -x src/calibre/*/*/*/*.py
105%{__chmod} -x src/calibre/*/*/*.py
106%{__chmod} -x src/calibre/*/*.py
107%{__chmod} -x src/calibre/*.py
108%{__chmod} -x resources/recipes/*
109
110%build
111OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
112
113%install
114%__rm -rf %{buildroot}
115
116%__mkdir -p %{buildroot}%{_datadir}
117
118# create directories for xdg-utils
119%__mkdir_p %{buildroot}%{_datadir}/icons
120%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
121%__mkdir_p %{buildroot}%{_datadir}/packages
122%__mkdir_p %{buildroot}%{_datadir}/mime
123%__mkdir_p %{buildroot}%{_datadir}/mime/packages
124%__mkdir_p %{buildroot}%{_datadir}/applications
125%__mkdir_p %{buildroot}%{_datadir}/desktop-directories
126
127# create directory for calibre environment module
128# the install script assumes it's there.
129%__mkdir_p %{buildroot}%{python_sitelib}
130
131XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
132XDG_UTILS_INSTALL_MODE="system" \
133LIBPATH="%{_libdir}" \
134python setup.py install --root=%{buildroot}%{_prefix} \
135                        --prefix=%{_prefix} \
136                        --libdir=%{_libdir} \
137                        --staging-libdir=%{buildroot}%{_libdir}
138
139# remove shebang from init_calibre.py here because
140# it just got spawned by the install script
141%{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
142
143# icons
144%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
145%__cp -p resources/images/library.png \
146        %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
147%__cp -p resources/images/viewer.png \
148        %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
149
150# every file is empty here
151find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
152
153# packages aren't allowed to register mimetypes like this
154%__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
155
156desktop-file-validate \
157    %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
158desktop-file-validate \
159    %{buildroot}%{_datadir}/applications/calibre-gui.desktop
160desktop-file-validate \
161    %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
162
163
164%__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
165    %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
166
167# mimetype icon for lrf
168%__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
169%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
170%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
171%__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
172%__cp -p resources/images/mimetypes/lrf.png \
173    %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
174%__cp -p resources/images/viewer.png \
175    %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
176
177# don't put bash completions in /usr/etc
178%__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
179
180# these are provided as separate packages
181%__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
182%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
183%__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
184
185# link to system fonts after we have deleted (see Source0) the non-free ones
186# http://bugs.calibre-ebook.com/ticket/3832
187%__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
188%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
189        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
190%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
191        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
192%__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
193        %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
194
195# http://bugs.calibre-ebook.com/ticket/3770#comment:7
196# man pages
197%__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
198
199# move locales
200%__mv %{buildroot}%{_datadir}/%{name}/localization/locales \
201    %{buildroot}%{_datadir}/locale
202for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/messages.mo; do
203    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
204    %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/messages.mo \
205        %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}.mo
206done;
207for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/iso639.mo; do
208    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
209    %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/iso639.mo \
210        %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_iso639.mo
211done;
212for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/qt.qm; do
213    lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
214    %__mv $file %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_$lang.qm
215done;
216
217%find_lang %{name} --with-qt --all-name
218
219# locales should be looked for in the proper place
220%{__sed} -i -e "s:P('localization/locales:('/usr/share/locale:" \
221        -e "s/messages.mo/calibre.mo/" \
222        -e "s/iso639.mo/calibre_iso639.mo/" \
223        %{buildroot}%{_libdir}/%{name}/%{name}/utils/localization.py
224
225%{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
226
227%__cp -a %{SOURCE2} %{buildroot}%{_bindir}/
228
229%clean
230%{__rm} -rf %{buildroot}
231
232%post
233update-desktop-database &> /dev/null ||:
234update-mime-database %{_datadir}/mime &> /dev/null || :
235touch --no-create %{_datadir}/icons/hicolor || :
236if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
237    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
238fi
239
240%postun
241update-desktop-database &> /dev/null ||:
242update-mime-database %{_datadir}/mime &> /dev/null || :
243touch --no-create %{_datadir}/icons/hicolor || :
244if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
245    %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
246fi
247
248%files -f %{name}.lang
249%defattr(-,root,root,-)
250%doc COPYRIGHT LICENSE Changelog.yaml
251%{_bindir}/calibre
252%{_bindir}/calibre-complete
253%{_bindir}/calibre-customize
254%{_bindir}/calibre-debug
255%{_bindir}/calibre-parallel
256%{_bindir}/calibre-server
257%{_bindir}/calibre-smtp
258%{_bindir}/calibre-mount-helper
259%{_bindir}/calibredb
260%{_bindir}/ebook-convert
261%{_bindir}/ebook-device
262%{_bindir}/ebook-meta
263%{_bindir}/ebook-viewer
264%{_bindir}/epub-fix
265%{_bindir}/fetch-ebook-metadata
266%{_bindir}/librarything
267%{_bindir}/lrf2lrs
268%{_bindir}/lrfviewer
269%{_bindir}/lrs2lrf
270%{_bindir}/markdown-calibre
271%{_bindir}/pdfmanipulate
272%{_bindir}/web2disk
273%config(noreplace) %{_sysconfdir}/bash_completion.d/
274%{_libdir}/%{name}
275%{_datadir}/%{name}
276%{_datadir}/pixmaps/*
277%{_datadir}/applications/*.desktop
278%{_datadir}/mime/packages/*
279%{_datadir}/icons/hicolor/scalable/mimetypes/*
280%{_datadir}/icons/hicolor/scalable/apps/*
281%{python_sitelib}/init_calibre.py*
282%{_mandir}/man1/*
283
284%changelog
285* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.50-1
286- new upstream release
287
288* Sat Feb 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.46-1
289- new upstream release
290
291* Thu Feb 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.44-1
292- new upstream release
293
294* Fri Feb 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.42-1
295- new upstream release
296
297* Fri Jan 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.40-1
298- new upstream release
299
300* Mon Dec 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.35-1
301- new upstream release
302
303* Sun Dec 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.34-1
304- new upstream release
305
306* Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.33-1
307- new upstream release
308- added BuildRequires: libicu-devel
309
310* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.32-1
311- new upstream release
312
313* Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
314- new upstream release
315
316* Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
317- new upstream release
318
319  * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
320  - Update to 0.7.24
321
322  * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
323  - Update to 0.7.23
324  - Fix up mount helper with our own local script.
325  - Change files to list binaries so missing ones can more easily be noted.
326
327  * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
328  - Update to 0.7.22
329
330  * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
331  - Update to 0.7.21
332
333  * Wed Sep 29 2010 jkeating - 0.7.20-2
334  - Rebuilt for gcc bug 634757
335
336  * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
337  - Update to 0.7.20
338
339  * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
340  - Rebuild for new ImageMagick
341
342* Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
343- new upstream release
344- Fix svg/png changes.
345
346  * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
347  - Fix svg/png changes.
348
349  * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
350  - Update to 0.7.18
351  - Require > 0.9.6 cssutils
352
353  * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
354  - Update to 0.7.17
355
356  * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
357  - Update to 0.7.16
358
359* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
360- initial build based on Fedora development
361
362* Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
363- Update to 0.7.15
364
365* Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
366- rebuild (poppler)
367
368* Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
369- Update to 0.7.14
370
371* Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
372- Update to 0.7.13
373
374* Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
375- Update to 0.7.12
376
377* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
378- Update to 0.7.11
379
380* Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
381- Rebuilt for python2.7
382
383* Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
384- Update to 0.7.10
385
386* Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
387- Update to 0.7.9
388
389* Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
390- Update to 0.7.8
391- build tar.xz instead of tar.bz2
392
393* Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
394- Update to 0.7.7
395
396* Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
397- Update to 0.7.6
398
399* Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
400- Update to 0.7.5
401
402* Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
403- Update to 0.7.4
404
405* Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
406- rebuilt with podofo 0.8.1
407
408* Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
409- Update to 0.7.1
410- Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
411
412* Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
413- Update to 0.7.0
414
415* Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
416- Update to 0.6.55
417
418* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
419- Update to 0.6.54
420
421* Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
422- Update to 0.6.53
423
424* Wed May  5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
425- Rebuild against new poppler
426
427* Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
428- new upstream release 0.6.47
429- new chmlib requirement
430- create directory for calibre's environment module
431- use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
432- remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
433
434* Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
435- new upstream release 0.6.42
436- remove shebang from default_tweaks.py
437
438* Mon Feb  1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
439- new upstream release 0.6.37
440
441* Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
442- new upstream release 0.6.36
443- fixed a cssprofiles issue with loading the profiles
444
445* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
446- added -cssprofiles patch to cvs
447
448* Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
449- remove python-cssutils 0.9.6 dependency
450
451* Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
452- new upstream release
453- fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
454- removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
455
456* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
457- fix for package tagged without adding new patch to cvs
458
459* Wed Jan  6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
460- new upstream release 0.6.32
461- project website has changed
462- added python-BeautifulSoup BuildRequire
463- new patch to fix full buildpath in binary files
464
465* Sun Dec  6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
466- New upstream version
467- Regenerated no-update patch because of code relocation
468
469* Wed Dec  2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
470- New upstream release
471
472* Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
473- New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
474
475* Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
476- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
477- patch to stop checking for new upstream version
478
479* Sat Nov  7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
480- new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
481- added python-BeautifulSoup requirement
482
483* Wed Nov  4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
484- new upstream version:
485http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
486- upstream now ships correct .desktop files
487- fixed missing dependency: PyQt4
488- fixed calibre-gui icon
489
490* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
491- removed unfree fonts from source package
492
493* Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
494- readability enhancements
495- added python-genshi requires
496- removed libwmf require since ImageMagick provides libwmf-lite as a
497  dependency and that's what we actually need
498
499* Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
500- new upstream version:
501  http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
502- delete fonts, calibre can find the system fonts
503- specify libdir as an install option, so calibre will link properly
504  even on 64bit
505
506* Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
507- updated requires list
508- new upstream release
509- can override CFLAGS now
510- removed trac and genshi duplicates
511- use xdg env variables to do desktop integration in the buildroot
512- added xdg-utils buildrequire
513- install udev rules in /usr/lib even on 64bit and don't own the whole dir
514- removed wrongly used Version field from .desktop files
515
516* Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
517- mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
518- removed unneeded INSTALL file
519- marked bash completion file as config(noreplace) and take ownership of the dir
520
521* Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
522- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
523- the install process changed significantly
524- locales were added
525
526* Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
527- new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
528- minor path fixes
529- rearranged files section
530
531* Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
532- handle desktop files
533- don't compress manpages and don't list them as duplicates
534- added lrfviewer icon
535
536* Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
537- Initial RPM release
Note: See TracBrowser for help on using the repository browser.