source: projects/specs/branches/6/c/cairo/cairo-vl.spec @ 3191

Revision 3191, 11.3 KB checked in by daisuke, 13 years ago (diff)

cairo:

  • enable tee support
  • add configure options specifically
  • disable static library
Line 
1Summary:        Cairo - multi-platform 2D graphics library.
2Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
3Name:           cairo
4Version:        1.10.2
5Release:        2%{?_dist_release}
6License:        LGPL/MPL
7Group:          System Environment/Libraries
8Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
9
10# don't use serverside gradients, most drivers don't handle those and are
11# really slow, should workaround performances issues for ati, nouveau and nvidia
12# https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
13Patch1:         cairo-1.10.0-dont_use_server_side_gradients.patch
14
15URL:            http://cairographics.org/
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: pkgconfig
19BuildRequires: pixman-devel
20BuildRequires: glib2-devel
21BuildRequires: libpng-devel
22BuildRequires: freetype2-devel
23BuildRequires: fontconfig-devel
24BuildRequires: libX11-devel
25BuildRequires: libXrender-devel
26BuildRequires: gtk-doc
27
28BuildConflicts: XOrg-compat70-devel
29
30%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
31
32%description
33Cairo provides anti-aliased vector-based rendering for X. Paths
34consist of line segments and cubic splines and can be rendered at any
35width with various join and cap styles. All colors may be specified
36with optional translucence (opacity/alpha) and combined using the
37extended Porter/Duff compositing algebra as found in the X Render
38Extension.
39
40Cairo exports a stateful rendering API similar in spirit to the path
41construction, text, and painting operators of PostScript, (with the
42significant addition of translucence in the imaging model). When
43complete, the API is intended to support the complete imaging model of
44PDF 1.4.
45
46Cairo relies on the Xc library for backend rendering. Xc provides an
47abstract interface for rendering to multiple target types. As of this
48writing, Xc allows Cairo to target X drawables as well as generic
49image buffers. Future backends such as PostScript, PDF, and perhaps
50OpenGL are currently being planned.
51
52%package -n compat32-%{name}
53Summary:        Cairo - multi-platform 2D graphics library.
54Summary(ja):    Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
55Group:          System Environment/Libraries
56Requires:       %{name} = %{version}
57
58%description -n compat32-%{name}
59Cairo provides anti-aliased vector-based rendering for X. Paths
60consist of line segments and cubic splines and can be rendered at any
61width with various join and cap styles. All colors may be specified
62with optional translucence (opacity/alpha) and combined using the
63extended Porter/Duff compositing algebra as found in the X Render
64Extension.
65
66Cairo exports a stateful rendering API similar in spirit to the path
67construction, text, and painting operators of PostScript, (with the
68significant addition of translucence in the imaging model). When
69complete, the API is intended to support the complete imaging model of
70PDF 1.4.
71
72Cairo relies on the Xc library for backend rendering. Xc provides an
73abstract interface for rendering to multiple target types. As of this
74writing, Xc allows Cairo to target X drawables as well as generic
75image buffers. Future backends such as PostScript, PDF, and perhaps
76OpenGL are currently being planned.
77
78%package devel
79Summary:        Development files for Cairo library.
80Summary(ja):    Cairo ライブラリの開発用ファイル
81Group:          Development/Libraries
82Provides:       lib%{name}-devel = %{version}-%{release}
83Requires:       %{name} = %{version}
84Requires:       libpng-devel
85Requires:       freetype2-devel
86Requires:       fontconfig-devel
87Requires:       libX11-devel
88Requires:       libXrender-devel
89Requires:       pixman-devel
90Requires:       glib2-devel
91
92%description devel
93Development files for Cairo library.
94
95%package tools
96Summary: Development tools for cairo
97Group: Development/Tools
98
99%description tools
100Cairo is a 2D graphics library designed to provide high-quality display
101and print output.
102
103This package contains tools for working with the cairo graphics library.
104 * cairo-trace: Record cairo library calls for later playback
105
106
107%prep
108%setup -q
109%patch1 -p1 -b .dont-use-server-side-gradients
110
111%build
112%configure --disable-static \
113           --enable-gtk-doc \
114           --enable-xlib \
115           --enable-freetype \
116           --enable-ps \
117           --enable-pdf \
118           --enable-svg \
119           --enable-tee \
120           --enable-gobject
121
122%ifarch x86_64
123cp libtool libtool.old
124ldpath="/lib64 /usr/lib64 /usr/lib /usr/X11R6/lib64 /usr/X11R6/lib"
125sed "s|^sys_lib_search_path_spec=.*|sys_lib_search_path_spec=$ldpath|" libtool.old \
126        > libtool
127rm libtool.old
128%endif
129make
130
131%install
132rm -rf $RPM_BUILD_ROOT
133
134%makeinstall
135rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%post   -p /sbin/ldconfig
141%postun -p /sbin/ldconfig
142
143%post   -n compat32-%{name} -p /sbin/ldconfig
144%postun -n compat32-%{name} -p /sbin/ldconfig
145
146
147%files
148%defattr(644,root,root,755)
149%doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
150%{_libdir}/lib*.so.*
151
152%files devel
153%defattr(644,root,root,755)
154%{_libdir}/lib*.so
155#{_libdir}/lib*.la
156%{_includedir}/*
157%{_libdir}/pkgconfig/*.pc
158#{_libdir}/lib*.a
159%{_datadir}/gtk-doc/html/cairo
160
161%files tools
162%defattr(-,root,root,-)
163%{_bindir}/cairo-trace
164%{_libdir}/cairo
165
166%if %{build_compat32}
167%files -n compat32-%{name}
168%defattr(644,root,root,755)
169%{_libdir}/lib*.so.*
170%endif
171
172%changelog
173* Tue Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
174- enable tee support
175- add configure options specifically
176- disable static library
177
178* Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
179- new upstream release
180- add BuildRequires: glib2-devel
181- add Requires: glib2-devel (devel package)
182
183* Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
184- add patch1 from ubuntu to fix performance regressions
185  - don't use serverside gradients, most drivers don't handle those and are
186    really slow, should workaround performances issues for ati, nouveau and nvidia
187    https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
188
189* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
190- new upstream release
191- add tools sub package
192
193* Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
194- add BuildRequires: fontconfig-devel
195- add Requires: fontconfig-devel (devel package)
196
197* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
198- build with rpm-4.8.1-1 for pkg-config file
199
200* Tue Mar  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
201- new upstream release
202
203* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
204- new upstream release
205
206* Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
207- applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
208- added BuildRequires: gtk-doc
209
210* Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
211- new upstream release
212
213* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
214- new upstream release
215
216* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
217- new upstream release
218
219* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
220- new upstream release
221
222* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
223- new upstream release
224
225* Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
226- add  Requires: pixman-devel to -devel
227
228* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
229- rebuilt with xorg-x11 7.3
230- spec in UTF-8
231
232* Thu May  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
233- new upstream release
234- removed lib*.la from devel package
235
236* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
237- used %%{?_dist_release}
238
239* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
240- new upstream release
241
242* Sun Dec  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
243- new upstream release
244
245* Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
246- new upstream release
247
248* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
249- new upstream release
250- remove BuildRequires: pango-devel, gtk2-devel
251  (these are only needed for testing)
252
253* Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
254- upstream release
255- Patch30 and Patch40 is skipped (not working correctly)
256  but held in src.rpm
257- add BUGS, ROADMAP to %%doc
258- add BuildRequires: pango-devel, gtk2-devel
259
260* Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
261- rebuild without XOrg-compat70-devel
262- add BuildConflicts: XOrg-compat70-devel
263
264* Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
265- new upstream release
266- remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
267
268* Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
269- added Patch40 for 15bpp problem
270
271* Tue Sep  5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
272- added ad-hoc Patch30 for 16bpp problem
273
274* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
275- new upstream release
276
277* Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
278- new upstream release
279
280* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
281- new upstream release
282
283* Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
284- added compat32- package for x86_64 architecture support
285
286* Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
287- added x86_64 architecture support
288
289* Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
290- add Patch20 to fix broken desktop rendering on xorg-x11-6.9
291  - add X.Org 6.9.0 (6090000) to blacklist
292
293* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
294- new upstream release
295
296* Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
297- update Patch10
298
299* Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
300- add Patch10 to use embedded bitmap font if available.
301  (controllable by "embeddedbitmap" in fontconfig)
302
303* Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
304- rebuild with new fontconfig
305
306* Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
307- add Requires: libpng-devel, XOrg-devel, freetype2-devel
308  to devel package instead of BuildRequires (typo)
309- add Japanese summaries
310
311* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
312- new upstream release
313- remove libpixman dependency (which is now included in cairo)
314- obsoletes libpixman <= 0.1.6
315- add more BuildRequires
316
317* Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
318- new upstream version
319
320* Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
321- new upstream version
322- fixed License (http://cairographics.org/introduction)
323
324* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
325- new upstream version
326- include gtk-doc files
327
328* Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
329- new upstream version
330- add Requires: libpixman
331
332* Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
333- new upstream version (cairo-0.2.0)
334
335* Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
336- rebuilt for VineLinux
337
338* Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
339- 0.1.23
340- reenable libtoolize
341
342* Wed May  5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
343- fix devel provides
344- drop redundant buildrequires
345- requires new pixman
346- autoconf 2.5 macro
347- New release 0.1.22
348
349* Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
350- build with X11
351
352* Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
353- 0.1.17
354- provides cairo
355- drop patch, use --disable-xlib
356- buildrequires
357- don't run libtoolize
358
359* Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
360- initial mandrake package
361
Note: See TracBrowser for help on using the repository browser.