source: projects/specs/branches/6/c/ca-ceritifates/ca-certificates-vl.spec @ 7827

Revision 7827, 6.8 KB checked in by daisuke, 11 years ago (diff)

import from vineseed

Line 
1# certdata.txt is generated by extracting it from Mozilla CVS.
2# This is done by running:
3#
4#   cvs -d :pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot   \
5#     co -p mozilla/security/nss/lib/ckfw/builtins/certdata.txt \
6#     > certdata.txt
7#
8# Keep the RCS version in sync with the spec Version.
9
10%define pkidir %{_sysconfdir}/pki
11
12Summary: The Mozilla CA root certificate bundle
13Summary(ja): Mozilla の CA ルート証明書バンドル
14Name: ca-certificates
15Version: 2013.1.94
16Release: 1%{?_dist_release}
17License: Public Domain
18Group: System Environment/Base
19URL: http://www.mozilla.org/
20Source0: certdata.txt
21Source1: blacklist.txt
22Source2: generate-cacerts.pl
23Source3: certdata2pem.py
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25BuildRequires: perl, java-openjdk, python, rcs
26BuildArch: noarch
27
28%description
29This package contains the set of CA certificates chosen by the
30Mozilla Foundation for use with the Internet PKI.
31
32%prep
33rm -rf %{name}
34mkdir %{name} %{name}/certs %{name}/java
35
36%build
37pushd %{name}/certs
38 cp %{SOURCE0} %{SOURCE1} .
39 python %{SOURCE3}
40popd
41pushd %{name}
42 (
43   cat <<EOF
44# This is a bundle of X.509 certificates of public Certificate
45# Authorities.  It was generated from the Mozilla root CA list.
46#
47# Source: mozilla/security/nss/lib/ckfw/builtins/certdata.txt
48#
49# Generated from:
50EOF
51   ident -q %{SOURCE0} | sed '1d;s/^/#/';
52   echo '#';
53 ) > ca-bundle.crt
54 (
55   cat <<EOF
56# This is a bundle of X.509 certificates of public Certificate
57# Authorities.  It was generated from the Mozilla root CA list.
58# These certificates are in the OpenSSL "TRUSTED CERTIFICATE"
59# format and have trust bits set accordingly.
60#
61# Source: mozilla/security/nss/lib/ckfw/builtins/certdata.txt
62#
63# Generated from:
64EOF
65   ident -q %{SOURCE0} | sed '1d;s/^/#/';
66   echo '#';
67 ) > ca-bundle.trust.crt
68 for f in certs/*.crt; do
69   tbits=`sed -n '/^# openssl-trust/{s/^.*=//;p;}' $f`
70   case $tbits in
71   *serverAuth*) openssl x509 -text -in "$f" >> ca-bundle.crt ;;
72   esac
73   if [ -n "$tbits" ]; then
74      targs=""
75      for t in $tbits; do
76         targs="${targs} -addtrust $t"
77      done
78      openssl x509 -text -in "$f" -trustout $targs >> ca-bundle.trust.crt
79   fi
80 done
81popd
82pushd %{name}/java
83 test -s ../ca-bundle.crt || exit 1
84 %{__perl} %{SOURCE2} %{_bindir}/keytool ../ca-bundle.crt
85 touch -r %{SOURCE0} cacerts
86popd
87
88%install
89rm -rf $RPM_BUILD_ROOT
90
91mkdir -p $RPM_BUILD_ROOT{%{pkidir}/tls/certs,%{pkidir}/java}
92
93install -p -m 644 %{name}/ca-bundle.crt $RPM_BUILD_ROOT%{pkidir}/tls/certs/ca-bundle.crt
94install -p -m 644 %{name}/ca-bundle.trust.crt $RPM_BUILD_ROOT%{pkidir}/tls/certs/ca-bundle.trust.crt
95ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{pkidir}/tls/cert.pem
96touch -r %{SOURCE0} $RPM_BUILD_ROOT%{pkidir}/tls/certs/ca-bundle.crt
97touch -r %{SOURCE0} $RPM_BUILD_ROOT%{pkidir}/tls/certs/ca-bundle.trust.crt
98
99# Install Java cacerts file.
100mkdir -p -m 700 $RPM_BUILD_ROOT%{pkidir}/java
101install -p -m 644 %{name}/java/cacerts $RPM_BUILD_ROOT%{pkidir}/java/
102
103# /etc/ssl/certs symlink for 3rd-party tools
104mkdir -p -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/ssl
105ln -s ../pki/tls/certs $RPM_BUILD_ROOT%{_sysconfdir}/ssl/certs
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%files
111%defattr(-,root,root,-)
112%dir %{pkidir}/java
113%config(noreplace) %{pkidir}/java/cacerts
114%dir %{pkidir}/tls
115%dir %{pkidir}/tls/certs
116%config(noreplace) %{pkidir}/tls/certs/ca-bundle.*crt
117%{pkidir}/tls/cert.pem
118%dir %{_sysconfdir}/ssl
119%{_sysconfdir}/ssl/certs
120
121%changelog
122* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2013.1.94-1
123- update to 1.94
124
125* Wed Jul 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.85-1
126- update to r1.85
127
128* Mon Mar 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012.81-1
129- initial build for Vine Linux
130
131* Mon Feb 13 2012 Joe Orton <jorton@redhat.com> - 2012.81-1
132- update to r1.81
133
134* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2011.80-2
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
136
137* Wed Nov  9 2011 Joe Orton <jorton@redhat.com> - 2011.80-1
138- update to r1.80
139- fix handling of certs with dublicate Subject names (#733032)
140
141* Thu Sep  1 2011 Joe Orton <jorton@redhat.com> - 2011.78-1
142- update to r1.78, removing trust from DigiNotar root (#734679)
143
144* Wed Aug  3 2011 Joe Orton <jorton@redhat.com> - 2011.75-1
145- update to r1.75
146
147* Wed Apr 20 2011 Joe Orton <jorton@redhat.com> - 2011.74-1
148- update to r1.74
149
150* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2011.70-2
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
152
153* Wed Jan 12 2011 Joe Orton <jorton@redhat.com> - 2011.70-1
154- update to r1.70
155
156* Tue Nov  9 2010 Joe Orton <jorton@redhat.com> - 2010.65-3
157- update to r1.65
158
159* Wed Apr  7 2010 Joe Orton <jorton@redhat.com> - 2010.63-3
160- package /etc/ssl/certs symlink for third-party apps (#572725)
161
162* Wed Apr  7 2010 Joe Orton <jorton@redhat.com> - 2010.63-2
163- rebuild
164
165* Wed Apr  7 2010 Joe Orton <jorton@redhat.com> - 2010.63-1
166- update to certdata.txt r1.63
167- use upstream RCS version in Version
168
169* Fri Mar 19 2010 Joe Orton <jorton@redhat.com> - 2010-4
170- fix ca-bundle.crt (#575111)
171
172* Thu Mar 18 2010 Joe Orton <jorton@redhat.com> - 2010-3
173- update to certdata.txt r1.58
174- add /etc/pki/tls/certs/ca-bundle.trust.crt using 'TRUSTED CERTICATE' format
175- exclude ECC certs from the Java cacerts database
176- catch keytool failures
177- fail parsing certdata.txt on finding untrusted but not blacklisted cert
178
179* Fri Jan 15 2010 Joe Orton <jorton@redhat.com> - 2010-2
180- fix Java cacert database generation: use Subject rather than Issuer
181  for alias name; add diagnostics; fix some alias names.
182
183* Mon Jan 11 2010 Joe Orton <jorton@redhat.com> - 2010-1
184- adopt Python certdata.txt parsing script from Debian
185
186* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2009-2
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
188
189* Wed Jul 22 2009 Joe Orton <jorton@redhat.com> 2009-1
190- update to certdata.txt r1.53
191
192* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2008-8
193- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
194
195* Tue Oct 14 2008 Joe Orton <jorton@redhat.com> 2008-7
196- update to certdata.txt r1.49
197
198* Wed Jun 25 2008 Thomas Fitzsimmons <fitzsim@redhat.com> - 2008-6
199- Change generate-cacerts.pl to produce pretty aliases.
200
201* Mon Jun  2 2008 Joe Orton <jorton@redhat.com> 2008-5
202- include /etc/pki/tls/cert.pem symlink to ca-bundle.crt
203
204* Tue May 27 2008 Joe Orton <jorton@redhat.com> 2008-4
205- use package name for temp dir, recreate it in prep
206
207* Tue May 27 2008 Joe Orton <jorton@redhat.com> 2008-3
208- fix source script perms
209- mark packaged files as config(noreplace)
210
211* Tue May 27 2008 Joe Orton <jorton@redhat.com> 2008-2
212- add (but don't use) mkcabundle.pl
213- tweak description
214- use /usr/bin/keytool directly; BR java-openjdk
215
216* Tue May 27 2008 Joe Orton <jorton@redhat.com> 2008-1
217- Initial build (#448497)
Note: See TracBrowser for help on using the repository browser.