source: projects/specs/branches/6/b/bzr/bzr-vl.spec @ 3245

Revision 3245, 9.9 KB checked in by iwaim, 13 years ago (diff)

bzr 2.3.1-1

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3# All package versioning is found here:
4# the actual version is composed from these below, including leading 0 for release candidates
5#   bzrmajor:  main bzr version
6#   Version: bzr version, add subrelease version here
7#   bzrrc: release candidate version, if any, line starts with % for rc, # for stable releas (no %).
8#   release: rpm subrelease (0.N for rc candidates, N for stable releases)
9%define bzrmajor 2.3.1
10#define bzrrc rc1
11%define release 1
12
13# Magics to get the dots in Release string correct per the above
14%define subrelease %{?bzrrc:.}%{?bzrrc}
15
16Name:           bzr
17Version:        %{bzrmajor}
18Release:        %{release}%{?subrelease}%{?_dist_release}
19Summary:        Friendly distributed version control system
20Summary(ja):    bzr - 分散型バージョン管理システム
21
22Group:          Development/Tools
23License:        GPLv2+
24URL:            http://www.bazaar-vcs.org/
25Source0:        https://launchpad.net/%{name}/%{bzrmajor}/%{version}%{?bzrrc}/+download/%{name}-%{version}%{?bzrrc}.tar.gz
26Source1:        https://launchpad.net/%{name}/%{bzrmajor}/%{version}%{?bzrrc}/+download/%{name}-%{version}%{?bzrrc}.tar.gz.sig
27BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
28
29BuildRequires:  python-devel zlib-devel
30# We're using an old version of Pyrex, use the pregenerated C files instead
31# of rebuilding
32#BuildRequires: Pyrex
33Requires:   python-paramiko
34# Workaround Bug #230223 otherwise this would be a soft dependency
35Requires:   python-pycurl
36
37# ElementTree is part of python2.5 on FC7+
38# This is also needed for EL-5
39#if 0%{?fedora} <= 6
40#BuildRequires:   python-elementtree
41#Requires:   python-elementtree
42#endif
43
44Vendor: Project Vine
45Distribution: Vine Linux
46
47%description
48Bazaar is a distributed revision control system that is powerful, friendly,
49and scalable.  It is the successor of Baz-1.x which, in turn, was
50a user-friendly reimplementation of GNU Arch.
51
52
53%prep
54%setup -q -n %{name}-%{version}%{?bzrrc}
55
56sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/_patiencediff_py.py
57sed -i '1{/#![[:space:]]*\/usr\/bin\/\(python\|env\)/d}' bzrlib/weave.py
58
59%build
60CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
61
62chmod a-x contrib/bash/bzrbashprompt.sh
63
64%install
65rm -rf $RPM_BUILD_ROOT
66%{__python} setup.py install --skip-build --install-data %{_datadir} --root $RPM_BUILD_ROOT
67chmod 0644 contrib/bzr_access
68chmod 0644 contrib/bzr_ssh_path_limiter
69chmod 0755 $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/*.so
70
71install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
72install -m 0644 contrib/bash/bzr $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/
73rm contrib/bash/bzr
74
75# This is included in %doc, remove redundancy here
76#rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/doc/
77
78# Use independently packaged python-elementtree instead
79rm -rf $RPM_BUILD_ROOT%{python_sitearch}/bzrlib/util/elementtree/
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84
85%files
86%defattr(-,root,root,-)
87%doc NEWS README TODO COPYING.txt doc/  contrib/
88%{_bindir}/bzr
89%{_mandir}/man1/*
90%{python_sitearch}/bzrlib/
91%{_sysconfdir}/bash_completion.d/
92
93#if 0%{?fedora} > 8
94%{python_sitearch}/*.egg-info
95#endif
96
97%changelog
98* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 2.3.1-1
99- new upstream release
100- add Vendor and Distribution tags
101
102* Sun Dec 12 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.2-1
103- new upstream release
104
105* Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 1.17-2
106- rebuilt with python-2.6
107
108* Thu Aug  6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
109- initial build for VineSeed
110
111* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.17-2
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
113
114* Mon Jul 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-1
115- Upgade to 1.17
116
117* Mon Jul 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.17-0.1
118- Update to 1.17rc1
119
120* Fri Jun 26 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16.1-1
121- Update to 1.16.1
122
123* Thu Jun 18 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.16-1
124- Update to 1.16
125
126* Wed Jun 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15.1-1
127- Update to 1.15.1
128
129* Sat May 23 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-2
130- Update to 1.15final
131
132* Sat May 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.15-0.1
133- Update to 1.15rc1
134
135* Sat May 02 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14.1-1
136- Update to 1.14.1
137
138* Wed Apr 29 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-1
139- Update to 1.14
140
141* Mon Apr 20 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.3.rc2
142- Update to 1.14rc2
143
144* Sat Apr 11 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.2.rc1
145- Correct build dependencies
146
147* Thu Apr 09 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.14-0.1.rc1
148- Update to 1.14rc1
149
150* Tue Mar 24 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13.1-1
151- Update to 1.13.1
152
153* Mon Mar 16 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-1
154- Update to 1.13
155
156* Tue Mar 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.13-0.1.rc1
157- Update to 1.13rc1
158
159* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-2
160- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
161
162* Fri Feb 13 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-1
163- Update to 1.12
164
165* Tue Feb 10 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.12-0.1.rc1
166- Update to 1.12rc1
167
168* Mon Jan 19 2009 Henrik Nordstrom <henrik@henriknordstrom.net> - 1.11-1
169- Update to 1.11
170
171* Wed Dec 10 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.10-1
172- Update to 1.10
173
174* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.9-2
175- Rebuild for Python 2.6
176
177* Thu Nov 13 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.9-1
178- Update to 1.9
179
180* Thu Sep 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-1
181- 1.7 Final
182
183* Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.7-0.1.rc2
184- 1.7rc2
185- Remove executable permission from a %%doc file
186
187* Wed Sep 3 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.6.1-0.1.rc2
188- New upstream bugfix release.
189
190* Thu May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-2
191- Upload tarball.
192
193* Wed May 21 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.5-1
194- Update to 1.5.
195
196* Thu May 15 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-2
197- Workaround upstream Bug# 230223 by Requiring python-pycurl.
198
199* Mon May 5 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.4-1
200- Update to 1.4.
201
202* Sun Apr 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-1
203- Paramiko/sftp backport from 1.4.0. bz#444325
204- Update to 1.3.1 final.
205
206* Sat Apr 4 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.3.1-0.1.rc1
207- Update to 1.3.1rc1 to fix a bug when you have a pack based remote repo and
208  knit based local branch.
209
210* Wed Mar 26 2008 Warren Togami <wtogami@redhat.com> - 1.3-1
211- Update to 1.3.
212
213* Mon Feb 25 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.2-1
214- Update to 1.2.
215
216* Fri Feb 8 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 1.1-2
217- Rebuild for new gcc.
218
219* Mon Jan 21 2008 Toshio Kuratomi <a.badger@gmail.com> - 1.1-1
220- Upstream 1.1 bugfix and performance enhancement release.
221- Enable bash completion script from the contrib directory.
222
223* Thu Dec 13 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-1
224- Update to 1.0 final.
225
226* Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc3
227- Update to 1.0rc3
228- The new rawhide python package generates egg-info files.
229
230* Fri Nov 30 2007 Toshio Kuratomi <a.badger@gmail.com> - 1.0-0.1.rc2
231- Update to 1.0rc2
232
233* Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.91-1
234- Update to 0.91.
235  + Fixes some issues with using tag-enabled branches.
236
237* Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-1
238- Update to 0.90
239
240* Mon Aug 27 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.90-0.1.rc1
241- Update to 0.90rc1.
242- 0.90 contains some pyrex code to speed things up.  bzr is now arch specific.
243- Update license tag.
244
245* Wed Jul 25 2007 Warren Togami <wtogami@redhat.com> - 0.18-1
246- Update to 0.18.
247
248* Tue Jun 26 2007 Warren Togami <wtogami@redhat.com>  - 0.17-2
249- Update to 0.17.
250
251* Tue May 08 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.16-1
252- Update to 0.16.
253
254* Thu Mar 22 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.15-1
255- Update to 0.15.
256- Simplify the %%files list.
257
258* Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.14-1
259- Update to 0.14
260
261* Sun Dec 10 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-2
262- Conditionalize the python-elementtree requires as python2.5 in FC7 includes
263  elementtree
264
265* Wed Dec 6 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.13-1
266- Update to 0.13
267
268* Thu Oct 30 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.12-1
269- Update to 0.12
270
271* Thu Oct 08 2006 Toshio Kuratomi <toshio@tiki-lounge.com> 0.11-1
272- Update to 0.11
273- New download location.
274
275* Sun Sep 17 2006 Warren Togami <wtogami@redhat.com> 0.10-1
276- 0.10
277
278* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.9-1
279- Update to new upstream
280
281* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.8.2-3
282- Include, don't ghost .pyo files per new guidelines
283
284* Mon Jun 26 2006 Shahms E. King <shahms@shahms.com> 0.8.2-2
285- Require python-paramiko for sftp support
286
287* Tue May 23 2006 Shahms E. King <shahms@shahms.com> 0.8.2-1
288- Update to new upstream version
289- Fix dist tag
290
291* Wed May 10 2006 Shahms E. King <shahms@shahms.com> 0.8-1
292- Update to new upstream version
293- Update bzr-sys-etree.patch for changes
294
295* Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-3
296- Add python-elementtree to BuildRequires
297
298* Mon Feb 13 2006 Shahms E. King <shahms@shahms.com> 0.7-2
299- Add dist tag
300
301* Fri Feb 10 2006 Shahms E. King <shahms@shahms.com> 0.7-1
302- Update to 0.7
303
304* Thu Jan 26 2006 Shahms E. King <shahms@shahms.com> 0.6.2-2
305- Fix system library patch
306
307* Wed Dec 07 2005 Shahms E. King <shahms@shahms.com> 0.6.2-1
308- Initial package
Note: See TracBrowser for help on using the repository browser.